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Chapter 1

GETTING STARTED

Welcome to Hatch Embroidery, Wilcom’s 
premier home embroidery software. 
Designed specifically for the hobbyist 
and home business, Hatch Embroidery 
includes all the features and tools you 
need to create simple or extravagant 
embroidery designs. It is the best 
machine embroidery software available 
today, featuring latest technology in an 
easy-to-use interface with 
add-as-you-go features.
A few of its amazing features...

 Select from powerful manual 
digitizing tools and an endless number of creative stitch types. Designs are only 
limited by your imagination.

 The Color PhotoStitch feature creates lasting gifts. Take a photo of a pet, baby 
or someone special and instantly convert it into embroidery. This takes 
personalization to another level.

 Redwork unlocks an ethereal artistic embroidery style. Available in multiple 
outline types, Hatch Embroidery will calculate the fastest and most efficient 
route to stitch out your designs.

Create appliqué by converting closed objects with a single click. This is truly 
automated. When done, export to SVG and prepare your cutting file in 
seconds.

 There are also special appliqué digitizing tools which allow you to choose how 
you want your appliqué to stitch. Select from one color or multiple color stops 
and optimize stitch order.

 Elastic Embossed fills and outlines turn with the shape of objects. Be even more 
creative whilst continuing to achieve accurate and clean designs.

 Alternating Motifs lets you combine two motifs into a single object. Now you 
can create unique patterns never seen before.

Hatch Embroidery really does it all. Some days you may simply want to resize or 
recolor a design, or just add some lettering. Other days you are in the mood to 
create a piece of art. All the tools are waiting at your fingertips, and of course, you 
have the Hatch Embroidery team and a helpful community to support you.
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Note: Hatch Embroidery is a downloadable product that you can buy all-in-one or 
start small and add modules when it’s right for you. For more product information 
and prices, please visit our website.

Introduction

If you are new to embroidery design 
software or machine embroidery, you 
are probably asking yourself ‘where do I 
start?!’
It’s safe to say that you will spend many 
hours learning how to get the most out of 
your embroidery machine and the 
design software which supports it. The 
two work together hand-in-hand and it 
takes practice and patience to master 
both the creation and production of fine 
embroidery.
The results, however, will speak for 
themselves, making the time you invest 
all the more valuable. With each project 
you complete, you will gain in experience and confidence and be ready to tackle 
the next challenge.

Working with embroidery
Let’s take a look at the scenarios that you will find yourself working with. Typically, 
you will be involved in one or all of the following:

 Take a ready-made design and sew it out
Make global changes to a design
Combine lettering with a design
Create a monogram design
 Adapt an existing design
Create embroidery from artwork using automated techniques
Create embroidery manually
 Use special embroidery features
Let’s look at those cases one-by-one. This section outlines the main uses you will 
make of Hatch Embroidery, together with references to sections of the User Guide 
where you can obtain more in-depth information.

Tip: For lots of great videos and ideas for using Hatch Embroidery, visit our online 
resource center.

https://help.hatchembroidery.com/hc/en-us/sections/360000025555-Getting-Started
https://www.wilcom.com/hatch
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Integration with CorelDRAW®
Integration with CorelDRAW® is automatically activated depending on your 
product level. This is available for customers who already own compatible 
CorelDRAW software or have purchased CorelDRAW GEM for Hatch Embroidery. 
If you have CorelDRAW® installed on your computer together with Hatch 
Embroidery, you will be prompted to link it upon launching Hatch Embroidery. See 
also Graphics Mode.

Note: CorelDRAW® integration is currently only available for certain models of 
CorelDRAW software and CorelDRAW GEM for Hatch Embroidery. And it only 
works with some levels of Hatch Embroidery. For more information, see FAQs on 
the Hatch Embroidery website. Note too that some CorelDRAW® functions may 
not be available in Graphics Mode.

The user interface

Link Hatch 
Embroidery to 
CorelDRAW

Double-click on the Windows Desktop to start Hatch Embroidery.

https://help.hatchembroidery.com/hc/en-us/articles/360000537936-Which-Version-of-CorelDRAW-does-Hatch-v2-integrate-with-
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Hatch Embroidery can be opened via the desktop icon or MS Windows® Start 
menu.

Caution: You may need to calibrate your monitor so that designs at 1:1 scale 
appear at real size. Do this when you first install Hatch Embroidery or when 
changing monitors. Screen calibration is generally not required on Windows 10/11 
as this is handled by the operating system itself. See Monitor calibration for details.

Operating modes
Hatch Embroidery has a single ‘design window’ but you interact with it in different 
ways. The main operating modes you’ll be using are:

Mode Function

Home With this mode you can return to the Home screen to access new designs, 
or access tutorials and other product information.

Embroidery 
Mode

This mode allows you to create and edit embroidery objects using an 
embroidery digitizing toolset.

Graphics Mode When installed, this mode allows you to insert, create and edit artwork, 
vector and bitmaps, using the CorelDRAW software toolset.

Design Library This mode allows you to manage embroidery files and artwork.

Multi-hooping 
mode

If your embroidery is too large or contains a number of designs spaced 
around an article, you can split it into multiple hoopings in Multi-Hooping 
mode.
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Note: The User Interface Settings > General tab allows you to preset the preferred 
default screen upon startup – Home, Design Library, or Embroidery Mode. See 
System preferences for details.

Home screen

The Home screen loads when Hatch Embroidery starts, offering you quick access 
to recent new designs, as well as value-add content, including tutorial videos and 
the latest Community Forum and Product Blog posts. You can also browse ‘My 
Hatch’ which provides details of your license, including product level and version.

Click Switch & Convert > Home to revisit the Home screen to access tutorials and 
other product information.
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In a nutshell, the Home screen provides the following:

Embroidery mode

Hatch Embroidery has a single workspace or ‘design window’. This allows you to 
modify or create embroidery designs using the extensive toolset. You can have 

Feature Benefits

Quick access to Hatch 
software features

• Links to the Design Space
• Links to the Design Library

Start Provides quick access to open:
• a new design
• an existing design
• a design from a list of recently opened designs.

My Hatch • Reports up-to-date product entitlement information such as: product 
level and version, font packs purchased, etc

• Indicates version status - whether up-to-date or not - plus links to latest 
version

• Links to upgrade path, depending on your current level
• Links to available font packs, again depending on current entitlements 

and available fonts

Hatch Academy Easy access to Hatch Academy website. Education is the key to 
getting more from your Hatch Embroidery software:
• Learn from hundreds of quality embroidery lessons designed by Hatch 

Embroidery experts
• Get answers to your questions directly from the trainers.

Community Join a worldwide community of Hatch users to discuss:
• News and announcements
• General questions and shared ideas
• New features and suggestions

Blog Access the Hatch Blog for:
• How tos
• Inspiration
• News

Help Access the Hatch Help for:
• General FAQs
• How To FAQs
• Technical FAQs
• Helpful videos
• Announcements

News and posts 
section

Provides access to:
• Latest Hatch News regularly updated by the Marketing Team
• List of latest Community Forum posts
• Latest blog posts.

Use Embroidery Mode to digitize and edit embroidery designs. Display embroidery 
as well as artwork. View designs realistically in 3D simulation.
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multiple designs open simultaneously and toggle between each via the design 
tabs.

Menu & toolbars
The main menu and toolbars are normally docked at the top of the screen above 
the design window. Use both to access common commands. As you get more 
familiar with them, you can speed things up by using keyboard shortcuts. For a list 
of available toolbars, go to the Window menu...

Hatch Embroidery includes a Context toolbar which changes according to the 
selected tool. If you have no tools selected, you will see droplists for machine, 

Design 
tabs

Available toolbars
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machine model, and hoop. Here you can also set your measurement units – Metric 
or U.S. – and adjust screen background settings. See also Hoop selection.

The Help menu provides easy access to online help and electronic 
documentation in the form of release notes and quick start guide. It also provides 
access to the Hatch Academy. This resource provides free and paid courses for 
both trial and registered users. Resources include ‘Embroidery Basics’ as well as 
premium Hatch Embroidery training that includes projects and webinars all aimed 
at improving the learning journey.

Tip: Tooltips provide a brief summary of tool characteristics. Online help provides 
quick access to step-by-step instructions. Context-sensitive help is available for 
tools and dialogs by pressing the F1 key.

Select preferred 
hoop

Select your machine 
and model

Electronic
documentation

Hatch Academy

Press F1 for more 
information

https://profile.hatchembroidery.com/?return_url=https://academy.hatchembroidery.com/enrollments


Chapte r  1     Gett ing  Sta r ted 9

Toolboxes
Toolboxes are like toolbars in that they contain 
software tools. However, each toolbox represents a 
typical scenario you will be engaged in, such as 
customizing designs or editing objects. Some tools 
may appear in more than one context. As such, 
toolboxes are organized in order of common 
operations, starting with managing your designs. See 
also Manage Designs.

Dockers
Hatch Embroidery includes a number of ‘dockers’ for 
key functions. These include operations to do with 
object sequencing, thread selection, as well as 
viewing and modifying object properties.

Dockers are normally docked to the right of the design window. They may also be 
‘floated’ by dragging the caption bar to the design window or double-clicking.

Available
dockers

Design Information
docker
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Depending on your level of product, available dockers may include some of all of 
the following...

Status bar
A Status bar at the bottom of the design window provides continuous display of 
current cursor position status as well as instructions for use of selected tools.

Information displayed includes...

Docker Purpose

Sequence This docker offers an easy way to selectively view and sequence 
color blocks and objects.

Design Overview This docker displays a thumbnail image of the design. Use it to pan 
and zoom the design when working at high zoom factors. Set view 
settings independently to the design window.

Object Properties This is an important docker if you are creating or editing 
embroidery objects. Use this together with the Context toolbar to 
access and modify the many properties of selected embroidery 
objects.

Design Information Use this docker to view and modify design details prior to design 
approval or stitchout.

Threads This docker allows you to select thread charts and assign threads 
to the current design. It works in conjunction with the Design 
Colors toolbar.

Keyboard Design 
Collection

Many hobbyists buy embroidery fonts from third-party suppliers. 
Use this docker to map these fonts to keyboard characters for use 
in Hatch Embroidery.

Hints This docker provides a valuable learning resource from within the 
software. When open, context-sensitive help appears, if available, 
whenever a feature is selected. Each hint includes a brief feature 
summary together with a link to a short video.

Field Notes

Prompt message To guide you through use of selected functions

Design size Width and height

Coordinates Current needle position (X/Y), and length (L) and angle (A) of current 
stitch. See also Design measurement.

Stitch count Total number of stitches in design

Current fabric Fabric settings take into account the type of fabric you are stitching on. 
See also Fabrics & densities.

Grade of design EMB designs are classified in four grades depending on how the file was 
created. See also Supported embroidery files.
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Design Library
The built-in Design Library is a ‘virtual library’ in that any designs on your system can 
be located and displayed within the navigation tree. Hatch Embroidery doesn’t 
care where they physically reside on your hard disk or external storage devices. 
Any folder containing embroidery designs can be included in the navigation tree. 
The library opens in its own tab on the design bar. It has five components – two 
toolbars, a toolbox, a navigation tree, a design display area, and an info panel. 
See also Browse designs.

Graphics Mode

Hatch Embroidery has a single ‘design window’ but when integrated with 
CorelDRAW®, you may interact with it via the Switch and Convert toolbar.

Use Switch & Convert > Graphics Mode to import, edit or create vector artwork as a 
backdrop for embroidery digitizing, manual or automatic.

Use Switch & Convert > Show Embroidery to show or hide embroidery components.

Switch between 
operating modes
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Note: CorelDRAW® needs to be registered before it can be used by Hatch 
Embroidery. Registration provides CorelDRAW® Standard Membership which gives 
you access to content – clipart, fonts, stock photos, templates – via Corel 
CONNECT. It also gives you access to the latest CorelDRAW® updates.
The Graphics Mode toolset offers many techniques for creating and editing vector 
graphics, according to the version of CorelDRAW software you own.

Here are some of the prominent Graphics Mode interface elements. 

Menu bar

Status bar

Toolbox Switch & Convert toolbar

Standard toolbar

Design window

Properties
docker

Property bar

Color
palette

Element Description

Menu bar This contains application menus such as File, Edit, View, etc.

Design window This contains the main work area where you create and edit graphics 
objects as well as embroidery objects when you switch to Embroidery 
Mode.

Switch & Convert 
toolbar

This contains the universal tools and icons which are visible in both 
Embroidery Mode and Graphics Mode windows.

Standard toolbar This contains commonly used tools and commands which are specific to 
and only visible in Graphics Mode.

Toolbox This contains the drawing/editing tools specific to and visible only in 
Graphics Mode.

Property bar This contains the commands and controls that relate to the active tool in 
the Toolbox or active object in the design window in Graphics Mode.
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In addition to the CorelDRAW software toolset, you can also use Graphics Mode 
to insert or paste third-party vector graphics such as clipart for use in embroidery 
designs. Alternatively, insert, paste or scan bitmap artwork for use as digitizing 
templates or ‘backdrops’. Imported vector graphics or created text can be 
converted directly to embroidery designs. See Convert artwork to embroidery with 
CorelDRAW® for details.

Note: For a detailed description of the CorelDRAW software interface, refer to the 
electronic User Guide available via the MS Windows® Start > Programs group. 
Alternatively, use the online help available from the Help menu.

Multi-hooping mode
Here is a screen image from the 
multi-hooping workspace which is 
accessed via the Multi-Hooping toolbox. If 
your embroidery is too large or contains a 
number of designs spaced around an 
article, you can split it into multiple 
hoopings. This means you can create 
embroidery designs that are larger than 
can be stitched in a single hooping. The 
multi-hooping workspace allows you to set 
up the position and sequence of each 
hoop. See also Multi-Hooping.

Properties docker In Graphics Mode, this contains graphics-specific dockers.

Color palette This contains the graphics color palette which is specific to and only visible 
in Graphics Mode.

Status bar This contains current status information visible only in the Graphics Mode.

Element Description



Chapte r  1     Gett ing  Sta r ted 14

First things first

You don’t need experience to start using 
your software. You can simply open a 
design and save it to your machine’s format, 
ready for ‘stitchout’. (Some machines may 
allow you to send designs directly to 
machine.) And this is the best place to start. 
As you gain experience, you will be able to 
‘read’ designs and identify which are good 
and which may cause problems.

Rules of good embroidery
Keep the following points in mind when 
looking at embroidery designs, both your 
own and others:

 Stitches are neat, smooth and even
 Design looks good – shapes, colors, balance
 Shapes are filled with correct fill and outline stitches
 Stitches are angled to match shapes
 Shapes are stitched correctly – no unwanted gaps
 Details are clearly defined
 Lettering is clear and easy to read.

The stitchout should also have the following characteristics:

 The design sews efficiently on the machine
 The fabric does not pucker around stitched areas
 The design is free of loose ends.
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Tip: Good embroidery quality starts with good design. You then need a good 
quality machine to stitch it out. But even that is not enough if you do not use the 
correct fabric, threads, backings, tension, and so on. Consult your machine 
manual for advice and get as much advice from other embroiderers as you can.

Sources of artwork
Electronic artwork in both bitmap and vector formats can be inserted, pasted or 
scanned into Hatch Embroidery for use as digitizing templates or ‘backdrops’. 
Likely sources include:

 Internet and CD clipart libraries
 Business cards, post cards and wrapping paper
 Samples in the Design Library
 Books of embroidery patterns
Children’s story books
 Printed table cloths or tea towels
Original artwork – e.g. children’s drawings.
Unless you are an experienced digitizer, do not use complicated artwork. Also, be 
sure to check the copyright of any images you have not created yourself. If unsure, 
contact the relevant supplier to seek their permission.

Sample designs & artwork
Hatch Embroidery contains many ready-to-stitch designs, samples and projects. 
These can be found in the built-in Design Library. The most valuable thing when 
starting out as a new user, is to spend some time exploring these designs and 
getting to know what’s available. See also Browse designs.
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There are also artwork files for use as digitizing backdrops. These are installed to 
your Pictures folder. See also Electronic Artwork.

There are many other sources of ready-made embroidery designs which you can 
purchase online and adapt as you wish. Just be aware of any copyright issues that 
may be attached to designs you find on the web.

Note: You can only open CDR files if you have an approved version of 
CorelDRAW® installed and linked to Hatch Embroidery. Other graphic formats can 
be read via CorelDRAW®. Refer to your installed CorelDRAW® documentation. For 
more information, see FAQs on the Hatch Embroidery website.

CorelDRAW resources
Integration with CorelDRAW® is automatically activated depending on your 
product model. This is available for customers who already own compatible 
CorelDRAW software or have purchased CorelDRAW GEM for Hatch Embroidery. 
CorelDRAW® Standard Membership provides access to content – clipart, fonts, 
stock photos, templates – via Corel CONNECT. Clipart and other content can be 

Select image
file type

https://help.hatchembroidery.com/hc/en-us/articles/115002027887-What-file-formats-does-Hatch-Embroidery-read-and-write-
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accessed via the program group. It can also be accessed via the built-in 
CONNECT Content docker in Graphics Mode.

Go to Window > Dockers > CONNECT Content to open the docker.

Get familiar with the many clipart samples available to you. Many can be 
adapted for use with embroidery design, either as digitizing backdrops or direct 
conversion. However, because of the time it takes to render images on your 
computer, use the filters to limit the number for display each time.

Caution: Included artwork (clipart) and embroidery designs are only available for 
personal use – i.e. they cannot be commercially sold in any form.

Stitch out a design

For many embroiderers, it is enough to take an existing design and stitch it out. This 
is certainly where most will start. Once you have found a design you like, you will 
want to preview it to see how it will sew out. A number of steps are involved. We 
outline the main ones here with reference to the User Guide.

Access CorelDRAW 
CONNECT to browse 
extensive collection of 
clipart and other assets

Access online content 
via the CONNECT 
Content docker
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Study sample designs

Open a design from your Embroidery Library. See also Open design files.

Adjust view settings

Use Manage Designs > Open Selected to open the design(s) selected in the 
Design Library.

Use Manage Designs > New From Selected to create new design(s) based on the 
selected design(s) and/or bitmap(s) from a chosen template.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.
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Adjust viewing settings as preferred. See also View Designs.

Change fabric type

Check the fabric type and change as necessary via the Customize Design toolbox 
or Design Settings menu. See also Fabrics & densities.

Assign threads

Use Customize Design > Auto Fabric to change the properties of the design for 
stitching on a different fabric.

Use Design Colors > Threads >> to toggle Threads docker display. Use it to find 
threads from different charts and change design colors. 

Select preferred 
viewing options

Selected target 
fabric type
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Go to Design Colors and check the thread colors. If necessary, change charts to 
suit one you are using. See also Design colors.

Preview stitchout

Press Shift+R or click on the Stitch Player icon to preview the stitchout so you 
understand how the design will sew on the machine. See also View stitching 
sequence.

Use View > Stitch Player to simulate embroidery design stitchout onscreen in either 
stitch or TrueView.

Default palette

Simulate design 
stitchout
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Preview a design worksheet

Preview the design via the Standard toolbar or Output Design toolbox and print a 
design worksheet as preferred. See also Print designs.

Output a design

Send the design to machine via data media (usually memory stick). Or by file 
transfer. But before outputting to machine file, be sure to first save your design as 
EMB. See also Output Designs.

Use Output Design / Standard > Print Preview to preview design worksheet. Print 
from preview window.

Use Output Design > Export Design to export the current design to a machine file for 
stitching.

Use Output Design / Context > Transfer Design to transfer current design to the 
design folder. Right-click for settings.

Design information 
provided on 
worksheet

Choose file format 
recognized by your 
machine
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Note: Check your machine documentation for steps involved after transferring the 
design to machine.

Modify a design

Once you are used to the steps involved in sewing 
out designs – either clipart or ones you have 
purchased – you will soon want to make global 
design modifications such as resizing, or changing 
thread colors and fabric types. These are all 
relatively simple operations. We outline some of the 
common ones here.

Tip: Often you will want to scale a design for use in 
different contexts. For instance, a design originally 
made to fit a pocket may be adapted to fit a cap. 
Hatch Embroidery provides techniques for 
transforming design objects just like a graphics 
program ... with one difference. When you scale, 
rotate, skew, or flip an embroidery object, stitches are regenerated.

Open a design

Use Manage Designs > Open Selected to open the design(s) selected in the 
Design Library.

Use Manage Designs > New From Selected to create new design(s) based on the 
selected design(s) and/or bitmap(s) from a chosen template.

Use Standard > Open Design to open an existing embroidery design.

Use Standard > New From Design to create a new design based on an existing 
design.
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Open the design you want to use. Press Ctrl+A to select all objects and press Ctrl+G 
to group them. See also Open design files.

Recolor a design

In addition to simple modifications such as resizing, many Hatch Embroidery users 
simply want to be able to recolor designs for different fabrics or articles. Hatch 
Embroidery provides many techniques for recoloring, including matching design 
colors to available thread charts. Recoloring by threads may involve either design 
files or machine files which include colors.

Use Design Colors > Threads >> to toggle Threads docker display. Use it to find 
threads from different charts and change design colors. 

Default palette
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When you open an existing design, colors may have been already assigned to 
actual threads – e.g. ‘Isacord 40’. Adjust design colors as preferred. The simplest 
technique is to click objects in the design and select a color from the Design Colors 
toolbar. Many other techniques exist such as using the Sequence docker to select 
objects or entire color blocks. You can also select colors from different thread 
charts. See also Design colors.

Resize a design

To check design dimensions, press Ctrl+A to select the entire design. Check the 
Width and Height values in the Context toolbar. To resize a design, use the sizing 
controls on the Context toolbar to scale up or scale down. Or simply key in the 
required dimensions and press Enter. For example, if you are stitching a cap design, 
maximum size will be approximately 4.25" or 108 mm square. Alternatively, visually 
resize by clicking and dragging the sizing handles. See also Transform objects.

Note: If your design contains multiple objects, you can select each one 
individually. In this case, the dimensions shown in the Context toolbar relate to the 
selected object or objects, not the entire design. The dimensions of the entire 
design are always shown in the Status bar at the bottom of the screen.

Use Context > Size +10% to increase the size of selected objects in 10% increments.

Use Context > Size -10% to decrease the size of selected objects in 10% increments.

Use Context
controls to scale

objects numerically

Use sizing handles 
to manually resize 
designs
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Rotate object in a design

Select an object or entire design and click twice to activate rotation handles. Use 
these or the controls on the Context toolbar to rotate objects into position. See also 
Transform objects.

Visualize a design

Use Context > Rotate Left 15° to rotate selection in 15° increments to the left.

Use Context > Rotate Right 15° to rotate selection in 15° increments to the right.

Use Customize Design / Context > Background and Display Colors to change design 
background and display colors.

Enter precise 
rotation angle

Use rotation handles 
to rotate objects 
interactively



Chapte r  1     Gett ing  Sta r ted 26

Go to the Customize Design toolbox and use the Background and Display Colors 
tool to visualize the design on a garment or article. See Add backgrounds for 
details.

Hoop a design

Choose a hoop via the View toolbar or Context toolbar. Alternatively, right-click 
the Show Hoop icon to access the Embroidery Settings dialog. If possible, choose 
a hoop which covers the entire stitching area. See Hoop selection for details.

Click View > Show Hoop to show or hide hoop. Right-click for settings.

Visualize design 
on product 
backdrop

Choose from 
filtered hoop list

Select your machine 
and model
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Add simple lettering

Once you are used to sewing out designs and resizing, changing colors and fabric 
types, you will certainly want to create your own lettering designs. While it takes 
practice to obtain a good quality stitchout, it is as simple as typing letters 
on-screen to create an attractive lettering design.

Open a design

Use Manage Designs > Open Selected to open the design(s) selected in the 
Design Library.

Use Manage Designs > New From Selected to create new design(s) based on the 
selected design(s) and/or bitmap(s) from a chosen template.

Use Standard > Open Design to open an existing embroidery design.

Use Standard > New From Design to create a new design based on an existing 
design.
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Open a design. Typically you’ll want to add lettering to an existing design. Go to 
the Design Library via the tab or the Manage Designs toolbox. Choose from one 
of the many samples. See also Manage Designs.

Add lettering to a design

Add embroidery lettering to designs quickly and easily, either on-screen using 
current settings or via ‘object properties’. See Create lettering for details.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets or TrueType fonts, or edit selected lettering.
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Tip: For best results when stitching, do not exceed the recommended maximum or 
minimum sizes. Recommended maximum and minimum heights refer to UPPER 
CASE letters. Some lower case letters – e.g. a and c – are about 70% the height of 
a capital letter. Thus you may need to make these characters larger than the 
recommended minimum.

Adjust baselines and other settings
It’s then a simple matter to adjust baselines, formatting, spacing settings, and 
colors. See Lettering layouts for details.

Try stitching out your lettering design. Study the stitch quality. Be aware that 
different fonts sew out better at different sizes.

Advanced lettering

Once you have tried your hand at creating 
lettering designs and sewing them out, you 
will want to do more adventurous things, 
such as monograms, fancy lettering, flair 
scripts, raised lettering with trapunto, as well 
as special ‘elastic lettering’ effects. The 
creative possibilities are endless. Your 
appetite to try new things will be stimulated 
as you gain experience and confidence. 
Part of that involves becoming adept at 
using your sewing machine as well as 
sampling and checking design quality.

Adjust lettering 
baselines for 
curved lettering
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Tip: Remember to study the sample designs included with your Hatch Embroidery 
installation.

Monogramming

Hatch Embroidery makes the creation of monogramming designs simple with the 
Monogramming tool. Optionally include lettering, ornaments, and/or up to four 
concentric borders in your monograms. See also Monogramming.

Flair script

Flair script is a special font which 
allows you to add decorative flairs to 
the end of text objects, mimicking 
flamboyant handwriting flourishes. 
See Special lettering for details.

Lettering stitch effects

Use Lettering / Monogramming > Monogramming to create personalized monograms 
using a selection of predefined styles, border shapes and ornaments.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets or TrueType fonts, or edit selected lettering.

Use Context > Feather Edge to create rough edges and shading effects, or imitate 
fluffy textures.
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By default, lettering objects are filled with satin 
stitching. You can apply other fill stitch types, 
such as tatami or embossed fills, as with any 
embroidery object. See Stitch Types & Effects for 
details.

Lettering art

Apply ‘lettering art’ effects to embroidery lettering 
to make it bulge or arch, stretch or compress. See 
Lettering layouts for details.

Customize a design

Customizing designs is perhaps the most common scenario in embroidery. You will 
sometimes want to create a new design, usually from artwork, but more often you 
will want to take an existing design and ‘re-purpose’ it. We’ve already seen how 
to make global changes such as sizing, changing colors and fabrics. It won’t be 
long before you want to try more ‘invasive’ changes such as reshaping, removing, 
combining, duplicating, resequencing, changing stitch types and effects, etc. 
Here is a sampling of the things you may want to try.

Tip: Remember to study the sample designs included with your Hatch Embroidery 
installation.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets or TrueType fonts, or edit selected lettering.
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Combine designs

One technique you will undoubtedly use is 
combining design elements. This will in turn 
teach you a lot about other editing operations 
such as resizing, positioning, rotating, 
sequencing objects, as well as removing 
underlying stitching. See Insert designs for 
details.

Transform a design

Use Customize Design / Standard / Create Layouts > Insert Design to insert an 
existing embroidery design into the current design. This tool is also available via File 
menu.

Use Context > Mirror X to flip selection horizontally.

Use Context > Mirror Y to flip selection vertically.

Use Create Layouts > Mirror-Copy Horizontal to mirror and copy selected objects 
horizontally. 

Use Create Layouts > Mirror-Copy Vertical to mirror and copy selected objects 
vertically. 
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Depending on the type of design work you are doing, you can make use of your 
software tools for duplicating, rotating, and mirroring designs to create wreathes, 
kaleidoscopes, and other effects. See also Transform objects.

Reshape objects in a design

Reshaping operations may be called on for anything from minor modifications to 
object shapes to reshaping letters for special effects. In most cases, if it is 
selectable, it can be reshaped. See Reshape objects for details.

Add stitch effects

Use Edit Objects / Select > Reshape to reshape an object outline, stitch angles or 
enveloping.

Use Object Properties > Fill > Embossed to create decorative patterns of needle 
penetrations while keeping the appearance of solid stitching. Choose from a pattern 
library.

Use Object Properties > Fill > Motif to create decorative open fill stitching. Choose 
from a motif library.

Duplicate and mirror to 
create wreaths
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It won’t take long before you get bored with simple fills and outlines and want to 
try out some of the many artistic stitch types and effects your software provides. 
See Stitch Types & Effects for details.

Auto-digitizing

If you have graduated this far in exploring your machine and embroidery software, 
you are doing well. You can already achieve a great deal without having to 
actually do your own digitizing. However, if you have got this far, that is probably 
exactly what you want to do!
One of the quickest ways to get started is to use the automated techniques that 
the software provides. While there are limitations to what can be done this way, 
auto-digitizing nevertheless allows you to prototype design ideas relatively simply 
and may be sufficient for your purposes. At least for now!

Using artwork

To create good quality embroidery, you need to choose suitable artwork. Possible 
sources include:

 samples in the Picture folder
 books of embroidery patterns and children’s story books
 printed table cloths or tea towels
 business cards, post cards and wrapping paper
 clipart libraries of your word processing or graphics program
 Internet or CD clipart libraries

Apply artistic 
stitch types and 
effects

Use Artwork > Prepare Artwork for Embroidery to prepare selected bitmap artwork 
for automatic digitizing.
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 original artwork – e.g. children’s drawings.
Artwork that is not in digital format needs to be scanned correctly to produce 
good quality images. For both manual and automatic digitizing purposes, ‘clean’ 
artwork with a limited number of solid colors and well-defined outlines works best. 
The Artwork toolbar contains tools for inserting, scanning, and preparing artwork 
for automatic digitizing. See Electronic Artwork for details.

Tip: Unless you are an experienced digitizer, don’t use artwork which is too 
complicated.

Insert artwork

You can load bitmap images of various formats for use as digitizing backdrops. Go 
to the Artwork toolbox and select Insert Artwork. The same command is available 

Use Standard > Insert Artwork to import vector or bitmap artwork into current design 
as a backdrop for manual or automatic digitizing. This tool is also available via File 
menu.

Clean picture with 
well-defined outlines

Clean picture with 
well-defined color blocks

Complex picture, needs editing to 
create clean color blocks
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from the Auto-Digitize toolbox and Standard toolbar. See Electronic Artwork for 
details.

Click-to-fill artwork

Bitmap artwork consists of colored dots or pixels. When you zoom in on a small 
area, outlines become jagged and ‘pixelated’. The Click-to-Fill tools in the 

Use Auto-Digitize > Click-to-Fill to digitize large artwork shapes with tatami fill, 
preserving any holes within.

Use Auto-Digitize > Click-to-Outline to digitize boundaries of shapes with run 
stitching using current properties.

Select image
file type
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Auto-Digitize toolbox provide everything necessary to digitize bitmap shapes 
automatically. See also Click-to-digitize artwork.

Auto-digitize artwork

An extension of this technology, Auto-Digitize makes decisions about the most 
suitable stitch types to use and can digitize whole designs. See also Auto-digitize 
artwork.

Use Auto-Digitize > Auto-Digitize Instant Embroidery to automatically digitize whole 
embroidery design directly from the imported bitmap artwork.

Use Auto-Digitize > Auto-Digitize Embroidery to automatically digitize prepared 
bitmap artwork, optionally with user's choices.

Auto-digitize 
selected shapes

Auto-digitize 
entire design
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Next steps

If you have reached this point, you have 
already mastered 90% of the techniques that 
most embroiderers need. However, coming 
to grips with manual digitizing is the next step 
in becoming an embroidery master. You can 
start with quite simple projects and work your 
way up to more complicated designs with 
more complicated stitch effects. See also 
Digitize Objects.

Special embroidery features
Once you have mastered manual digitizing, you are in a position to take 
advantage of the full range of stitch types and effects that the software offers. 
Many of them you will be familiar with, having already adapted existing designs 
for different purposes. Some of the many techniques supported by the software 
include:

 Freehand
 Embossed fills
Curved fills
 Buttonholes
Refer to the User Guide or the many online resources.

Happy embroidery!
Do good work with your machine and software. With this equipment you have 
everything you need to create top quality, fully professional embroidery.
Remember to make good use of the packaged designs and clipart. When in 
doubt, go back to first principles. And when you find you want to expand and 
extend your repertoire, study the sample designs carefully to see how it’s done.
All the best. And have fun!
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PART I
HATCH SETUP

In order to work with your particular equipment, Hatch Embroidery needs to be 
properly configured. You may also want to configure the software to your 
particular design requirements.
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Chapter 2

SOFTWARE SETUP

This section describes how to install your embroidery software and all required 
components. It also deals with product integration with CorelDRAW®. There is also 
summary information about device connections as well as how to access product 
help & support.

System requirements

In order to run your software, you need to ensure that the following prerequisite 
system requirements are met.

Component Minimum Recommended

CPU Intel® Core i3 (6th Gen) or AMD Ryzen 3 Latest Intel® i5/7 processor or AMD 
Ryzen 6/7

Operating 
system

Microsoft® Windows® 10 (64-bit edition) 
with latest updates

Microsoft® Windows® 11 (64-bit edition) with 
latest updates

Browser Microsoft Edge or later Microsoft Edge or later

Memory 8 GB 16 GB or more

Hard disk size 80 GB 256 GB or more (solid state drive)



Chapte r  2     S of t ware  S et up 41

Before you start

There are various scenarios you may encounter when installing or upgrading 
Hatch Embroidery software:

 Download a trial
 Purchase after a trial
 Purchase without a trial
 Upgrade an existing installation
 Purchase with a product key
All of these scenarios require you to sign in, if you already have a Hatch Embroidery 
account, or register a new account. Simply go to the Hatch Embroidery website 
at hatchembroidery.com and click the Sign In button at the top of the screen. Any 
of the other buttons on the home page – Buy Digitizer, Download Free Trial, 
Update/Upgrade to Hatch 3, etc – will eventually lead to the same sign-in screen.
If you have an existing installation, take note of the following...

Custom assets
Hatch Embroidery allows you to create files or ‘assets’ of various kinds during 
normal use. The most important of these are of course actual embroidery designs. 
There are other assets you may create such as design templates, custom motifs 
and borders, and keyboard design collections. These assets are preserved from 
installation to installation, whether installing a new version of Hatch Embroidery or 
an update patch. If you want to move your Hatch Embroidery to another PC, you 
will need to manually transfer any custom assets you have created or received 
from third parties. See Personal data for details.

Free disk 
space

40 GB 60 GB or more

Graphics card Support for Highest Color (32bit) and screen 
resolution 1920 x 1080

Support for Highest Color (32bit) with 3D 
acceleration and screen resolution 2560 x 
1440 or higher

Monitor 1920 x 1080 screen resolution Dual monitors capable of 2560 x 1440 
screen resolution

Sound Required for online video help Required for online video help

Windows file 
server

For fast searching on shared network drives, you will need a minimum of Windows Server 
2010 on the server to enable fast-search indexing.

Internet 
connection

Required to sign in to Hatch Embroidery 3, receive software updates, and access online 
content. You can use Hatch Embroidery offline provided you connect to the Internet at least 
once every 30 days to validate your software license. You will not have access to all features 
while working offline.

Component Minimum Recommended

https://www.hatchembroidery.com
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Caution: When installing new or updated assets, such as design templates, custom 
motifs and borders, or keyboard design collections, the installation procedure will 
not overwrite existing assets of the same name. If you do want to install new assets, 
remove or back up the old ones before updating your current installation.

Periodic updates
Periodically you will receive automatic updates to your software installation. These 
will include improvements and fixes to known problems. To update your 
embroidery software...

Connect your computer to the internet.
 Start your Hatch Embroidery software. It will automatically check for software 

updates.
 If it is not up-to-date, you will be prompted to start the update.
 The required file will be downloaded from a secure server.
Once download has completed, follow the prompts.
Once completed you will need to restart your PC for all changes to take effect.

Note: Automatic updates overwrite your ‘normal’ template. If you have made 
changes, you will need to save them to a custom template – e.g. ‘My Template’.

License management
Each licensed copy of the software is for a single user. You may install Hatch 
Embroidery on multiple computers but only one active session can be used at one 
time. Some frequently asked questions...

 How do I release the Hatch 3 license on my computer to use it on another 
computer? See this article.

 If I uninstall the software does that does release my license? In short - No!
 How do I use Hatch Embroidery while not connected to the internet? On the 

Sign-in dialog, select ‘Keep me signed in’ and you will not have to re-connect 
to the Internet for 30 days.

Registration & installation

Whether you are downloading a trial, purchasing Hatch Embroidery from the 
website, or purchasing the software with a product key, you will need to sign in or 
register a new account. Registration simply requires a username, an email address, 
and a password of your choosing. Registration is linked to your email account.

https://help.hatchembroidery.com/hc/en-us/articles/4903749849871-How-do-I-release-the-Hatch-v3-license-on-my-computer-to-use-Hatch-v3-license-on-another-computer


Chapte r  2     S of t ware  S et up 43

Sign in or register an account
If you download or purchase directly from the Hatch Embroidery website, you will 
not need a product key. It will automatically be assigned to the email used to 
create your Hatch Embroidery account.

To sign in or register an account...
1 Go to the Hatch Embroidery website at hatchembroidery.com and click the 

Sign In button at the top of the screen or one of the other buttons on the home 
page. You will encounter the below sign-in screen...

Note: If you are already registered, simply enter your email and password. Your 
Hatch Embroidery account is registered to your email address.

Click to register a 
new account

Click to sign in to an 
existing account

https://www.hatchembroidery.com
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2 Click the Register new account button to access the below registration form. 

3 Enter a few personal details together with a password you can easily memorize. 
Keep a written copy in case you forget.

Registration linked 
to email account

Click to register
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4 Click Register. You will receive a confirmation code via email.

5 Copy and paste the confirmation code and click the Submit button.

Install the software
If you are installing on an operating system (OS) that is in a supported language, 
the installation process will run in that language.

Copy the 
confirmaton code to 
the clipboard

Enter the 
confirmaton code to 
complete registration
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To install the software...
1 Ensure your computer meets the system requirements.
2 Close all MS Windows® applications.

Note: When you install the software, you will be prompted to reboot your PC to 
complete the installation. Make sure you save any files and close all 
applications beforehand.

3 Run the installation.
4 Follow the onscreen instructions. You will be prompted to choose:
where the software will be installed on your PC (default location 

recommended)
which components to install – i.e. additional languages. English is the 

default.
which installed version you wish to merge user-defined settings with.

5 Reboot the PC when prompted.

Note: If you encounter problems with the installation, please contact Hatch 
Support.

Run the software

Once you have rebooted your PC following installation, you can run the software.

To run the software...
1 Double-click the icon on the desktop to start the software for the first time.
2 When prompted, enter your Hatch Embroidery email and password in the fields 

provided.
3 Click OK and the software will connect to our activation server and the 

software will open.

Run Hatch Embroidery in other languages
If you want to install and run a specific language on an English OS, you will need 
to select it from the available languages during installation. The software will then 

Double-click on the Windows Desktop to start Hatch Embroidery.

https://help.hatchembroidery.com/hc/en-us/requests/new
https://help.hatchembroidery.com/hc/en-us/requests/new


Chapte r  2     S of t ware  S et up 47

need to be ‘switched’ to the additional installed language from the Hatch 
Embroidery program group before it can be run in that language.

Run Hatch Embroidery on MAC computer
Hatch Embroidery has been developed for Windows operating system. However, 
many customers successfully run Hatch Embroidery on their MAC computers by 
using ‘Parallels’ and ‘Windows for MAC’. Parallels is designed to be installed on 
MAC computers to run Windows programs. For more information, see Parallels 
website. If you have a MAC with an M1 chip, see this FAQ.

Activate software with product key
If you download or purchase directly from the Hatch Embroidery website, you will 
not need a product key. It will be automatically assigned to the email used to 
create your Hatch Embroidery account. You will only receive a product key if you 
have purchased the software directly from a reseller at a show, retail shop, or 
receive it with your machine. You may have received a 5-part product key in the 
form...

d566695e-zzxx-4417-a5e7-8326056cd267

The product key can be activated after your Hatch Embroidery software is already 
installed. Once you have input your product key, you never need to use it again. 
It has a one-time use. Once activated, it is assigned to your email.

Switch to additional 
language as 
preferred

https://www.parallels.com/
https://www.parallels.com/
https://help.hatchembroidery.com/hc/en-us/articles/4403994060047-How-to-Install-Windows-on-Mac-with-Apple-M1-Chip-using-Parallels-Desktop
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To activate the software with a product key...
1 Launch Hatch Embroidery. If your Hatch Embroidery software has not yet been 

activated, the trial period screen will appear.

2 If you have not yet activated your Hatch Embroidery installation and you have 
a product key, click Activate with Product Key.

Click to activate 
the product

Enter your 
product key
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3 Enter or paste your 5-part Hatch Embroidery product key and click the Activate 
Product button. Once activated, the below confirmation message will appear.

The next time you launch Hatch Embroidery, simply sign into your account and 
the software will start. To avoid signing in each time, ensure the ‘Keep me 
signed in’ option is ticked.

Click to launch 
your product

Keep signed into 
to the current 
installation
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Integration with CorelDRAW®

Integration with CorelDRAW software can be activated according to product 
level. It is available to customers who have purchased CorelDRAW GEM for Hatch 
Embroidery or already have a compatible version of CorelDRAW software 
installed.

Usage tips
 Integration is currently only available with certain models of CorelDRAW 

software. For more information, see FAQs on the Hatch Embroidery website.
Currently, CorelDRAW software can be linked to Hatch Digitizer and Hatch 

Composer only.
 Hatch Embroidery only supports the MS Windows® version of CorelDRAW®. 
 You will be prompted to link upon launching Hatch Embroidery.

 Some CorelDRAW® functions may not be available in Graphics Mode. 
 To purchase CorelDRAW Standard 2021, visit the products page of the Hatch 

Embroidery 3 website.

https://help.hatchembroidery.com/hc/en-us/articles/4890730088079
https://hatchembroidery.com/coreldraw/
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Device connections

You will need to connect peripheral devices for use with Hatch Embroidery. 
These may include digitizing tablets, printers, scanners and embroidery 
machines. Different devices are set up in different ways – some in 
MS Windows®, via the Control Panel, others within Hatch Embroidery itself.

Tip: The number of available ports limits the number of devices you can 
connect. If additional ports are required, you can add them. Multi-port serial 
cards can also be used. See a PC technician about your requirements.

Machine connection
Hatch Embroidery supports various sets of machine model. Most machine models 
can read USB memory sticks. These are convenient portable memory devices 
which can hold large amounts of data.

Tip: Some customers want to connect their embroidery software directly to 
machine. If your embroidery machine can be seen as an external drive in File 
Explorer, you may be able to send designs directly. For instance, some single 
needle Brother machines have a mode which enables them to be set up like this.

Related topics

Machine selection
 Hoop selection
 Transfer designs
 How to connect directly to embroidery machine

https://help.hatchembroidery.com/hc/en-us/articles/360000115375-How-to-connect-directly-to-my-embroidery-machine-
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Scanner setup
Your embroidery software supports TWAIN-compatible scanners. Peripheral 
devices can be connected to your computer via serial ports, parallel ports, a 
specialized network card or an Ethernet network.

To set up the scanner...
1 Connect the scanner using the accompanying instructions.
2 Set it up in MS Windows® using the accompanying instructions and/or the 

MS Windows® documentation.
3 Start Hatch Embroidery.
4 Select Software Settings > Scanner Setup. The Select Source dialog opens 

displaying a list of scanner drivers loaded on your computer.

5 Select the scanning driver to use, then click Select.

Note: If you have trouble with scanning after re-starting the software, there may 
be a conflict with previously installed scanner drivers. Re-install the software and 
test the scanner. If the selected scanner driver does not work, select another 
scanner driver from the list. There are usually two installed for each scanner.

Configure embroidery libraries in File Explorer

If you are already familiar with File Explorer, the Design Library interface will be 
quite intuitive to you. You may, however, need to make a few adjustments to 
folder options for recommended embroidery design settings. The steps below are 
based on Windows 10 settings.

Activate embroidery libraries in File Explorer
Embroidery libraries may not automatically appear in Windows 10. If you do not 
see your them in File Explorer, follow the steps below.

To activate embroidery libraries in File Explorer...
1 Go to File Explorer and select This PC.
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2 Right-click the empty window to invoke the popup menu as shown.

3 Alternatively, click the Navigation pane to open the dropdown smenu.

4 Select Show libraries. Embroidery libraries are added to File Explorer.

Select ‘This PC’

Choose ‘Show 
Libraries’

Activate ‘Show libraries’

Select ‘This PC’

Embroidery libraries 
now visible



Chapte r  2     S of t ware  S et up 54

Note: If you want to display embroidery libraries in the Save As dialog, you need 
to activate them in the same way.

Related topics

Manage Designs
 Browse designs

Configure design thumbnails
In some Windows 10/11 installations, embroidery design thumbnails may not 
automatically appear. If so, follow the steps below.

To configure design thumbnails...

 Start the File Explorer program from the Windows taskbar.

Activate libraries in 
Save As dialog

Open File
Explorer
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 Select the Embroidery folder.

Note: Embroidery libraries do not automatically appear in some installations of 
Windows 10/11. See Browse designs for details.

Go to File Explorer > View > Options and select Change folder and search 
options.

 The Folder Options dialog opens.

Select
Embroidery folder

Select ‘Change folder
and search options’

Apply settings to
all folders
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Go to the View tab. Several Windows default settings are not ideal for 
embroidery. Recommended settings include:

Click Apply to Folders to apply settings to the Embroidery folders. Summary:

 If your File Explorer settings are properly configured, thumbnail images will 
appear as expected in the Design Library:

Tip: In addition to the Design Library, these settings affect how thumbnails display 
in File Explorer and other Windows applications.

Setting Reason

Always show icons, 
never thumbnails

Untick So thumbnail images of embroidery designs will 
show, not the program icon.

Display file icon on 
thumbnails

Untick So program icons do not display in the corner of 
design thumbnails.

Hide extensions for 
known file types

Untick So you can see the different types of embroidery 
design files – EMB, DST, JEF, etc.

Show preview handlers 
in preview pane

Tick So you can see a preview of the embroidery design 
in the preview pane.
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Fast searching on shared network drives
For networks with multiple computers reading and writing EMB or machine format 
designs, you may want to set up a dedicated PC as a repository for all design files. 
Connect any folders on the repository to each ‘client’ PC via Design Library. 
Design Library relies on Windows indexing to ensure fast searching. 

To set up searching on shared network drives...

 For the Windows file server, make sure you have the Windows Search service 
running. You should have the latest Windows Server installed to enable 
fast-search indexing. You will also need some version of Hatch Embroidery 
installed.

 Add the design folder to be shared with the indexing function. Go to Control 
Panel > Indexing Options > Modify and select the correct path.

 Install Hatch Embroidery so that the Shell Extension is registered. This allows the 
server to index additional embroidery file properties.

Once the server has finished indexing the folder, then, for every PC using the file 
server, add the design folder to Design Library. See above.

Add design folder 
as indexed location
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Product help & support

Hatch Embroidery provides many ways to access information about the software 
and how to use it. You will need a correctly configured web browser together with 
web access.

Product help
Refer to the Help menu for the following sources of information...

 ‘Release Notes’ and a ‘Quick Start Guide’ can be viewed and downloaded via 
the Help menu.

 Follow the link to Product Help to download a PDF of the entire Hatch 
Embroidery User Guide.

 A printed copy can also be ordered via Product Help.
 The Hints docker provides a valuable learning resource from within the 

software. It can be activated via the Help menu. Each hint includes a brief 
feature summary together with a link to a short video.

 Note that ‘just-in-time’ help for each tool can also be accessed via F1 keypress. 
Simply point to the tool and press F1.

 The Help menu also provides access to the Hatch Academy. This resource 
provides free and paid online courses from Hatch and embroidery experts. 
Resources include embroidery basics, Hatch software training and projects.

Product help 
available online

Training material and 
courses available from 
Hatch Academy

https://profile.hatchembroidery.com/?return_url=https://academy.hatchembroidery.com/enrollments
https://hatch.embroideryhelp.net/v3/en/index.htm
https://hatch.embroideryhelp.net/v3/en/index.htm
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 Run the Check for updates command to check for periodic software updates.

Product support
You can access technical support and account and billing information easily from 
online Help & Support. Below are some common troubleshooting issues. Click the 
links or use as keywords to search for information on the Help & Support page.

 System requirements
 Preliminary checks
Missing toolboxes, toolbars, or empty dockers
Missing control points
 Exception access violation at startup
 Hardware or software failure
 Security problems
 HASP LM not running during installation
 Purge corrupted, recovery, and backup files
 Revert to factory settings
 Display embroidery libraries in Windows 10

Tip: If you can’t find the information you need, you can also raise a support ticket 
from Help & Support. Or report an issue as outlined below.

Follow link for 
details

Download and 
install as preferred

https://help.hatchembroidery.com/hc/en-us/articles/115002133468-What-are-the-System-Requirements-for-Hatch-Embroidery-Software
help.hatchembroidery.com
https://help.hatchembroidery.com/hc/en-us/articles/5741359266319
https://help.hatchembroidery.com/hc/en-us/articles/5741457474447
https://help.hatchembroidery.com/hc/en-us/articles/5741477984783
https://help.hatchembroidery.com/hc/en-us/articles/5741481176719
https://help.hatchembroidery.com/hc/en-us/articles/5741538929039
help.hatchembroidery.com
https://help.hatchembroidery.com/hc/en-us/articles/360000140615-Toolbars-or-Dockers-misplaced-or-missing-information-Reset-Toolbar-Layout
https://help.hatchembroidery.com/hc/en-us/articles/360001162695-A-valid-license-to-run-Hatch-Embroidery-could-not-be-found-H0007
https://help.hatchembroidery.com/hc/en-us/articles/115011355368-How-to-reset-back-to-default-settings-in-Hatch-Embroidery
help.hatchembroidery.com
https://help.hatchembroidery.com/hc/en-us/articles/115011355268-How-do-I-delete-recovery-files-in-Hatch-Embroidery
https://help.hatchembroidery.com/hc/en-us/articles/5741595764367
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Issue reporting
Hatch Embroidery includes a feedback reporter, when connected to the internet, 
to provide direct contact with Hatch Support following a system crash...

Use the issue reporter to request assistance on specific issues. The reporter can also 
be run independently from the Hatch Embroidery program group.

Report an issue in the
event of a system

crash

Report an issue in the 
event of a system crash

https://hatchembroidery.com/support/
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Chapter 3

SOFTWARE SETTINGS

Configure the Hatch Embroidery work environment to suit your working 
methodology. For instance, set up your personal hoop list, set design backgrounds, 
unit of measurement, and so on.

Machine selection

Different embroidery machines speak different languages. Before you can stitch a 
design, it must be in a file format which can be understood by the embroidery 
machine. When you select a machine format, Hatch Embroidery uses it to 
translate digitized designs into machine-readable form. The software supports 
various sets of machine model. Most machine models can read USB memory sticks. 
These are convenient portable memory devices which can hold large amounts of 
data.

Note: Some customers want to connect Hatch Embroidery directly to machine. If 
your embroidery machine can be seen as an external drive in File Explorer, you 
may be able to send designs directly. For instance, some single needle Brother 
machines have a mode which enables them to be set up like this. See Transfer 
designs for details. See also FAQs on the Hatch Embroidery website.

https://help.hatchembroidery.com/hc/en-us/articles/360000115375-How-to-connect-directly-to-my-embroidery-machine-
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Select machine model or type

Hatch Embroidery supports many machine brands and models. These are 
available from the droplists on the Context toolbar. Choose your machine brand 
from the droplist.

Choose your machine model or type from the accompanying droplist. When the 
Janome or Elna machine brand is selected, you can select one of the available 
machine models. When any other machine brand is selected, you have a choice 
of ‘single-needle’ or ‘multi-needle’ machine types.

Alternatively, use the Embroidery Settings dialog to preset machine brand and 
model. Click the Machine & Hoop Options button to access these settings.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Choose your 
machine brand

Choose your 
machine model

Choose your 
machine brand
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Depending on the selected machine brand, you may have the option of selecting 
your machine type – single- or multi-needle. Different hoops are available for each 
of these machine types.

Note: With PES format specifically, the hoop code output for the same size hoop 
differs depending on whether the machine type is single or multi-needle.

Configure hoop list

The Hoop List on the Context toolbar shows which hoops are currently available for 
your selected machine. When you first run the software, the hoop list is populated 
with standard hoops for the selected machine. This list may be configured to 
include non-standard hoops you may wish to use.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Choose your 
machine type

Currently available
hoops
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To configure your hoop list...
1 Click the Machine & Hoop Options button to access the dialog.

2 Click the Add/Remove Hoops button to associate a custom hoop list with the 
selected machine. The dialog opens. The left-hand panel shows all hoops 
available for the selected machine. It also shows custom hoops you may have 
added.

3 Select hoops you own in the Available hoops list. Transfer them via the arrow 
buttons to the Machine hoops list in the right-hand panel.

4 Click OK. The hoop list is available for use. Whenever you select this machine, 
the hoop list is filtered according to your selection.

Tip: Hatch Embroidery allows you to define your own hoops and save for later 
use. Custom hoops are needed because new hoops become available for 
sewing machines more frequently than the software is updated. Also some 
machines include hoop adapters for third-party hoops which need to be 
defined in the software.

Hoops added 
to your list

Click to configure hoop 
list for selected machine

Currently
available hoops

Selected machine 
model

Currently available
hoops
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Related topics

 Hoop selection
Custom hoops

Create custom brand

Hatch Embroidery supports most domestic machine brands and models. However, 
if you have a different machine, you may need to set up a custom brand and 
hoop list.

To define a custom brand...
1 Right-click the Show Hoop icon to open the dialog.
2 Click the Create button in the Hoop panel. The Create Brand dialog opens.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Click Create to
create custom

brand

Enter name of new 
machine brand
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3 Enter a name for your new machine brand and click OK. The Add/Remove 
Hoops dialog opens.

Tip: Green hoop icons represent single-needle hoops while blue icons represent 
multi-needle hoops.

4 Select hoops you want to associate with the new brand from the Available 
hoops panel. Use the controls to transfer them to the Machine hoops panel and 
click OK.

Note: Once your new brand is saved, it can be edited or removed via the 
available buttons in the Machine & Hoop tab.

Set start & end points

Before stitching, some embroidery machines require you to position the hoop 
precisely in relation to the needle. Some machines require stitching to start in the 
center of the hoop, some at the periphery. Some machines require the needle to 
finish at the center, others at the last stitch.

Click View > Show Hoop to show or hide hoop. Right-click for settings.

Use Customize Design / Output Design > Auto Start and End to set start and end 
points for the entire design.

Select hoops for
new machine

brand

Click to create
custom hoop

Hoops added 
to your list

Edit or remove custom 
brand as needed
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To set and end points...

 Turn on connectors via the Show Design droplist or press Shift+C. A green circle 
indicates the start point while a white square indicates the end point.

 Use the Auto Start and End shortcut in the Customize Design toolbox to access 
the dialog. The Design Settings menu also provides a link. By default, design start 
and end points are set according to the currently selected machine and hoop. 
These correspond to cross hairs on the hoop.

 Sometimes you want to set your own start and end points for a particular design 
or hoop. Click Start position and End position to activate options. In the 
example below, start and end points are set to top left and bottom right 
respectively.

Start point

End point

Start and end points 
set according to 
current machine and 
hoop

Save to template

Set start point
within hoop

Set end point
within hoop
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 Alternatively, digitize your own start and/or end points by choosing the Manual 
method. This is usually used to align embroidery with other components on the 
garment or article.
 By ticking the checkbox, you will be prompted to mark the start/end point 

after closing the dialog.
 By leaving it unticked, the software will use the previously-digitized position.

 Alternatively, untick Start position and End position checkboxes to return 
settings to default values – the first and last stitch of the design become start 
and end points.

Click OK. Connecting stitches will be inserted as required before the first and 
after the last stitches of the design.

 Use the Save button to save your preference to the template. This becomes the 
default setting for all new blank designs.

Usage tips
Check your machine for the required start and end needle positions. If not to 

set correctly in the software, your machine may not be able to read the design.
 Some file formats will override auto start and end settings set in the software.
 The Manual method is also convenient if you want to prevent the hoop moving 

around while digitizing, as occurs with Automatic Centering. 
 By setting manual start and end points, the hoop remains in a fixed position, 

similar to Brother PE-Design. This gives you the freedom to position objects 
anywhere within the hoop. It is especially useful for multi-position hoops as it can 
help to minimize re-hooping.

 The Context > Center All command can be used to center the whole design 
and hoop at the (0,0) position. This means you can reposition the hoop around 

Untick start 
position

Untick end 
position
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the design after you have finished digitizing without the need for 
auto-centering.

Related topics

Center hoops

Design settings

Hatch Embroidery provides a number of 
global settings which apply to entire 
designs. The Auto Start & End feature is 
available to connect first and last 
stitches in a design. This is important for 
needle positioning. The Remove Small 
Stitches function automatically removes 
unwanted small stitches from a design 
either on opening or on output.

Background colors

Set the color inside the hoop to match the fabric you intend to stitch out on. You 
can also set a background color outside the hoop by way of contrast. 

To set background colors...

 Select Customize Design > Background and Display Colors or right-click the 
design window and select from the popup menu.

Use Customize Design / Context > Background and Display Colors to change design 
background and display colors.
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 To select a color inside the hoop, choose the Solid Color option. This allows you 
to set separate colors inside and outside the hoop. Select a color from the 
palette or mix your own.

 Set the color inside the hoop to match the color of the fabric you intend to 
stitch out on.

Related topics

 Add backgrounds

Eliminate small stitches
Small stitches can damage fabric and cause thread or needle breakage. Before 
you stitch out, unwanted small stitches can be automatically removed. The filter 
can be applied continuously, on output only, or never.

Set colors inside and
outside hoop
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To eliminate small stitches...

 Select Design Settings > Remove Small Stitches.

Choose your preferred option:
When set to Always, the filter will be automatically applied in the 

background whenever objects are edited or digitized.
When set to On Output, the filter is only applied when printing or outputting 

files.
 Enter the minimum Stitch length you want to preserve.
Click OK to confirm.
Check the Status Bar for the new stitch count.

Design measurement

Use grid and guide lines to help 
accurately align or size embroidery 
objects. The grid can be turned on or 
off and grid spacing changed as 
preferred.
In addition a ruler can be turned on 
or off for accurate measuring. The 
zero point of the ruler can be set to 
any point on the design or design 
window. The ruler scale depends on 
the zoom setting.
Together with the ruler, guides can 
be placed across the design window 
to help align objects. Each guide has 
a yellow handle on the ruler to move 
or delete it. Guides are displayed on 
top of the grid, if present, but ‘beneath’ design objects. Rulers must be displayed 
before a guide can be set.
You can use different measurement units within Hatch Embroidery without having 
to exit and change system settings. This is useful, for example, if you receive a 
request from somewhere that uses a different measurement system. For instance, 

Choose automatic 
small stitch removal 
option
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a US contact may request lettering in inches – say ¾" – while you are working in 
metric. Hatch Embroidery allows you to enter ‘3/4"‘ without having to do any 
mathematical conversion to mm yourself.

Monitor calibration
You may need to calibrate your monitor so that designs at 1:1 scale appear at real 
size. Do this when you first install Hatch Embroidery or when changing monitors. 
Screen calibration is generally not required on Windows 10/11 as this is handled by 
the operating system itself. The first time you run Hatch Embroidery, the 
measurement system will default to whatever the operating system is using.

To calibrate the monitor...
1 Choose the preferred measurement system via the droplist on the Context 

toolbar.

Tip: To get the most precise measurements for screen calibration, it is 
recommended you use the Metric setting. Also, if you are using multiple 
monitors, take the measurement on your computer’s main monitor.

2 Select Software Settings > Calibrate Screen.

3 Measure the width and height of the dialog box. Make sure you measure edge 
to edge.

4 Enter the precise measurements in the relevant fields.
5 Click OK to confirm.

Change measurement units

Use Context > Measurement Units to change measurement units within software 
without changing operating system settings.

Choose preferred
measurement units

Measure width

Measure 
height
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The default unit of measurement – mm or inches – depends on the regional settings 
in the Windows Control Panel. The first time you run Hatch Embroidery, the 
measurement system will default to whatever the operating system is using. The 
measurement units can be changed via the droplist on the Context toolbar. 
Technically, when you select ‘U.S.’, you will get the imperial measurement system 
– inches, feet, and yards. The selected measurement system will default the next 
time you run the software.

Changing the measurement system will change the units used by most (but not all) 
controls. Stitch length and density controls will change to reflect the measurement 
system.

Tip: The Context toolbar is dynamically configured depending on which objects 
you have selected. The measurement droplist only appears when no objects are 
currently selected.

Specify units on-the-fly
As an alternative to changing the overall measurement system used in the 
software, you can specify units of measurement when typing values into a 
measurement control. When you include the unit of measurement, Hatch 
Embroidery automatically converts the entered value into the units of the control.

Say, for example, you are using the metric measurement system so your lettering 
heights are in mm. And say you receive a request for ¾" lettering. Simply enter 
‘3/4in’ or ‘3/4 in’ into the Lettering Height field and it is automatically converted to 
19.1mm.

Choose preferred
measurement units

Specify unit of
measurement

on-the-fly

Height converted
to current units
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Tip: Hatch Embroidery supports both proper and improper fractions – e.g. ‘1 1/3’ 
as well as ‘4/3’. It does not, however, support mixed units – e.g. 1’3". Nor does it 
display values as fractions after they are entered, only during.

Supported units
Supported units include:

millimeters, mm
 inches, in
 feet, ft
 yards, yd
 centimeters, cm
meters, m
Hatch Embroidery also allows entering units in text form, both English and the 
language the software is currently running in.

Rulers & guides

Hatch Embroidery allows you to turn rulers on and off and create guides for more 
accurate digitizing. These make it possible to accurately position and size objects 
and whole designs.

To display rulers and guides...

 Turn on grids and rulers via the View toolbar.

Click View > Show Rulers & Guides to show or hide rulers and guides. Right-click for 
settings.

This button appears at the point where rulers intersect. Click to set the ruler zero 
point to the top left corner. Alternatively, drag to set a zero point in the design window.

Turn on grids 
and rulers
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 Alternatively, right-click a blank part of the design window to invoke the popup 
menu.

 Reset the ruler zero point by clicking and dragging the box in the top left-hand 
corner to a point on the design. This becomes the new zero point – X,Y (0,0). The 
grid always aligns with the rulers.

 To create a guide, click on either ruler – horizontal or vertical – and 
click-and-drag into position. Multiple guides can be created and just as easily 
removed.

Turn on grids 
and rulers

Click and drag
to reset zero

point

Click ruler to
create a

guideline
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 For more accurate positioning, double-click the yellow guide handle. In the 
Guide Position dialog, enter a precise distance from the zero point, and click 
OK.

 To remove a guide, drag the yellow guide handle off the design window.

Grids & hoop templates

Templates for all hoops are included in Hatch Embroidery. They can be used for 
positioning in place of the design grid. Alternatively, use grid lines to help 
accurately align or size embroidery objects. Grid and hoop template are mutually 
exclusive.

To display grid or hoop template...

 Adjust the background as preferred.
Click the Show Hoop Template icon to toggle hoop template display on or off.

Click View > Show Grid to show or hide grid. Right-click for settings.

Click View > Show Hoop Template to show or hide hoop template.

Enter precise 
distance from zero 
point
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Click the Show Grid icon to toggle grid display on or off.

 Right-click the Show grid icon to access grid settings. Optionally, adjust grid 
spacing and turn on Snap to grid.

 You can adjust grid spacing in both horizontal and vertical directions. 
Sometimes you might want to set it for precise design work such as cross stitch.

Optionally, activate Snap to grid and Snap to guides. Reference points, control 
points or leading edges of objects ‘snap’ to grid lines during digitizing, sizing, 
reshaping, or positioning operations.

 Select the Set reference point checkbox to set the zero point of the rule. For 
example, you can set the grid reference point to the design center. This is easier 
and faster than moving the whole design. When you close the dialog, you are 
prompted to mark the zero point of your design.

Tip: To temporarily disable Snap to grid as you work, hold down the Alt key.

Adjust grid 
spacing
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Measure distances on screen

Measure the distance between two points on screen using the Measure tool. 
Measurements are shown in millimeters or inches, depending on current settings.

To measure distances on screen...

 Select View > Measure Tool or press M.
Click the start point and drag the mouse. The tooltip displays the length of the 

measured line. The angle shown is the angle of the measured line relative to the 
horizontal.

 Press Esc to finish.
 You can also check the width and height of your design in the status bar.

Tip: For more accurate results, zoom in before you measure. The measurement is 
always the actual size and is not affected by zoom factor.

System preferences

The User Interface Settings dialog is an important dialog in Hatch Embroidery. It 
allows you to control a variety of system defaults including automatic save options, 
toolbar display options, auto-save and scrolling preferences, mouse-wheel 
behavior, and other general options. Access the dialog via Software Settings > 

Use Context > Measurement Units to change measurement units within software 
without changing operating system settings.
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User Interface Settings. Alternatively, right-click a blank part of the design window 
to access the command from the popup menu.

Customer experience program
Hatch Embroidery includes a Customer Experience Program which is designed to 
provide Wilcom with valuable data concerning software usage patterns. The 
program is entirely anonymous and is aimed at improving the features and 
functions of Hatch Embroidery. However, you have the option of opting out of the 
program altogether by deactivating the checkbox in the dialog. Access the 
dialog via the Software Settings > Customer Experience Program command.

Automatic save options
Open the User Interface Settings dialog and choose the General tab. Save your 
work automatically at regular intervals using Auto Save to protect you from losing 

Access user 
interface settings 
from popup menu
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work in the event of hardware or software failure. Select the Auto-save design 
every checkbox and specify an auto-save frequency in minutes.

Note: The design will be saved in the BACKUP folder of your installation. It will have 
the same name as the original file with the extension EMB. Backup files remain in 
the backup folder until you delete them. To prevent the folder from using too much 
hard disk space, delete unwanted files regularly. For more information, see FAQs 
on the Hatch Embroidery website.

Start screen options
The User Interface Settings > General tab allows you to preset the preferred default 
screen upon startup – Home, Design Library, or Embroidery Mode.

Edit artwork options
Sometimes you need to edit images directly in a third-party graphics package. 
You would normally do this in order to eliminate backgrounds, flood-fill solid areas 
with color, or add outlines, close gaps, or reinforce outlines. The User Interface 
Settings > General tab allows you to pre-select your preferred graphics package 
– Paint, CorelPHOTO-PAINT, or Paint Shop Pro.

Related topics

 Edit artwork externally

Set auto-save 
timing

Set preferred 
startup screen

Set preferred 
graphics package

https://help.hatchembroidery.com/hc/en-us/articles/115011355268-How-to-delete-recovery-files-in-Hatch
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Font list display options
You can set the size of your font preview via the User Interface Settings > General 
tab. You can also adjust the number of recently used fonts.

Related topics

 Add lettering

Toolbar display options
Customize the user interface to suit your preference or monitor. The User Interface 
Settings > General tab allows you the choice of large or small tool icons, with or 
without short names.

You may wish to activate large icons for better visibility, especially when working 
with 4K high resolution monitors. Buttons are large enough to be seen while 
allowing effective use of the large design window.

Set font preview 
size

Set number of recent 
fonts shown in font list

Show large or
small icons



Chapte r  3     S of t ware  S et t ings 82

Auto-scroll behavior
Use User Interface Settings > Auto Scroll to scroll automatically within the design 
window while digitizing. This can be more convenient than using panning or scroll 
bars, especially when working on large designs.

Auto scroll options include:

The effect of the Auto Scroll setting only becomes apparent when you start to 
digitize. The design window automatically scrolls to follow the current cursor 
position. The Move Pointer option gives you the following choices:

Tip: Hold down the Alt key to temporarily deactivate Auto Scroll. Use the 
Ctrl+Shift+A key combination to toggle Auto Scroll on/off.

Mouse-wheel behavior
The Scrolling tab also allows you to set four different mouse wheel behaviors based 
on your selection of default options. Whenever a setting is changed, the system will 

Option Purpose

Auto scroll Tick checkbox to enable automatic scrolling while digitizing.

Move pointer after 
scroll

Tick checkbox to force pointer to move with the current cursor position 
after each scroll.

Response time Enter smaller values to increase scrolling speed.

Option Purpose

Center Center of the window. Use this setting for large movements.

Midway Halfway between the original pointer position and the center of the window. Use 
this setting for smaller movements – e.g. when zooming into a small area of the 
design.

Corner The edge of the screen. Use this setting for slow scrolling or when using the 
Freehand Digitizing tools.

Set auto-scroll 
behavior
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update other mouse wheel behaviors, but you have complete control to change 
as desired.

The same four options are available for use when deploying the mouse wheel on 
its own or in combination with Alt, Ctrl, and Shift keystrokes. That is, you can 
program the wheel to scroll horizontally, vertically, or zoom by preset factors. Tick 
Center pointer when zooming to ensure that the pointer stays centered on screen 
at all times.

Other general options
Miscellaneous other system settings available via the User Interface Settings > 
General tab.

These options include:

Embroidery settings

The Embroidery Settings dialog is another important dialog in Hatch Embroidery. It 
allows you to preset behaviors for design handling, design editing, overlapping 
objects, appliqué frame-outs, machine and hoop configuration, as well as 
multi-hooping registration marks and color optimization. Access the dialog via 
Software Settings > Embroidery Settings.

Option Purpose

Show measure 
tooltip

Shows length and angle in a tooltip when measuring distances on 
screen. See also Design measurement.

Enable mouse-click 
sound

Enables beeping sounds made by the software in response to mouse 
clicks and pressing <Enter> or <Spacebar> keys while digitizing.

Crosshair cursor Changes the default cursor pointer to crosshairs for more precise 
positioning. It is best used together with the grid.

Set mouse 
wheel behavior

Set general 
behavior



Chapte r  3     S of t ware  S et t ings 84

Design settings
The Embroidery Settings > Design tab controls a variety of options which affect 
design file handling. By default...

Machine files are converted to design files upon opening. You can choose to 
leave machine files as stitch blocks or ‘manual objects’. 

 Inserted designs are grouped and centered onscreen. 
Objects are joined by the Closest Join method. If deactivated, all newly 

digitized objects are joined by the As Digitized method.
Use the Embroidery Settings > Design tab to control all these options. Access the 
dialog via the Software Settings menu.

Related topics

Machine file recognition
 Insert designs
Closest joins
 Digitize open & closed shapes

Edit settings
Cut and paste operations behave according to presets in the Edit tab of the 
Embroidery Settings dialog. Alternatively, with object/s selected, various options 
become available via the Context toolbar. Use the Duplicate tool or press Ctrl+D 
to duplicate them. If you have already used ‘quick clone’, the duplicate object 

Machine files
recognized by default

If deactivated, ‘As
Digitized’ method used
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will be offset by the same amount. Use the Embroidery Settings > Edit tab to control 
all these options. Access the dialog via the Software Settings menu.

Related topics

Copy & paste objects
 Duplicate & clone objects

Overlap settings
The settings on the Embroidery Settings > Overlap tab allow you to control the 
overlap margins of both the Remove Overlaps and Fill Holes tools. The Remove 
Overlaps tool to remove underlying layers of stitching in overlapping objects. The 
Fill Holes tool lets you fill holes in closed objects by creating new objects based on 
existing holes. Access the dialog via the Software Settings menu.

Set offset values
for pasted objects

Preset duplicate
object offsets

Set nominal
overlap margin

Set nominal
overlap margin
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Related topics

 Remove underlying stitching
 Fill holes in objects

Appliqué settings
On some machines, wherever the frame (hoop) moves, the needle will form a 
tie-off. When it starts up again, it will add a tie-in. To avoid unwanted needle 
penetrations and ‘knots’ appearing in your fabric, various presets are available via 
Frame-out Options on the Embroidery Settings > Appliqué tab. Access the dialog 
via the Software Settings menu.

Related topics

Create appliqué objects
 Set frame-out position

Machine & hoop settings
Use the Embroidery Settings dialog to preset machine brand and model. 
Depending on the selected machine brand, you may have the option of selecting 
your machine type – single- or multi-needle. Different hoops are available for each 
of these machine types. All options are available via the Embroidery Settings > 
Machine & Hoop tab. Access the dialog via the Software Settings menu.

Alternative
frame-out presets

Choose your 
machine brand
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Related topics

 Select machine model or type
Configure hoop list
 Hoop selection

Multi-hooping settings
In order to help you correctly align multiple hoopings during stitchout, Hatch 
Embroidery can stitch out registration marks for each hooping. These do not form 
part of the design and are not saved with the design file. You set registration marks 
via the Embroidery Settings > Multi-Hooping tab. If you activate color optimization 
in the Multi-Hooping tab, color optimization is automatically applied to an entire 
design when generating automatic hoopings. Access the dialog via the Software 
Settings menu.

Related topics

Create multi-hoop designs
 Add registration marks
Optimize color changes for auto-hooping

Optionally, add
registration marks and

set margin

Optionally, optimize
color changes when

adding hoop
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Chapter 4

FILES & ASSETS

Hatch Embroidery allows you to create files or ‘assets’ of various kinds during 
normal use. The most important of these are your actual embroidery designs. There 
are other assets you may create, such as design templates, custom motifs and 
borders. These are preserved from installation to installation, whether installing a 
new version of Hatch Embroidery or an update patch.
This section details the types of files used and created by Hatch Embroidery as well 
as where they are stored on your computer system.

Embroidery files

There are two types of embroidery file format:

Design files are generally ones you open and modify in the software. Machine files 
are generally ones you send to machine for production. EMB is the native design 
format. Other ‘all-in-one’ formats such as ART and JAN are also supported. Hatch 
Embroidery supports many machine formats. There is some inter-convertibility 
between design and machine formats. Note that you can filter your design library 
between these two broad categories...

Note: Hatch Embroidery supports many machine formats such as JEF, SEW, DST, 
EXP, and others. See also Supported embroidery files.

File type Function

Design Design files, also known as ‘outline’ or 'all-in-one' files, usually contain 
digitized shapes and lines, selected stitch types and stitch values and 
effects.

Machine Machine files, also known as ‘stitch’ files, generally contain stitches and 
machine functions and are only suited to specific embroidery machines.

Filter by 
design or 
machine files
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Design files
All-in-one design files are high-level formats which contain object outlines, object 
properties and stitch data. When you open a design file in the software, 
corresponding stitch types, digitizing methods and effects are applied. These can 
all be viewed in the Sequence docker. See also Viewing methods.

Design files can be scaled, transformed and reshaped without affecting stitch 
density or quality. After modification, you can save your design to any supported 
file format. See also Machine file recognition and Output Designs.

Machine files
Different embroidery machines speak different languages. Also known as ‘stitch’ 
files, machine files are low-level formats for direct use by machines. They contain 
information about the position, length and color of each stitch. When read by the 
software, machine files do not contain object information such as outlines or stitch 
types, but present as a collection of stitch blocks also known as ‘manual objects’. 
Stitch blocks consist entirely of individual stitches.

Manual objects
Manual objects are created wherever machine functions – e.g. color changes or 
trims – are detected in the design. They have only general and connector 
properties. Manual objects, in turn, consist of individual stitches, called ‘manual 

Design file contains 
objects each with 
object properties
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stitches’. In the Sequence docker, manual objects and manual stitches appear as 
one-and-the-same thing.

Scaling machine files
You can scale raw machine files, but because the stitch count does not change, 
the density increases or decreases with the design size. Thus you should not scale 
these designs by more than ±10% or some areas may be too thickly or too thinly 
covered.

File sources

There are two types of embroidery file format:

Machine file 
contains ‘manual 
objects’ with no 
object properties

Don’t scale machine
files by more than

±10%

File type Function

Design Design files, also known as ‘outline’ or 'all-in-one' files, usually contain 
digitized shapes and lines, selected stitch types and stitch values and 
effects.

Machine Machine files, also known as ‘stitch’ files, generally contain stitches and 
machine functions and are only suited to specific embroidery machines.
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Design types
While embroidery files are broadly classified as ‘design’ (outline) or ‘machine’ 
(stitch), Hatch Embroidery internally tags files as belonging to one of four types – 
native design (A), imported outlines (B), processed stitches (C), or imported 
stitches (D). These are summarized as follows:

For information about the source of an embroidery file, refer to the Design tab of 
the Design Information docker.

Grade Source Description

A Native 
design

Native EMB designs as well as ART and JAN files are all ‘Grade A’ 
design formats read and written by the software. They are called ‘Grade 
A’ because they contain a complete set of design information in a single 
file – object outlines, properties, stitches, thread colors, thumbnail 
image, and comments. It goes without saying that only Grade A files 
provide 100% perfect scaling and transformation.

B Imported 
outlines

Designs read from an outline format such as GNC and saved in ART / 
EMB / JAN format. Such designs cannot be read directly by the software 
but once converted, they are treated as Grade B designs.

C Processed 
stitches

Designs read from machine files – EXP, DST, PES, etc – where stitches 
have been converted to objects.

D Imported 
stitches

Designs read from machine files, where outlines may or may not have 
been ‘recognized’, but stitches have not been regenerated through 
stitch processing. Note, however, that if you change a stitch design – 
e.g. add a lettering object – the status changes to ‘Processed Stitches’ 
even though the imported stitches may not have been regenerated.
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Design type warnings
By default, Hatch Embroidery displays a warning message whenever you open a 
non-native design.

Alternatively, to toggle non-native design warnings on or off, access the Help > 
Show Design Warning options.

Machine file recognition

While machine files are generally not suited to scaling, Hatch Embroidery can 
derive object outlines, stitch types and spacing from raw stitch data with some 
success. The Sequence docker will generally display recognized designs as a 

Toggle off warning 
message as preferred

Toggle non-native 
design warnings on or 
off as preferred
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mixture of ‘embroidery objects’ and ‘manual objects’. In other words, where it is 
unable to recognize objects, it leaves them as stitch blocks.

Processing is effective for most machine files but cannot produce the same level 
of quality as original outlines and may not handle some fancy stitches. When 
Hatch Embroidery ‘recognizes’ a machine file, it recognizes stitch types, spacing 
and length values, stitch effects, and can determine object outlines. Stitch types 
are assigned as satin or tatami depending on the pattern of needle penetrations.

Note: Recognized object outlines and stitch values are stored as object properties. 
This means you can scale and transform recognized designs in the usual way. 
Stitches are recalculated for recognized outlines but not for manual objects.

File recognition options
By default, machine files are converted to design files upon opening. If you want 
machine files left as stitch blocks, or ‘manual objects’, select the ‘Grade D’ option 
in the Embroidery Settings > Design tab.

Opening machine files with object recognition turned on (EMB Grade C) may 
result in small discrepancies between object coordinates and stitch coordinates. 
It's normal for object extents to be slightly different from stitch extents because 
stitches will often extend beyond the object shape due to pull compensation, 
stitch effects, manual edits, and so on. However, the slight difference will make no 
difference on the machine.

‘Recognized designs’ 
contain mixture of 
‘embroidery objects’ 
and ‘manual objects’

Machine files 
recognized by 
default
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Related topics

 Design settings

Convert stitches on opening
If you want to convert machine files on a case-by-case basis, you can choose to 
convert at the time of opening via the Open Options dialog. This can be accessed 
via the Options button in the Open Design dialog.

Convert stitches after opening
Even after opening a machine file, you can recognize stitch blocks as objects by 
selecting Recognize Stitches from the Edit menu.

Turn on stitch 
recognition via Open 
Options

Machine file opened 
without object 
recognition
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Select objects on a case-by-case basis and apply the Recognize Stitches 
command. Recognized stitch blocks contain a mixture of ‘embroidery objects’ 
and ‘manual objects’.

Note: Even after recognition, the density of manual objects increases or decreases 
with design size. Thus you should not scale these designs by more than ±10% or 
some areas may be too thickly or too thinly covered.

Supported embroidery files

Details are provided here of the embroidery file types supported by Hatch 
Embroidery.

Note: Embroidery files fall into two broad categories – ‘all-in-one’ design files and 
machine files. Design files are generally ones you open and modify in the software. 
Machine files are generally ones you send to machine for production. There is 
some inter-convertibility between the two formats. Note that you can filter your 
design library between these two broad categories. See also Embroidery files.

Recognized stitch 
blocks contain mixture 
of ‘embroidery objects’ 
and ‘manual objects’
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Embroidery files
Hatch Embroidery supports the following embroidery file formats:

Format File Description Read Write

Wilcom EMB 
design EMB Wilcom ‘all-in-one’ design file (up to & 

including the latest EMB format) ● ●

BERNINA ART BERNINA ‘all-in-one’ design file ●

Janome JAN JANOME ‘all-in-one’ design file ●

Wilcom Cross 
Stitch EMX ^ Wilcom Cross Stitch design file ● ○

Great Notions GNC Great Notions production file ●

Melco Condensed CND Melco ‘condensed’ design file ●

BERNINA / Melco EXP Melco embroidery design file. Also used for 
newer BERNINA embroidery USB format. ● ●

Tajima DST ‡ Used for main types of Tajima machines ● ●

BERNINA Cross 
Stitch ARX BERNINA cross stitch file ●

Deco / Brother / 
Babylock PES Deco, Brother, Babylock production file ● ●

Deco / Brother / 
Babylock PEC Deco, Brother, Babylock production file ● ●

Elna EMD Elna production file ● ●

Janome / Elna / 
Kenmore SEW JANOME/Elna/Kenmore production file ● ●

Janome JPX JANOME/Elna/Kenmore production file ● ●

Janome / Elna / 
Kenmore JEF JANOME/Elna/Kenmore production file ● ●

Janome / Elna / 
Kenmore JEF+ JANOME/Elna/Kenmore production file ●

Husqvarna / Viking HUS Husqvarna/Viking/Pfaff production file ● ●

Husqvarna / Viking SHV Husqvarna/Viking/Pfaff production file ● ●

Husqvarna / Viking 
/ Pfaff VIP Husqvarna/Viking/Pfaff production file ● ●

Husqvarna / Viking 
/ Pfaff VP3 Husqvarna/Viking/Pfaff production file ● ●

Pfaff PCD Pfaff production file ● ●

Pfaff PCM Pfaff production file ● ●

Pfaff PCQ Pfaff production file ● ●

Pfaff PCS Pfaff production file ● ●

^ Hatch Embroidery can write EMX with the Hatch Cross Stitch GEM ‡ DST files can be read 
by MB-4 machines.
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Design templates
Hatch Embroidery supports the following design template formats:

JPX file format
The JPX production file format includes a JPG image, in addition to the 
embroidery, of any graphics included in the design. This provides you with a better 
means of visually aligning embroidery on a printed item when hooped in the 
machine.
Older machines display only thread codes and not the specific brand. This causes 
confusion as the same code across two (or more) different brands of thread may 
be completely different colors. With newer JANOME MemoryCraft machines, a 
thread brand ID identifying the thread chart is now recognized. The specific brand 
is displayed on the machine itself.

Supported artwork

Artwork can be imported into Hatch Embroidery in both vector and bitmap 
formats. Generally speaking, vector images preserve the picture quality when 
resized, whereas bitmap images cause problems of pixilation and image 
degradation when enlarged or scaled down. However, any scaling required 
should be done before importing into the software as the importing operation 
automatically transforms vector images into bitmaps.

Note: If your Hatch Embroidery installation is linked to a compatible version of 
CorelDRAW software, you can open many more formats – bitmap or vector – and 
transfer them to Embroidery Mode.

Singer / Poem / 
Huskygram CSD Singer / Poem / Huskygram production file ● ●

Singer XXX Singer production file ● ●

OESD Project ART42 OESD ‘all-in-one’ design file ●

Format File Description Grade Read Write

Hatch Template JMT Hatch design template A ● ●

Wilcom Template EMT Wilcom design template A ●

Digitizer Template JMT JANOME design template A ●

BERNINA Template AMT BERNINA design template A ●

Format File Description Read Write

^ Hatch Embroidery can write EMX with the Hatch Cross Stitch GEM ‡ DST files can be read 
by MB-4 machines.
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Supported vector formats
Embroidery mode supports the following vector formats:

Supported bitmap formats
Embroidery mode also supports the following bitmap formats:

Personal data

Hatch Embroidery allows you to create files or ‘assets’ of various kinds during 
normal use. The most important of these are your actual embroidery designs. But 
there are other assets you may create, such as design templates, custom motifs 
and borders. These are preserved from installation to installation, whether installing 
a new version of Hatch Embroidery or an update patch. However, it’s a good idea 
to familiarize yourself with the locations and file names of your custom assets for 
various reasons...

 In the first instance, you should back up your custom assets in case of computer 
crash.

 Also, you may want to share assets with other Hatch Embroidery users, or install 
third-party assets such as custom fonts.

 Finally, if you want to install your software to a new computer, you will need to 
manually copy the contents of your asset folders to the new locations.

Tip: In order to preserve any custom assets, do not uninstall your existing version of 
Hatch Embroidery. Any new updates can be installed over top of your existing 
installation. If you want to move Hatch Embroidery to another PC, you will need to 
manually transfer any custom assets you have created or received from third 
parties.

Extension Format Read Write

EMF Enhanced Metafile ●

EPS Encapsulated PostScript ●

WMF Windows Metafile ●

CDR CorelDRAW® vector file format ○ ○

● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)

Extension Format Read Write

BMP Windows Bitmap ● ●

JPG JPEG File Interchange ● ●

PNG Portable Network Graphics ● ●
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Custom assets
Hatch Embroidery allows you to create files or ‘assets’ of various kinds during 
normal use. The most important of these are your actual embroidery designs. There 
are other assets you may create such as design templates, custom motifs and 
borders, and keyboard design collections. These assets are preserved from 
installation to installation, whether installing a new version of Hatch Embroidery or 
an update patch. For more information about custom assets, refer to...

Note: In order to preserve any custom assets, do not uninstall your existing version 
of Hatch Embroidery. Any new updates can be installed over top of your existing 
installation. If you want to move your Hatch Embroidery to another PC, you will 
need to manually transfer any custom assets you have created or received from 
third parties.

Assets Description

Embroidery and 
other designs

The built-in 'embroidery library' makes it easy to search, sort and browse 
all embroidery designs on your system. Any folder containing embroidery 
designs can be included in the navigation tree. See also Manage design 
folders.

Custom motifs and 
borders

Motif stamps are ready-made design elements, such as hearts, leaves or 
geometric patterns which are contained in libraries or 'sets'. You can 
define your own stamps for individual use or for use in motif runs or fills. 
Similarly, you can create your own borders for use in monograms. See 
also Custom objects.

Keyboard design 
collections

Embroidery character designs are very popular. Many hobbyists buy 
these from third-party suppliers. Naturally, embroiderers want to be able 
to use them in Hatch Embroidery by mapping to keyboard characters. 
The Keyboard Design Collection (KDC) feature provides a convenient 
way to do this. See also Keyboard Design Collections.

Carving stamps The Carving Stamp feature allows you to select object outlines from the 
design window and apply them directly as stamps or save them to a 
library for future reference. You can use vector or embroidery objects as 
a basis for stamps. See also Carving stamps.

Design templates Templates are special files used to store fabrics, objects and default 
settings. Use templates when digitizing frequently-used design types so 
that you do not have to adjust current settings every time. See also 
Design templates.

Thread charts The thread charts contained in the software represent the many different 
brands and colors of thread available. You can modify thread charts to 
reflect the threads you are currently using. You can even create your 
own. See also Manage thread charts.

Custom hoops The software allows you to define your own hoops and save for later use 
or associate with a custom machine type. Custom hoops are needed 
because new hoops become available for sewing machines more 
frequently than the software is updated. See also Hoop selection.
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Custom asset locations
User data – including custom fabrics, templates, motifs, borders, and keyboard 
design collections – is stored in dedicated folders. Familiarize yourself with them so 
you know where all your custom assets are located. Go to...

Graphical data is stored in a separate library. Go to...

Note: Some data folders will only be created when Hatch Embroidery is opened 
for the first time after restarting your system.

Custom assets C:\ProgramData\Wilcom\Hatch Embroidery File types

Auto fabrics \RES\AUTOFABRIC userdefined.autost

Hoops \RES\Hoops USRHOOPS.DSC

Thread charts \RES\ThreadCharts *.TCH

Machines \RES\Machines UserBrands.txt

Motifs \MOTIFS *.ESA

Templates \TEMPLATE *.JMT

Carving stamps \STAMPS *.ESA

Borders \BORDERS *.ESA

Custom fonts \FONTS *.ESA

Keyboard design 
collections

\FONTS *.KDC

Custom assets C:\Users\Public\Public Pictures\Hatch Pictures File types

Articles \Articles *.PNG

Fabrics \Fabrics *.JPG, *.BMP
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In File Explorer, you can navigate to the precise location of your Hatch Embroidery 
assets using the navigation tree on the left of the window, or simply by typing or 
copying the path name into the address field and pressing Enter.

Whenever you install updates or upgrades to your existing software, the above 
folder structure, together with any custom assets, will be preserved. However, if 
you install your software to another PC, you will need to manually copy the 
contents of these folders to the new location. 

Note: The C:\ProgramData folder may be hidden on some PCs depending on the 
permissions of the user who is logged in. See also Show hidden folders.

Folder options –
show hidden
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Personal designs & artwork
Amongst your most important assets are of course your embroidery designs and 
any artwork files you may use. These can potentially be saved anywhere on your 
system. By default however...

 Any designs, cutting files, or machine files that you save from Hatch Embroidery 
will be saved by default to the My Embroidery folder at the location...
C:\Users\<USER>\My Embroidery\

 If you save to a different location, MS Windows® will continue saving to that 
location until you change it again.

 Similarly, any artwork you save from Hatch Embroidery will be saved by default 
to the My Pictures folder at the location...
C:\Users\<USER>\Pictures\My Pictures\

Note: Whenever you install updates or upgrades to your existing software, the 
above folders will be preserved. However, if you install your software to another 
PC, you will need to manually copy the contents of the My Embroidery and My 
Pictures folders to the new location.

Show hidden folders
If you need to manually copy the contents of your asset folders to a new location, 
you may find that the C:\ProgramData folder is hidden on your PC, depending on 
your login permissions. To view the folder structure, go to the Folder Options in File 
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Explorer and tick the Hidden items option. This will reveal the ’ProgramData’ folder 
and all its contents.

Folder options –
show hidden



Hatch Embroidery 3 User Guide 104

PART II
HATCH BASICS

Embroidery design with Hatch Embroidery consists of turning basic artwork shapes 
into embroidery designs. Hatch Embroidery gives you the flexibility of creating 
embroidery objects using artwork as backdrops, or of directly converting digital 
artwork. You can take a mixed mode approach as well, doing the bulk of the 
design by means of automatic conversion, followed by touch-ups and edits using 
the suite of Hatch Embroidery embroidery digitizing tools.
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Chapter 5

MANAGE DESIGNS

The Manage Designs toolbox provides a way to view and organize all your 
embroidery designs. The inbuilt Design Library makes it easy to search, sort and 
browse all designs and artwork on your system. If you are already familiar with File 
Explorer, the interface will be quite intuitive to you. In a nutshell, the library lets you:

 Search for designs by file type, key words, and other criteria.
Create a structure for easy categorization.
 Batch-convert design files to many machine formats – JEF, SEW, DST, EXP, and 

others.
 Print designs or send them to embroidery machine for stitchout.
 Find designs anywhere on your hard drive or external storage device and add 

them to the Design Library.

Caution: If you are already familiar with File Explorer, the Design Library interface 
will be quite intuitive to you. You may, however, need to make a few adjustments 
to folder options for recommended embroidery design settings. See Configure 
embroidery libraries in File Explorer for details.

Browse designs

The built-in Design Library is a ‘virtual library’ in that any designs on your system can 
be located and displayed within the navigation tree. Hatch Embroidery doesn’t 
care where they physically reside on your hard disk or external storage devices. 
Any folder containing embroidery designs or artwork can be included in the 
navigation tree.
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Open Design Library
Design Library opens in its own tab on the design bar. It has five components – two 
toolbars, a toolbox, a navigation tree, a design display area, and an info panel.

Interface components

Component Function

Toolbox Use the toolbox to open selected designs and convert, print, or output them to 
any connected embroidery machine or data media. Use it also to find folders 
containing designs and add/remove folders to/from the library.
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Navigation 
tree

Navigating to design folders with Design Library is similar to browsing with File 
Explorer. View any supported file type residing in design folders. Designs can 
be searched, sorted, grouped, and browsed by name and other information. 
Right-click the navigation tree to access a popup menu. Use it to copy and 
delete without leaving the software.

Design Library is ‘virtual’ in the sense that any designs on your system can be 
located and displayed within the library. You can add folders both in File 
Explorer and in the Design Library itself. The initial folder structure is created 
by your installation. However, any folders on your local network which contain 
embroidery designs or artwork can potentially be included and viewed in 
Design Library.

Design 
display

The design display area shows any designs in selected folders corresponding 
to the filter selected and search criteria entered in the View toolbar. Search or 
sort the entire library or any chosen folders on any criteria selected. Use this 
toolbar also to customize the design display view. See below.

Component Function
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Change design display
Use the View (Manage Designs) toolbar to control display of the navigation pane 
as well as thumbnail appearance. Use the Change View droplist to display designs 
in the preferred format.

Columns vary by file type and are controlled by MS Windows®. Design Library, 
however, provides extra columns for data derived from embroidery files. These 

Design info When a design is selected, summary information is displayed in the info panel 
which may at the bottom or to the side, depending on your version of Windows. 
Some of the fields, such as ‘Comments’, can be edited in the info panel and 
saved to the design for future reference. See also View design information.

Standard 
toolbar

Create new designs, open existing designs, open recent designs, and cut, 
copy and paste selected designs.

Component Function

Display designs in 
the preferred 
format
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can be accessed by right-clicking the top of the column and selecting a field from 
the droplist. These may include design status, customer, size, author, etc. Such 
details are primarily intended for use with EMB but can apply to other embroidery 
formats. Columns themselves can be arranged in any order by clicking and 
dragging to the preferred position.

Search for designs
The View toolbar allows you to sort, filter, and search for designs in the library. For 
instance, filter the library to show only certain file types. Use the toolbar to search 
for names or keywords. Alternatively, sort designs by name, date, and other 
criteria. Use it also to control display of the navigation tree and thumbnail 
appearance. First select the root folder in the Design Library navigation tree that 
you want to search on. Every highlighted folder will be included in the search...

Right-click column 
header to invoke 
popup menu

Select ‘root folder’ 
to search on
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Use the Showing droplist to narrow the search according to file type – e.g. 
‘all-in-one’ design files, machine files, or all embroidery files (the default).

The Search field is very powerful. Use it to narrow the search by choosing a criteria 
from the droplist.

If you select Date modified, you can further narrow the search according to the 
criteria available in the droplist – e.g. ‘Last week’.

Search on specific details
Use the General field to search on any criteria displayed on the Info panel. For 
example...

This search translates to:

Filter file types to 
search on

Narrow search with 
listed criteria

Narrow search by 
timeframe

Search on 
specific details
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 Author name: ‘Hatch’
 Number of colors: ‘less than 5’
 Number of stitches: ‘less than 3000’
This will narrow the search to only those designs which have been authored by 
‘Hatch’, which have less than 5 colors, and which have less than 3000 stitches.

Make sure you use the correct syntax. 
 Each field name must include a colon ‘:’ after the name. 
 Use the Clear Search Filter (X) button to clear the Search field before 

conducting another search. 
You can search on the following machine file data:

 Name
 Stitches
 Height
Width
Colors

Search for artwork
The Design Library also allows you to search for and manage artwork files. Along 
with the dedicated ‘Embroidery’ library, the software also installs a dedicated 
‘Pictures’ library. First select the root folder in the Design Library navigation tree 
that you want to search on. Every highlighted folder will be included in the search:

Select ‘root 
folder’ to search 
on
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The View toolbar allows you to sort, filter, and search for artwork in the 
Design Library. Filter the library to show only artwork file types.

Optionally, refine your search by filtering on specific file formats such as PNG, BMP, 
JPG, etc.

Again, use the Date modified field to further narrow the search according to the 
default criteria – e.g. ‘Last week’.

Open design files

You don’t need experience to start using your embroidery software. You can 
simply open a design and send it to your machine for ‘stitchout’. Alternatively, you 
may want to combine designs or add lettering to existing designs. Once you are 
used to the steps involved in sewing out designs – either included samples or ones 
you have purchased – you will soon want to make global design modifications 

Filter artwork 
files only

Filter search by 
specific artwork file 
format

Narrow search by 
timeframe
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such as resizing, or changing thread colors and fabric types. As you gain in 
confidence, you will want to create your own designs from scratch.
By default Hatch Embroidery saves designs to its native ‘all-in-one’ EMB file format. 
This contains all information necessary for stitchout and for later modification. 
Hatch Embroidery opens and saves many other embroidery file formats. See also 
Embroidery files.

Open blank designs

When you create a blank design, a new tab is added to the design bar. The blank 
design is loaded with predefined fabric settings and design colors.

Related topics

 Embroidery files
 File sources
 Supported embroidery files

Open or copy designs

Use Standard > New Blank Design to create a new blank design.

Use Manage Designs > Open Selected to open the design(s) selected in the 
Design Library window.

Use Manage Designs > New From Selected to create new design(s) based on the 
selected design(s) and/or bitmap(s) from a chosen template.

Use Standard > Open Design to open an existing embroidery design.

Blank design 
opens with default 
color set
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With the Manage Designs toolbox, you have the option of opening one or more 
selected designs in their own design tabs.

To open or copy designs...

 Simply double-click to instantly open a design in the design window.
 To open multiple designs simultaneously, hold down the Ctrl key as you select, 

and then click Open Selected.
 Alternatively, click New From Selected. The only difference for practical 

purposes is that this command creates a copy which opens in a new design 
tab, thus preserving the original design file.

Use Standard > New From Design to create a new design based on an existing 
design.

Open selected 
design/s
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 You can also open selected artwork by the same methods.

 The Standard toolbar which is available at all times, also lets you open designs 
from the Design Library or any other network location.

Related topics

 Embroidery files
 File sources
 Supported embroidery files
 Insert designs

Ungroup designs on inserting

Use Context > Group to group selection. Or press <Ctrl+G>. This tool is also 
available via Arrange menu.

Use Context > Ungroup to ungroup grouped selection. Or press <Ctrl+U>. This tool 
is also available via Arrange menu.

Open selected
artwork

Open new file from 
selected design
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By default, designs are grouped when first opening or inserting them into the 
software. In higher product levels, they can be ungrouped by means of the 
Ungroup tool on the Context toolbar. To turn off default grouping for inserted 
designs, untick the ‘group design’ checkbox in the Embroidery Settings > Design 
tab. Once ungrouped, you are free to edit individual objects in the design. 

Note: In lower product levels, designs always remain grouped since object editing 
is unavailable.

Related topics

Combine designs

Output designs from Design Library

Send selected designs to a preset 
folder on your network or PC. Create a 
hard copy report of a selected design 
using a printer or plotter. Report types 
may include design worksheets, 
appliqué patterns, color films, hooping 
sequence reports, as well as catalogs 
and lists of selected designs. See also 
Print designs.

Transfer selected designs

Hatch Embroidery provides a method of connection to machines that appear as 
removable media or use a third-party application to connect to the machine and 

Untick to turn off 
default grouping

Use Manage Designs > Transfer Selected Design to transfer the design selected to 
the default Machine Folder.
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require files to be placed in a specific network location. Once your machine is set 
up, it only requires a single click to send a selected design to the preset folder on 
your network or PC. The first time you do it, you will be prompted to specify your 
machine type and file type. 

Note: Using the Output Design toolbox you can output embroidery designs in a 
variety of ways – by printing as worksheets, as appliqué patterns, color sequence, 
or as thread charts. 

Related topics

Output Designs
 Transfer designs

Convert multiple designs

You can convert your EMB and other design files to and from other file formats 
directly from your embroidery library.

Use Manage Designs > Convert Selected Designs to convert the design selected in 
the Design Library window into different file types.

Specify machine 
type and file 
type
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To convert multiple designs...

 Select the file(s) to be converted and click the Convert Selected Designs icon. 
The dialog lists all machine file formats the software supports.

 Select the file types you want to convert to.
Click Browse to locate a destination folder for the converted designs.
Click Convert to start the conversion. The converted designs will be stored in the 

nominated folder.

Print selected designs

The Print Selected command allows you to print worksheets directly from 
Design Library.

Go to the Design Library (Manage Designs) and select a design to print.

Use Manage Designs > Print Selected to print the design selected in the 
Design Library window.

Select file types for 
batch conversion



Chapte r  5     M anage D esi gns 119

Click the Print Selected icon. The Print Design dialog opens.

 To customize the printout, click the Options button.

 Use the preset buttons to filter the design worksheet options – ‘Standard’, 
‘Design View’, and ‘Template Mode’. The Design Worksheet panel provides 
options for further customization. See also Print designs.

Click OK and ensure correct printer settings in the MS Windows® Print Setup 
dialog.

 The dialog and the settings available will vary from printer to printer. See your 
printer manual for details.

Report Purpose

Design 
worksheet

This provides complete sewing information for the design. All related 
information, such as bobbin length, design size, garment fabric, etc, is 
provided.

Appliqué 
patterns

This shows appliqué patterns – cutter information – isolated from the 
design. These can be used as a guide to cutting out fabric pieces.
They also show which appliqué pieces are to be included.

Color 
sequence

Provides a list of colors in the design, together with color and stitch 
information for each color layer. This helps the machine operator to see 
each stitch color in order of stitchout.

Hooping 
sequence

If there is more than one hooping in the design, this option displays 
hoopings in their correct color sequence.

Customize 
design printout
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Print design catalogs

Printed HTML catalogs contain thumbnails plus limited text details. These can be 
posted to a website or printed to PDF or printer.

To print selected design to catalog...

Open Design Library and filter designs as desired.

 Select the designs you want to include in the catalog.
 Select Manage Designs > Print Selected to Catalog. The dialog opens.

 Adjust settings as preferred:
Change Scale (%) to adjust thumbnail size.
 Select a catalog format – thumbnails with or without design details.
 In this dialog, you don’t actually have the option to select a specific printer 

type.

Use Manage Designs > Print Selected to Catalog to print selected designs to an 
HTML catalog.

Adjust scale, catalog 
format, and target 
output
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Click Print. The Print Design dialog opens. Here you can choose a specific printer 
or, if you have it, a PDF printer.

Click Preview to view the catalog.

Click Print Now to send the design report to your local printer. If the catalog 
requires more than one page, you can select which page to print in the MS 
Windows® Print Setup dialog.

Note: Designers frequently want to distribute designs for viewing in real colors, in 
TrueView or otherwise, with or without fabric backgrounds. Screen images can be 
captured in PNG format and send as email attachments. See also Capture design 
images.

Export design lists

Use Manage Designs > Export Design List to export a text or CSV file containing a 
list of the visible design files and their properties.

Click
Preview

Choose
printer

Click Print
Now
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The Export Design List option can be used to print design lists for selected folders. 
This option allows you to create a simple design report which can easily be 
imported into a spreadsheet. You may want to use this in order to manage designs 
by file name.

To export a design list...

 Preset the measurement units you want to use – metric or U.S.

Open Design Library and select a design folder.

 Sort and filter the designs to be printed. See also Browse designs.

Select preferred 
measurement units

Select root folder
and filter as

required
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Click the Export Design List icon and choose a location to save the list. Choose 
whether to save as a tab-delimited or comma-separated text file.

Open the text file in a spreadsheet for further sorting and printing.

Manage design folders

Design Library is a ‘virtual library’ in that any designs on your system can be 
located and displayed within the navigation tree. Design Library doesn’t care 

Choose a 
location and 
save the list

Open txt file in 
spreadsheet

Use Manage Designs > Manage Embroidery Library Locations to add or remove 
existing folders to/from the Design Library, enabling fast searching and filtering.
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where they physically reside on your hard disk, network, or external storage 
devices. Any folder containing designs can be included in the navigation tree.

When you add or remove folders from the navigation pane, this only affects the 
Design Library. It does not affect the folder structure on your hard drive or network.

To add folders to the library...

 Use the Manage Embroidery Library Locations function to locate folders 
containing designs anywhere on your local network. 

 Use the Remove button in the dialog to remove a folder from the Design Library. 
All subordinate folders will disappear from the navigation pane.

Virtual folders in
embroidery

library

Locate and add 
design folders to 
your library
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Chapter 6

VIEW DESIGNS

Your embroidery software provides many viewing features to make it easier to 
work with your design. Zoom in on an area to see more detail or view the design 
at actual size. Show or hide various design elements with the available display 
settings. You can show or hide needle penetration points, connectors and the 
stitches themselves.

Viewing methods

Hatch Embroidery provides many viewing techniques to make it easier to work 
with your designs. Turn on or off design artwork. View selected parts of a design. 
Zoom in on an area to see more detail or view the design at actual size. The View 
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toolbar and Sequence docker provide access to most of the viewing options you 
will need.

Display backdrops

In addition to embroidery designs, artwork may be inserted, pasted or scanned 
into the software for use as digitizing backdrops, depending on product level. You 
can turn on or off embroidery, vector and/or bitmap artwork selectively. 
Depending on view options set in the Options dialog, bitmap images display in full 
color or dimmed. Use the Show Design menu to selectively turn on or off 

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.
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backdrops. Alternatively, use the shortcut keys D and Shift+D. See also Import 
artwork.

In addition to artwork, you may choose to display a garment or article on which to 
position your designs. The software provides a library of articles to choose from, 
including multi-color garments. Use the Show Design menu to toggle articles on or 
off. See also Add backgrounds.

Tip: So you don’t accidentally move or delete the backdrop, select it and press K 
on the keyboard to lock it down. Or right-click and lock it from the popup menu.

Zoom & pan designs

Use Zoom > Pan to pan across a design at high zoom factors.

Use Zoom > Zoom 1:1 to display design at actual size.

Click Zoom > Zoom In to zoom in for more design detail.

Click Zoom > Zoom Out to zoom out for broader view.

Use Zoom > Zoom to Fit to display whole design in the design window.

Turn on or off 
artwork

Turn on or off 
background 
fabrics or articles
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Magnify your view of the design by zooming in on individual stitches or details, or 
zoom out to display more of the design in the window. In addition to the scroll bars, 
panning provides a quick way to view parts of a design which are not currently 
visible in the design window. You can also set your system to display all embroidery 
objects in a design, or hide all but the selected objects. Panning is typically used 
after zooming in on an area.

To zoom and pan across your design...

 Activate the Zoom toolbar via the Window > Toolbars menu.

 Because you will use these tools frequently, it’s a good idea to memorize the 
shortcut keys indicated in brackets after the tool name.

Use Zoom > Zoom to zoom on a specific area of the design window.

Click Zoom > Zoom Scale to display design at a specific scale.

Activate Zoom tools
from Window menu
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 For instance, to zoom in on a section of the design, press the B key on your 
keyboard, then drag a bounding box around the zoom area.

 To pan across a design in the design window, use Pan or press P. The cursor 
changes to a grabbing hand symbol. Click and drag to pan the design.

 To display selected objects, select View > Zoom > Zoom to Selected or press 
Shift+0.

 To fit the whole design in the design window, select View > Zoom > Zoom to Fit 
or press 0.

 To view the design at actual size, select View > Zoom > Zoom 1:1 or press 1.

Drag bounding 
box to zoom in

Zoom to selected 
parts of a design
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 The same zoom options are available via the View menu. Alternatively, 
right-click the design window to open the popup menu.

Note: Press Esc to cancel tool selection.

View colors & objects

The Sequence docker provides an easy way to view color blocks and individual 
objects in a design. Use the ‘Switch’ buttons on the Sequence docker toolbar to 

Use Edit Objects > Sequence >> to open the Sequence docker. Click again to 
close. Also available via Windows > Dockers menu.

Use Sequence > Show Color List to display color blocks with included object 
thumbnails in the docker.

Use Sequence > Show Object List to display individual object thumbnails in the 
docker.

Use Sequence > Show More to show more details in the docker. Object thumbnails 
are not resizable.

Use Sequence > Show Less to show only summary details in the docker. Object 
thumbnails are not resizable.

Activate Zoom 
tools from menus
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toggle between color blocks and individual objects. Drag the edge of the docker 
to widen the view and enlarge thumbnails.

Use the ‘Show’ buttons to expand the docker for greater or lesser detail. The details 
view provides information about each color block or object in the design – color, 
type, stitch type applying, stitch count, etc. Object types correspond to the input 
methods used in their creation:

Object type Use

Filled shape Use Digitize Closed Shape to create closed shapes using fill 
stitching. See also Input methods.

Outline shape Use Digitize Open Line to create a row of run or other outline stitching 
along a digitized line. See also Input methods.

Branched object Use Branching to automatically sequence selected outlines for 
efficient stitchout. See also Embroidery connections.

Block object Use Digitize > Digitize Blocks to digitize shapes of varying width with 
turning stitching. See also Input methods.

Freehand 
closed object

Use Digitize > Freehand Closed Shape to draw closed shapes on 
screen using current stitch settings for a hand-drawn look. See also 
Freehand.

Toggle between
objects or color

blocks

Drag edge to widen
docker and enlarge

thumbnails
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Use the popup menu in the Sequence docker to hide selected objects. The 
command is also available in the Arrange menu. Use the same menu to ‘hide 
unselected’ which has the effect of hiding all other objects apart from the one you 
have currently selected. To reveal all hidden objects, select Unhide All.

Note: The Sequence docker provides various techniques for sequencing objects or 
entire color blocks in a design. See also Split objects.

Hide selected
objects
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View by color
The View by Color function allows you to view objects by color block. This is useful 
when re-sequencing colors. The function will not work with grouped objects. Select 
the View by Color command from the Arrange menu.

Design overview
Use the Design Overview docker to navigate designs at high zoom factors via a 
design thumbnail. The docker updates whenever you make a change and can be 
used to zoom in or pan across the design window.

To use the docker...

 Toggle the docker on or off via the Window menu.

Click the docker to make it active.

Tick to view 
selected colors only

Click Zoom button and 
drag bounding box around 
area to view
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Click the Zoom button at the bottom and drag a bounding box around the 
area to view.

Click and drag the bounding box to pan across the design.

View design details

Hatch Embroidery provides a number of viewing modes to 
selectively display design details. Show or hide needle 
penetration points and connectors. Show or hide selected 
colors. The View toolbar and menu provide access to most 
viewing options you will need.
View settings can also be accessed via the View tab of the 
User Interface Settings dialog. The dialog itself can be 
accessed via the design window popup menu or Software 
Settings menu.

View stitching

During design creation and editing, you will be constantly switching between 
stitch views. TrueView offers a graphical representation of what the final 
embroidery will look like. Use TrueView together with a background fabric to see 
how your design will look when stitched out. Turn off TrueView to view stitches in 

Use View > Show Design to show or hide design elements. Click to open a menu 
of view settings.

Click View > TrueView to show or hide simulation of stitched embroidery.

View settings via 
User Interface 
Settings dialog
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your design. This is useful when viewing stitches for editing. Sometimes you may 
want to turn off stitching altogether and just view the shapes in your design.

Hatch Embroidery also lets you show or hide 
needle points. This is useful when you want to 
select stitches for editing.

Tip: In addition to background color or 
fabric, display colors for stitches, needle 
points, object shapes, and grid are part of 
the colorway definition. Change them if the 
default display color is not visible against the 
current colorway.

Related topics

 Adjust display colors

View connectors

The software automatically adds connectors between objects in a design. When 
connectors become long enough to trim, the software adds tie-in and trim 
functions. These are indicated by the symbols shown below – circle for tie-in, 
triangle for trim and tie-off. The Show Design droplist includes Connectors and 
Functions options. Use these or the associated shortcut keys to toggle display of 

Stitch viewTrueView View shapesStitch view View shapes

Click View > TrueView to show or hide simulation of stitched embroidery.
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connecting stitches and machine functions such as trims and tie-offs. This helps you 
when checking your design prior to stitchout.

Some machines will, by default, tie-off and trim at the specified positions. This 
behavior is alternately known as ‘Trim By Jumps’, ‘Jump Stitch Cutting’ or ‘Jump 
Thread Trimming’. Some machines also allow you to switch to automatic machine 
trimming. This means that, while the machine will tie off whenever it encounters a 
tie-off function, it will only trim connectors longer than the length specified on the 
machine itself, regardless of whether there is a trim function in the machine file. 
Other machines only have the automatic machine trim function. These machines 
ignore any trim data in the machine file.

Tip: Old designs which have different connector settings do not display trim 
symbols at all in some cases where the machine actually trims. You can overcome 
this by inserting the old design into a new blank design. The old design will inherit 
the new connector settings.

Related topics

 Embroidery connections
Closest joins

View stitching sequence

When working with embroidery designs, you need to understand the stitching 
sequence. The Travel toolbar and menu provide access to most of the travel 
options you will need. View a design’s stitching sequence by ‘traveling’ through it 

Connecting
stitches

Trim
functions
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by colors or objects, or even by stitches. The Stitch Player lets you simulate a design 
stitchout on screen. 

Simulate design stitchout

The Stitch Player lets you simulate a design stitchout on screen. Use it to view 
stitching and color sequence in slow motion. Simulation can be started from any 
stitch. With larger designs, scroll automatically so that the area being stitched 
remains on screen.

Because the Stitch Player emulates the movements of the embroidery machine, 
you are able to make decisions about how to optimize your design and lessen 
load on the machine. This is important if you intend to make multiple stitchouts of 
the same design. It is always good practice to run the Stitch Player on completed 
designs. Stitch Player controls allow you to:

Move through the design stitch by stitch.
 Set the stitch you want to run from.
Move through the design color block by color block.
 Select the color block you want to run from.
With larger designs, use the Auto Scroll toggle to scroll automatically so that the 

area being stitched remains on-screen.

Use View > Stitch Player to simulate embroidery design stitchout onscreen in either 
stitch or TrueView.

Simulate design 
stitchout
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Travel through designs

These tools allow you to:

 Jump to the start or end of a design
 Jump from object to object
 Jump from color block to color block.
Simply choose an option and click the forward and back buttons. Keyboard 
shortcuts are also available. Home, End, and Arrow keys can also be used to 
change stitch cursor position.

Tip: ‘Traveling’ through a design is usually associated with checking the stitching 
sequence. However, you can also select objects as you travel. In order to select 
while traveling, you must be working in stitch edit mode.

Related topics

 Travel functions
 Edit stitches
 Select while traveling

Use Travel > Jump By Color in conjunction with Forward and Backward icons to 
travel to the previous or next color change.

Use Travel > Jump By Object in conjunction with Forward and Back icons to travel to 
the previous or next objects.

Use Travel > Jump to Start/End in conjunction with Forward and Backward icons to 
travel to the start or end of a design.

Use Travel > Travel Backward to travel backwards through a design.

Use Travel > Travel Forward to travel forwards through a design. 
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Chapter 7

CUSTOMIZE DESIGNS

The Customize Design toolbox provides functions which allow you to make global 
adjustments to your designs.

View design information

Manage and check design details via the Design Information docker. This is always 
advisable prior to stitchout. Choose a file and select Design Information via the 
Design Library or the Customize Design toolbox.
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All EMB designs in Design Library can be tagged for easy search and find. 
Summary information such as design title, subject, authors, tags, is fully 
customizable. All additional information is saved with the actual design file and 
can be viewed in any software that can read EMB files. See also Browse designs.

Tip: Hatch Embroidery users generally start with a large library of machine files, but 
not necessarily EMB design files. Most machine files do not natively support color 
and other types of design information. However, you can convert machine files to 
design files with some success and then add information to your requirements. See 
also Embroidery files.

Note: Hatch Embroidery also provides information about designs in other ways. 
Before even opening a design, you can check design information directly from File 
Explorer. The design printout too provides essential stitching information, including 
a design preview, the size of the design, color sequence and any special 
instructions.

Summary information

Summary information about a design can be viewed and edited in the Summary 
tab. Generally this data is used to improve search-ability. Use the information to 
search and filter EMB designs by author, title, or subject. Information can be added 

Use Customize Design > Design Information to view design information such as size 
and number of stitches. Add comments to print on worksheet.
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in the docker itself or in the Details pane (if activated). Click Save to save details 
with the design file.

Click a field and enter any text which will help you or others identify the design at 
a later date. All information on this tab is also included in the design worksheet. 
Information types include:

Field Purpose

Title Defaults to filename. Add a more descriptive name for easy searching. This 
name appears on the design worksheet.

Subjects This may conform to the primary category by which the design is cataloged – 
e.g. the name of the containing folder.

Authors Name of digitizer and/or designer – appears in design worksheet footer.

Tags Keywords for potential Design Library searches.

Comments These comments are included in the design worksheet as production notes.

Add tags to improve 
searchability
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Information from this tab also appears in the Details pane in Design Library. The 
same information can also be edited in this pane.

Design details

Select the Design tab to view design details such as height, width, stitch count and 
colors. The data is extracted from the design file and, apart from design title, 
cannot be modified.

Use Customize Design > Design Information to view design information such as size 
and number of stitches. Add comments to print on worksheet.

View design details 
such as height, 
width, stitch count 
and colors
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Field summary

Thread colors

Field Description

Filename File name of the selected design. This will often be a number or alphanumeric 
format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy searching. This 
name appears on the approval sheet or worksheet.

Height / width Total height and width of design extents.

Stitches Total stitch count for design.

Colors Number of thread colors involved in the design.

Stops Normally color changes are associated with Stop functions. Depending on 
machine file, however, the design may include an additional last stop to 
ensure the machine returns to the starting needle for the next run.

Colorways Number of colorways in the design.

Trims Number of trims in the design. Generally, you will try to minimize the number 
of trims.

Color changes Number of color changes required to stitch out design.

Objects Indicates total number of objects in the design.

Appliqués Number of appliqué objects in the design (if any).

EMB grade While embroidery files are broadly classified as ‘design’ (outline) or ‘machine’ 
(stitch), the software internally tags each as belonging to one of four types – 
native design (A), imported outlines (B), processed stitches (C), or imported 
stitches (D).

EMB version The specific version of software the file was created in – e.g. Hatch 3.

Hoop The current hoop associated with the design.

Use Customize Design > Design Information to view design information such as size 
and number of stitches. Add comments to print on worksheet.
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The Thread Colors tab displays the color sequence and stitch counts for each 
design ‘element’. Elements equate to color changes. Each can be named for 
easy identification.

Data is extracted from the design file and, apart from the Element column, cannot 
be modified.

Field Description

Filename File name of the selected design. This will often be a number or 
alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy searching. This 
name appears on the approval sheet or worksheet.

Stitches Indicates total stitch count for design.

Colors Indicates number of thread colors involved in the design.

Colorways Number of colorways in the design.

Colorway Use the droplist to change colorways, if available. When choosing a different 
colorway, the thumbnail and stop sequence list are updated.

View color sequence 
and stitch counts for 
each design ‘element’

Name design elements 
for easy identification – 
double-click to activate
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The table at the bottom lists all color changes in the design as they will appear on 
the production worksheet. It provides the following details:

Stitching details

The Stitching tab displays technical stitching details. Information includes such 
details as target fabric, required stabilizers, as well as total thread estimates. These 
may be used for costings as well as production requirements. The tab also provides 
thread usage estimates which may be used for costings as well as production 

Field Description

Stop # The machine stop corresponding to the color change.

Color Indicates color slot number of the color in color palette.

Element User-defined name to identify each color block. Double-click to activate the 
field.

Stitches There is a stitch count for each element in the design. You can show this as 
a discrete stitch count or a cumulative stitch count.

Length Meterage of thread required per color.

Code Color code as registered in the thread chart.

Name Color name appearing in thread chart.

Chart name Brand name of thread chart used.

Thickness A: Normal embroidery thread (approx. denier 40)
B: Thicker than normal (approx. denier 30)
C: Finer than normal (approx. denier 80)
D: Very fine (approx. denier 100)

Use Customize Design > Design Information to view design information such as size 
and number of stitches. Add comments to print on worksheet.
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requirements. Bobbin length calculation can be further refined if you are planning 
a lot of production.

Data is extracted from the design file and, apart from title and bobbin length 
calculation, cannot be modified.

Field summary

Field Description

Filename File name of the selected design. This will often be a number or 
alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy searching. 
This name appears on the approval sheet or worksheet.

Auto fabric Predefined fabric settings used in current design.

Required 
stabilizer

Indicates recommended stabilizer(s) for selected fabric type.

Design area Total area covered by design – used for estimating hoop sizes, fabric 
requirements, 3D foam, or whether design will fit target location.

Total thread Indicates total meterage of top thread required to stitch out the design.

Total bobbin Indicates total meterage of bottom (bobbin) thread required to stitch out 
the design. These figures may be required for inventory control depending 
on business practices.

Length calculation Allows you to revise thread usage estimates according to target fabric 
thickness.

Left / right / up / 
down

Depending on where the design start/end point has been set, these 
figures indicate the distance from that point.

Max/min stitch / 
jump length

The maximum and minimum stitch lengths, and maximum jump stitch 
length in the design.

View technical stitching 
details such as target 
fabric, required 
stabilizers, total thread 
estimates, etc
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Thread usage estimates
In order to obtain more precise thread usage estimates, you can adjust fabric 
thickness to suit the target fabric. Settings are generally fine-tuned on a 
case-by-case basis. However, adjusted settings can also be saved to the current 
template.

To estimate total thread usage...
1 Select Customize Design > Design Information > Stitching tab.
2 Click Length Calculation.

3 Enter the thickness of the target fabric.
4 Adjust the bobbin thread length according to the mixture of thread types in the 

design. This factor provides a simple mechanism for a more accurate bobbin 
thread length estimate. The default value (100%) is suitable for a design with a 
mixture of stitch types. If the design is all run stitches or all tatami, more bobbin 
thread will be used and the factor can be increased say to 125%. If the design 
is all satin stitch, the factor can be reduced to say 65%.

5 Click OK. The Total Thread and Total Bobbin values are adjusted to take into 
account fabric thickness on total thread requirement.

6 Optionally, click Save to save revised settings to the current template.

Add backgrounds

Hatch Embroidery lets you set the color inside the hoop to match the fabric you 
intend to stitch out on. You can also set a background color outside the hoop by 

Enter the 
thickness of the 
target fabric

Click Length Calculation 
for more precise thread 
usage estimates
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way of contrast. Alternatively, you can add background fabrics based on samples 
packaged with the software.

Note: Backgrounds are treated as design details and are included when saving.

Background colors

Set the background color of the design window to match the fabric you intend to 
stitch on.

To change background colors...
1 Select Customize Design > Background and Display Colors or right-click the 

design window with nothing selected and select from the popup menu.

Use Customize Design / Context > Background and Display Colors to change design 
background and display colors.
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2 To select a color inside the hoop, choose the Solid Color option. This allows you 
to set separate colors inside and outside the hoop. Select a color from the 
palette or mix your own.

3 You can also set a background color outside the hoop by way of contrast. Set 
the color inside the hoop to match the color of the fabric you intend to stitch 
out on. See Hoop selection for details.

Background articles

Use Customize Design / Context > Background and Display Colors to change 
design background and display colors.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.

Choose 
background color

Choose separate 
inside color
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The same Background and Display Colors dialog also lets you choose a garment 
on which to position your designs. Use it to visualize location, size and overall 
appearance. Hatch Embroidery provides a library of articles to choose from, 
including multi-color garments. You can also load your own product images via 
the Custom Article option. The background is saved with the design.

Toggle articles on or off via the Show Design tool on the View toolbar. See also 
Viewing methods.

Tip: Some articles allow you to set up to three colors.

Visualize design 
on product 
backdrop
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Background fabrics

In addition to setting background colors, you can also set textures to further imitate 
the fabric you intend to stitch out on.

To change background fabrics...
1 Select Customize Design > Background and Display Colors or right-click the 

design window with nothing selected and select from the popup menu.
2 To use one of the preset fabric types, select the Factory Fabric option and 

select from the droplist and apply a color.

Tip: You can add your own fabric samples to the Fabrics folder in any of the 
supported file formats. You can also browse to another folder on your PC and 
select a file in any of these formats using the Custom Fabric option.

Use Customize Design / Context > Background and Display Colors to change design 
background and display colors.

Choose fabric for 
design backdrop
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Adjust display colors

In addition to background color or fabric, display colors for stitches, needle points, 
object shapes, and grid are part of the colorway definition. Change them if the 
default display color is not visible against the current colorway. The Background & 
Display Colors dialog includes a Display Colors panel.

Adjust colors as required for:

Use Customize Design / Context > Background and Display Colors to change design 
background and display colors.

Element Notes

Selected Selected objects or stitches.

Unsewn Unsewn stitches as they appear when traveling through the design.

Object shapes Object outlines as they appear when Show Shapes is activated. See View 
design details for details.

Special symbols Symbols such as trims and tie-offs as they appear in stitch view.

Grid lines Depending on the colorway, you may need to adjust grid display colors in 
order to view them against the background color.

Guidelines Depending on the colorway, you may need to adjust guide display colors in 
order to view them against the background color.

Needle points Needle points as they appear when Show Needle Points is activated. See 
View design details for details.

Adjust display
colors as preferred
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Combine designs

Hatch Embroidery lets you insert one design into another. The two (or more) 
designs can then be saved as a combined design. When you insert a design into 
another, the two color palettes are combined. Colors with the same RGB values 
are automatically identified as having the same thread color. If you want to 
preserve them as separate colors, you need to change one or other before 
importing.

Insert designs

The simplest way to create design layouts is to simply combine designs or design 
elements into a single design layout. Hatch Embroidery lets you insert one design 
into another. Use the Insert Design tool on the Standard toolbar or Customize 
Design toolbox.

Use Customize Design / Standard / Create Layout > Insert Design to insert an 
existing embroidery design into the current design. This tool is also available via File 
menu.

Insert chosen 
design into current 
design
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By default, the inserted design will be added to the first design and appear after it 
in the stitching sequence. The two (or more) designs can then be saved as a single 
combined design. 

Tip: Alternatively, travel to the point in the stitching sequence where you want to 
insert the second design. You can insert a design between objects in the 
sequence, or ‘nest’ the design within an object. By default, inserted designs will be 
grouped and centered on the screen.

Related topics

 Ungroup designs on inserting
 Save & export designs
 View stitching sequence
 Design settings

Fabrics & color palettes

When you insert one design into another, fabrics and design palettes are merged.

 If Auto Fabric is on in the current design, the inserted design will adapt to current 
fabric settings.

 If Auto Fabric is off in the current design, settings of the inserted design will stay 
the same.

Design colors of the inserted design will be appended to the Design Color toolbar, 
unless they are both using same colors and thread charts. If the inserted design is 
using a different thread chart, the design palette will show threads from both 

Use Customize Design > Auto Fabric to change the properties of the design for 
stitching on a different fabric.

New design 
inserted at end of 
stitching sequence
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charts. If you want the inserted design to share the same thread chart, use the 
Threads docker to merge thread colors.

Tip: If the two designs share colors, you may want to resequence them for efficient 
stitchout.

Related topics

 Fabrics & densities
 Sequence objects

Insert & modify

Typically, when design elements are combined, you will want to apply various 
transformations, including duplication, scaling, mirroring, and other operations.

When you select an object or design element, you will be presented with both a 
Context and a Standard toolbar. These allow you to insert designs as well as 
perform numbers of transformations to selected elements. Explore other topics in 
this section to acquaint yourself with the possibilities.

Use Customize Design / Standard / Create Layouts > Insert Design to insert an 
existing embroidery design into the current design. This tool is also available via File 
menu.

Select inserted design 
element to transform

Duplicate and mirror
inserted design element
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Design colors

You change colors for embroidery objects from the Design Colors toolbar. This is 
the simplest way to customize a design. Various techniques are available:

 Recoloring object-by-object
 Recoloring entire color blocks
 Picking and applying colors from the design
 Recycling colors within an existing design palette
Choosing new base colors and cycling the rest
In addition to the Design Colors toolbar, you use the Threads docker to change 
thread charts and assign threads to the design.

Tip: Hatch Embroidery users generally start with a large library of machine files, but 
not necessarily EMB design files. Most machine files do not natively support color 
information. However, you can convert machine files to EMB design files with some 
success and then recolor and resize to your requirements. Be sure to save to EMB 
after you change colors and before you export to your machine file so that color 
information will be saved with the file. See also Supported embroidery files.

View color blocks

The Design Colors toolbar offers an easy way to selectively view color blocks and 
embroidery objects. This is useful when re-coloring.

To view color blocks in isolation...

Open the design you want to recolor.

Use Design Colors > Current Color to view the current design color.
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Click and hold a color in the Design Colors toolbar to isolate it in the design 
window.

 Another technique for isolating colors is via the Arrange > View by Color 
command. The dialog allows you to tick the colors you want to view in isolation.

Click and hold 
design color to 
view color block

Select design 
colors to isolate
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Tip: Hidden colors are marked in the Sequence docker. Right-click to access 
the ‘unhide’ commands from the droplist. The same commands are available 
from the Arrange menu.

Usage tips
 The design is displayed in TrueView in the center of the design window, at 

actual size or at the design window location it was previously saved at.
 Design colors are displayed in the Design Colors toolbar, usually docked at the 

bottom of the screen.
 The ‘current color’ is highlighted in the Design Colors toolbar.
 Note the list of available thread colors in the Threads docker at the right side of 

the screen.
 The closest thread to the current design color is sorted to the top of list. The next 

closest shades follow it in the list.

Change thread charts

Use Threads > Select Thread Charts to select the thread charts you currently have 
available for use.

Use Threads / Customize Design > Match All Design Colors to automatically match 
and assign threads in the thread list to all colors in the Design Color toolbar.

Right-click to 
access popup menu

'Unhide' 
hidden colors



Chapte r  7     Customize D e signs 159

Often you will want to assign your own thread chart to the Design Colors toolbar. 
For instance, if you open a design which uses colors from a thread chart you don’t 
have, you can match them to your preferred chart.

To select a preferred thread chart...
1 Open the design you want to recolor.

2 Hover the cursor over a color in the Design Colors to view the tooltip. Note the 
name of the thread chart currently used in the design.

3 Click the Threads >> button or press Alt+T to open the Threads docker.

View associated thread 
and chart details



Chapte r  7     Customize D e signs 160

4 To change thread charts, click the Select Thread Charts button at the top left 
of the docker, and select your preferred chart/s from the dialog. Double-click 
or use the controls to transfer to the Selected panel and click OK.

5 Click the Match All button in the Threads docker or Customize Design toolbox.

Click to view and/or
change current

thread chart

Transfer 
preferred thread 
chart/s to 
‘Selected’ panel

Match threads in selected 
chart to current palette



Chapte r  7     Customize D e signs 161

All threads in the Design Colors toolbar will be substituted automatically by the 
nearest matching thread colors in the selected chart.

Related topics

 Print designs

Change design colors

The Design Colors toolbar has up to 128 color slots. When you open a new, blank 
design, it contains a palette of default colors. These can be used as is or matched 
to the thread chart of your choice. The Threads docker contains potentially 
hundreds of thread colors to choose from.

Use Design Colors > Current Color to view the current design color.

Use Design Colors > Threads >> to toggle Threads docker display. Use it to find 
threads from different charts and change design colors. 

Note new thread and 
chart details

Default palette
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When you open an existing design, colors may have been already assigned to 
actual threads – e.g. ‘Isacord 40’. Some file formats are not able to retain colors – 
e.g. DST, EXP. Used colors are tagged with a blue dot.

To change design colors...
1 Open the design you want to recolor.

2 Hover the mouse pointer over a color to view its code, name, and chart in the 
tooltip.

3 To change colors, select an object in the design window or Sequence docker 
Object list. Alternatively, use the Sequence docker Color list to select an entire 
color block.

Hover pointer to view its 
code, name, and chartCurrent color

Use slider to scroll 
through the list
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4 Scroll through the Threads list and single-click the desired color. The object 
changes color and the Design Colors toolbar is updated.

Usage tips
 Let’s say you want to change the color of selected objects within an existing 

color block. Click and hold the color in the Design Colors toolbar to view all 
objects in the block.

Click to choose 
replacement color

Click and hold design
color to view color block
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 Select the objects within the block you want to recolor, and choose a color 
from the Threads docker with a single-click. The new color is added to the 
Design Colors toolbar as shown. 

Note: The color block in the Sequence docker is split by the new color. Colors 
added in this way may need re-sequencing for more efficient stitchout.

Pick & apply colors

Use the Pick Color and Apply Color tools from the Design Colors toolbar to copy 
colors and re-assign existing colors from the design.

Use Design Colors > Pick Color to pick up a color from the design window and make 
it current.

Use Design Colors > Apply Color to apply the current color to embroidery objects.

Choose objects 
to recolor
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To copy and apply existing colors...
1 Open the design you want to recolor.

2 Select the Pick Color and move the cursor over the design. Note how different 
objects are highlighted.

3 Click the highlighted object to select the color. This becomes the current color 
and is shown in the current color slot.

4 Alternatively, select a design color directly by clicking the color slot in the 
Design Colors toolbar. This becomes the current color.

5 Select the companion tool, Apply Color and move the cursor over the design. 
Note how different objects are highlighted.

Target object
highlighted

Selected color
now current

Target object 
highlighted
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6 Click highlighted object to apply the selected color as shown.

7 Alternatively, use the Sequence docker Color list to recolor entire color blocks 
with a single click. This will assign the color to all objects within the color block.

Add threads to design palette

Use Design Colors > Threads >> to toggle Threads docker display. Use it to find 
threads from different charts and change design colors. 

Use Design Colors > Add Design Color to add a color to the end of the design palette.

Use Design Colors > Remove Design Color to remove an unused color from the end 
of the design palette. 

Target object 
recolored

Click to recolor 
entire color block
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Often you simply want to add new thread colors to your Design Colors without 
changing the color of existing objects. You can do this in a number of ways.

To add new thread colors...
1 Click the Add Design Color button on the Design Colors toolbar to add a new 

color slot to the end of the palette. An arbitrary color will be assigned and will 
become the ‘current color’.

2 Find the color you want in the Threads docker and click once. The color will be 
assigned to the new color slot.

Find new color 
to assign

New color slot 
appended to paletteCurrent color

Click to assign 
new color

New color assigned 
to color slot

Assign new
color to

selected object
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3 Alternatively, find the color you want in the Threads docker and simply 
double-click. The color is appended to the Design Colors as a new color slot.

4 Select objects in the design and click the new color to assign.

Customize design palette

Hatch Embroidery lets you manage thread colors for each design. Select from a 
wide range of commercial thread charts. Find and sort specific threads by color 
code. Replace colors with ones from a different thread chart. Add or remove color 
slots as required. 

Use Design Colors > Threads >> to toggle Threads docker display. Use it to find 
threads from different charts and change design colors. 

Use Threads > Select Thread Charts to select the thread charts you currently have 
available for use.

Use Design Colors > Add Design Color to add a color to the end of the design palette.

Use Design Colors > Remove Design Color to remove an unused color from the end 
of the design palette. 

Use Design Colors > Hide Unused Colors to show or hide all unused colors in the 
design palette.

Use Design Colors > Discard Unused Colors to remove all unused colors from the 
design palette.
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To customize your design colors...
1 Open the design you want to recolor.

2 Click the Threads >> button or press Alt+T to open the Threads docker.
3 Click Select Thread Charts and use the dialog to select your current/preferred 

thread chart/s. Thread colors from the chart can be assigned manually or 
automatically to the Design Colors toolbar.

4 Press the Esc key to deselect all objects in the design window.

Open Threads
docker

Transfer preferred 
thread chart/s to 
‘Selected’ panel
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5 Select a color in Design Colors toolbar. The Threads docker automatically 
locates the nearest matching thread in the selected chart. Make sure the 
thread list is sorted by Color column.

6 Choose your preferred thread and single-click to transfer to the Design Colors 
toolbar.

7 If you know the exact code or name of the thread you are looking for, key it into 
the Find Code field. Optionally, sort the thread list by clicking the Code column 
header. To view complete thread details, click the Show Thread Details button.

Click to sort 
list by color

Search by thread 
code if known
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8 Once you have located the desired thread, single-click to transfer to the Design 
Colors toolbar. The selected color becomes the Current Color.

9 Alternatively, click the Match All button in the Threads docker or Customize 
Design toolbox. All threads in the Design Colors toolbar will be substituted 
automatically by the nearest matching thread colors in the current chart.

10 Finally, to consolidate the Design Colors toolbar, use the Hide Unused or 
Remove Unused buttons as preferred. Hide Unused can be toggled on or off if 
you want to be able to access unused colors at a later stage. Used colors are 
tagged with blue dots, as shown.

Match threads in 
current chart to design 
colors

Hide or remove 
unused colors from 
palette
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Usage tips
When you open a machine file, color changes will be assigned arbitrarily to the 

default color palette. Again, you can match these colors to an actual thread 
chart.

When you convert graphics to embroidery in Graphics mode, colors are 
appended to the color palette as RGB values. These can be matched to an 
actual thread chart.

 In the machine file, a color block will be created at each color change.

Change color schemes

The Cycle Used Colors and Color Wheel tools allow you to change entire color 
schemes. Their main purpose is to create a new ‘colorway’ quickly and easily in 
order to ‘spice up’ old designs or place them on a different fabric. 

Use Customize Design > Cycle Used Colors to cycle through combinations of used 
colors. Left- or right-click.

Use Customize Design > Color Wheel to test combinations of related colors.

Color changes assigned 
to default palette
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To change color schemes...

 Use the Cycle Used Colors tool to try out different combinations of the colors 
within the design.

 Alternatively, use the Color Wheel. This allows you to cycle through many color 
combinations using preset color schemes including Analogous, 
Complementary, Harmonious, etc.

Click and drag the larger ‘base color’ node to try out different combinations of 
the same colorway. The base color nominally relates to the color of the target 
fabric and/or the dominant color scheme of the design.

 To adjust the brightness of the entire design, select the base color node and 
adjust the Brightness control.

Click and drag individual color nodes to fine-tune. Use the Brightness control 
further adjust selected colors.

Drag base color to cycle
through combinations

Current threads
and chart
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Click OK to confirm. The new color scheme is transferred to the Design Colors 
toolbar as RGB values. Click Match All to match them to the current thread 
chart.

Object properties

Designs created in Hatch Embroidery are composed of ‘embroidery objects’. They 
are called ‘objects’ because they can be manipulated independently of each 
other. Like drawing objects, embroidery objects have defining characteristics or 
‘properties’ such as color, size, position, and so on. They also have properties 
unique to embroidery such as stitch type and density. The most important property 
of an embroidery object is its stitch type. Other important properties include 
underlay type and pull compensation.

Use Edit Objects > Object Properties to show Object Properties docker. Use to 
preset properties for new embroidery objects or adjust properties for selected 
embroidery objects.

Access object properties

Colors transferred 
as RGB

Use Edit Objects > Object Properties to show Object Properties docker. Use to preset 
properties for new embroidery objects or adjust properties for selected embroidery 
objects.
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When you start a new design, Hatch Embroidery uses settings associated with the 
chosen fabric. Some properties can be modified on-screen – for example, you can 
change object size by scaling with selection handles. Others, such as stitch 
spacing or length, can be modified via the Object Properties docker.

To change object properties...
1 Select the object/s to change.
2 If not already open, double-click to open the properties docker. If you select 

more than one object, only settings relevant to all are displayed.

3 Select a tab and adjust settings.
4 Click OK to apply changes.

Tip: Changing details of selected objects does not affect default settings, nor 
the properties of any objects not in the selection. Changes to object properties 
are preserved if an object is modified and regenerated.

Related topics

Modify vector properties

Copy properties

Use Edit Objects > Copy Object Properties to make properties of a selected object 
current for the design.

Modify properties 
for selected 
objects
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You can make a selected object’s ‘actual’ properties ‘current’ for all new objects 
or apply them to other objects.

To copy properties...
1 Select the object and click Copy Object Properties. Alternatively, right-click the 

object and use the popup menu command.

2 Select the target object/s and click Apply Object Properties. The popup menu 
command is also available.

3 Repeat as necessary.

Fabrics & densities

Embroidery stitches pull fabric inward where the needle penetrates. This can 
cause fabric to pucker, and gaps to appear. For an object to sew out correctly, it 
must have correct stitch spacing, sufficient pull compensation together with a 
suitable underlay for the combination of cover stitch type, object type, object 

Use Edit Objects > Apply Object Properties to apply current settings to selected 
objects. 
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shape and fabric. Hatch Embroidery provides a set of optimized auto fabric 
settings so that it will take into account the type of fabric you are stitching on.

Choose auto fabrics

Choose from a set of predefined auto fabrics aimed at minimizing stitching defects 
when designs are sewn out. These make the necessary changes to the system 
settings – e.g. ‘pull compensation’. The new settings can be applied to all 
applicable objects. Normally you choose an auto fabric when you first set up a 
design although you can change it at any stage. Go to the Customize Design 
toolbox and choose Auto Fabric...

Use Customize Design > Auto Fabric to change the properties of the design for 
stitching on a different fabric.

Choose auto fabric to 
minimize stitching 
defects

Click to activate
auto fabrics
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Notice that the Auto Fabric dialog also provides recommended stabilizers 
according to the selected auto fabric. Stabilizer backings are woven or 
non-woven materials placed beneath the item or fabric being embroidered for 
stability and support. The more stitches a design has, the heavier the backing 
required. Backings are available in various weights and types such as cut-away, 
tear-away and wash-away (soluble). Professional embroiderers use tear-away 
stabilizers for woven fabrics and cut-away stabilizers for knits.

Tip: The auto fabric you choose here does not have a direct effect upon the 
design background nor vice versa. It’s up to you to set the background fabric to 
match your chosen auto fabric. 

Related topics

 Add backgrounds

Manage fabrics
In addition to the predefined auto fabric settings, you can create custom fabric 
settings to suit particular needs. You can also modify, rename or delete any 
custom fabrics you create.

To manage auto fabrics...
1 Select Software Settings > Manage Auto Fabrics. Most of the time, you will come 

to this dialog in order to edit auto fabric settings or create fabric variants.

2 To create a variant, select the base fabric and click Create.
3 Enter a descriptive name.

Choose auto 
fabric to edit

Enter descriptive 
name
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4 Click OK. The Fabric Settings dialog opens. This dialog lets you set auto fabric 
values for four object groups – Tatami/Embossed Fill, Wide Satin, Narrow Satin, 
and Lettering – as well as details of any recommended stabilizers.

Related topics

Customize design fabric settings

Adjust stitch densities

You may need to change stitch density in order to stitch on a different fabric or 
with a different thread. Or you may want to do a test design and reduce the 
overall stitch count for efficient stitchout. Hatch Embroidery lets you change the 
density of most stitch types across the whole or selected parts of a design.

To override current settings for the entire design, press Ctrl+A to select everything. 
Open the dialog and set a percentage adjustment – e.g. 200% to increase stitch 

Use Customize Design / Edit Objects > Adjust Stitch Spacing to manually override 
stitch densities for selected objects.

Preset fabric 
settings for each 
tab

Change density 
of most stitch 
types
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spacing and thereby reduce overall density. Check the revised stitch count in the 
Status Bar. See also Object properties.

Design templates

Templates are special files used to store fabrics, embroidery objects, and default 
settings. Essentially, anything that can be saved with a design can be saved in a 
template. Use templates when digitizing frequently-used design types so that you 
do not have to change current settings every time. When you start a new design 
using the File > New from Template command, a list of available templates is 
provided in the New from Template dialog...

What settings can I save to template?

Use Edit Objects > Object Properties to show Object Properties docker. Use to preset 
properties for new embroidery objects or adjust properties for selected embroidery 
objects.

Select from 
available 
templates
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Base properties or ‘defaults’ are stored with design templates and form the basis 
of all new designs. As the graphic shows, these include object properties as well as 
embroidery settings. The template may also include a default auto fabric. Note, 
however, that user-interface settings do not form part of the template.

The ‘Hatch3.JMT’ template is the default template supplied with Hatch 
Embroidery. If you use the New Blank Design command (Ctrl+N) either from the File 
menu or Standard toolbar, the ‘Hatch3.JMT’ template is applied by default. 
Template settings apply to all newly created objects in a design. Each object can 
be further customized as necessary.

When should I turn off auto fabrics?
As shown, auto-fabric settings are a subset of object properties. When Auto Fabric 
is turned on (the default), these settings override template defaults. When turned 
off, template defaults apply to all newly created objects. With Auto Fabric turned 
off, you can preset object properties before you start digitizing. These can be 
saved to template.
The decision to deactivate auto fabrics is in your hands. Bear in mind that template 
defaults are not adjusted for any particular fabric type. So any adjustments to 
object properties you make need to take into account...

 The kind of work you are doing
 The kind of fabric you will be using.

Tip: You can create a dedicated custom fabric and save this with your template. 
See Fabrics & densities for details.

Embroidery 
Settings

Object 
Properties

Auto Fabric
Settings

Template UI Settings
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Customize design environment

Setting up a custom template may not necessarily involve changes to fabric 
settings or object properties. You may simply want to preset your embroidery and 
design settings – e.g. background colors and articles, auto start and end points, 
preferred auto fabric, machine settings, hoop settings, current thread charts and 
design palettes, etc. You can access most of these settings from the Customize 
Design toolbox. Embroidery settings can be accessed from the Software Settings 
menu.

Use Customize Design / Context > Background and Display Colors to change design 
background and display colors.

Use Customize Design > Auto Fabric to change the properties of the design for 
stitching on a different fabric.

Use Customize Design / Output Design > Auto Start and End to set auto start and 
end points for entire design.

Use Customize Design > Threads >> to toggle Threads docker display. Use it to find 
threads from different charts and change design colors.

Dialogs required to
change template

defaults
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User interface settings
As mentioned, User Interface Settings such as grids, rulers and guides, are not 
saved to a template. These form part of the system defaults and are automatically 
saved when you close Hatch Embroidery. If, for example, you turn on grids and set 
a specific grid size, this will be remembered the next time you run the software. Like 
Embroidery Settings, User Interface Settings can be accessed from the Software 
Settings menu.

Customize design fabric settings

In addition to embroidery settings, you may want to save a particular set of object 
properties to your template depending on the type of work you are doing. As 
mentioned, when turned on, Auto Fabric settings override template defaults. So 
the first thing you need to decide is whether to turn auto fabrics on or off for your 
custom template. The options are these...

 Turn on Auto Fabric and set it to a predefined fabric type.
 Turn on Auto Fabric and set it to a custom fabric type.
 Turn off Auto Fabric and adjust object properties to suit the particular type of 

work and fabric you are using.

Use Customize Design > Auto Fabric to change the properties of the design for 
stitching on a different fabric.

Customize 
user-interface settings
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If you turn off auto fabrics, all object properties become available for 
modification, as shown below.

Preset object properties

You can preset object properties in two ways. Remember though that when Auto 
Fabric is turned on (the default), these settings override template defaults. 

Use Customize Design > Auto Fabric to change the properties of the design for 
stitching on a different fabric.

Use Edit Objects > Copy Object Properties to make properties of a selected object 
current for the design.

Use Edit Objects > Apply Object Properties to apply current settings to selected 
objects. 

Turn off auto-fabrics to 
access all object 
properties

Some object properties 
unavailable with 
auto-fabrics on
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To preset object properties...
1 Go to the Customize Design toolbox and choose Auto Fabric. Deactivate auto 

fabrics. See also Fabrics & densities.

2 With no objects selected, make the necessary adjustments to available object 
properties directly in the docker. For instance, for different types of work, you 
may want to modify stitch settings such as underlays, pull compensation, 
connectors, trims, etc.

3 Alternatively, having modified a particular object, you can make its properties 
current for the entire design. Simply right-click the object and select the Copy 
Object Properties command.

Tip: You may also want to save actual design objects to be used as templates 
for particular styles of work such as lettering.

Click to deactivate
auto fabrics

Copy object 
properties to 
make current

Select object to 
copy
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Save settings to template

Templates are essentially design files but use the extension JMT. When you close a 
design, current settings are not automatically saved to the current template. You 
can save modified settings to the default template though you should consider 
saving them to a separate template. 

To save current settings to a template...
1 Start a new design file or open an existing one.
2 Optionally, turn off auto fabrics if you need access to all object properties.
3 Adjust property settings, backgrounds, start/end points, effects, etc, as 

required.
4 Add any objects and/or lettering to be included in the template. For instance, 

you may want to include sample lettering using different baselines. When using 
the template, simply over-type the sample text.

5 Select File > Save as Template. The Save as Template dialog opens onto the 
TEMPLATE folder. This is located within the Hatch Embroidery installation folder. 
Templates must be saved here in order to appear in the template list when you 
start a new-from-template design. By default, the file type will default to the 
Hatch Template (JMT) format.

6 Enter a meaningful name for your template, and click Save. The template is 
ready for use and will appear in the New from template droplist.

Use Customize Design > Auto Fabric to change the properties of the design for 
stitching on a different fabric.

Save new template to 
TEMPLATE folder
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Caution: When saving to a new blank template, make sure there is no design 
currently open in the file. If there is, it will appear when you next open ‘new from 
template’.

Revert to default settings
If you unintentionally modify the default template supplied with Hatch Embroidery, 
you can revert to the original version. A copy is always maintained so factory 
defaults can be restored. Using Revert will of course erase any of your own settings 
saved to the default template. It will not, however, erase or affect any custom 
templates saved to names other than ‘Hatch3.JMT’. 

To revert the template to factory settings...
1 Close Hatch Embroidery.
2 Click the MS Windows® Start button and go to the Hatch Embroidery group.

3 Under the Tools folder, select Revert. The Revert to Factory Settings dialog 
opens.

4 Select the Templates checkbox and click OK. The original settings for the 
default template are restored.

Click Revert

Revert Templates 
to factory 
defaults
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Manage thread charts

The thread charts contained in Hatch Embroidery represent the many different 
brands and colors of thread available. Change thread charts to reflect the chart 
or charts you are currently using. Update thread charts by modifying thread details 
or removing threads. You can also rename or delete thread charts. Change code, 
brand or description for an existing thread. Create your own charts to represent 
the palette of threads you have available.

Modify thread charts

Thread charts may not always be accurate because thread manufacturers 
sometimes change, delete, and add new colors to their lines. For this reason, you 
can modify charts to update your own personal palette of threads.

To modify existing thread charts...
1 Click the Change Thread Chart button in the Customize Design toolbox. Click 

the Manage button.

2 Select a thread chart from the droplist. You have the option of deleting or 
renaming the chart.

3 In the Threads panel, select a thread to modify. Use the Search field to search 
on a specific thread code or name.

Use Customize Design > Select Thread Charts to select factory or custom thread 
charts to use in Threads list.

Click to open
Manage Thread

Charts

Click to edit 
selected thread 
chart
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4 To change thread details, click Edit. Here you can edit the color, code, brand, 
and description details of the selected thread. Code is the identification 
number of a thread color in a brand.

Create new thread chart

Sometimes, rather than modify an existing thread chart, it may be simpler to define 
your own. When you create a thread chart, you are creating a store of colors for 
future use. Select names that will help you remember the charts or help you sort 
frequently-used charts to the top of the list. You can copy colors from other charts 
or mix them yourself. You can also set the code, description, and brand of existing 
threads. Remove obsolete thread colors for good housekeeping.

To create new thread chart...
1 Click the Change Thread Chart button in the Customize Design toolbox. Click 

the Manage button.

Use Customize Design > Select Thread Charts to select factory or custom thread 
charts to use in Threads list.

Edit color, code, 
brand, and 
description details of 
selected thread

Click to open 
Manage Thread 
Charts

Click to create 
custom thread 
chart
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2 Click Create.

3 Enter a name for the chart and click OK. You have the option of adding threads 
singly or copying existing thread and editing them.

4 If you choose to copy, click the Copy button, and choose the source thread 
chart from the droplist.

5 Select the thread or threads you want to copy. Hold down the Ctrl key to make 
multiple selections.

6 Use the Edit thread option to change thread details as required.

Enter name for 
new thread 
chart

My Thread Chart

Copy selected colors 
from existing chart to 
new chart

Selected colors 
copied to new 
thread chart
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Chapter 8

OUTPUT DESIGNS

Using the Output Design toolbox you 
can output embroidery designs in a 
variety of ways – by printing as 
worksheets, as appliqué patterns, 
color sequence, or as thread charts. 
Hatch Embroidery also allows you to 
save your designs as images for use 
with fabric and garment 
applications. You can also send 
them directly to machine for 
stitching. When working with designs 
that are larger than the available 
physical hoop, you can split them 
into parts, each containing an 
object or group of objects. Hatch 
Embroidery automatically calculates which files are to be sent and shows you how 
they will look.

Note: You are advised to save designs stored in the machine’s built-in memory to 
hard disk or ATA PC card to prevent accidental loss of data due to improper 
operations or malfunctions.

Save & export designs

There are two types of embroidery file format:

EMB is the native file format of Hatch Embroidery. Other ‘all-in-one’ formats such 
as JAN are supported. Hatch Embroidery also supports many machine or stitch 
formats such as JEF, SEW, DST, EXP, and others. For a comprehensive list, see 
Supported embroidery files.

File type Function

Design Design files, also known as ‘outline’ or 'all-in-one' files, usually contain 
digitized shapes and lines, selected stitch types and stitch values and 
effects.

Machine Machine files, also known as ‘stitch’ files, generally contain stitches and 
machine functions and are only suited to specific embroidery machines.
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Save designs

The Save options allow you to save a design, whatever the file source, to native 
EMB format. EMB itself comes in many different versions. The Save options default 
to the latest. Choose the one which best suits the target software, if not your own.

To save changes to an existing design...
1 Simply click the Save Design icon on the Standard toolbar or press Ctrl+S. 
2 Or, to save to another version, choose Save Design As.
3 Select an EMB version from the Save as type list.

4 Enter a filename, navigate to the design folder, and click the Save button.

Related topics

 File sources
 Supported embroidery files

Small stitch removal
You have control over the automatic removal of small stitches. This functionality is 
accessed via Design Settings > Remove Small Stitches...

Use Standard > Save Design to save the current design.

Use Output Design > Save Design As to save current EMB design with a different 
name or location.

Choose an 
EMB version

Choose method 
for automatic 
removal of small 
stitches
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The filter can be applied continuously, on output only, or never. When set to 
‘Always’, the filter is automatically applied in the background whenever objects 
are edited or digitized. The default is ‘On output’. This option applies to all design 
output, whether you are saving to design file or exporting to machine file.

Export designs

You can export an open design to machine file format for use by embroidery 
machines. Hatch Embroidery supports machine formats such as JEF, SEW, DST, EXP, 
and many others. For a comprehensive list, see Supported embroidery files.

To export designs...
1 Open the design you want to export.
2 To export to a format recognized by your selected machine, click the Export 

Design icon.

3 Select the machine file type you want to export to.
4 Click Browse to locate a destination folder for the converted designs.

Related topics

Convert multiple designs
 Supported embroidery files

Export cutting lines

Use Output Design > Export Design to export the current design to a machine file for 
stitching.

Use Output Design > Export Cutting to export the current design or selected objects 
to SVG file format for cutting.

Choose file format 
recognized by your 
machine
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The Export Cutting command lets you export appliqué and/or embroidery shapes 
to SVG file format. The command also works with fonts. You can export entire 
lettering objects as cutting lines or break apart to export individual letters. Cutting 
data includes appliqué shapes outlining the fabric patches that will fill the 
appliqué. Only closed shapes can be exported as cutting files. Hatch Embroidery 
allows you to export entire files or selected objects only. Exported SVG files can be 
used directly in some cutters or converted to a format such as FCM. 

To export cutting lines...
1 Open the design to export. Optionally, select the object or objects you want to 

export.

Note: Only closed shapes can be exported as cutting files. The Close Shape 
commands can be used to close open shapes.

2 Click Output Design > Export Cutting or select the command from the File menu.

Select objects to 
export as cutting 
lines

Set object, layout, 
element, and location 
options for cutting 
lines
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3 Adjust settings as necessary:

4 Open the files in a suitable SVG editor. Brother cutters use their own format FCM. 
This format can be created via their online free conversion software. Other 
cutters now read PES files. Several cutters allow online editing. If you have 

Settings Details

Objects Choose whether to export the entire design or selected object/s only.

Layout Choose whether cutting lines should be exported as they were 
digitized, or automatically distributed.

Elements Choose whether to export appliqué cutting lines only and/or cutting 
lines for other embroidery shapes. Cutwork and Bling will only be 
displayed if those features are enabled in the software.

File locations Export files will be saved by default into a folder called ‘My Cutting Files’ 
under the ‘My Embroidery’ folder in the Design Library. This folder will 
be created when exporting if it doesn’t already exist. Alternatively, you 
can set up separate export locations for each element as shown:

Design name This defaults to the current design name. It can be changed prior to 
exporting cutting files. Separate files are exported for each element. 
The element name is appended to the design file name - e.g.
• Dog Applique_applique.SVG
• Dog Applique_embroidery.SVG
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chosen to export the entire design, you may need to separate objects in the 
editor for individual cutting.

5 Appliqué cutting lines can also be printed onto design reports.

Related topics

 Digitize open & closed shapes
 Print designs

Cutting lines in 
SVG format

Cutting lines printed 
in worksheet
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Transfer designs

Hatch Embroidery provides another 
method of connection to machines that 
appear as removable media or use a 
third-party application to connect to the 
machine and require files to be placed in 
a specific network location. Once your 
machine is set up, it only requires a single 
click in order to send a design to the preset 
folder on your network or PC.

Set up machine connection

In order to utilize the Transfer Design capability, you need to configure you 
machine connection to a specific network location. If there is nothing set up for a 
specific brand/model/type, you will be automatically prompted to configure 
machine details upon clicking the button. The dialog allows you to set up multiple 
brand, model/type combinations to use with the Transfer Design tool. When the 
machine is selected as current, the design will be transferred according to the 
machine details set here.

To set up a machine connection...
1 Right-click the Transfer Design button. The Machine Details dialog opens.

Use Output Design / Context > Transfer Design to transfer current design to the 
design folder. Right-click for settings.

Choose machine 
brand
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2 Select your machine brand and model from the droplists.

3 Select the file type required by the machine.

Choose machine 
model/type

Choose required 
file type
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4 Depending on the selected file type, further options may be available via the 
Options button.

5 Enter or browse to a file location on the network or the PC.

6 Click OK when complete. The new machine and machine folder will now be 
preset for the Transfer Design button.

Related topics

Machine selection

Choose further 
options as 
available

Browse to file 
location
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Transfer design to machine folder

Once your machine is set up, it only requires a single click in order to send a design 
to the preset folder on your network or PC.

To transfer design to machine folder
1 Click the Transfer Design button. A confirmation message appears.

2 The design is transferred to the preset machine folder in the required file format. 
From here it may be picked up by third-party machine connection software.

Use Output Design / Context > Transfer Design to transfer current design to the 
design folder. Right-click for settings.
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3 Whenever you want to change machine type and/or file type, right-click 
Transfer Design to access the Machine Details dialog.

Print designs

You can output embroidery designs in a variety of ways – by printing as 
worksheets, as appliqué patterns, color sequence, or as thread charts. Even print 
thread charts as a shopping reference when purchasing threads.

Note: A ‘PDF’ is an Adobe document file type designed for onscreen viewing, 
printing, and electronic distribution. In Hatch Embroidery, you can use the ‘Print 
Design’ function to save to PDF. However, you need to have the capability 
already installed on your computer. It may be included with your version of 
Windows. Or you may have a PDF writer already installed via Adobe, MS Office or 
a third-party program. There are free PDF writers available online. See also How to 
save to PDF in Hatch Embroidery.

Print preview

Use Print Preview to view stitching information and to check the sewing sequence. 
Your design displays as it will be printed. If you are using a color printer, you can 
print in TrueView. Large designs may be displayed over a number of pages if 

Edit machine 
details as 
necessary

Use Output Design / Standard > Print Preview to preview design worksheet. Print 
from preview window.

https://help.hatchembroidery.com/hc/en-us/articles/360000155155-How-to-save-to-PDF-in-Hatch-Embroidery
https://help.hatchembroidery.com/hc/en-us/articles/360000155155-How-to-save-to-PDF-in-Hatch-Embroidery
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printed at actual size. Use the Options buttons at the top of the screen to configure 
the appearance of the printout.

Design information includes design size, color sequence, and stitch count, 
together with an image of the design. It also includes author, estimated length of 
upper thread per color and total bobbin usage.

Note: Designers frequently want to distribute designs for viewing in real colors, in 
TrueView or otherwise, with or without fabric backgrounds. Screen images can be 
captured in PNG format and send as email attachments. See also Capture design 
images.

Print options

Print options give you precise control over your design printout. Different worksheet 
configurations are available for different purposes – design worksheet, color 
sequence, appliqué pattern, as well as hooping sequence. Each configuration 
can be further customized.

Use Output Design / Standard > Print Design to print the current design.

Use Output Design / Standard > Print Preview to preview design worksheet. Print 
from preview window.

Design information 
provided on 
worksheet
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To set print options...
1 Click Print Preview or Print Design.

2 Choose your preferred printer if not already set up. Many PDF programs are set 
up as a PDF printer. In this case, you may ‘print to PDF’ which actually saves the 
file to PDF format.

3 In the dialog, click Options to further configure print options. The default 
worksheet type is the ‘design worksheet’.

Access worksheet
options

Adjust printer 
settings as 
necessary

Select worksheet 
type

Fine-tune design 
worksheet settings

Choose preset 
configurations

Adjust design 
zoom settings
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4 Set a worksheet type.

5 If you have selected ‘design worksheet’, three presets are available:

6 Further configure design worksheet options as preferred. See below for details.
7 Optionally, print the whole design or selected objects only. If the latter, select 

the objects before accessing the Print Options dialog.
8 Select a sizing option from the Zoom panel. When selecting Template Mode, the 

Actual Size option is automatically selected. If the Zoom 1:1 option is selected, 
both an assembled appliqué layout and individual patterns in the actual size 
are created on separate pages. If the Zoom to fit or % of Actual options are 
selected, the assembled appliqué layout is created in the selected size, but 
individual patterns are still printed in the actual size on separate pages.

Note: While the cloth setting marking is supported in JEF and SEW files, outlines are 
not. Since JEF and SEW are machine file formats, they only contain stitch data, no 
outlines. The workaround is to display JEF and SEW files with stitches and cloth setter 
marking turned on.

Report options

Type Purpose

Design worksheet This provides all production-related information, such as bobbin 
length, design size, garment fabric, etc, is provided.

Appliqué patterns This shows appliqué patterns – cutter information – isolated from the 
design. These can be used as a guide to cutting out fabric pieces.

Color sequence Provides a list of colors in the design, together with color and stitch 
information for each color layer.

Hooping sequence If there is more than one hooping in the design, this option displays 
hoopings in their correct color sequence.

Preset Purpose

Standard Resets worksheet options to default values.

Design view Shows the design as it appears in the design window.

Template mode Shows the design outlines with no stitches.

Use Output Design / Standard > Print Design to print the current design.
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The Print Options dialog gives you three preset configurations:

You can further customize these print options by including or excluding the 
following:

Preset Purpose

Standard Resets worksheet options to default values.

Design view Shows the design as it appears in the design window.

Template mode Shows the design outlines with no stitches.

Option Purpose

Stitches Display design as stitches with or without Artistic View. In stitch view, 
connectors may also be shown. Use them as a guide when you save to 
multiple files for multi-hooped positioning.

Outlines In stitch view, outlines helps delineate shapes. Alternatively, turn off 
stitches and print outlines alone.

Artwork Include any bitmap or vector artwork in the printout.

Start & end 
crosshairs

The start/end needle position is included in the printout. See also Set 
start & end points.

Background Include design background if set – for instance, to indicate fabric 
appearance or position on garment. See also Add backgrounds.

Design boundary Display design bounding rectangle and reference marks similar to the 
machine display. This means start and end point positions can be easily 
identified. When designs are located on a large work piece, like a table 
cloth, design extents and geometric center become important for 
positioning.

Hoop It may be important to include the hoop in the printout for positioning 
purposes. Alternatively, use the hoop position marker to align the needle 
and orientate the hoop.

Hoop template Printing the hoop template allows you to cut out the printed design and 
align it within the hoop. Use the template markings to align it to physical 
hoop template.

Hoop position 
marker

This indicates the hoop center and orientation for more accurate 
hoopings.

Work area This lets you arrange multi-hoopings on an item or fabric to be sewn. It 
should be printed together with hoop position markers. See also Design 
Layouts.

Grid / guides These may be used to help align the hoop template lines. See also 
Change measurement units.
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Optionally, tick Design Information to include production information in the 
printout:

Appliqué patterns
Print a copy of the appliqué pattern to cut out fabric pieces. Each appliqué 
pattern piece is numbered according to the stitching sequence.

Information Purpose

Thread usage Helps you determine length of threads required and assemble prior to 
production. Thread usage appears below the color sequence list.

Machine runtime Estimated machine runtime based on default machine type.

Print on separate 
page

Print all design information on a separate page for easy reference. For 
instance, a multi-hooped design may include many color changes, 
requiring a dedicated page to display.

Appliqué patterns 
numbered according 
to stitching sequence
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Color sequence
The Color Sequence option lets you include a list of color layers in the current 
design, together with color and stitch information for each layer.

Hooping sequence
If there is more than one hooping in the design, you have the option of printing 
hoops in multi-hooping view in their correct color sequence. The Hooping 
Sequence option allows you to print a color film type printout showing the objects 
in each hooping.

Design layouts

Use Output Design / Standard > Print Preview to preview design worksheet. Print 
from preview window.

Color and stitch 
information for each 
layer

Color film printout 
showing objects in 
each hooping
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You can sew embroidery out by sending the design directly to a sewing machine 
or saving it to removable media and stitching out using a layout template and the 
cloth setter. The device has a transparent plastic bar with marked cross. See Print 
layouts for details.

Capture design images

Designers frequently want to distribute designs for viewing in real colors, in 
TrueView or otherwise, with or without fabric backgrounds. In a commercial 
environment, this might be for stock design sales purposes, for approval of digitized 
designs, or for presentation on the web or in catalogs.

Screen images are captured in PNG format. Bitmap resolution defaults to current 
screen resolution. Properly calibrated, this figure should default to approximately 
72 or 96 DPI (dots per inch), depending on the resolution of your monitor. Options 
are self-explanatory...

Use Output Design > Capture Design Image to save design image as bitmap exactly 
as it appears in the current design window.

Capture design 
image as it appears 
in design window
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Selection options include:

Output options include:

Print layouts

You can sew embroidery out by sending the design 
directly to a sewing machine or saving it to removable 
media and stitching out using a layout template and 
the cloth setter. The device has a transparent plastic 
bar with marked cross.
Hatch Embroidery allows you to define layout work 
areas of up to 3m x 3m. Large layouts may print to 
many pages. To save paper, you may choose to print 
at a percentage of actual size. You must then 
remember to multiply the template dimensions by a scale factor. For example, if 
you print at 50%, you need to double the measurements on the worksheet when 
transferring to the fabric. Use the table below as a guide.

Option Description

Whole design (1:1) Captures the screen image in a ratio of 1:1.

Current design 
window

Captures the screen image at the currently selected zoom factor.

Custom Lets you specify a capture area. You are prompted to define the area 
to capture.

Option Description

Save to disk Save screen capture to disk. Select a location, name and format for the 
captured design image.

Send via email A new email message opens with the image attached.

Save & send Save to hard disk and send as an email attachment.

Use Output Design / Standard > Print Preview to preview design worksheet. Print 
from preview window.

% Scale Factor

50% 2:1 x 2

25% 4:1 x 4

20% 5:1 x 5

10% 10:1 x 10
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To print a design layout
1 Click the Print Preview icon. Your design layout displays as it will be printed.

2 Click Options. The Print Options dialog opens.
3 Select Template Mode. These settings show the design outline with no stitches.

4 Make sure Cloth Setter Marking and Work Area options are checked. The cloth 
setter marking indicates the hooping center. It is printed with each hooping in 
the design.

5 Select the Zoom 1:1 option in the Zoom group.

Access print
options

Choose Template 
Mode
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6 Click OK. Each hooping has a number printed near the cloth setter mark to 
indicate the hoop sequence.

7 You can print out an overview of the layout by selecting Zoom to Fit or entering 
a value in the % of Actual field.

Note: While the cloth setting marking is supported in JEF and SEW files, outlines 
are not. Since JEF and SEW are machine file formats, they only contain stitch 
data, no outlines. The workaround is to display JEF and SEW files with stitches 
and cloth setter marking turned on.
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PART III
STITCH TYPES & EFFECTS

Designs are composed of ‘embroidery objects’. They are called ‘objects’ because 
they can be manipulated independently of each other. Like drawing objects, 
embroidery objects have defining characteristics or ‘properties’ such as color, size, 
position, and so on. They also have properties unique to embroidery such as stitch 
type and density. The most important property of an embroidery object is its stitch 
type. Other important properties include underlay type and pull compensation.
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Chapter 9

BASIC STITCH TYPES

The most important object property is stitch type. Hatch Embroidery uses object 
outlines and the associated stitch type to generate stitches. Whenever you 
reshape, transform or scale an object, stitches are regenerated according to 
current settings. Depending on your level of product, you may have access to 
properties of all embroidery objects or restricted to objects such as lettering.

Different stitches are suited to different objects. You can change stitch types at 
any stage. A wide range of fill and line stitch types is available via the Object 
Properties docker.
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Outline stitches

Hatch Embroidery provides tools for creating outline stitching of varying 
thicknesses and styles. Digitize outlines with both open and closed shape methods. 
Lines of varying thickness are typically used to add borders, outlines, and details to 
shapes. There are tools for creating simple run stitching as well as decorative 
outlines using motifs.

Backstitch is an older-style, adaptable stitch which can be used for delicate 
outlines. Stemstitch is thicker and can be used to mimic hand-sewn embroidery. 
Satin lines can be used for stem shapes or thicker borders.
In all cases, digitizing techniques are the same. Most digitizing tools are available. 
Simply select a digitizing tool, a fill or outline method, a stitch type, and click 
reference points. Press Enter to confirm or Esc to cancel. Stitch types can be easily 
swapped. Simply select the object and choose another stitch type.

Simple outlines

Use Object Properties > Outline > Single Run to create single rows of stitching for 
borders or details along a digitized outline.

Use Object Properties > Outline > Triple Run to create a thicker outline for heavier 
borders or details.
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Use Single and Triple Run tools to digitize lines of simple run stitching. Digitize simple 
runs as you would any other outline stitch. Adjust settings via Object Properties.

For both run and triple-run stitches, stitch length can be adjusted via Object 
Properties to suit the shape. If a line has tight, sharp curves, reduce the length, for 
example to 1.8 mm, so that the stitches follow the line. To reduce the stitch count 
for flatter curves, increase the stitch length.

Choose between run or triple run for thicker lines...

Usage tips
Mimic hand-made embroidery by using triple run and setting run length to 

4.0mm.
 Hatch Embroidery also provides tools for automatically generating outlines. See 

also Outlines & offsets.
 Use Backtrack and Repeat to reinforce outlines while specifying the direction of 

the stitching. See also Stitch reinforcement.

Satin outlines

Satin stitch can be used for outlines. It is well-suited to thicker borders. Adjust stitch 
density by setting a fixed spacing value, or let auto spacing calculate it for you. 

Use Object Properties > Outline > Satin to create thicker borders or columns of even 
thickness.

Use Object Properties > Outline > Raised Satin to create raised satin borders – can 
be used with trapunto for quilting effects.

Too few stitches to follow 
tight curve

Stitches follow the curve 
more closely

Stitch length Stitch length

Stitch length 1.7mm
Stitch length 2.5mm

Single Run

Stitch length

Triple Run

1 2 3 4 5 6

1

2

3

5

6

4
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Use Raised Satin to create raised borders consisting of multiple layers of satin 
stitching. Stitch settings can be adjusted before or after digitizing. See also Satin 
stitch.

Motif outlines

Motifs are predefined design elements, such as hearts, leaves or border patterns, 
that can be quickly inserted into a design. They generally consist of one or more 
simple objects, and are stored in a special pattern set. Motif line is a stitch type that 
creates motif repeats along a digitized line. Choose from a motif library or create 
your own. Motifs can be scaled, rotated and mirrored in the same way as other 
objects.

Tip: You can use the same motif patterns singly – one-by-one – or in motif fills for 
open, decorative stitching. See also Motif stitching.

Use Object Properties > Outline > Motif to create ornamental craftstitch borders. 
Choose from pattern library.

Satin outline
settings

Motif outline
settings
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Backstitch outlines

Backstitch is a traditional, adaptable stitch which can be used as a delicate 
outline. This small, even stitch follows intricate curves well. Backstitch can be used 
for blackwork and redwork designs. You can specify the exact stitch length, 
thickness and overlap values as well as the number of strokes (single or triple).

Stemstitch outlines

Stemstitch is a detail stitch. It is used for stems and vines with other decorative 
stitches, or as an outline for stitches such as satin or motif fills. You can specify 
various settings including line width, spacing, angle, strokes (single or triple), and 
stitch thickness.

Tip: Stemstitch can also be used to create heavier stipple fills with stemstitch lines. 
See also Stipple fills.

Sculpture outlines

Use Object Properties > Outline > Backstitch to create traditional backstitch borders 
– old, adaptable stitch type used for delicate outlines.

Use Object Properties > Outline > Stemstitch to create traditional stemstitch borders 
or details such as stems and vines.

Use Object Properties > Outline > Sculpture to place a row of 'sculpture' stitches 
along a digitized line to simulate line stitches used in quilting.

Backstitch
outline settings

Stemstitch
outline settings
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The Sculpture Run outline is used to simulate line stitches in quilting. It is a variation 
of multiple run stitching, where each alternative triple/multiple run stitch is 
replaced by a single run stitch. Sculpture Run outline is recommended for use only 
with later-model machines.

Recommended sewing settings for Sculpture Run include:

Zigzag outlines

Zigzag stitch is similar to Satin in that the needle penetrates each side of the 
column. But while Satin gives a straight line followed by a diagonal, Zigzag 
produces two diagonal lines, thereby producing a more open stitch.

Blanket outlines

Setting Recommended

Needle Large eye needle

Needle thread Monofilament clear thread (with spool net)

Bobbin thread Depends on the look you want to achieve

Bobbin holder Bobbin holder for hand-look stitching (preset with lower tension)

Upper thread tension 7

Stitch length 2

Speed 400 spm

Use Object Properties > Outline > Zigzag for long, narrow columns of slanted, 
side-by-side stitches in a zigzag pattern.

Use Object Properties > Outline > Blanket for long, narrow columns with a ‘comb’ 
effect.

Sculpture run
settings

Zigzag outline
settings
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Blanket, sometimes referred to as ‘E stitch’, produces long, narrow columns with a 
‘comb’ effect. It is often used to stitch borders around appliqué. The needle 
penetrates both sides of the column, and then penetrates the second side again, 
laying the thread along the side. Blanket stitches are usually more open than Satin 
or Zigzag stitches.

Satin stitch

Satin stitch can be used for outlines or fills. It is 
well-suited to borders and thicker outlines. It is 
also well-suited to narrower shapes where 
stitches run the entire width of the column. Satin 
stitches are almost parallel. Because there are 
generally no needle penetrations breaking up 
the fill, satin stitch creates a glossy, high-quality 
effect. Satin stitch can be used with any of the 
digitizing tools.

Tip: Puffy foam is commonly used to achieve 
3D-like raised embroidery. Digitizing for puffy foam may be a bit more technical 
than every-day digitizing, but if you follow a few rules, it’s actually not that 
complicated.

Satin lines

Blanket outline
settings

Use Object Properties > Outline > Satin to create thicker borders or columns of even 
thickness.

Use Object Properties > Outline > Raised Satin to create raised satin borders – can 
be used with trapunto for quilting effects.
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Use Satin line to create thicker borders. Use Raised Satin line to create raised 
embroidery designs consisting of multiple layers of satin stitching. Stitch spacing 
and width can be adjusted before or after digitizing via Object Properties.

Line thickness

Satin line width can be controlled either by means of the Width setting in Object 
Properties, or interactively, using the Reshape tool and dragging the sizing 
handles. When you drag them, a prompt appears indicating the line width, as 
shown below. Use the Offset setting if you want your satin line to overlap the 
boundary of the shape. This will stop gaps from appearing when using satin line as 
a border adjoining another object.

Stitch spacing
Stitch spacing is the distance in millimeters between two needle penetrations on 
the same side of a shape. Where it is very narrow, stitches need to be less dense 
because too many needle penetrations can damage the fabric.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Use Reshape or 
Object Properties to 
control line 
thickness

Length 1

Spacing 1

Spacing 2

Length 2

Auto spacingFixed spacing
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Where a border narrows, stitches are tight, thus requiring fewer stitches to cover 
the fabric. The Automatic setting adjusts stitch spacing for satin stitches according 
to outline width. For objects of varying width, Automatic adjusts spacing 
accordingly. Manual spacing allows you to set a fixed spacing of greater or lesser 
density.

Stitch quality
Stitch shortening is automatically applied to sharp corners to decrease density on 
the inside edge...

Calligraphic satin lines

Satin lines, both open and closed, include a ‘calligraphy’ setting which allows you 
to specify an angle like an italic pen nib. Generally you will use this setting with 

Use Digitize > Digitize Open Shape to create a row of run or other outline stitching 
along a digitized line. Left-click for corner points, right-click for curves.

Use Context > Outline to outline closed shapes with the current line stitch type.

Choose between 
variable (automatic) 
and fixed spacing

Stitch ‘shortening’ 
applied to sharp corners 
to reduce ‘bunching’ 
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Digitize Open Shape but it can also be applied to Digitize Closed Shape with line 
stitching selected.

Tip: The same setting can be used with Freehand tools to create more interesting 
‘calligraphic’ effects. See Freehand for details.

Satin fills

Satin fill is well-suited to narrow borders and shapes where the length of each stitch 
runs the width of the shape. Satin stitches are almost parallel, with every second 
stitch slightly slanted. Because there are generally no needle penetrations 
breaking up the fill, satin creates a glossy, high-quality effect.

As shown above, satin stitching can also be used for larger shapes where a glossy 
effect is desired. However, embroidery machines have a maximum possible stitch 
length which is determined by the physical frame movement. If a stitch exceeds 

Use Object Properties > Fill > Satin to create stitch fills for narrow shapes and thick 
borders.

Use Object Properties > Fill > Raised Satin to create raised surfaces – can be applied 
to lettering or used with trapunto for quilting effects

Use ‘calligraphy’ 
setting for italic pen 
nib effect

Auto split onAuto split off
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this, it is generally broken into smaller stitches of equal length. The line formed by 
needle penetrations can affect embroidery appearance. The example below 
shows a hard line of needle penetrations where long satin stitches have exceeded 
the maximum stitch length. Usually 12.1 or 12.7 mm, this maximum value varies with 
the selected machine type.

There are two techniques for handling unwanted split lines - automatic splits and 
automatic jumps...

Automatic splits
Auto Split breaks long satin stitches into shorter ones. But it also distributes needle 
penetrations in a random pattern so that they do not form a line down the middle 
of the shape.

While Auto Split is used primarily to prevent long stitches in wide shapes, it can also 
be used as an alternative to tatami fill. Auto Split looks more satin-like and works 
well with turning stitches, creating soft lines and a little more depth. By contrast, 
tatami fill is flat and can show unwanted patterns with tight curves.

Automatic jumps
Alternatively, you can apply Auto Jump to satin objects that exceed the maximum 
stitch length. In essence, Auto Jump is a means of preserving long stitches. It affects 
other stitching but is primarily used with satin. Long stitches are automatically 
divided into increments of maximum stitch length but without needle penetrations. 
To see the effect, you need to turn off Auto Split. In stitch view, the line down the 
middle represents jumps or ‘needle up’ movements at the maximum stitch point. 

Line of needle 
penetrations where 
max stitch length 
exceeded

Auto split distributes 
needle penetrations 
at random
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Unless there are trims present, there will be a long uncut thread. TrueView shows 
long stitches as they will appear in stitchout.

Auto Jump generally makes stitching looser and subject to being caught and 
pulled and potentially broken. Thus Auto Jump can be used, for example, with 
manually digitized underlays which will be held down by cover stitching. It can also 
be used to create quilted effects, for example, by applying it to satin areas that 
are over-stitched with Run stitch or Motif Fill.

Tip: Typically, Raised Satin is used to create extra body in satin objects for visual 
effect and to provide a raised or ‘sculpted’ surface. See also Raised embroidery.

Turning satin

In addition to normal digitizing tools, the Digitize Blocks tool 
can be used with Satin to create turning fills of varying width.

 Digitize the column by marking points on alternate sides 
of the column. Click to enter corner points. Right-click to 
enter curve points.

 The control points in a pair do not have to be the same 
type. For example, one can be a corner point, the other 
a curve.

Use Digitize > Digitize Blocks to digitize column shapes of varying width, setting the 
stitch angle at each pair of points.

Use Auto Jump to 
preserve long 
stitches
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 If you make a mistake, press Backspace to delete the last point. Press Esc to 
undo all new points. Press Esc again to exit digitizing mode.

When you have finished digitizing, either:
 Press Enter to keep the last stitch and place the exit point at the last point 

you digitized, or
 Press Spacebar to omit the last stitch and place the exit point on the 

opposite side of the column.

Tatami fills

Tatami Fill stitch consists of rows of run stitches and is suitable for filling large, 
irregular shapes. Stitches are laid in rows going back and forth across the shape. 
These can be parallel or slightly turning. Stitch offsets in each row eliminate 
unwelcome split lines. You can control stitch density in tatami fill objects by 
adjusting the pattern, stitch spacing and length.

Apply tatami fill

To preset Tatami Fill, open the Object Properties with no objects selected. To edit 
settings, select a tatami fill object. The Object Properties > Fill tab opens. Select 

Stitches change angle 
through the entire 
shape

Stitches remain parallel 
between parallel stitch 
angles

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.
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Tatami and choose a suitable pattern from the gallery. Any closed line digitizing 
tool is available for use.

Tatami patterns are formed by needle penetrations. The default pattern (No. 1) is 
designed to create a uniformly flat and smooth texture similar to a woven mat. 
There are many other preset patterns to choose from. Experiment to find the best 
pattern for your purpose.

Generally default size and spacing will produce the best results, but you may want 
to change stitch angle.

Choose from a 
gallery of predefined 
tatami patterns

Stitch angle 
affects tatami 
pattern
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Adjust tatami fill density
For Tatami Fill, stitch density is determined by row spacing. The spacing setting is 
the distance between two forward rows. To increase density, enter a smaller value. 
To create a more open fill, enter a larger value.

Stitch length varies slightly in tatami fill to ensure that small stitches are not 
generated at the edges of the shape. Increase length for a looser, more glossy 
appearance.

Tip: Notice that the Travel on Edge setting is activated automatically for spacings 
larger than 0.9mm. This forces underlying travel stitches to the edges of shapes, 
preventing them from showing through open stitching. See also Gradient fill 
effects.

Use row spacing to 
control stitch 
density

Increase length for 
a looser, more 
glossy appearance
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Chapter 10

DECORATIVE STITCH TYPES

In addition to outline stitches, satin stitching, and tatami fills, Hatch Embroidery 
provides many decorative stitch types to enliven your designs and create visual 
interest. Depending on your product model, these may include embossed fills, 
curved fills, motif stitching, fancy stitches, stipple fills, as well as cross stitch. These 
can be used on their own or usually in combination with other stitch types and 
effects.

Embossed fills are used to fill wide and large areas with patterned stitching while 
keeping the appearance of a solid field. Contour fills follow the contours of a 
shape, creating a curved, light and shade effect. Ripple fills radiate outwards from 
a common central point. Motif stitching can be used for lines or fills. Select from a 
library of pre-defined motifs. These are repeated in parallel rows to form 
decorative outlines or fills. Stippling is a method for creating textured fills of run 
stitching which meanders more or less randomly within a border. Cross stitching is 
a popular technique for filling large areas with low stitch counts. Crosses in 
separate objects line up precisely when using the same fabric count. 
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Embossed fills

Embossed Fill is a decorative fill stitch used to fill wide and large areas with 
patterned stitching while keeping the appearance of a solid field. The pattern is 
repeated along a grid. You can change grid settings for greater variation.

Note: Elastic Embossed Fill is a decorative effect where the pattern follows the 
stitch angle and may be scaled to fit the width of the object. You can apply Elastic 
Embossed Fill to a variety of object and stitch types. See also Contoured fills.

Apply embossed fill

To preset Embossed Fill, open the Object Properties docker with no objects 
selected. Any closed line digitizing tool is available for use. Double-click to edit 

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.
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existing objects. The Object Properties > Fill tab opens. Select Embossed Fill. You 
can choose from many patterns.

Embossed fill settings
Embossed fill settings can be controlled in a similar way to motif fill settings, both 
via the Object Properties docker and interactively on screen. The docker allows 
you to control pattern size, spacing, and orientation by the same settings as motif 
fill. It also allows you to control the stitch density via Stitch values.

Choose from a gallery 
of predefined 
embossed fill patterns

Control pattern size, 
spacing, and 
orientation
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Pattern size and angle

Adjust pattern size via the Width and Height fields. The scaling lock maintains 
aspect ratio. Use the Angle setting to orientate the pattern within the shape.

Column & row spacing

Column and row spacing settings determine distance between grid lines. Patterns 
are placed at intersection points – the center of each pattern coincides with an 
intersection.

Column & row offsets
You can vary the pattern by applying offset settings to rows and/or columns. If 
both offsets are set to ‘0’, grid lines are perfectly vertical and horizontal. As a rule, 
it only makes sense to use values between 0 and half the pattern size. For example, 
if the pattern is 8 mm, select row and column offsets between 0 mm and 4 mm.

Default values Width and height increased Angle adjusted

Column spacing increased Row spacing decreasedDefault spacing values

Column offset: 0.00 Column offset: 1.00 Column offset: 2.50

Row offset: 0.00 Row offset: 1.00 Row offset: 2.50
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Adjust pattern layout interactively
In addition to object properties, you can adjust layouts interactively. Lay out 
patterns on-screen by using ‘guide patterns’ to scale, space, transform and offset 
the entire pattern.

To adjust pattern layout interactively...
1 Adjust view settings as necessary and turn off TrueView for better visualization.

2 Click Layout. Three guide patterns appear in the design window. Each guide 
pattern lets you change a different element of the layout.

Tip: Zoom in and adjust selected guides to achieve the effect you want. 
Release the mouse button. All patterns in the fill change accordingly.

Adjust pattern 
layouts interactively

Click to lay out
pattern
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3 Click and drag the guide pattern with the aqua circle node to move all.

4 Click and drag the yellow square node of the top guide pattern to change row 
spacing. 

 Hold the Shift key while dragging to adjust row offset. 
 Hold the Alt key while dragging to adjust row spacing and offset together.

5 Click and drag the yellow square node of the right guide pattern to change 
column spacing.

 Hold the Shift key while dragging to adjust column offset. 

Move entire
pattern

Adjust row 
spacing and offset

Adjust column 
spacing and offset
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6 Click and drag the right guide pattern with the yellow square node while 
holding Ctrl key to rotate.

 Hold the Alt key while dragging to rotate and adjust column spacing at the 
same time.

7 Click the guide pattern with the aqua circle node to access pattern sizing 
handles. Use these to adjust pattern width and/or height.

8 Release the mouse button and view the result in TrueView.

Related topics

 View design details

Rotate entire 
pattern

Click to access
sizing handles
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Grid orientation

As an alternative to using the layout guides to control grid orientation, you can use 
stitch angle to control pattern orientation.

Where this feature really comes into its own, however, is in combination with 
turning stitch angles. When activated, the grid orientates itself to the stitch angles 
defined within the object. If the object does not contain turning stitches, you can 
generally add them with the Add Stitch Angles tool.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Use Edit Objects / Digitize > Add Stitch Angles to add stitch angles to selected closed 
objects with or without holes.

Use stitch angle to
orientate pattern

Choose turning
pattern option

Use turning 
angles to bend 
patterns
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Embossed fills can be applied to objects with turning stitches to create 3D, turning 
pattern effects which can’t be achieved by embossed fill alone.

Related topics

 Stitch angles
Curved fill effects

Contoured fills

Hatch Embroidery provides several techniques for creating curved stitching. 
Contour Fill follows the contours of a shape, creating a curved, light and shade 
effect. Ripple Fill is achieved by radiating a stitch pattern from a common central 
point.

Contour fills

Create 3D 
turning pattern 
effects

Use Object Properties > Fill > Contour to create stitching which follows object 
contours, creating a curved, light-and-shade effect.

Use Digitize > Circle / Oval to quickly digitize circular shapes using current stitch 
settings.

Use Digitize > Digitize Blocks to digitize column shapes of varying width, setting the 
stitch angle at each pair of points.
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Contour is a curved fill stitch type – stitches follow the contours of a shape, creating 
a curved, light and shade effect. 

Use it to create a sense of movement in contrast to flatter fills created by satin or 
tatami stitching. It can be used with Circle or Digitize Blocks input tools.

Adjust Stitch length for smoother or sharper curves. Adjust stitch spacing for denser 
or more open stitching.

Use Contour to create 
sense of volume and 
movement

Adjust spacing for 
more open 
stitching
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Stitch angle has little effect on pattern layout, but entry point in circle objects does.

Ripple fills

Ripple Fill stitch is related to Contour stitch, providing a similar look (with a fixed 
number of lines and variable spacing) but spiraling out from the center of a filled 
object. It can be applied to any filled object. Stitch angle has no effect on pattern 
layout.

Use Object Properties > Fill > Ripple to create spiral stitching from the center of any 
filled object.

Adjust start/end 
points to control 
orientation

Stitch angle has 
little or no effect



Chapte r  10    Decorat ive St i tch Types 239

Adjust stitch spacing for denser or more open stitching. Adjust stitch length for 
smoother or sharper curves.

The center of the Ripple stitch can be moved with the Reshape tool.

If the object has a hole, this is ignored when Ripple is applied but still exists when 
other stitch types are applied.

Motif stitching

Motif stitch can be used for lines or fills. You can create decorative outlines using 
any pattern from the selection list. You can modify the rotation angle, orientation 

Adjust stitch length 
for smoother or 
sharper curves

Adjust ripple 
center point with 
Reshape tools
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and scale, and vary the space between patterns. Motifs are repeated in parallel 
rows to form decorative fills.

Tip: The Create Motif function lets you save your own motif shapes for future use. 
Create your own ‘motif sets’ to organize and classify your motifs. See also Custom 
objects.

Select motif patterns

Whether you are digitizing motif lines or fills, you have access to the same pattern 
gallery. Choose a library from the droplist. Note that you can detach the Pattern 
Gallery from the docker and float it in the design window for easy access. Change 
a motif at any time by selecting a motif line or fill, or any other line or fill for that 

Use Object Properties > Outline > Motif to create ornamental craftstitch borders. 
Choose from pattern library.

Use Object Properties > Fill > Motif to create decorative open fill stitching. Choose 
from a motif library.
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matter, and choosing another motif from the gallery. You can even define your 
own motifs and motif libraries. See also Motif stamps.

Motif outlines

Using Motif Line in combination with Digitize Open Line or any other line input 
method. 

 Digitize motif line as you would a normal run line. Left-click for corner points, 
right-click for curve points.

 Press Enter to complete.

Choose from 
gallery of motif 
patterns

Use Digitize > Digitize Open Shape to create a row of run or other outline stitching 
along a digitized line. Left-click for corner points, right-click for curves.
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 To use the original size and orientation of the motif press Enter.
 To scale the motif, move the pointer until the motif is the required size, click, then 

press Enter.

Motif sizing & spacing
Set the exact size and spacing of motifs in a Motif Line via the Object Properties 
docker before or after digitizing.

Scale individual motifs in the motif run by adjusting Width and Height settings. In the 
Spacing field, enter the distance between each repetition. If the motifs do not fit 
the digitized line exactly, Hatch Embroidery adjusts spacing to make them fit.

Reshape motif runs

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Set motif size 
and spacing

Motif spacing
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Reshape motif runs in the same way as you reshape lettering objects. Select a 
motif line object and click the Reshape icon.

Use the control points to adjust outline and motif spacings:

 Drag the sizing handle to scale the object proportionately.
 Right/left-click to add reshape nodes.
Click-and-drag individual motifs to adjust spacing.
 Select reshape nodes and press Spacebar to toggle between corner and 

curve points.

Motif orientation

If you digitize a circle outline object (using Circle/Oval tool) using an asymmetrical 
motif, the motif runs inside the circle in an anti-clockwise direction. Rectangle 

Use Digitize > Circle / Oval to quickly digitize circular shapes using current stitch 
settings.

Use Digitize > Rectangle / Square to quickly digitize rectangular shapes using current 
stitch settings.

Use Context > Mirror X to flip selection horizontally.

Use Context > Mirror Y to flip selection vertically.

Use control points 
to adjust outline and 
motif spacings
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objects place the motif outside the shape. If you want to reverse the orientation, 
first apply Mirror X or Y to the single run object and then apply the motif.

Tip: If you have already created the motif and want to invert it, first select the 
object and click Single Run. Then invert it using Mirror X or Y and re-select the 
desired motif.

Motif fills

Use Motif Fill in combination with Digitize Closed Shape or any available closed 
shape digitizing method. 

To create motif fills...

 Digitize motif fills as you would a normal tatami fill. Click for corner points. 
Right-click for curve points. 

 As soon as entry and exit points are entered, motif fill stitches are generated 
using current settings. Stitch angle has no effect on layout.

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.

Use Mirror X 
or Y to invert 
motifs

Stitch angle has 
no effect on 
layout
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 Alternatively, apply motif fill to existing closed objects. Change motifs as you like 
via the Object Properties docker.

Tip: Blackwork gets its name from the black silk thread traditionally used in this form 
of embroidery. Use the special Blackwork Fill pattern set to create interesting 
scrolling or geometric patterns.

Alternating motif fills

Mix and match different motifs for forward and backward rows, or use the same 
motif for each.

Use Object Properties > Fill > Motif to create decorative open fill stitching. Choose 
from a motif library.

Apply motifs to existing 
fills via pattern gallery
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To create alternating motif fills...

 Tick the Use Alternate Motif checkbox and select a complimentary motif from 
the Pattern Gallery. Forward and backward rows of motifs have their own width 
and height settings.

 Use the Layout settings to control row spacing. See below for further detail.

Alternate motif rows

Use ‘alternate motifs’ 
to define forward and 
backward rows

Control alternating 
row spacing
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 Try combining alternating motifs with curved fill effects such as 3D Warp. See 
also Contoured fills.

Adjust motif pattern settings
You can adjust motif fill size and spacing as you would motif lines. The same 
controls exist for pattern sizing. Spacing is the distance between each pattern 
repetition except that in a motif fill, you can control both row and column spacing. 
By default, column spacing defaults to pattern width, while row spacing defaults 
to pattern height.

In addition to column and row spacing, motif fills also allow you to specify an 
orientation for the entire fill using the Angle setting.

Control both row and
column spacing

Specify motif
orientation
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In addition, you can offset one row from another. Hover the cursor over the field to 
view a graphical representation.

Note: Stitch angle has no effect on motif layout.

Adjust motif layout interactively
In addition to object properties, you can adjust motif layouts interactively. Lay out 
motif fills on-screen by using ‘guide patterns’ to scale, space, transform and offset 
the entire layout.

To adjust motif layout interactively...
1 Adjust view settings as necessary and turn off TrueView for better visualization.

Offset one row 
from another
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2 Click Layout. Three guide patterns appear in the design window. Each guide 
pattern lets you change a different element of the layout.

Tip: Zoom in and adjust selected guides to achieve the effect you want. 
Release the mouse button. All patterns in the fill change accordingly.

3 Click and drag the guide motif with the aqua circle node to move all.

4 Click and drag the yellow square node of the top guide pattern to change row 
spacing. 

 Hold the Shift key while dragging to adjust row offset. 
 Hold the Alt key while dragging to adjust row spacing and offset together.

Adjust motif layouts 
interactively

Move entire 
pattern

Adjust row 
spacing and offset
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5 Click and drag the yellow square node of the right guide pattern to change 
column spacing. 

6 Click and drag the right guide pattern with the yellow square node while 
holding Ctrl key to rotate.

 Hold the Alt key while dragging to rotate and adjust column spacing at the 
same time.

7 Click the guide motif with the aqua circle node to access motif sizing handles. 
Use these to adjust motif width and/or height.

Adjust column 
spacing and offset

Rotate entire 
pattern

Click to access 
sizing handles
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8 Release the mouse and view the result in TrueView. You can make further 
adjustments in TrueView as required.

Related topics

 View design details

Fancy motifs
Apart from the default motif gallery, Hatch Embroidery provides a number of 
specialist or fancy motif fills as well. For example, Blackwork gets its name from the 
black silk thread traditionally used in this form of embroidery. Early designs tend to 
be angular, whereas later designs use more diagonal stitches. Blackwork employs 
just a few simple stitches to create complex designs. It can be used to decorate 
articles of dress or furnishings such as hankies, table napkins, tablecloths, and 
doilies.

Candlewicking is a traditional white-on-white embroidery technique, usually done 
on white linen or cotton fabric with heavy cotton threads. More use of color is 
becoming popular today. Stitches used are mostly knots, both Colonial and 
French, as well as Stemstitch. Candlewicking can be used to embroider white 

Make 
micro-adjustments 
in TrueView

Blackwork fancy stitching
also available
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bedspreads, pillows and clothing. Candlewicking Outline can be used for ornate 
borders.

Stipple fills

Stippling is a method for creating textured fills of run stitching which meanders 
more or less randomly within a border. It can be applied to closed objects with a 
single stitch angle. You control stitch density in stipple objects by adjusting Stitch 
length and loop spacing.

Candlewicking fancy
stitching also available

Use Object Properties > Fill > Stipple Single Run to create fills made up of run 
stitches which meander within a border.

Use Object Properties > Fill > Stipple Stemstitch to create heavier stipple run fills with 
stemstitch outlines.

Use Object Properties > Fill > Stipple Backstitch to create heavier stipple run fills with 
backstitch outlines.
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Stipple fills are actually made up of a long meandering run stitch. Three types are 
available – single, stemstitch, and backstitch. Apply them as you would any other 
fill type.

Stipple settings
The Stipple settings panel in the Object Properties docker helps you control the 
stippling effect. 

To adjust stipple settings...

 Adjust Loop spacing for tighter or more open stitching.

Three types of 
stipple fill 
available

Adjust loop 
spacing
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 Adjust Chord gap for smoother or sharper curves.

 Adjust Inset step to set the margin from the object outline.

Control run stitch settings via the Stitch settings panel. Adjust Stitch length for 
smoother or sharper curves. The Run count defines stitch repetitions – e.g. 1, 3, 
5, 7, 9 – and hence stitch bulk.

 Stemstitch and Backstitch offer further settings.

Related topics

Outline stitches
 Simple outlines
 Backstitch outlines
 Stemstitch outlines

Adjust chord 
gap

Adjust margin 
from object 
outline

Adjust stitch 
length
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Reshape stipple fills

While consisting of run stitching, stipple fill objects can be reshaped like any other 
closed object.

Related topics

 Reshape objects

Cross stitch fill

Cross stitching is a popular technique for filling 
large areas with low stitch counts. Cross stitch is also 
sometimes combined with appliqué. Cross Stitch 
Fill is something like Motif Fill but is generated 
differently. Crosses in separate objects line up 
precisely when using the same fabric count. This is 
because cross stitch fills are generated on a 
universal grid not object-by-object. Fractional 
crosses are generated at object boundaries in 
order to avoid gaps. Cross Stitch Fill uses travel runs 
under and along the cross stitching. stitch angle 
has no effect on pattern layout.

Note: Cross Stitch Fill is a stitch type that is available 
in Hatch Embroidery software. This fill type is 
different to the Hatch Cross Stitch GEM.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Reshape stipple fills 
like any closed 
object

Use Object Properties > Fill > Cross Stitch to create open patterned fills with 
crosses generated to suit standard grid for entire design.
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To adjust settings...
1 Select and double-click an object.

2 Select Cross Stitch if not already selected.
3 Cross stitch settings include:

Setting Purpose

Cross density Controls the size of cross specified as a fabric count rather than cross 
size. Crosses in different objects align precisely if using the same cross 
density.

Threads Sets the number of times – 2, 4 or 6 – thread passes over the same cross 
in order to make it bulkier.

Stitch style Specifies whether full cross (X) or upright (+). Stitch style as no effect on 
grid alignment if the same stitch size is used.

Floss direction Controls which way top leg of the cross – i.e. full length stitch – is directed 
– forward or backward for diagonal full crosses and horizontal or vertical 
for upright full crosses.

Use Cross Stitch to fill 
large areas with low 
stitch counts
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4 Cross stitch can be perpendicular or diagonal. Note that stitch angle has no 
effect on the cross stitch grid.

Tip: The cross stitch grid is not displayed, but you can set the background grid 
to the cross size to see how the grid is being used. See also Design 
measurement.

Cross stitch can be 
perpendicular or 
diagonal
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Chapter 11

STITCH EFFECTS

In addition to its many stitch types, Hatch 
Embroidery also provides stitch effects to 
create artistic effects such as textured or 
contoured fill stitching. These can be 
applied to satin, tatami, run, backstitch, 
and other stitch types, to imitate hand 
stitching, create fluffy edges, as well as 
other interesting and decorative effects.
Create interesting curved effects by 
shaping needle penetrations to follow the 
contours of digitized lines. Create more 
organic or hand-crafted stitching with 
hand stitch effects and feathered edges. 
Use ‘gradient fills’ to vary stitch spacing 
between dense and open fill, producing shading effects which are difficult to 
achieve manually.

Curved fill effects

Create interesting curved effects by shaping needle penetrations to follow the 
contours of digitized lines. These can be achieved using Florentine or Radial fills 
creating a appearance of turning stitches. Elastic effects can be applied to 
Embossed fills to create a sense of movement or volume. You can apply it to a 
variety of object and stitch types. 3D Warp provides another way to create 
movement with motif fills. Use it to make shapes appear concave or convex.

Florentine fills

Florentine Effect contours fill stitches along a digitized guideline. Stitches follow the 
line but maintain uniform density and needle penetration patterns. The effect can 
be applied to regular tatami patterns, embossed fills, as well as motif fills. It doesn’t 
apply to outline objects. To apply the effect to new objects, select a digitizing tool 
and click the toggle on the Context toolbar. See also Input methods.

Use Context > Florentine Effect to create custom curve-line stitching with a single 
guideline. Right-click for settings.
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Note: Florentine Effect cannot be used in conjunction with Branching or Redwork

To apply the effect to existing objects...

 Select a filled object and select an option in the Effects > Radial / Curve Fill 
panel.

 Use smaller Stitch lengths – e.g. 4.00 mm or less – for best results. 

Florentine effect 
applied to 
embossed fill

Tick to apply
Florentine effect
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 Use the Reshape tool to change the shape of the curve. Press Enter to finish.

 Use it with motif fills as an alternative to 3D Warp.

Radial fills

Radial Fill generates radial turning stitching in several stitch types such as satin and 
tatami stitch. Use tatami patterns to accentuate the effect. Stitches are 
generated from the outside edge to the geometric center. To apply the effect to 
new objects, select a digitizing tool and click the toggle on the Context toolbar. 
The effect will be applied to all newly digitized filled objects. It doesn’t apply to 
outline objects. See also Input methods.

Use Context > Radial Fill to create radial turning stitching with various stitch types 
including satin, tatami and program splits. Right-click for settings.

Use Reshape to 
modify curve
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To apply the effect to existing objects, select a filled object and select an option 
in the Effects > Radial / Curve Fill panel.

Radial Fill is applicable to several object shapes – closed, circle and rectangle. Use 
the Reshape tool to modify the effect. The hole can be resized either interactively 
or via object properties. It can be relocated by means of the positioning handle 
at the center.
Unlike Ripple Fill, the center of Radial Fill can be moved outside the shape or into 
an included hole to achieve a different effect. Different tatami patterns achieve 
different effects. It can also be applied together with various fancy fills.

Usage tips
Not all patterns and stitch settings or objects (size specific) are suitable for Radial 
Fill. In particular, if you are using it with larger objects, use one or a combination of 
the following to avoid bunching at the center:

 Increase the size of the hole.
Move the center into an existing hole in the object, or move it outside the 

object altogether.
 Add Feather Edge to the inside. See also Feathered edges.
 Use larger stitch spacing – increase by about 20%.
 Avoid patterns which add needle penetrations close to the center of the 

object.

Apply radial fill to
satin or tatami fills

Apply radial fill to any 
of the available tatami 
patterns
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 Use Edge Run underlay with smaller objects, to help reduce the number of 
stitches at the object center. See also Stitch reinforcement.

 For best effect, use Radial Fill with ring shapes. The size of ring should be about 
20% of the outer diameter.

Tip: You are not able to directly edit the stitch angles generated by Radial Fill. 
However, you can apply Break Apart to edit the resulting turning angle closed 
object.

Elastic embossed fills

Elastic Embossed Fill is a decorative effect where the pattern follows the stitch 
angle and may be scaled to fit the width of the object. You can apply it to a 
variety of object and stitch types. It works best with satin stitching. It is intended for 
use with objects with turning stitches or varying column width. To apply the effect 
to new objects, select a digitizing tool and click the toggle on the Context toolbar. 
The effect will be applied to all newly digitized filled objects. It doesn’t apply to 
outline objects. Embossed fills turns with the shape unlike regular embossed fills...

Tip: If you are using satin stitch with Elastic Embossed Fill, turn off Auto Split. See also 
Satin stitch.

Use Context > Elastic Embossed Fill to create embossed fill patterns that follow the 
stitch angles and are scaled according to the object width. Right-click for settings.

Regular embossed fill Elastic embossed fills
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To modify elastic fancy fills...
1 Select an object and choose Elastic Embossed Fill from the Object Properties > 

Effects tab.

2 Select a pattern from the Pattern Gallery. You have the same range of patterns 
as Embossed Fills. See also Embossed fills.

3 Select one of four layout options:

Choose from gallery 
of elastic embossed 
fill patterns

Single row Multiple rows Multiple rows with 
scaling

Single row with 
scaling
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4 Optionally, adjust or add stitch angles. Stitch angles have a strong bearing on 
the orientation of the pattern.

5 Optionally, adjust Elastic Embossed Fill settings to vary size, shape indent, 
spacing and pattern offsets. See also Embossed fills.

6 In the Width and Height fields, adjust the dimensions of the largest pattern in the 
effect.

7 In the Indent field, adjust the distance between the first pattern and the first 
stitch line.

8 In the Column panel, enter spacing and offset settings as preferred:

9 If you selected an option that uses more than one row of patterns, the fields in 
the Row panel are available.

Note: Embossed Satin turns with the shape and is scaled accordingly:

Adjust stitch 
angles to 
fine-tune elastic 
embossed fill

Satin stitch 
outline

Elastic satin 
stitch outlines
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3D Warp
Another way to create curved motif fills is with 3D Warp. Use it to make shapes 
appear concave or convex.

Using Globe In with 3D Warp gives a concave effect by increasing motif size and 
spacing around a center point. Globe Out gives a convex effect by decreasing 
motif size and spacing.

Create curved motif
fills with 3D Warp
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Use the Reshape tool to customize the shape of the 3D Warp envelope. You can 
apply the effect to an entire object, or to a specific part of the fill.

Tip: You can generate layers of colored motifs by duplicating an object and 
applying a different color. For example, after filling a shape with circles, you can 
create a second layer, offset it, and apply a different color. You can then apply 
effects such as Globe Out to the whole motif fill.

Organic stitch effects

Hatch Embroidery provides tools for creating more natural, ‘organic’ stitching 
styles with the Hand Stitch and Feather Edge effects. 

Handstitch effects

Fashion trends sometimes favor a more organic look which is very hard to achieve 
with normal design tools. With Hand Stitch, you can create effects which combine 
randomized stitch length, angle and count. It can be used to create ‘fur’ effects. 

Use Reshape to modify 
3D Warp envelope

Use Context > Hand Stitch to create hand-stitch effects which combine randomized 
stitch length, angle and count. Right-click for settings.
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It also works well with color blending. You can even create effects that resemble 
water.

To apply handstitch effect
1 Choose the object you want to apply the effect to or toggle on Hand Stitch 

effect before you start digitizing. It can be applied to satin, tatami, run, 
backstitch, and other stitch types.

2 Click the Hand Stitch icon. The effect is applied based on current settings.

3 Right-click the Hand Stitch icon to access object properties.

4 Adjust stitch roughness settings to diminish or exaggerate the effect:

Adjust 
roughness

Select Hand 
Stitch effect

Adjust stitch 
density or ‘mass’
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 In the Length field, enter a value between 0 and 5 to set stitch-length 
variation. ‘0’ indicates that no change is applied to current stitch settings.

 In the Angle field, enter a value between 0 and 5 to set stitch-angle 
variation.

5 Adjust stitch mass settings to diminish or exaggerate stitch mass:
 In the Count field, select a multiplication factor to increase hand-stitch 

density.

 In the Random field, select a value between 1 and 5 to set a random factor 
for the stitch count. The system randomly adds or sometimes removes 

Length: 0 Length: 3 Length: 5

Angle: 0 Angle: 3 Angle: 5

Count: 1x Count: 3x Count: 5x
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stitches when Count > 1x, usually resulting in increased stitch mass. (When 
count is 1x, no stitches are removed but some are added.)

6 Optionally, in the Variant field, enter a value between 1 and 10 to experiment 
with variants of the same roughness and mass settings.

Tip: Make any further adjustments necessary to the underlying stitch type. For 
instance, when using Satin stitch, you may want to increase stitch spacing as 
well as use a lighter underlay.

Usage tips
 For hand-stitching, embroiderers tend to use ‘long & short’ satin stitching or 

contoured runs to fill a large area. This is the effect we are aiming for.
When used with satin stitching, Hand Stitch effect works best with Auto Split 

turned off. However, when used with higher stitch roughness ‘length’ settings, 
jump stitches are sometimes generated as this setting affects Stitch length.

 For smaller objects, turn off underlay.
More stitch spacing is needed for higher stitch counts to avoid stitch bunching.
 Tatami fill is can also be used with Hand Stitch effect. Try using a random factor 

to eliminate split-line patterns.

Related topics

 Satin fills
 Tatami fills
Color blending

Random: 0 Random: 3 Random: 5

Variant: 1 Variant: 6 Variant: 10
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Feathered edges

Use Feather Edge to add rough edges to objects, create shading effects, or 
imitate fur or other fluffy textures in your design. To apply the effect to new objects, 
select a digitizing tool and click the toggle on the Context toolbar. The effect will 
be applied to all newly digitized filled objects. It doesn’t apply to outline objects. 
See also Input methods.

To apply the effect to existing objects...
1 Select a filled object and select an option in the Effects > Feature Edge panel.

Use Context > Feather Edge to apply or exclude Feather Edge effect to new or 
selected objects. Right-click for settings.

Use Object Properties > Effects > Feather Edge to create rough edges and shading 
effects, or imitate fluffy textures.

Apply Feather 
Edge to different 
sides
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2 Use the Raggedness slider to select the degree of texture. Use the Max Width 
setting to control the stitch range within which you want the stitches to fall.

3 You can apply the effect to one side of the object or both.

Note: To remove the effect from selected objects, click the Remove Effect button.

Gradient fill effects

The Gradient Fill feature varies stitch 
spacing between dense and open fill, 
producing gradient and shading effects 
which are difficult to achieve manually. It 
provides a simple way to produce 
variation in a filled pattern and the illusion 
of depth. It is best used with Tatami fill. 
When you use it, current settings – 
including Auto Spacing and Fractional 
Spacing – are ignored. However, other 
stitch effects still apply.

Create gradient fills

Set degree of 
texture

Apply Feather 
Edge to different 
sides

Use Context > Gradient Fill to apply or exclude Gradient Fill effect to new or selected 
objects. When turned on, stitch spacings vary between dense and open fill. 
Right-click for settings.
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To apply the Gradient Fill effect to new objects, select a digitizing tool and click 
the toggle on the Context toolbar. The effect will be applied to all newly digitized 
filled objects. It doesn’t apply to outline objects. See also Input methods.

To apply the effect to existing objects...

 Select a filled object and select an option in the Effects > Gradient Fill panel. 
Gradient Fill can be applied to tatami or satin objects. Use any one of the preset 
profiles.

 Apply Travel on Edge to force underlying travel runs to the edges of an object 
so that they can’t be seen through open stitching. Because of its open stitch, 
Gradient Fill is also best used without Auto Underlay.

Use Object Properties > Effects > Gradient Fill to create perspective and shading 
effects.

Use preset 
profile to apply 
gradient fill

Apply Travel 
on Edge

Turn off 
underlay
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Note: In addition to gradient fills, color blending allows you to create interesting 
color blends, perspective effects and shading effects. Two colors are merged 
smoothly using a mixture of dense and open fill. See also Color blending.

Gradient fill settings
Both stitch angle and spacing values have a significant effect on gradient fill 
appearance.

Gradient fill angle

Use the Reshape tool to adjust the angle of the gradient fill.

Gradient fill spacing
Use the Gradient Fill panel to adjust spacing values between maximum and 
minimum spacings.

Tip: Travel on Edges and Gradient Fill can also be combined with Florentine Effect 
to produce curved color blending. 

Related topics

 Stitch angles
Curved fill effects
Color blending

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Use Reshape to 
adjust gradient fill 
orientation

Set min and 
max spacing
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PART IV
EMBROIDERY EDITING

In addition to making global changes to a design, such as changing the thread 
palette and design colors, some product levels allow you to edit design objects 
and even individual stitches. When available, the Edit Objects toolbox provides 
many tools for reshaping, resizing, rotating objects, as well as add or remove stitch 
angles. The Edit Objects toolbox also provides specialized features to create 
special effects as well as save time while you digitize. From sunsets to wood grains, 
color blending creates interesting color blends, perspective effects and shading 
effects. Other editing functions are available via the Context toolbar, popup 
menu, and Edit menu. 
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Chapter 12

EDIT OBJECTS

In addition to making global changes to a design, such as changing the thread 
palette and design colors, some product levels allow you to edit design objects 
and even individual stitches. When available, the Edit Objects toolbox provides 
many tools for reshaping, resizing, rotating objects, as well as add or remove stitch 
angles. Other editing functions are available via the Context toolbar, popup 
menu, and Edit menu. Explore the topics in this section to find out what else you 
can do with the software’s editing features.

Designs are composed of ‘embroidery objects’. They are called ‘objects’ because 
they can be manipulated independently of each other. Like drawing objects, 
embroidery objects have defining characteristics or ‘properties’ such as color, size, 
position, and so on. They also have properties unique to embroidery such as stitch 
type and density. The most important property of an embroidery object is its stitch 
type. Other important properties include underlay type and pull compensation. 
See also Object properties.
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Select objects

Hatch Embroidery provides various 
ways to select the objects that 
comprise an embroidery design. You 
can select all objects to modify the 
design as a whole, or individual objects 
for more precise modification.

Select with ‘Select’

The Select tools provide various means for selecting objects including point and 
click, selection marquee selection, and – in conjunction with Shift+Tab keys – 
first/last and next/previous object selection. You can also select all objects to 
apply changes to a whole design.

To select objects...

 Use the drop arrow to select the tool you want to use.

 The Select tool provides various means for selecting objects including point and 
click, selection marquee selection, and – in conjunction with Shift+Tab keys – 
first/last and next/previous object selection. You can also select all objects to 
apply changes to a whole design.

 To select all objects in a design, select Edit > Select All or press Ctrl+A.
 To deselect, press X or Esc.

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Select > Polygon Select to select an object or group by digitizing a polygon line 
around them.

Choose selection 
method
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 The simplest way to select objects is by pointing and clicking with the mouse 
with the Select tool activated. With Shift and Ctrl keys, you can select multiple 
objects.

 To select an object which is behind another object, zoom in and click the 
outline. Alternatively, position the pointer over the object, hold down the 2 key, 
and click until the object is selected. Each click selects the next overlapping 
object.

With the Select tool activated, you can also select objects by dragging a 
selection marquee around them.

 Use the Polygon Select tool to select an object or group by clicking reference 
points around them.

 Lock objects in place to prevent them from being moved or modified by 
accident by pressing K or via the popup menu. Similarly, hide selected object/s 
from view via the popup menu. Use the menu commands in the Sequence 
docker to unlock or unhide objects.

Drag a selection marquee 
around objects to select

Lock or hide
selected objects
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Select with ‘Sequence’

The Sequence docker provides a sequential list of objects as digitized, grouped by 
‘color block’. It stays on the design window as long as you need it and offers an 
easy way to select objects and view them. It is normally docked on the right of the 
design window but can be dragged to any position and resized as required. See 
also Split objects.

To select objects in the docker...

 Toggle between object view and color block view via the toggles on the 
Sequence docker toolbar. In color mode, the docker displays a separate icon 
for each color block in the design, in order of stitching. In object mode, it 
displays a separate icon for each object in the design.

 Use the list to perform many object manipulations, including sequencing, 
editing, locking, hiding, etc.

 To select a range of items, hold down Shift as you click.
 To select multiple items, hold down Ctrl as you click.

Use Edit Objects > Sequence >> to open the Sequence docker. Click again to close. 
Also available via Windows > Dockers menu.

Use Sequence > Show Color List to display color blocks with included object 
thumbnails in the docker.

Use Sequence > Show Object List to display individual object thumbnails in the 
docker.

Choose objects 
to manipulate
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 To deselect all objects, click away from them or press Esc.
 Right-click to access the popup menu.

Group objects

Hatch Embroidery provides various means for grouping and ungrouping objects. 
Grouped objects can then be selected, moved, copied, resized and transformed 
as a single object. Select the objects to group. The Context toolbar which appears 

Use Context > Group to group selection. Or press <Ctrl+G>. This tool is also 
available via Arrange menu.

Use Context > Ungroup to ungroup grouped selection. Or press <Ctrl+U>. This tool 
is also available via Arrange menu.

Right-click to 
access popup 
menu
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by default provides options for grouping and ungrouping selections. The popup 
menu accesses the same commands.

Replicate objects

Hatch Embroidery lets you add to designs by copying and pasting objects by a 
variety of methods. The Standard toolbar provides standard copy/cut/paste tools. 
Right-click a selected object to invoke the popup menu. This provides access to 
the same command set.

Group like-objects to select, 
move, copy, resize and 
transform as single object

Right-click to 
access popup 
menu
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Copy & paste objects

You can create multiple, identical objects in Hatch Embroidery, or insert objects 
from other designs, with standard Copy, Cut, and Paste operations. By default, 
copied objects are pasted at the same position and at the end of the stitching 
sequence.

To copy and paste at a preset position...

Cut and paste operations behave according to presets in the Edit tab of the 
Embroidery Settings dialog. Select Software Settings > Embroidery Settings to 
access the dialog.

Click Standard > Copy to copy the selection and place it on the clipboard. This tool 
is also available via Edit menu.

Click Standard > Cut to cut the selection and place it on the clipboard. This tool is 
also available via Edit menu. 

Click Standard > Paste to paste contents of the clipboard. This tool is also available 
via Edit menu. 

Set offset values for 
pasted objects
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 By default, objects are pasted at the same location they were copied from. 
However, by setting X/Y values, you can ensure that pasted objects are offset 
from their original location.

Once pasted, copied objects can be dragged into position and resized and 
rotated as required.

Cut, copy and paste operations change the stitching sequence. By default, 
objects are pasted at the end. Use the Sequence docker to resequence 
pasted objects.

Tip: If you are copying a group of objects containing more than one color, you 
will need to resequence each to optimize color changes.

To copy and paste at the current stitch...

 Alternatively, you can duplicate objects by cutting them and pasting them at 
the current stitch. For this operation, you will need to use Travel tools.

Object resized 
and rotated in 
position

Duplicate object
offset from original

Duplicate objects 
placed at end of 
stitching sequence
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 Again use the Software Settings > Embroidery Settings tab to preset copy and 
paste behavior.

Options include:

 Travel to the point in the stitching sequence where you want to paste your 
object/s. You can paste between other objects or even ‘nest’ the duplicate 
object within another.

Related topics

 Edit settings
 Arrange objects
 Transform objects
 Sequence objects
 Remove underlying stitching
 Travel through designs

Option Effect

Center at current 
stitch

When activated, duplicate objects are centered above the stitch 
cursor, wherever this is located in the design. This is the default 
behavior.

Start at current 
stitch

When activated, cloned objects are pasted at the current stitch 
cursor.

Paste object at 
current stitch

Travel to required 
point in design

Paste at current 
stitch
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Duplicate & clone objects

Objects can be duplicated rather than copied. When an object is duplicated, it is 
not copied to the Clipboard. This leaves the Clipboard free for other objects.
The ‘quick clone’ function provides a simple way to copy selected objects. Simply 
right-click and drag selected objects, and release.

Alternatively, with object/s selected, various options become available via the 
Context toolbar. Use the Duplicate tool or press Ctrl+D to duplicate them. If you 
have already used ‘quick clone’, the duplicate object will be offset by the same 
amount. This is handy for creating step-repeats.

Caution: By default, the Duplicate tool duplicates objects at the same location. 
Unless dragged to another location, the object will be stitched twice.

Use Context > Duplicate to duplicate selection in the same position. Duplicate is 
placed at end of stitching sequence. This tool is also available via Edit menu.

Use Context > Duplicate with Offset to duplicate selection in an offset position. Use 
to create regular patterns of duplicate. Right-click for settings. This tool is also 
available via Edit menu.

Right-click and 
drag to clone

Press Ctrl+Shift+D 
to duplicate with 
offset
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The Duplicate with Offset option (Ctrl+Shift+D) provides yet another way to create 
step-repeat offset objects. It places duplicates according to presets in the Edit tab 
of the Embroidery Settings dialog. Select Software Settings > Embroidery Settings to 
access the dialog.

Usage tips
Clone objects to another window by the same method. A copy of the selection 

is created at the same coordinates as the first window, no matter where the 
mouse is released.

 Duplicates can be used to create effects like drop shadows for lettering or 
other objects. 

 For more precise positioning, hold down Ctrl while dragging – movement is 
constrained to X / Y axes.

 To temporarily deactivate automatic scrolling, hold down the Shift key while 
dragging.

Related topics

 Edit settings
 Arrange objects
 Transform objects
 Sequence objects

Preset duplicate
object offsets

Duplicate objects with 
Duplicate tool or by 
pressing Ctrl+D
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Arrange objects

Position objects in your design using the 
mouse to drag them to a new position, 
nudging them with the arrow keys or by 
specifying the X:Y coordinates in the 
Customize toolbar.

Position objects

The simplest way to move an object in your design is to click and drag it to a new 
position with the Select Object tool. For more accurate positioning, press the arrow 
keys to ‘nudge’ the object into the required position.

You can also position selected objects relative to the center of a design by 
entering its X:Y coordinates in the Context toolbar which appears whenever you 
select objects. Use the ruler (Ctrl+R) for more precise measurements.

Align objects

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Context > Align Centers to align the centers of selected objects.

Use arrow keys to 
‘nudge’ object into 
position

Alternatively, use 
position settings in 
combination with rulers
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Quickly align selected objects in a design to the left, right, top, bottom or center 
of a specific object. The Align commands can be accessed via the Context 
toolbar which appears whenever you select objects. They can also be accessed 
via the Arrange menu or popup menu. The commands are all enabled when two 
or more objects are selected. Objects are aligned with the last object selected.

Distribute objects

Distribute selected objects evenly across or down the design window. The Space 
Evenly commands can be accessed via the Context toolbar which appears 
whenever you select objects. They can also be accessed via the Arrange menu or 
popup menu. The commands are all enabled when three or more objects are 
selected.

Use Context > Space Evenly Across to evenly space 3 or more selected objects 
horizontally. 

Use Context > Space Evenly Down to evenly space 3 or more selected objects 
vertically. 

Use alignment tools to 
precisely arrange 
objects on screen

Use alignment tools to 
precisely arrange 
objects on screen
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Transform objects

Often you will want to scale a design for use in different contexts. For instance, a 
design originally made to fit a pocket may be adapted to fit a cap. Hatch 
Embroidery provides techniques for transforming design objects just like a graphics 
program ... with one difference. When you scale, rotate, skew, or flip an 
embroidery object, stitches are regenerated.

Note: The scalability and stitching quality of a design ultimately depend on its 
original source. Only ‘all-in-one’ design files such as EMB, ART, or JAN, contain the 
complete set of design information required for 100% perfect scaling and 
transformation. If you scale a stitch design by more than 10%, changes to stitch 
density will affect design quality.

Scale objects

You can scale objects by dragging the selection handles with the mouse or by 
specifying the exact dimensions in the Context toolbar. As an object is scaled, the 
stitch count changes to preserve current stitch spacing.

To scale objects...

 To scale objects using click and drag, select the object/s to scale. Click and 
drag a selection handle to resize the object.

 To scale height and width proportionally, use a corner handle.

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Context > Size +10% to increase the size of selected objects in 10% increments.

Use Context > Size -10% to decrease the size of selected objects in 10% increments.

Scale proportionally Scale freely in both 
directions

Ctrl + drag
Drag
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 To change the height or width, use the center handles.

 To scale proportionally around an anchor point, hold down Shift as you drag.

 Alternatively, scale selected objects or a whole design using Width and Height 
settings. Stitches are regenerated and original stitch density preserved.

 Alternatively, use the Size buttons to resize in 10% increments. After scaling, the 
new object size is reset to 100%.

Tip: Stitches are recalculated for objects whenever you press Enter. They are 
also updated whenever you scale, transform or move the object. Press G to 
manually regenerate stitches for selected objects.

Scale 
vertically

Drag

Scale 
horizontally

Drag

Scale proportionally 
about center

Shift + dragScale horizontally in 
both directions

Shift + drag

Use Context
controls to scale

objects numerically

Use sizing handles to 
manually resize 
designs
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Rotate objects

When creating design layouts, you’ll frequently find yourself duplicating objects 
and rotating them into position.

To rotate objects...

When you select an object or group, selection handles display at its extremities.

Click a second time. Rotation handles appear at the corners and an anchor 
point at the center.

Optionally, drag the anchor point to any position.

Click-and-drag a rotation handle in either direction.
 If required, drag the rotation anchor from the center to a new position.

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Context > Rotate Left 15° to rotate selection in 15° increments to the left.

Use Context > Rotate Right 15° to rotate selection in 15° increments to the right.

Click second 
time

Anchor point

Skew handle

Rotation handle

Drag corner point to rotate 
about the anchor point

Anchor point
repositioned

Drag corner point to rotate 
about the anchor point
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 Alternatively, use the buttons to rotate selections by 15° rotations in either 
direction. Alternatively enter a precise rotation value in the Rotate field and 
press Enter.

 Alternatively, right-click the object and select a Rotate command from the 
popup menu.

Skew objects

You can skew objects along the horizontal plane by clicking skew handles and 
dragging to the required angle. Skew handles are diamond-shaped and appear 
at the center-top and bottom of the object. Alternatively enter a precise skew 
value in the Skew field and press Enter.

Enter precise
rotation angle

Use rotation 
handles to manually 
rotate

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Context > Skew to skew selection by specified amount – positive or negative – 
in degrees.

Use skew handles to skew
objects on screen or set skew

value in Context toolbar
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Mirror objects

Fashion and textile designs often use copied and mirrored design elements. You 
can mirror objects horizontally or vertically by means of the Mirror tools on the 
Context toolbar. Select objects to mirror and click a Mirror icon. For productivity, 
shortcut keys are available for mirror operations.

Tip: The Mirror-Copy tools allow you to duplicate and transform selected 
embroidery objects, as well as merge them into a single object. This feature is often 
used in making fashion or textile designs. See also Mirror-copy objects.

Reshape objects

You modify object shapes in your embroidery software by means of control points 
similar to objects in a graphics package. These vary slightly with object type. For 
some objects, you can change control points from corners to curves. Stitch angle 
adjustments depend on object type. With some objects you can set a single stitch 
angle. With others, you adjust turning angles. You can also change entry and exit 

Use Context > Mirror X to flip selection horizontally.

Use Context > Mirror Y to flip selection vertically.

Mirror objects in 
horizontal or vertical 
planes
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points. This is useful in order to minimize travel runs between objects. Modify outline 
by adding, deleting, or moving control points.

Adjust control points

Control points can be selected individually or together, for repositioning or 
modification.

To adjust control points...

Click to select a single control point.

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Select individual 
control points
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 Holding down Ctrl, click to select multiple control points. Or click and drag a 
selection marquee around a group of control points.

 Press Delete to delete selected control points.
 Add control points to object outlines by clicking with the Reshape tool selected. 

Left-click to add a corner point. Right-click for curve points.

 Reposition control points to change an outline shape. Simply click and drag to 
a new position along the boundary. Or click and drag multiple points as 
needed. Use the arrow keys to ‘nudge’ selected reshape nodes.

Select control 
points with a 
selection marquee

Add control points 
with Reshape tool

Reposition reshape 
nodes by 
click-and-drag or using 
arrow keys
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 Press Spacebar to toggle between corner and curve points.

 If you make a mistake, press Ctrl+Z to undo changes. Press Esc to exit Reshape 
mode.

When in Reshape mode, use the Tab or Shift+Tab keys to jump between objects. 
Alternatively, use the Sequence docker to select objects.

Tip: Stitches are recalculated for objects whenever you press Enter. They are 
also updated whenever you scale, transform or move the object. Press G to 
manually regenerate stitches for selected objects.

Adjust entry & exit points

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Press Spacebar to 
toggle between 
curves or corners

Shift + Tab Tab

Click to select in
Reshape mode
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You can change stitch entry and exit points of individual objects. Do this to place 
the exit point next to adjoining objects for smaller connecting stitches, or to reduce 
the number of travel runs. Select the entry or exit point as required, and drag it to 
a different position on the object outline. The cross represents the end point.

To adjust entry & exit points...

 Select the object and click Reshape. Reshape nodes appear, including entry 
and exit points.

 Select the entry or exit point as required, and drag it to a different position on 
the object outline. To minimize gaps in your embroidery, place entry and exit 
points opposite each other on the outside boundary.

 Press Enter to apply the changes, then Esc to finish.
 It’s a good idea to define the stitch angle so it is perpendicular to the line 

between entry and exit points.

Tip: By default, objects are joined by the Closest Join method. If deactivated, 
all newly digitized objects are joined by the As Digitized method. Press Enter to 
accept default entry and exit points, or follow the prompts in the Prompt Bar to 
manually digitize them. See also Design settings.
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Reshape circle objects

You can change circle objects to ovals using the Reshape tool. Circle objects 
have two reshape control points (used to change the radius and orientation of the 
object), a center point (used to reposition it), and a stitch entry point. You cannot 
add, change or delete control points in these objects.

Stitch angles

Stitch angle adjustments depend on the type of 
object you are working with. With filled objects you 
can set a stitch angle for the entire object. 
Alternatively, you can add multiple stitch angles with 
the Add Stitch Angles tool. You can also adjust the 
stitch angle using the Reshape tool.

Add stitch angles

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Click-and-drag 
control point to 
reshape

Use Edit Objects / Digitize > Add Stitch Angles to add stitch angles to selected closed 
objects with or without holes.

Use Edit Objects > Remove Stitch Angles to remove stitch angles from selected 
objects with turning stitching. 
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Stitch angle adjustments depend on the type of object you are working with. With 
filled objects you can set a stitch angle for the entire object. Alternatively, you can 
add multiple stitch angles with the Add Stitch Angles tool.

To add stitch angles...
1 Select a closed object with or without turning stitches.
2 If necessary, click the Remove Stitch Angles tool to return it to the current 

nominal stitch angle.

3 Click the Add Stitch Angles icon. Enter stitch angles as prompted. Stitch angles 
can overlap holes within objects.

Adjust stitch angles

You can change stitch angles of filled objects using the Reshape tool. To adjust 
stitch angles, select the filled object and click the Reshape icon.

To adjust stitch angles...
1 Select stitch angle nodes and press Delete to remove stitch angles.
2 When you move the mouse pointer over the stitch angle point, a tooltip displays 

the stitch angle of the selected object.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Adjust stitch angles
to re-orient stitch

patterns
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3 Click and drag lines as required.

4 Press Enter to apply the changes, then Esc to finish.

Tip: The nominal stitch angle can also be controlled via Object Properties...

Delete and/or 
reorient stitch 
angles

Set nominal 
stitch angle
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Chapter 13

ADVANCED EDITING

The Edit Objects toolbox also provides specialized features to create special 
effects as well as save time while you digitize. From sunsets to wood grains, color 
blending creates interesting color blends, perspective effects and shading effects.

The embroidery objects in a design form a stitching sequence. Initially, objects are 
stitched in the order in which they were created. The Sequence docker provides 
various techniques for sequencing objects or entire color blocks in a design.
Connectors link objects in a design. They can be run stitches or jumps. You can use 
automatic settings to generate connectors, trims and tie-offs, or add them 
manually. Designs stitch out more efficiently when the connectors between 
objects are short. This also tends to reduce the number of trims in a design. Hatch 
Embroidery has a Closest Join method which can be applied while digitizing 
and/or after editing.
Depending on your product level, Hatch Embroidery will let you split composite 
objects – monograms, appliqué, lettering, etc – into their components. You can 
also cut shapes into smaller fragments which is especially useful for editing 
converted TrueType fonts.
With embroidery designs, stitches are automatically generated from design 
outlines and properties. This means you can scale, transform and reshape designs 
without affecting stitch density or quality. However, Hatch Embroidery also lets you 
edit individual stitches.



Chapte r  13    Ad vanced Edit ing 301

Sequence objects

The embroidery objects in a design form a stitching sequence. Initially, objects are 
stitched in the order in which they were created. As a general rule, it is important 
to establish the stitching order so that objects in the foreground are sewn after 
those in the background. If you combine designs or design elements, you will also 
want to ensure that like-colors are sewn together.

You can change the position of selected objects by cutting and pasting 
elsewhere in the sequence. The Sequence docker provides various techniques for 
sequencing objects or entire color blocks in a design.

Tip: The Sequence docker provides an easy way to view color blocks and 
individual objects in a design. Use the ‘Switch’ buttons on the Sequence docker 
toolbar to toggle between color blocks and individual objects. The Design Colors 
toolbar offers an easy way to selectively view color blocks and embroidery 
objects. This is useful when re-sequencing. See also Design colors and Viewing 
methods.

Sequence by objects

Use Edit Objects > Sequence >> to open the Sequence docker. Click again to close. 
Also available via Windows > Dockers menu.

Use Sequence > Show Object List to display individual object thumbnails in the 
docker.

Same-color 
objects should be 
sewn together
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The Sequence docker provides an easy way to select design objects and 
reposition them in the preferred sequence.

To sequence by objects...

 Switch to Object List view via the toggle.

 Use the More button to display more information about each design object, 
including object type, stitch type used, and number of stitches.

Click to select the object or objects you want to sequence. Hold down Ctrl to 
select multiples.

Use Sequence > Show More to show more details in the docker. Object thumbnails 
are not resizable.

Use Sequence > Show Less to show only summary details in the docker. Object 
thumbnails are not resizable.

Switch to 
Object List 
view

View more 
details



Chapte r  13    Ad vanced Edit ing 303

 Use the buttons on the toolbar to reposition the selection in the list. 

 Alternatively, drag-and-drop to the required position. The list will scroll 
automatically.

Tip: The Apply Closest Join command allows you to (re-)apply closest join to 
selected objects after editing. It is enabled when two or more embroidery objects 
are selected. It is available from the Edit menu or by pressing J. 

Related topics

 Design settings
Closest joins

Sequence by selection order

Another useful technique is to sequence objects by order of selection. This works in 
either object view or color view. 

Tool Function

Use Move Up to move the selection up one object or color block, depending on 
display mode.

Use Move Down to move the selection down one object or color block, depending 
on display mode.

Use Move to Top to move the selection to the top of the stitching sequence.

Use Move to End to move the selection to the end of the stitching sequence.

Use Edit Objects / Sequence docker > Sequence by Selection Order to resequence 
objects in the order of selection. Hold down <Ctrl> and click to select.

Drag & drop to 
reposition within 
stitching 
sequence
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To sequence by selection order...

 Simply select the first object or color block you want to include in the sequence. 
 Holding down Ctrl, select subsequent objects in the desired stitching order. You 

can do this on-screen or with the Sequence docker.

Click the Sequence by Selection Order button. The objects are sequenced in 
the order of selection.

Select objects 
in the preferred 
stitching order

Objects 
resequenced in 
selection order 
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Sequence by color list

The Sequence docker also provides an easy way to sequence designs by color.

To sequence by color list...

 Switch to Color List view via the toggle. 
 Select the color block or blocks you want to sequence. Hold down Ctrl to select 

multiples.

 Use the buttons on the toolbar or drag-and-drop to reposition the selection.

Use Sequence > Show Color List to display color blocks with included object 
thumbnails in the docker.

Select entire 
color block

Click-and-drag to 
reposition in 
stitching sequence

Alternatively use
tools to reposition
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Sequence by color block

Yet another sequencing technique is via selected color blocks. 

To sequence by color block...

 Select color blocks you want to include in the sequence. You can do this 
on-screen or with the Sequence docker. 

 The Sequence by Color tool becomes available. Click to invoke the dialog.

Use Sequence > Sequence by Color to resequence selected color blocks in the 
Sequence docker toolbar. Hold down <Ctrl> and click colors to select.

Sequence colors 
within selection order 
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Move colors up or down in the sequence via the ‘Move’ buttons, and click OK. 
Colors and component objects are sequenced in the selected color 
sequence.

Optimize color changes

The Optimize Color Changes feature improves the quality and efficiency of the 
stitchout by minimizing the number of color changes and trims. All existing overlaps 

Use Customize Design > Optimize Color Changes to optimize design by reducing 
color changes to a minimum, while maintaining color layers.

Move color blocks
up or down within

stitching sequence
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are preserved by the operation. It is good practice to run this command whenever 
you combine designs or cut and paste design elements.

You will be prompted when optimization is complete. See also Insert designs.

Tip: You can also manually resequence objects in the Sequence docker by 
dragging them into your preferred order. You have to be careful in reordering 
colors, however, that you don’t inadvertently cover up objects that are supposed 
to be stitched on top. It is also good practice to use the J shortcut to apply Closest 
Join to selected consecutive objects.

Color blocks
used in design

Objects
resequenced by

color
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Related topics

 Design settings
 Split objects
Closest joins

Color blending

From sunsets to wood grains, color blending creates interesting color blends, 
perspective effects and shading effects. Two colors are merged smoothly from 
one to another using a mixture of dense and open fill.

Apply color blending

Color blending can be applied to most objects filled with satin, raised satin, tatami, 
or zigzag stitching.

To apply color blending...
1 Select an object.
2 To prevent underlay stitching from showing through, deselect underlay. Travel 

on Edge is applied by default. See also Gradient fill effects.

Use Edit Objects > Create Color Blend to generate color blends, perspective effects 
and shading in selected objects.

Use Context > Underlay to apply or exclude automatic underlays to new or selected 
objects. Right-click for settings.
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3 Click Create Color Blend. The dialog opens.

4 Select a profile for top or bottom layers. The complementary layer is 
automatically selected so that rows blend into one another. However, the 
bottom layer contains an additional ‘even profile’ option. This can be used with 
any of the top layer profiles.

5 Choose complementary colors for each layer and adjust spacing settings. 
Generally, you will want to use the same spacing values so that rows blend 
evenly.

6 Click OK to generate the blended object.

Select a profile and
complementary colors

Even – no profile 
applied to bottom 
layer

Complementary
profiles selected by

default
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Related topics

 Stitch reinforcement

Edit color blends

Objects with color blending can be resized, rotated and skewed without losing the 
color blending effect. The two components must first be ungrouped and objects 
edited separately.

To edit color blends...
1 Select the blended object and press Ctrl+U to ungroup.

2 Select an object and change color as required.

Use Context > Group to group selection. Or press <Ctrl+G>. This tool is also 
available via Arrange menu.

Use Context > Ungroup to ungroup grouped selection. Or press <Ctrl+U>. This tool 
is also available via Arrange menu.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Ungroup blended 
objects

Recolor blended 
objects as 
preferred
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3 Double-click the object to open the Object Properties dialog.
4 In the Effects tab, select a profile and adjust spacing settings as required. 

Repeat the process for the second object.

5 Optionally, use Reshape to adjust gradient orientation.

6 When you have finished editing, re-group the blended objects.

Related topics

 Reshape objects

Change profiles as
preferred

Adjust gradient 
orientation with 
Reshape
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Embroidery connections

Connectors link objects in a design. They can be 
run stitches or jumps. You can use automatic 
settings to generate connectors, trims and tie-offs, 
or add them manually. If you prefer to add tie-offs 
and trims as you digitize, you can turn off 
automatic connectors altogether.

Tip: Hatch Embroidery also allows you to create 
‘branched objects’. Selected objects are 
resequenced, connectors minimized, 
components grouped, and stitches regenerated. 
Underlay can be applied to all. See also Branching 
and Redwork.

View connectors

Turn on connectors via the Show Design droplist or press Shift+C. The triangle 
indicates a trim, while a dotted line indicates a jump. In TrueView, jumps do not 
appear.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Turn on 
connectors
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When studying connectors, you may find that the distance between consecutive 
objects is not as close as it could be. To adjust connecting stitches, use Reshape to 
reset entry and exit points.

Tip: The Apply Closest Join command allows you to (re-)apply closest join to 
selected objects after editing. It is enabled when two or more embroidery objects 
are selected. It is available from the Edit menu or by pressing J. 

Related topics

 Design settings
Closest joins

Automatic connectors

Hatch Embroidery generates connecting stitches both within and between 
objects, based on embroidery objects. You can use the Always Tie-Off & Trim tool 
on the Context toolbar to force the use of trims when you don’t want connecting 
stitches to appear. For instance, lettering objects often contain connecting 
stitches between letters. In the sample below, the first object uses default settings 
and includes connecting stitches between letters ‘b_l_i_c_k’. The second object 
includes trims between each letter as indicated by the small triangles. The Always 

Use Context > Always Tie-Off & Trim to trim connectors. When turned on, connectors 
will always be tied off and trimmed. Otherwise, the software will decide when to trim.

Use Edit Objects > Object Properties to show Object Properties docker. Use to preset 
properties for new embroidery objects or adjust properties for selected embroidery 
objects.

Use Reshape to 
adjust entry and exit 
points
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Tie-Off & Trim tool will appear on the Context toolbar whenever you choose one or 
more embroidery objects. See View design details for details.

You can change connector settings for a whole design or selected objects. 
Sometimes, for instance, you may want to insert a jump as a connector between 
embroidery objects. Hatch Embroidery inserts Tie-off and Trim functions which 
command the machine to cut the connecting thread. The easiest way to do so is 
to select the first object and click Always Tie-Off & Trim on the Context toolbar.

At other times, you may actually want the software to turn off Trims and Tie-offs for 
selected objects or for entire designs. For instance, if the connecting run is hidden 
beneath another object, it is more efficient to use a connecting run rather than a 
trim and tie-off. You can do this via the Object Properties > Stitching tab. The 

Connectors 
between lettering

Connectors 
within lettering

Adjust connector
properties for

selected object
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following settings apply selectively to tie-ins, tie-offs, and/or trims. They work both 
for selected objects and when digitizing new objects.

Closest joins

Designs stitch out more efficiently when the 
connectors between objects are short. This 
also tends to reduce the number of trims in 
a design. Hatch Embroidery has a Closest 
Join method which can be applied while 
digitizing and/or after editing. When 
activated, entry and exit points of objects 
are automatically placed close together 
while you digitize. However, closest joins are 
not automatically maintained when 
objects are moved, re-sequenced, or 
edited. Closest Join can be (re-)applied to 
selected objects or entire designs after 
editing.

Tip: Connectors link objects in a design. 
They can be run stitches or jumps. You can 
use automatic settings to generate connectors, trims and tie-offs, or add them 
manually. If you prefer to add tie-offs and trims as you digitize, you can turn off 
automatic connectors altogether. See also Embroidery connections.

Apply closest join

When you are digitizing closed objects, the Closest Join method automatically 
calculates the closest join between them, saving you having to think about entry 
and exit points. The Apply Closest Join feature allows you to (re-)apply closest join 

Setting Purpose

On, if next 
connector >=

When selected, automatic trims are applied when connectors are greater than 
or equal to the specified value (default = 3mm). This setting can be activated 
for selected objects. The ‘Always Tie-off and Trim’ icon on the Context toolbar 
is enabled but not activated.

Always When selected, automatic trims will always be applied when digitizing or to 
selected objects. This setting is activated whenever the ‘Always Tie-off and 
Trim’ icon is activated.

Off This has the effect of turning off trims when digitizing. The setting can be 
turned off for selected objects. When selected, the ‘Always Tie-off and Trim’ 
icon on the Context toolbar is greyed out.

Use Edit Objects > Apply Closest Join to join selected objects at the closest point. 
Re-apply closest join after editing.
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to selected objects after editing. The image below shows a) joins as digitized, b) 
joins after repositioning, c) joins after reapplying closest join. The Apply Closest Join 
command is only enabled when two or more embroidery objects are selected.

The Apply Closest Join command is also available from the Edit menu or by 
pressing J.

Tip: Hatch Embroidery also allows you to manually change entry and exit points of 
individual objects. See also Reshape objects.

Closest join option
The Closest Join method (the default) automatically calculates closest join 
between objects while digitizing. When deactivated, entry and exit points of all 
newly digitized objects are set manually. If you want to deactivate it for this 
purpose, choose Embroidery Settings from the Software Settings menu and 
deactivate the option on the Design tab.

When deactivated, all newly digitized objects are joined by the As Digitized 
method. As shown in the first example below.

Joins as digitized Joins after 
resequencing

Joins after reapplying 
closest join

Closest Join 
method activated 
by default
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This means that you manually specify entry and exit points while digitizing. 
Generally it’s good to check entry and exit points before stitching out.

Related topics

 Design settings
 Reshape objects

Closest join limitations
The Closest Join feature is not applicable to all objects in all circumstances. Closest 
Join requires the complete stitch regeneration of the selected objects – the whole 
object, not just connectors. Stitch regeneration has its limitations:

 Recognized objects – i.e. opened from machine files – may generate poor or 
incorrect embroidery.

Manual (unrecognized) objects cannot be changed by stitch regeneration. 
Thus Closest Join will not work properly for them.

Manual stitch edits to objects will be lost.
Manually inserted machine functions may be mistakenly regenerated on the 

underlay.
 Nested objects are not supported. They will become un-nested and placed 

after the object in which they were originally nested.
The Closest Join technique is not as powerful as Branching for run objects. The best 
it can do is swap the ends of the runs whereas Branching produces a 
nicely-merged double-run joined in the middle. See also Embroidery connections.

Tip: Obviously, it only makes sense to apply closest join to sequential objects. Any 
non-sequential embroidery objects in the selection will trigger an error message.

Closest Join
not applied

Branching 
applied

Closest Join 
applied
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Split objects

Depending on your product level, Hatch Embroidery will let you split composite 
objects – monograms, appliqué, lettering, etc – into their components. You can 
also cut shapes into smaller fragments which is especially useful for editing 
converted TrueType fonts.

Tip: The design should be saved before you break it apart. Save to a different 
name so you can go back to the original composite object to edit if necessary.

Break apart composite objects

Certain objects such as appliqué, are ‘compound’ objects and cannot be 
ungrouped in the normal way. Sometimes, you may want to edit components 
which cannot be done within the grouped composite object. For example, you 
may want to make edits to the various layers of appliqué such as the tackdown 
stitch, etc. Alternatively, you may want to sequence the stitching order of 
appliqué components. To perform such editing operations, composite objects 
need to be ‘broken apart’. Use Break Apart to split all composite objects – 
monograms, appliqués, lettering, etc – into components. The effect on these 
objects is similar to the ungrouping operation. However, once it is broken apart, it 
cannot be re-grouped as a composite object again.

To break apart composite objects...

 Select the object to break apart – open-object appliqué, auto-appliqué, 
monogram, or lettering. The Break Apart command is activated.

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split 
composite objects – monograms, appliqués, lettering, etc – into components. Allows 
each to be edited individually. This tool is also available via Edit menu.

Select composite 
object



Chapte r  13    Ad vanced Edit ing 320

Click Break Apart. The object is separated into its component source (primary) 
and any generated (secondary) objects.

 The operation ungroups monograms into component objects – a lettering 
object, ornaments (each ornament set remaining as a group) and borders 
(also grouped).

Appliqué broken 
into components

Monogram 
broken into 
components
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 Lettering too can be broken into separate letters. Individual letters can even be 
broken into embroidery objects. Lettering properties are lost. See also Split 
lettering.

 To modify individual objects – e.g. to change the stitching sequence of 
monogram borders – use the Sequence docker to ungroup objects and 
sequence.

Tip: When saved into earlier versions of Hatch Embroidery, monograms, 
appliqués, and lettering may be subjected to Break Apart by default.

Related topics

 Split objects
 Appliqué
Monogramming

Cut shapes manually

Depending on your product level, the Knife tool may be available in your Edit 
Objects toolbox. Use it to manually cut closed or block-digitized shapes into 

Use Lettering / Monogramming or Edit Objects > Knife to cut objects along a digitized 
line, preserving stitch settings and colors.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Lettering broken 
into separate 
letters
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smaller fragments. It can, for instance, be useful when editing artwork converted 
to embroidery with auto-digitizing methods.

The Knife tool has two modes of operation:

With nothing selected, it will cut all objects under the knife.
With selected objects, it will only cut those within the selection.
The Knife tool will cut both filled objects and outlines. This is often necessary when 
objects include an outline type of stitch which also needs to be cut. This is often 
the case, for example, where you want to make a split monogram. It also affects 
any object with a z-z underlay, blanket stitch, etc. It also affects machine format 
designs that you may work with.

Tip: Generally, auto-digitizing conversion problems can be fixed with a 
combination of Knife and Reshape tools.

Combine objects

Digitizers often want to combine or ‘weld’ objects into a single object. Also when 
opening machine files which have been broken into multiple objects, you 
sometimes want to merge these back together. The technique can also help with 

Use Digitize / Edit Objects > Weld to merge selected overlapping objects into a single 
‘flattened’ object.

Cut fills or 
outlines with 
Knife tool
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auto-digitized designs. Simply select the objects you want to merge, and click the 
Weld button.

Improve objects

Hatch Embroidery provides tools for improving the quality of corners, smoothing 
shapes, as well as removing underlying stitching. Use them to reduce the number 
of reshape points as well as eliminate areas of unwanted stitching.

Corner stitching

The quality and style of corners is important in borders and appliqué, and satin 
column sewing in general. Sharp corners may cause stitch bunching which can 
create hard spots in the embroidery and may damage fabric or needle. The 
Automatic Corners feature helps you control sharp corners in satin objects. When 
the function is applied, corner types are automatically optimized according to 
corner angle.

Weld separate 
objects into 
single object

Use Context > Automatic Corners to turn automatic corners on or off. When turned 
on, the corners in line objects will be mitred or capped automatically depending on 
how sharp the corner turns. Can be turned on or off on an object by object basis.

Automatic Corners 
helps control 
sharp corners
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Apply smooth curves

Like vector objects, embroidery objects contain reshape nodes on their outlines. 
On shapes where the angle changes constantly, Hatch Embroidery may insert 
hundreds of reshape nodes, making reshaping difficult. This is particularly so when 
using auto-digitizing methods to generate objects. The Smooth Shapes command 
lets you apply curve ‘smoothing’ to embroidery objects.

To apply smooth curves...
1 Select the object (or objects) to smooth. You can only smooth objects that 

have been ungrouped and selected. However, you can select multiple 
objects.

2 Optionally, click the Reshape icon. Reshape nodes display around the outline.
3 Click Smooth Shapes and enter the precision value in millimeters. This controls 

how closely the smoothed outline follows the original. The larger the precision 
value, the fewer the reshape nodes.

Use Auto-Digitize / Edit Objects > Smooth Shapes to remove excess reshape-nodes 
from selected embroidery objects.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Enter smoothing 
precision value

Smooth 
outlines
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Remove underlying stitching

Use the Remove Overlaps tool to remove underlying layers of stitching in 
overlapping objects. This helps to reduce the stitch count and prevent a build-up 
of stitches where they are not needed.

To remove underlying stitching...
1 Select one or more ‘cutters’.

2 Click the Remove Overlaps tool. The stitching overlap is removed. A margin of 
overlap is automatically calculated between cutter and underlying object/s in 
order to avoid unsightly gaps.

Use Edit Objects > Remove Overlaps to remove stitches that are covered by the 
selected objects. Overlap value can be changed in the Overlap tab of Embroidery 
Settings dialog.

Select
‘cutter’

Stitching overlap 
removed and overlap 
calculated
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3 Note that you can control the overlap margin via the Embroidery Settings > 
Overlap tab which can be accessed via the Software Settings menu. Softer 
fabrics may require more overlap to prevent gaps from forming.

Tip: You can use an entire design as a cutter excluding objects, such as borders 
or details, less than a certain width.

Related topics

Overlap settings
Create holes in objects
 Fill holes in objects

Edit stitches

With embroidery designs, stitches are automatically generated from design 
outlines and properties. This means you can scale, transform and reshape designs 
without affecting stitch density or quality. However, Hatch Embroidery also lets you 
edit individual stitches.

For example, you can insert stitches in an object to fill gaps, or move and delete 
individual or clusters of selected stitches. You may need to do this, for example, 
when working with machine files which do not contain design outline data. In 
essence, you simply select and manipulate stitches like any other object.

Set nominal 
overlap margin
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Where possible though, edit embroidery objects rather than individual stitches. All 
stitch edits are lost when an object is modified and regenerated. For that reason, 
stitch edits are mainly applied to machine files rather than design files.

Select stitches

The Stitch Edit feature lets you select single stitches, several stitches, or a range of 
stitches by selecting their needle points.

Tip: In addition to background color or fabric, display colors for stitches, needle 
points, object shapes, and grid are part of the colorway definition. Change them 
if the default display color is not visible against the current colorway. See Adjust 
display colors for details.

To select stitches...

 Zoom in and display the needle points for easier selection.
 Select the object and click Stitch Edit.
 Select individual stitches in Stitch Edit mode by selecting their needle points.
 The needle point and stitch colors change and the needle position marker 

moves to the selected stitch.

Use Edit Objects > Stitch Edit to place stitch cursor at selected insertion point.

Selected stitches 
in Stitch Edit 
mode
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 To select multiple stitches, drag a bounding box around needle points.

 Alternatively...
 Hold down the Shift key and click to select a range of stitches
 Hold down the Ctrl key and click to select multiple stitches.

 Press Delete to eliminate unwanted stitches.

Related topics

 Adjust display colors
 View design details

Insert stitches
You can insert stitches in an object to fill gaps. Inserted stitches are incorporated 
into the object. They will, however, be lost if the object’s stitches are regenerated.

To manually insert stitches...
1 Select a needlepoint. The needle point and stitch colors change and the 

needle position marker moves to the selected stitch.
2 Use the arrow keys to travel between stitches.

Drag a bounding 
box to select

Selected stitches 
eliminated
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3 Move the mouse pointer where you want to insert the new stitch, and 
right-click.

4 Continue right-clicking as needed.

Move stitches
You can move individual or groups of selected stitches. As always, if an object’s 
stitches are regenerated for any reason, all stitch editing functions are lost.

 Zoom in, select the object and click Stitch Edit.
 Select the stitches to move.
Move selected stitches by dragging one of the selected needle points. The 

stitch shadow outline shows the new position.

Select while traveling

‘Traveling’ through a design is usually associated with checking the stitching 
sequence. However, you can also select objects as you travel. Switch to Stitch Edit 

Use Edit Objects > Stitch Edit to place stitch cursor at selected insertion point.

Use Travel > Select While Traveling to toggle on to select stitches, objects, or colors 
while traveling through a design.

Right-click to 
insert stitch

Click and drag 
individual stitches to 
reposition
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mode. Then, with the Select While Traveling tool activated, use any of the Travel 
tools and as you move through design, objects are selected. See also View 
stitching sequence.

Related topics

 Travel through designs

Select objects while 
traveling through 
design
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PART V
LETTERING & 
MONOGRAMMING

Create top-quality lettering quickly and simply. Hatch Embroidery provides a large 
range of scalable closest-join font styles and multi-color and fancy embroidery 
fonts to choose from. The Monogramming feature offers a simple way to create 
personalized monograms using a selection of predefined monogramming styles, 
border shapes and ornaments. The Keyboard Design Collection feature allows you 
to map embroidery character designs to keyboard characters for quick and easy 
use in Hatch Embroidery.
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Chapter 14

LETTERING

Once you are used to sewing out designs and 
resizing, changing colors and fabric types, you 
will certainly want to create your own lettering 
designs. While it takes practice to obtain a 
good quality lettering stitchout, it is as simple as 
typing letters on-screen to create attractive 
lettering in your software. The Lettering / 
Monogramming toolbox provides the tools 
needed to add high quality embroidery 
lettering to your designs as well as create 
monogram designs.

Tip: The Monogramming feature offers a simple 
way to create personalized monograms using a selection of predefined 
monogramming styles, border shapes and ornaments, together with a set of tools 
to help you place these elements in creative and decorative ways. See 
Monogramming for details.

Create lettering

Hatch Embroidery lets you add lettering to designs quickly and easily using the 
built-in library of embroidery fonts. Select from the supplied fonts or convert 
TrueType or OpenType fonts. If you are embroidering on a child’s outfit you might 
use a simple font like ‘Curly’. If you are embroidering on a ladies nightdress you 
might use an elegant script font like ‘Edwardian Script’.
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Add lettering

Place lettering on horizontal or vertical baselines, curve it around a circle or arc, or 
digitize your own baseline curves. Apply formatting similar to a word processor, 
including slanted letters and left/right justification. Hatch Embroidery provides a 
font range suitable for many applications.

To add lettering...
1 Select a color. See also Design colors.
2 Click the Lettering tool, click the design window, and start typing. 
3 Alternatively, enter the text you want to embroider in the Lettering tab. To start 

a new line of lettering, press Enter.

Note: The 0,0 point shown on the ruler defaults to the center of the screen. If you 
have moved the center point for any reason, the lettering object will still appear 
at center screen. If necessary, select and move to the required location in the 
design.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets, Keyboard Design Collections or TrueType fonts, or edit 
selected lettering.

Enter text – press
Enter to start new

line
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4 Select a font from the Font list. You can use both native embroidery fonts and 
many TrueType fonts installed on your system. Native fonts generally offer better 
results. 

5 Use the filter to sort the font list for easier selection. Preset the font type – 
TrueType or Embroidery. Note that embroidery fonts include the recommended 
size range.

TrueType fonts can be further filtered by style – block, serif, etc.

Tip: You can set the size of your font preview via the User Interface Settings > 
General tab. You can also adjust the number of recently selected fonts. See 
Font list display options for details.

Native embroidery fonts 
include recommended 
size range

Recently selected 
fonts

Filtered by all 
font types

Keyboard design 
collections

TrueType fonts

Filtered by 
TrueType fonts
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6 With the font list still highlighted, use the arrow keys to scroll through the list with 
or without the preview panel opened. Try out different fonts ‘on-the-fly’.

7 You can modify lettering objects directly on-screen to achieve various artistic 
effects. Appearance and layout depend on current settings.

8 Embroidery and TrueType fonts generally contain many more characters than 
are available via your keyboard. Click Insert Character to add special 
characters and symbols via the dialog.

9 Select a lettering baseline. You can place lettering on a straight horizontal or 
vertical baseline, curve lettering around a circle or arc baseline, or digitize your 
own. See also Lettering layouts.

10 The Lettering tab contains a number of preset ‘lettering art’ styles which can be 
applied to lettering to make it bulge or arch, stretch or compress. The effect is 
best used with a fixed-line baseline. See also Lettering layouts.

Select 
baseline type

Select gallery of 
lettering art styles
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11 Adjust lettering height as preferred. Consider the font before changing letter 
size. Some fonts look best in a smaller size. Others can be stitched at a larger 
size.

12 Select an alignment setting. Alignment governs the way lettering aligns itself 
along a baseline. Full alignment spreads letters out to fill the length of the 
baseline.

Note: You can insert Japanese characters from the Insert Character dialog or 
use Google Translate and copy and paste into Hatch Embroidery via the 
Lettering or Monogramming tools.

Lettering join method
The lettering join method is preset to give the best results for each font. Options 
include:

In most cases, Closest Join is used in order to minimize trims...

Lettering objects normally consist of one stitch type and one color only. However, 
the As Digitized join method is used with special fonts which combine several stitch 
types – e.g. Satin with Run, or Tatami, or Motifs.

Join Purpose

Closest join CJ Letters are joined at the closest point. Use it to minimize trims.

As digitized AD Letters are joined as they were digitized. Use it with fonts combining 
different fill stitch types or special effects.

Select alignment 
style

‘Closest Join’ 
join method

‘As Digitized’ 
join method
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As Digitized fonts may also include multiple colors, special effects or run stitches as 
part of the cover stitching. You can tell if a font is ‘As Digitized’ because you will 
not have the option to change fills, effects, or stitching.

Tip: The Included Fonts section in the online documentation lists all fonts that are 
standard with your embroidery software. For best results when stitching, do not 
exceed the recommended maximum or minimum sizes. The font tables also 
indicate the join method used.

Advanced settings
Adjust lettering Width and Italic settings in the Advanced panel. See also Reshape 
lettering.

Lettering width
Change the appearance of a font by changing the letter width in proportion to 
height. The default Width value is 100%.

Slant
You can slant letters to the left or right for an italic effect. The default slant angle is 
0° which is equivalent to no italics.

Adjust width and 
italic settings

100% 70%

150%

Adjust width as 
percentage of 
height

Slant lettering 
to right or left

https://www.embroideryhelp.net/hatch/digitizer/en/quick-reference/included-fonts
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Letter spacing
Letter spacing is calculated automatically as a percentage of letter height. Script 
fonts default to zero or 1mm spacing depending on font style. In most cases the 
default spacing is adequate. Sometimes, however, you may want to change it for 
effect or to fit within a fixed baseline.

Letter & baseline angles
You can control the angle of letters and lettering baselines via the Letter angle and 
Baseline angle settings. Use both negative and positive values to control direction.

Line spacing
Adjust Line spacing value to fine-tune the space between lines of text.

Letter sequence
Hatch Embroidery allows you to specify the sequence in which letters are stitched 
to minimize registration problems with caps or difficult fabrics. Stitch the lettering 
from left or right, or from center out. This is especially useful when stitching on caps. 

Adjust spacing as 
percentage of 
height

Control angles of 
letters and lettering 
baselines
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To change letter sequencing, double-click a lettering object. Select a letter 
stitching sequence in the Advanced panel. Options include:

Tip: Travel through your design to check the stitching sequence. See also View 
stitching sequence.

Insert color changes
Hatch Embroidery lets you insert a color change on any stitch. A color change is 
inserted at the current cursor position. This is particularly useful when working with 
monograms or other lettering objects.

To edit lettering on screen...

 Select the object and click the Lettering tool. An I beam will appear.

 Select a letter (or letters) by dragging the cursor over the letter.
 Select a color on the Design Colors toolbar.

 To remove unwanted color changes, simply select the entire object and select 
a color on the Design Colors toolbar. The object reverts to the chosen color.

Left-to-right When selected, lettering is stitched from left to right (the default).

Center-out
When selected, letters to the left of center are stitched first, going 
from right to left. Next letters to the right of center are stitched, 
going from left to right.

Right-to-left Lettering is stitched from right to left.

Drag I beam over 
letter to select
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Lettering layouts

The lettering baseline determines its shape. 
You can place lettering on a straight 
horizontal or vertical baseline, curve 
lettering around a circle or arc baseline, or 
digitize your own. Different reference points 
are needed depending on the baseline you 
use. Baselines use default settings to 
determine their size, spacing and angles. 
Hatch Embroidery gives you interactive 
control over many baseline settings. 
Techniques are available to modify baseline 
type, length, radius and angle, as well as 
baseline position. Change lettering 
orientations of selected lettering objects at 
any stage.

Horizontal baselines

Both Free Line and Fixed Line baselines form straight, horizontal baselines. Free Line 
does not have a fixed or predetermined length – the baseline extends as long as 
you keep adding letters.

Fixed Line has a fixed length. If the text extends beyond it, lettering size and/or 
spacing is reduced according to the chosen reduction method. This option is 
intended, in particular, for cap or pocket production.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets, Keyboard Design Collections or TrueType fonts, or edit 
selected lettering.

Fixed line fits 
lettering to available 
space
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When you choose Fixed Line baseline, other advanced options become 
available. For a precise fit, adjust the baseline length in the Baseline Length field.

With fixed-length baseline, lettering is ‘reduced’ to fit if the baseline is too short to 
accommodate all letters at their nominal width and default spacing. Select the 
reduction method you want to use. Various methods are available:

Tip: If you change baseline length by reshaping lettering or by changing the 
Baseline Length value, lettering reduction will be recalculated. The same applies if 
you change any lettering attribute which could affect its length, such as nominal 
width, nominal height or number of characters.

Fixed line method Purpose

Space 
and width

Letter width and spacing are reduced proportionately if the baseline 
length requires it.

Space 
and size

Letter width, height and spacing are reduced proportionally if the 
baseline length requires it.

Space Letter size and width stays the same and letters are spaced evenly 
along the baseline. Letters may overlap if the text is too wide.

Width The width of each letter is reduced and the original spacing kept.

Size Letter width and height is reduced proportionally but the original 
spacing remains.

Adjust baseline 
length as 
necessary
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Vertical baselines
Free Line Vertical is a straight, vertical baseline. It is useful for 
embroidering on sleeves, as a decorative effect, and for Asian text. 
Vertical lettering is best suited to uppercase for Western languages 
because descenders in lowercase letters are not accommodated in the 
letter spacing. They don’t have a fixed length and extend to fit the letters 
you enter. Line spacing is calculated horizontally while letter spacing is 
calculated vertically. Letters, by default, are centered along vertical 
lines.

Circular baselines

Use Circle CW and Circle CCW baselines to place letters around a full circle in 
clockwise or counter-clockwise directions. By default, letters are positioned above 
Circle CW baselines and below Circle CCW baselines. Use the Reshape tool to 
control the orientation and radius of the baseline. A radius setting is also available 
in the Advanced panel.

Custom baselines

Use Any Shape baseline to shape lettering around elements in your design. When 
you first apply Any Shape, it appears like Free Line baseline. Use the Reshape tool 
to add control points – left-click for corners, right-click for curves. The number of 
reference points and length of baseline are practically unlimited. If the baseline 

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Circular baselines
available

Adjust 
selected 
baseline 
settings
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has tight curves, or sharp corners, the letters may overlap. For best results, only 
mark curve points to create shallow, gentle curves.

Because Any Shape baselines tend to compress or stretch letter spacing around 
curves, adjust letter kerning by means of the diamond control points. Select and 
drag the letter along the baseline. Alternatively, use arrow keys to nudge the letter 
into position.

Lettering art
The Lettering tab contains a number of preset ‘lettering art’ styles which can be 
applied to lettering to make it bulge or arch, stretch or compress. The effect is best 
used with a fixed-line baseline.

The Envelope Gallery can be floated by click-and-drag. Keep it on screen to aid 
your selection. Remove unwanted envelopes by clicking the X button at the top.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

‘Any Shape’ 
baseline

Adjust kerning 
around corners as 
necesssary

Select from gallery 
of lettering art styles
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Lettering styles can be adjusted with the help 
of the Reshape tool. See Reshape lettering 
for details.

Preset layouts
Hatch Embroidery provides two presets for 
easy multi-line layouts.

 Enter the text as you normally would in the 
text entry panel.

 Press Enter to create new lines – two or 
three. Each line can contain one or more 
words.

 Select a preset from the Layouts group. You have a choice of a two- or 
three-line layout.

 You will be prompted to enter control points. Press Enter to accept defaults. The 
text is laid out on two or three separate lines. Each line is a separate lettering 
object and can be adjusted accordingly.

Use preset layouts 
for multi-lines

Text laid out on 
two or three 
separate lines
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Lettering settings

By default, lettering objects are filled with Satin stitch. You can apply other fill stitch 
types such as Tatami or Embossed as well as stitch effects such as Jagged Edge. 
See also Stitch Types & Effects.

Lettering stitch types

By default, lettering objects are filled with Satin stitch. You can also apply other 
basic fill stitch types, such as Tatami or Embossed, as with other embroidery 
objects.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets, Keyboard Design Collections or TrueType fonts, or edit 
selected lettering.

Experiment with 
different stitch 
types and effects
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Lettering underlay
Most embroidery lettering is 15 mm high or less although Hatch Embroidery 
provides fonts suitable for small and for large lettering. At normal sizes, columns are 
less than 3 mm wide for normal – not heavy or block – fonts. Such objects are best 
served with a single Center Run or Edge Run underlay or both. Hatch Embroidery 
decides on a suitable underlay for normal purposes though this can be overriden 
in Object Properties.

Usage tips
 Lettering with heights under 5 mm should not have underlay.
 Lettering 6 mm to 10 mm can use a center-run underlay.
 Lettering larger than 10 mm can use an edge-run underlay.
 Large lettering for jacket backs and the like can use a second layer of underlay. 

Double-zigzag is sometimes used for added loft. For even more loft, try using 
Raised Satin.

Letter underlay 
automatically selected 
according to size
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With fancy fonts such as ‘Charcuterie’, the minimum height is 20mm, the 
maximum 65mm. Even at 20mm, Auto Split should be turned on otherwise stitch 
length will be too long for domestic machines.

 You need to generate fonts at the recommended sizes (25mm-50mm) to 
clearly see their characteristics. For instance, ‘Engraved Serif’ includes an open 
tatami fill while ‘Invitation’ has no fill.

 Some small fonts may require the use of different needles and threads for the 
font to work.

Auto Split on

Engraved Serif

Invitation
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Reshape lettering

The Select and Reshape tools give you precise control over your lettering 
appearance. Scale lettering on screen. Adjust letter, word and line spacings. 
Modify baselines. Even transform and reshape individual letters.

Summary of methods

Lettering objects can be reshaped like any other embroidery object by means of 
Select and Reshape tools. However, in Reshape mode, additional control points 
are available due to the properties of lettering objects. For instance, lettering 
objects include spacing between letters. They also have baselines which have 
their own properties.

Reshape mode
In Reshape mode, control points allow you to...

 Resize lettering by means of triangular resize handles.
 Adjust overall letter spacing by means of the baseline arrow.
 Adjust letter kerning by means of diamond control points.
 Size the baseline by means of the yellow end points.
 Adjust entry and exit points by means of the green diamond and red cross.

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Reshape mode 
control points
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Single-click Select mode
In single-click Select mode, control points allow you to...

 Stretch lettering horizontally by changing width.
 Stretch lettering vertically by changing height.
 Size lettering proportionately by changing width and height.

Double-click Select mode
In double-click Select mode, control points allow you to...

 Rotate lettering by dragging the large rotation handles.
 Skew lettering in either direction by the small handles.
Change rotation axis by moving the circle control point.
With a lettering object selected, the Context toolbar also provides methods for 
adjusting object width, height, size, skew, and orientation. You can even flip 
lettering objects horizontally or vertically.

Single-click ‘Select 
mode’ control points

Double-click ‘Select 
mode’ control points

Use Context controls 
to scale, mirror, rotate 
and skew lettering
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Scale lettering

Scale your lettering objects vertically, horizontally and proportionally by means of 
the Select tool.

You can also scale lettering objects with the Reshape tool.

Note: The Context toolbar provides an alternative method for scaling lettering, 
both by precise dimensions or by scale factors of ±10%.

Rotate lettering
Rotate lettering objects by means of the Select tool.

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Scale in Select 
mode by means of 
control points

Scale in Reshape 
mode by means of 
control points

Rotate in Select 
mode by means of 
control points
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Alternatively, use the Reshape tool to rotate lettering objects by means of baseline 
control points.

Tip: The Context toolbar provides an alternative method for rotating lettering, both 
by precise rotation angle or by rotation factors of ±15°.

Adjust spacings

Letter spacing is calculated automatically according to justification – Left 
Justification, Right Justification, Center Justification, or Full Justification. In most 
cases default spacing is adequate. Sometimes, however, you may want to 
change overall letter spacing. Drag the spacing control handle on the baseline to 
adjust overall letter spacing.

Sometimes spacing between letters may appear too large or too small, 
depending on the shape of neighboring letters. Any Shape baselines in particular 
have a tendency to squash or stretch letter spacing around corners. To 
compensate for this visual effect, you can manually adjust letter ‘kerning’. Simply 
click-and-drag the magenta diamond in the center of each letter.

Note: When lettering is set to Full Justification, letters are evenly distributed along 
the baseline. To change spacing for fully justified lettering, simply change the 
length of the baseline by dragging the yellow control handle.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Rotate in Reshape 
mode by means of 
baseline control points

Adjust overall 
spacing in 
Reshape mode

Adjust letter spacings 
by means of triangle 
control points
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Change the space between lines in a multiple-line lettering object using the 
Reshape tool. Drag the triangular line spacing handle up or down to change line 
spacing.

Note: Overall letter spacing can also be controlled numerically in the Advanced 
panel of the Lettering tab. Line spacing can also be controlled by manual 
adjustments on screen.

Reshape baselines

Lettering baselines have their own control points. In addition those mentioned 
above, some baselines have other properties.

To reshape baselines...

 To adjust the arc of a circle baseline, drag the control point in the center. This 
control has no numeric equivalent.

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Adjust line spacing 
by means of 
control point

Drag control point to 
reshape baseline 
arc
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 Any Shape baselines can be modified by moving, changing, adding or 
deleting control points along the baseline. To reshape the baseline, click the 
point on the baseline you want to bend (change direction).

 Left-click to bend the line at an angle. 
 Right-click to bend the line into a curve. Switch control points in the normal 

way by selecting and pressing the Space key.

Reposition letters

You can reposition individual letters in a lettering object using the Reshape tool. 
Reposition right or left by dragging the diamond control point in Reshape mode. 
To move them up/down, hold down the Ctrl key as you drag.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Right-click to 
bend line into a 
curve

Reposition letters by 
dragging diamond 
control points
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When you click a diamond control point, another set of reshape nodes appears 
around the letter. Use these to resize, rotate, and skew individual letters.

Reshape letters

Create special lettering effects by reshaping letter outlines with the Reshape tool. 
Click the letter outline. Use the reshape nodes to modify the letter like any other 
object. Press Esc to finish.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Use control points to 
transform individual 
letters

Reshape individual 
letters by means of 
control points
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Split lettering

Applying the Break Apart function to a lettering object breaks it into a logical 
stitching sequence while maintaining lettering object characteristics. Object 
properties can be edited separately for single lines, single words, or even single 
characters. Stitching sequence is maintained. Similarly, if you apply Break Apart to 
monograms, they are broken into their component objects.

Note: When saved into earlier versions of Hatch Embroidery, monograms and 
appliqué may be broken apart by default.

Break apart lettering

Lettering can be progressively broken apart down to individual letter patches.

To break lettering apart...

 Select the lettering object and click Break Apart.
 Individual lines are broken into separate words.

 Individual lines are broken into separate words.

Tip: Multi-line lettering is first broken into separate lines.

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split 
composite objects – monograms, appliqués, lettering, etc – into components. Allows 
each to be edited individually. This tool is also available via Edit menu.

Break apart 
lettering object

Lines broken into 
separate words
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Words are broken into separate letters.

 Letters can be broken into their individual embroidery patches. Lettering 
properties are lost. Only general embroidery object properties remain.

Note: An exception for single-line (multi-word) objects is the case of the center-out 
stitching sequence. Such objects are broken apart directly into single-letter 
objects. The stitching sequence is thereby preserved.

Cut lettering manually

Depending on your product level, the Knife tool may be available in your Lettering 
/ Monogramming toolbox. Use it to manually cut closed or block-digitized shapes 

Use Lettering / Monogramming or Edit Objects > Knife to cut objects along a digitized 
line, preserving stitch settings and colors.

Use Lettering / Select > Reshape to reshape an object outline, edit stitch angles, or 
adjust entry and exit points.

Words broken 
into separate 
letters

Letters broken 
into separate 
patches
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into smaller fragments. It can, for instance, be useful when editing converted 
TrueType fonts.

When you select a TrueType font in the font list, it is automatically converted to 
embroidery lettering. While TTF conversion produces similar results to digitized 
embroidery fonts, some letters may not contain the correct sequence of strokes. 
Generally, conversion problems can be fixed with a combination of Knife and/or 
Break Apart tools together with the Reshape tool.

Generally, you should not need to use Knife with native embroidery fonts. 
However, you might want to use it to make creative changes to a letter.

Tip: The Knife tool will also work with Satin, Zigzag, and Blanket outlines. It does not 
work with other outline types such as Run or Motif.

Special lettering

Hatch Embroidery provides a variety of editing techniques for fine-tuning lettering 
designs. Add special characters and symbols as desired. By default, lettering 

Native embroidery 
font list

Filtered by 
all fonts

Convert and edit 
TrueType fonts

Cut into 
embroidery 
patches to edit
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objects are filled with satin. Apply other basic fill stitch types as with all embroidery 
objects. Lettering appearance and quality can be improved by the correct 
selection of underlay.

Insert special characters

Embroidery and TrueType fonts generally contain many more characters than are 
available via keyboard. You can add special characters and symbols directly or 
by means of the MS Windows® Character Map.

To insert special characters...
1 Click Insert Character button in the Lettering tab.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets, Keyboard Design Collections or TrueType fonts, or edit 
selected lettering.

Insert special 
characters
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2 Optionally, select a different font from the Font list.
3 Select the characters you want to use and click OK. Selected characters are 

added to the text entry panel of the Lettering tab.
4 Alternatively, use the MS Windows® Character Map to provide quick access to 

common symbols and letters. By default, you will find it under Start > Programs 
> Accessories > System Tools > Character Map.

5 Copy the characters you want and paste them into the text entry panel of the 
Lettering tab by pressing Ctrl+V.

6 Colors will default to the initial colors of the Design Colors toolbar. The letters will 
appear as a single lettering object.

7 Place and size the lettering object as desired.
8 Optionally, in order to change colors, assign them via the Design Information > 

Thread Colors dialog. See also Design colors.

Note: In the Sequence docker, each letter is sewn out separately. With 
multi-color fonts, this may involve many color changes.

9 Optionally, use the Break Apart tool to split the lettering object into its 
components. These can then be recolored and resequenced as desired. 
However, note that lettering properties are lost.

Insert special 
characters via 
Character Map

Special 
character 
inserted
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Flair script

Flair script is a special font which allows you to add decorative flairs to the end of 
text objects, mimicking flamboyant handwriting flourishes.

To create a flair script...
1 Select Flair Script from the Font list.
2 Enter the text you want to embroider in the text entry panel.
3 Click Insert Character and select the flair character(s) you want to use. The 

selected characters are added to the text entry panel.

4 Experiment with different flair characters to obtain the look you want.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets, Keyboard Design Collections or TrueType fonts, or edit 
selected lettering.

Insert special 
flair characters
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Monogram fonts

In addition to the dedicated Monogramming feature, Hatch Embroidery allows 
you to create monogramming designs using special monogram fonts.

To create a monogram...
1 Select a suitable monogram font such as Octagon Monogram.
2 Use the Select Character dialog to choose the letters and ornaments you want 

to use. Octagon Monogram, for example, has three sets of each letter, one for 
the left side, one for the middle and one for the right side.

Note: For a list of available monogram fonts, see included fonts in the online 
documentation.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets, Keyboard Design Collections or TrueType fonts, or edit 
selected lettering.

Insert special
monogram characters Select monogram 

font

https://www.embroideryhelp.net/hatch/digitizer/en/user-guide/lettering/included-fonts
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Chapter 15

MONOGRAMMING

A monogram is a design composed of 
one or more letters, typically the initials of 
a name, used as an identifying mark. The 
Monogramming feature offers a simple 
way to create personalized monograms 
using a selection of predefined 
monogramming styles, border shapes 
and ornaments, together with a set of 
tools to help you place these elements in 
creative and decorative ways.

Tip: Lower level products do not provide the full range of monogramming 
functionality. Depending on your product level, you may not have access to 
ornaments or borders or to all advanced properties and editing capabilities. See 
also Monogram fonts.

Select monogram designs

When you use the Monogramming feature, you 
build monograms using the Monogramming 
docker. Depending on your product level, 
monograms may include letters, ornaments, 
and/or borders.

Designs tab
The simplest way to get started is to select a 
base design from the Designs tab. This gives you 
a bunch of design templates ranging from 

Use Lettering / Monogramming > Monogramming to create personalized monograms 
using a selection of pre-defined styles, border shapes and ornaments.
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lettering only, with borders, and with ornaments. Select one as a starting point and 
then modify by means of the other tabs.

The monogramming design is grouped in the Sequence docker. It is treated as a 
single, composite object. It can only be edited via the Monogramming docker. It 
cannot be ungrouped but it can be broken apart into its components. See also 
Split lettering.
If all you want to do is to recolor monogram elements, you can select them 
individually without breaking apart the monogram. Simply hold down the Alt key 
and click the object.

Select monogram 
sample from 
Designs tab

Hold down Alt and 
click object to 
select
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Tip: It is common to use laydown stitch with monograms in order to flatten the nap 
of textured fabrics like terry toweling. In order to apply laydown stitching to a 
monogramming object, you need to add laydown fill as the #1 border, and then 
offset it to be larger than letter and ornament components. See Add monogram 
borders for details.

Add monogram letters

The Letters tab of the Monogramming 
docker allows you to create personalized 
monograms with initials, including special 
characters and symbols, or unlimited 
lines of characters. Any number of initials 
can be entered into your 
monogramming design, including 
special characters and symbols.
The Letters tab provides similar options to 
the Lettering tab of the Object Properties 
docker. If you are using one of the 
template designs, the easiest way to 
adapt it is to apply a different style. 
Change initials as required and choose from any number of native embroidery 
fonts, keyboard design collections, or any TrueType font installed on your system. 
In addition, this tab also provides a selection of styles to choose from.

Use Lettering / Monogramming > Monogramming to create personalized monograms 
using a selection of pre-defined styles, border shapes and ornaments.

Modify initials 
as required
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In place of single letters, the same tab allows you to enter multiple lines.

If a selected style doesn’t quite give you what you are looking for, open the 
Advanced panel to access more settings. Use these to adjust letter width, spacing, 
etc. Adjust letter rotation and baseline angle. These allow you rotate individual 
letters or the entire baseline.

Tip: Click Properties to make any further adjustments – e.g. stitch type. The default 
values for monogram lettering are different from those for conventional lettering. 
All settings can, however, be controlled via the Object Properties docker.

Add monogram ornaments

Ornaments can be added to a monogram either from motif patterns or from any 
design file. You have a choice of:

 Adding ornament motif patterns or designs
Creating single ornament layouts
Creating multi-ornament layouts.

Alternatively, 
add multiple 
lines

Use Advanced settings
to rotate lettering
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Modify ornaments

If you are using a template design or adapting another monogram, it is a simple 
matter to change the ornament to a different type or configuration. Use the 
buttons at the top of the Ornaments tab to add, delete, or change ornaments.

Choose from a range of preset placement patterns, including Mirrors, Duplicates, 
and Cycle. Note that the pyramid icon indicates not only the placement but also 
the orientation of the pattern in both horizontal and vertical planes. 
If the preset pattern gallery doesn’t quite give you what you are looking for, open 
the Advanced panel. These settings give you precise control over ornament 
placement, size, rotation, orientation, and margin.

Use Lettering / Monogramming > Monogramming to create personalized monograms 
using a selection of pre-defined styles, border shapes and ornaments.

Change ornaments 
as preferred

Access Advanced 
settings for 
precise orientation
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Add ornaments
You can add up to ten ornament sets to a monogram design and change them 
at any time. Any available pattern set can be used. A set of ornamental designs is 
also available. These are stored in their own Ornaments folder.

Use the checkboxes to add up to eight instances of a selected ornament. These 
are arranged according to ornament placements relative to the lettering. 
Excluding Position #5, any combination of checkboxes can be used.

The first selected serves as the ‘anchor’ position (highlighted in red). All other 
ornaments are sized, rotated and mirrored in relation to it. Use the Width and 

Use ornaments from 
any pattern set

Add up to eight 
ornament repeats
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Height fields to change ornament dimensions. The Lock Aspect Ratio toggle forces 
width and height to maintain their proportions. Use the Margin setting to offset 
ornaments from the lettering.

Create single ornament layouts
Use Position #5 to insert an ornament as a standalone element within a set. All 
other checkboxes are unchecked automatically. Width, Height, and Rotate By 
fields and Mirror checkboxes remain available, and Offset controls replace the 
Margin control.

Use the X and Y fields in the Offset panel to position the ornament horizontally or 
vertically relative to the lettering object. These settings specify the position of the 
ornament center relative to the center of the lettering object.

Add single ornament 
design using 
Position #5
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Multi-ornament layouts
You can add up to eight instances of a selected ornament to your monogram. 
Any combination of ornaments and ornament positions can be used. Add the 
ornament sets you want and assign placements to each one.

Tip: Remember, if you want to recolor monogram components, you can select 
them individually without breaking apart the monogram. Simply hold down the Alt 
key and click the object.

Add monogram borders

You can add up to four borders of the same 
shape to a monogram design.

Tip: It is common to use laydown stitch with 
monograms in order to flatten the nap of 
textured fabrics like terry toweling. In order to 
apply laydown stitching to a monogramming 
object, you need to add laydown fill as the #1 
border, and then offset it to be larger than 
letter and ornament components. See also 
Laydown stitch.

Use any 
combination of 
ornaments
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Modify border

If you are using one of the template designs, it is a simple matter to change 
borders. Use the Change button on the Borders tab to select from one of the many 
available.

Note: The Create Border function allows you to create your own borders for use in 
monograms. These can be saved to a custom border set. See also Custom objects.

Adjust border shape & offset
When using Standard Shapes, some irregular shapes may cause a larger offset 
than expected. Once created, you can select and resize the shape to the desired 
size.

Use Lettering / Monogramming > Monogramming to create personalized monograms 
using a selection of pre-defined styles, border shapes and ornaments.

Add borders from 
the Border library



Chapte r  15    Mono gramming 371

To adjust border shape & offset...

 Use the Aspect Ratio settings to adjust height and width proportions.

 Use the Offset field to fine-tune margins between lettering and border, and 
between border and border.

Adjust aspect 
ratio as 
preferred

Adjust offset 
setting to fine-tune 
margins
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 Use the Rotate field to re-orientate the border as desired.

 Use the Properties button to further adjust border settings. For instance, change 
the border fill to tatami with spacing = 1.5, underlay = none, angle = 45. 

Caution: If you add a new border, stitch angles revert to default settings. To 
avoid this, set up all borders and only then adjust the angles.

Add multiple borders
Add up to four borders to the selected monogram. Use the Offset field to adjust 
margins between multiple borders. When you set multiple borders, the offset you 
specify is calculated from the previous border.

Rotate borders 
as preferred

Add multiples of 
different borders
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Tip: Hatch Embroidery lets you enter a negative offset. This allows you to create 
multiple overlapping borders.
Use the Stitch Type buttons to change to line or fill stitch type for selected borders. 
Satin line is the default stitch type. All line and fill stitch types available in Hatch 
Embroidery can be used as borders. Click the Properties button to make further 
adjustments.

Tip: Remember, if you want to recolor monogram elements, you can select them 
individually without breaking apart the monogram. Simply hold down Alt and click 
the object.

Break apart monograms

Applying the Break Apart function to a lettering object breaks it into a logical 
stitching sequence while maintaining lettering object characteristics. Object 
properties can be edited separately for single lines, single words, or even single 
characters. Stitching sequence is maintained. Similarly, if you apply Break Apart to 

Adjust properties 
for each border

Adjust stitch types 
for border outlines 
or fills

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split 
composite objects – monograms, appliqués, lettering, etc – into components. Allows 
each to be edited individually. This tool is also available via Edit menu.
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monograms, they are broken into their component objects – lettering, ornaments 
and borders.

Each ornament set remains as a group as do borders. These too can be further 
broken apart.

To modify individual objects – e.g. to change the stitching sequence of monogram 
borders – use the Sequence docker to ungroup objects and sequence. See also 
Split objects.

Note: If all you want to do is recolor monogram components, you can do this by 
holding down the Alt key and clicking the component you want to modify.

Split monograms 
into component 
objects

Recolor and 
resequence 
component objects
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Chapter 16

KEYBOARD DESIGN COLLECTIONS

Embroidery character designs are very popular. Many hobbyists buy these from 
third-party suppliers. Naturally, embroiderers want to be able to use them in Hatch 
Embroidery by mapping to keyboard characters. The Keyboard Design Collection 
(KDC) feature provides a convenient way to do this.

Note: Grade A or Grade B files always produce best results. You will find sample 
collections amongst your Hatch Embroidery design inclusions. However, most 
third-party embroidery character designs will be a Grade C or D machine file 
formats such as EXP, DST, PES, etc. See also Machine file recognition.

Map character designs in Design Library

The Keyboard Design Collection feature allows you to map embroidery character 
designs to keyboard characters for quick and easy use in Hatch Embroidery. First 
you must create a keyboard design collection to store your characters. Once 
created, you can begin mapping character designs into corresponding slots in the 
KDC. There are various ways to do this. This procedure shows how to map 
character designs from the Design Library, singly and as a batch.

To create a keyboard design collection...
1 Access Design Library via the Manage Designs toolbox.

Use View (Manage Designs) > Keyboard Design Collection to toggle Keyboard 
Design Collection docker display.
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2 Locate the folder containing the character designs you want to use and select 
a character on which to base your reference height.

Tip: The Keyboard Design Collection feature provides a number of 
purpose-made character design collections. You will find these amongst your 
Hatch Embroidery design inclusions.

3 Open the Keyboard Design Collection docker and click the New button.

4 Enter a name for your collection in the Name field or accept the default. Hatch 
Embroidery will display the currently selected folder name. 

Select test
KDC

Enter collection 
name

Create new 
KDC

Click Use 
Selection and 
adjust reference 
height

Select
reference
character
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5 Specify a reference height. The best way to do this is to click the Use Selection 
button. This will assign the height of the selected character directly to the 
Reference Height field. Round off as necessary – e.g. ‘85 mm’.
Reference height does not resize designs while mapping. Original design colors 
and size are maintained. However, the reference height you set here becomes 
the default height in the Object Properties docker when using the font. 

Tip: To ensure relative scaling of all letters, use the average height of the tallest 
characters in the collection. These are usually uppercase letters. The letter ‘M’ 
commonly represents the average height.

6 Optionally, adjust character spacing. This is specified as a percentage of 
height. It may vary with the style of source characters. For instance, with script 
fonts, character spacing should be set to 0% of height. This value can be 
adjusted in the Object Properties > Lettering dialog when using the font.

7 Optionally, enter a recommended height range. Scalability depends on the 
quality of the original characters. Rules of thumb:
Grade A designs: ±20%
Grade B, C, D: ±10%
For example, a Grade A font with a reference height of 150mm might have a 
recommended size range of 135mm to 165mm.

Specified
reference height

Enter min / max 
values
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The values you enter here are indicative only. They are displayed in the 
collection list of the Keyboard Design Collection docker as well as the font list 
of the Object Properties > Lettering dialog.

8 Click OK to complete.

Tip: Use the buttons at the top to manage your collections – copy, rename, or 
delete. The Copy option can be useful if you want to base a new collection on 
an old one.

Recommended 
height range

Enter name for 
duplicate KDC

Click to copy
existing KDC
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To map character designs...
1 Filter the character set using the Filter by droplist.

2 Select a character design or designs to map. Hold Shift or Ctrl keys to select a 
group or a range of characters.
 To map a single character, select the corresponding slot and double-click 

or click Map. The character is added to the collection.
 To map multiple characters, click the relevant batch mapping button – A-Z, 

a-z, or 0-9. Selected characters are added to their corresponding slots in the 
keyboard design collection.

Sometimes batch mapping can take longer with intricate character designs. 
Some fonts may be more stitch-intensive and take longer to generate.

Note: Design files need to be named consistently so they can be sorted in 
ascending or descending order. For example, ‘A, B, C, D’ and ‘a, b, c, d’, etc.

Map character designs in the design window

Sometimes you may receive a character design file containing an entire 
character set. You can map these for use as a KDC font. In this case, you need to 
select each character in the design window and map it to the corresponding slot 
in the target KDC. If your font includes ‘descenders’ which drop below the 
baseline, you need to pay attention to reference height and baseline position.

Select target 
KDC

Use buttons to 
map selected 
characters

Filter list as 
preferred
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To map characters from a character design...
1 Open the design file and Keyboard Design Collection docker.

2 Create a Keyboard Design Collection via the New button. The New Keyboard 
Design Collection dialog opens.

3 Enter a name for the collection and enter a reference height.

Create new KDC

Enter collection 
name
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With this font, we have a mixture of upper-case and lower-case characters. To 
ensure relative scaling of all letters, use the average height of the tallest 
characters in the collection. These are usually uppercase characters. The letter 
‘M’ commonly represents the average height.

Tip: The easiest way to specify reference height is to select a reference 
character – e.g. ‘M’ – and click the Use Selection button. This will assign the 
height of the selected character directly to the Reference Height field. Round 
off as necessary – e.g. ‘25 mm’.

4 Optionally, specify character spacing and recommended height range.
5 Select characters and map them one-by-one.

Note: This collection was purchased from 3rd party supplier 
LindeeGEmbroidery.com with permission to use it in this documentation.

Specify reference height
based on average height of

tallest characters

Map selected
characters
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Edit design collections

Once you have created your keyboard design collection, you may want to 
remove or reassign selected characters. You may also decide that individual letter 
baseline and spacing settings need further adjustment.

Reassign design characters
If you make a mistake assigning characters, follow these steps...

To reassign design characters...
1 Open the Keyboard Design Collection docker and select the target KDC from 

the Collection droplist.
2 Use the Remove Mapping button to clear a slot and start again. To select 

multiple characters, hold Shift or Ctrl keys to select a group or a range of 
characters.

Select characters 
to unmap

Remove character 
mapping
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3 Alternatively, simply overwrite a mapped character with another selection. You 
will be prompted with a confirmation message.

Adjust baseline & spacing settings
Once you have mapped your characters, review baseline and spacing settings. If 
your font includes ‘descenders’ which drop below the baseline, you need to pay 
attention to reference height and baseline position for each character. This will 
affect character alignment when using the font.

To adjust baseline and spacing settings...
1 Open the Keyboard Design Collection docker and collection you want to 

review.

Review spacing 
and baseline 
guidelines
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2 Select the character you want to adjust, and click the Adjust Baseline & 
Spacing button.

Tip: In the dialog, use TrueView and Zoom controls for a clearer view of the 
character to be edited.

3 Click and drag vertical guidelines to adjust spacing on either side. 
4 Similarly, click and drag the horizontal guideline to adjust baseline position. This 

does not affect reference height which moves with the baseline, but it will 
affect character alignment when using the font.

5 Click OK. Re-test your font to make sure letters align correctly.

Use KDCs as lettering fonts

Click to access
baseline spacings

Select character
to edit

Click-and-drag 
horizontal guideline 
to adjust baseline 
position

Use controls for 
better viewing

Review spacing 
and baseline

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets, Keyboard Design Collections or TrueType fonts, or edit 
selected lettering.
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Once you have created your keyboard design collection, it’s a good idea to take 
it through it paces to see how far you can ‘push it’. Depending on how it was 
digitized and whether or not characters are scalable, you should be able to apply 
most Lettering properties to your embroidery characters. You may also decide that 
individual letter baseline and spacing settings need further adjustment.

To test your keyboard design collection...
1 Click the Lettering tool and filter the Font list by ‘Keyboard Design Collection’.

2 Select the KDC you want to test from the Font list.

3 Enter some characters in the Lettering tab. To start a new line of lettering, press 
Enter.

4 Adjust letter height as preferred. The recommended height range appears in 
the droplist – e.g. ‘45 - 60 mm’. For best results, keep lettering within the 
recommended range.

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split 
composite objects – monograms, appliqués, lettering, etc – into components. Allows 
each to be edited individually. This tool is also available via Edit menu.

Filter font list by 
KDCs

Enter test 
characters

Select KDC 
to test
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5 Try modifying the lettering settings such as spacing or slant.

6 Try out different baseline or Lettering Art settings.

7 If you are using multi-colored keyboard design collections, try breaking apart 
lettering and individual characters for color re-sequencing.

Adjust letter 
settings

Try different 
baseline or art 
settings

Break apart and
resequence by color
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Components are re-sequenced for more efficient stitchout. See also Split 
objects and Sequence objects.

Note: KDC fonts can be applied to monogramming as well.

Related topics

 Add lettering
 Add monogram letters
 Laydown stitch

Components broken
apart and resequenced

for efficient stitchout
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PART VI
USING ARTWORK

Embroidery design with Hatch Embroidery consists of turning basic artwork shapes 
into embroidery designs. There are two broad categories of artwork file, both of 
which can be imported into Hatch Embroidery for use as digitizing backdrops – 
vector and bitmap. Hatch Embroidery gives you the flexibility of creating 
embroidery objects using artwork as backdrops, or of directly converting digital 
artwork. You can take a mixed mode approach as well, doing the bulk of the 
design by means of automatic conversion, followed by touch-ups and edits using 
the suite of Hatch Embroidery embroidery digitizing tools.
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Chapter 17

ELECTRONIC ARTWORK

Artwork can be inserted, pasted or scanned into Hatch Embroidery for use as 
digitizing templates or ‘backdrops’. The Artwork toolbox allows you to import 
electronic artwork.

Backdrops can help you…

Choose artwork

For both manual and automatic digitizing, ‘clean’ images, sometimes referred to 
as ‘cartoons’, work best. Such images have a limited number of solid colors which 
in turn have well-defined outlines. Ideally, they are:

Well-defined, where each shape is made up of pixels of the same color

Digitize... Details

Manually You trace shapes and lines over the artwork using the appropriate 
Input methods. Using a bitmap image in this way is like using an 
enlargement drawing and digitizing tablet, except that everything is 
done on-screen.

Semi-automatically You click a shape in the artwork and Click-to-digitize artwork 
automatically determines the required stitches.

Automatically You select the image and Auto-Digitizing Prepared Artwork 
automatically determines the shapes and stitches needed to digitize 
the design.
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Clearly ‘blocked’, where each shape is a stitchable size, at least 1 sq mm
 Saved at a color depth of at least 256 colors (8 bit), or preferably millions of 

colors (16 bit).

Automatic digitizing techniques produce best results with images of the type 
found in clipart libraries or created from scratch in a graphics package. Automatic 
digitizing can work with images from other sources but they require some 
preparation. This is because most commonly available images are not made up 
of solid colors. Scanners introduce noise, while graphics packages perform 
‘dithering’ and ‘anti-aliasing’. Automatic digitizing works least effectively with 
photographic images which may contain many dithered colors and complex 
forms. With photographs, however, you can pick out shapes that you want to 
embroider, leaving out unnecessary detail.

Scanned images
Images scanned from hardcopy drawings or existing 
embroidery typically contain a lot of introduced ‘noise’. 
While they can be used as input to automatic digitizing, 
once again, best results are achieved with relatively 
clean images consisting of solid color blocks. Typically, 
logos and simple drawings scanned from business cards, 
letterheads, books, magazines, cards fall into this 
category. Noisy images typically need to be prepared 
by reducing the color count and sharpening the 
outlines.

Clean picture with 
well-defined outlines

Clean picture with 
well-defined color blocks

Complex picture, needs editing to 
create clean color blocks
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Dithered images
Dithering is a software technique which combines existing colors in a 
checkerboard arrangement of pixels. It is typically used to simulate colors that are 
missing from an image palette.

Like noisy images, dithered images need to be color-reduced before use. Be 
aware though, that while Hatch Embroidery is good at processing dithered colors 
within a defined outline, it does not work so well with non-outlined images.

Anti-aliased images
Anti-aliasing is a software technique similar to dithering which is used to soften hard 
outlines where color blocks intersect. It produces smoother outlines by ‘blurring’ 
the pixels where colors join.

Where anti-aliasing is deliberately used to blur outlines, these need to be 
‘sharpened’ before use with automatic digitizing.

Dithering combines 
colors in a 
checkerboard 
arrangement of pixels

Anti-aliasing softens
hard outlines where

color blocks
intersect
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Image quality

Before applying automatic digitizing, you frequently need to improve or ‘clean up’ 
artwork. To work effectively, both Auto-Digitize and Click-to-Fill require solid color 
images as input. You can improve artwork both with bitmap editing tools in 
graphics packages and/or the image processing tools provided in the design 
software. In fact, Hatch Embroidery will not let you apply automatic digitizing until 
the image has been suitably processed.

Image cleanup
In practice, cleaning up scanned images may involve any one or a combination 
of the following techniques:

 Reducing the number of colors
 Adding or emphasizing outlines
 Removing noise, dithering or anti-aliasing
 Eliminating unnecessary detail
Cropping sections
 Eliminating backgrounds.
You can allow the design software to reduce the color count automatically or 
specify a precise number. The latter is useful if you want to match design colors to 
an exact number of thread colors. See also Using artwork.

Outlined vs non-outlined images
Before preparing your image you need to know what type you are using. For the 
purposes of automatic digitizing, there are two categories – outlined and 
non-outlined. Outlined images ideally have a solid black outline around each 
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colored area. Non-outlined images ideally consist of solid areas of color. Outlined 
and non-outlined images require different methods of preparation.

Color reduction
Sometimes an image looks clean but extra colors have been introduced during 
scanning or in a graphics package. Color reduction means reducing the actual 
number of image colors in order to eliminate unnecessary detail and reduce each 
block to a single color. Color reduction also cleans the image, removing noise and 
anti-aliasing if present. This in turn helps minimize the number of trims and color 
changes required in the resulting embroidery design.

Tip: If you are scanning images, make sure you scan them at the optimal color 
depth. See also Scan artwork.

Outline sharpening
Outline sharpening means more clearly defining the outlines bordering distinct 
color blocks or shapes in the image. These may have been indistinct in the original 
or made so by the scanning process. Outline sharpening is important for automatic 
digitizing because it makes it easier for Hatch Embroidery to identify the distinct 

Image without 
outlines

Image with 
outlines

Use color reduction to 
eliminate noise and 
anti-aliasing
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areas which become embroidery objects in the resulting design. Outline 
sharpening only works on images with black or dark outlines.

Some images have solid outlines but they may be indistinct or incomplete. These 
need to be rectified with the image preparation tools or a graphics package. See 
also Edit artwork.

Noise filtering
Noise filtering means restoring the solid color blocks of the original image in 
scanned images. This is achieved by merging different shades into one solid color. 
Noise filtering is important for automatic digitizing because it makes it easier for 
Hatch Embroidery to identify solid color blocks which become embroidery objects 
in the resulting design. It also cleans up blurred or mottled areas of color.

Image preparation summary
Even if your artwork looks ready to stitch when inserted into Hatch Embroidery, it 
will need to be image-processed before conversion. Hatch Embroidery will not let 
you apply automatic digitizing techniques without preliminary image-processing.

Use outline sharpening 
to improve 
auto-digitizing

Image before 
noise filtering, 
mottled color

Image after noise 
filtering, single 
colors

Action Outlined image Non-outlined image Photo

Scan images • Scan in RGB mode
• Use sharpening

• Scan in RGB mode
• No sharpening

Scans in RGB 
mode

Scan line drawing Scan in two-color mode - -
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Usage tips
Bear in mind the following key points when selecting artwork for auto-digitizing:

 Use 300 DPI high-resolution images, NOT low-res 96 DPI.
 Do not use anti-aliasing.
 Do use PNG format, not JPG.
 Do use transparent backgrounds.
 If the image does not conform to these settings, go back to the original vector 

artwork and generate a bitmap that includes them.

Scan artwork

If you have existing artwork, you can scan it with a TWAIN-compatible scanner 
using the scanning function. It is important to scan your artwork properly if you 
intend to use one of the automatic digitizing methods. The scanned image quality 
will affect the quality of the final embroidered design.
With embroidery design, less is more. You do not need every detail in an image to 
create a design. You use the ‘structure’ of the image rather than the fine details of 
texture and color. To simplify artwork, you can cover it with tracing paper and 
draw only the essential shapes and lines which will be filled with stitches. When 
scanning, take away the original artwork and put white paper behind the tracing 
paper. Shiny surfaces, such as glossy photographs, may not scan well. Cover them 
with tracing paper. If the artwork has very light colors, highlight outlines with a fine 
black felt-tip pen.

Touch up in 
graphics package

• Resize
• Crop
• Add or edit outlines
• Edit colors
• Remove noise

• Resize
• Crop
• Edit image shapes
• Edit colors
• Remove noise

• Resize
• Resample
• Crop
• Convert to 

grayscale
• Remove 

background
• Lighten or darken
• Adjust contrast

Use Prepare 
Artwork tool

Adjust outline contrast. 
Automatically:
• blend each outlined block 

into a single color
• remove anti-aliasing, noise 

and dithering
• sharpen outlines.

Reduce colors to a specified 
number. Automatically:
• reduce each block to a single 

color
• remove anti-aliasing, noise and 

dithering
• remove colors less than specified 

area.

-

Digitize • Manual
• Click-to-Fill
• Auto-Digitize

• Manual
• Click-to-Fill
• Auto-Digitize

Auto-Digitize 
PhotoStitch

Action Outlined image Non-outlined image Photo
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Scanning resolution
Most scanners require you to enter scanning resolution information. Resolution 
determines the number of dots per inch (dpi) used to create a drawing. The higher 
the value, the clearer the image but larger the file. For digitizing purposes, use a 
maximum resolution of 300 dpi (dots per inch). A resolution of 72 dpi (screen 
resolution) will usually be sufficient. Generally speaking, the smaller the source 
image and/or more detail it contains, the higher the resolution needs to be. Use 
the following table as a guide.

Color mode
Most scanners also require you to enter color mode information. First decide 
whether your image is line art (black and white drawing), sketch, color picture, or 
black and white or color photograph, then choose an appropriate mode. Black 
and white mode produces the smallest files. Color photograph and grayscale 
modes generate 256 color images and produce similar sized files. ‘RGB’, ‘True 
Color’ or ‘millions of colors’ modes generate 16.7 million colors and produce the 
biggest files. Use the table below to decide which mode is suitable for use with 
your image.

Type of artwork Scanning resolution

Business cards, letterheads 150 – 300 dpi

Hand sketches 150 – 300 dpi

Photos and images 150 – 300 dpi

Commercial art, line drawing 72 – 150 dpi

Source Sample Description Color mode ^ Colors

Line art Two colors – usually black and white Black / white drawing
Line art

2
2

Drawing Sketch or drawing with shades of gray Grayscale
Line art

256
2

Color picture Two colors or more Color RGB
Millions of colors
Color drawing

16 mill
16 mill
2 – 256

^ Different scanning software uses different terms for the same mode.
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Color depth
Scan color images in RGB mode (millions of colors) rather than 256 color mode. 
You may not notice any difference on screen. In fact the 256 color image may 
look better than the RGB image. However, Hatch Embroidery converts all images 
to 256 colors or less upon loading. It uses the extra information to produce a better 
image than if it was originally scanned at 256 colors.

Usage tips
 Do not scan line art images in grayscale mode; grayscale scanning produces 

fuzzy edges.
 Do not scan color images in CMYK mode as this is only used for images that will 

be printed and the colors may be different from RGB colors.
 If the image needs to be resized, scale it when you scan it. Scaling afterwards 

may distort the image.

Sharpening
Some scanning software lets you apply what is called ‘sharpening’ as you scan. 
Sharpening compensates for the slight blurring in a scanned image by looking for 
any differences between colors in the image. Sharpening accentuates these 
differences which makes the image edges more defined. It does not increase the 

Scanned in 
256 colors

Scanned in 
millions of colors

Reduced to 
8 colors

Reduced to 
8 colors
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image details; it just makes them more obvious. In general, use sharpening with 
images that have well-defined outlines. Do not use it with non-outlined images.

Scan artwork

You can scan images directly into the design software for use as digitizing 
backdrops. The scanning feature allows you to use most TWAIN-compatible 
scanners. You can use any scanning software provided that it can save the image 
in one of the compatible formats. 

To scan an image...
1 Set up your scanner.
2 Prepare the artwork for scanning.
3 Create a new file or open a design you want to insert the drawing into.
4 Go to Artwork > Scan Artwork. Your scanning program will open.
5 Choose a scanning mode and resolution.
6 Preview the image in the scanning program.
7 Select the area to scan and scan the image.
8 Save the scanned image in a third-party application. Save in a compatible 

format to your designs folder.

Import artwork

Artwork can be inserted, pasted or scanned into Hatch Embroidery for use as 
digitizing backdrops. For both manual and automatic digitizing purposes, ‘clean’ 
images, sometimes referred to as ‘cartoons’, work best. Scanners introduce noise, 

Use Artwork > Scan Artwork to scan artwork directly into the current design window 
from an attached scanner.

Scanned with 
sharpening

Scanned without 
sharpening
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while graphics packages perform ‘dithering’ and ‘anti-aliasing’ to improve image 
print quality.

Note: Hatch Embroidery has width and height limits for Color PhotoStitch and Reef 
PhotoStitch processing. If width or height are greater than 400 mm, the larger 
dimension will be reduced to 400 mm and the image will be resized proportionally. 

Tip: You can scale and transform images after importing, but it is generally better 
to do so during scanning. Scaling afterwards may distort the image.

Insert artwork as bitmaps

You can load bitmap images of various formats for use as digitizing backdrops. 
Vector graphics are converted to bitmap images upon insertion. Go to the 
Artwork toolbox and select Insert Image. The dialog allows you to navigate to 

Use Artwork / Auto-Digitize / Standard > Insert Artwork to import vector or bitmap 
artwork into current design as a backdrop for manual or automatic digitizing.

Traced image
scanned

Auto-digitized
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artwork folders and open artwork in both bitmap and vector formats. See also 
Supported artwork.

Note: CDR files are not available for opening in Hatch Embroidery unless you have 
an approved version of CorelDRAW installed and linked to Hatch Embroidery. 
Other graphic formats can also be read via CorelDRAW. Refer to your installed 
CorelDRAW documentation.

Insert artwork as vectors

Vector graphics of different formats can be inserted or ‘loaded’ into Hatch 
Embroidery for use as digitizing backdrops or for conversion to embroidery. Hatch 

Use Switch & Convert > Graphics Mode to import, edit or create vector artwork as a 
backdrop for embroidery digitizing, manual or automatic.

Use Artwork > Insert Artwork to import vector or bitmap artwork into current design 
as a backdrop for manual or automatic digitizing.

Open artwork in both
bitmap and vector formats
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Embroidery has a single ‘design window’ but when integrated with CorelDRAW, 
you may interact with it via the Switch and Convert toolbar.

Vectors can be inserted both in Embroidery Mode and, if available, Graphics 
Mode. Embroidery Mode has limited options for vector import. Graphics Mode 
gives you access to the full range of CorelDRAW® supported vector graphic types 
as well as bitmaps. See also Supported artwork.

Note: CorelDRAW® needs to be registered before it can be used by Hatch 
Embroidery. Registration provides CorelDRAW® Standard Membership which gives 
you access to content – clipart, fonts, stock photos, templates – via Corel 
CONNECT.

To insert vector artwork in Embroidery Mode
1 In Embroidery Mode, click Insert Artwork on the Artwork toolbox or Standard 

toolbar.

Switch between 
operating modes

Choose vector format

Untick to insert as vector 
rather than bitmap
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2 Navigate to the graphics folder. The dialog defaults to ‘All graphic files’ which 
displays all supported file types – BMP, PNG, EPS, etc.

3 Select the vector artwork you want to import – e.g. EPS.
4 Untick the As Bitmap checkbox to insert the artwork as vectors. Not all vector 

formats support this option. These will be imported as a bitmap images.

Caution: EPS files imported into Hatch Embroidery as vectors may use different 
colors to the source file. Also unexpected outlines sometimes appear around 
imported vector objects. These can be edited in the design window.

5 Click Open to insert the vector graphic into the design window.

Tip: You can also paste vectors directly into Hatch Embroidery through the 
MS Windows® clipboard.

To insert vector artwork in Graphics Mode
1 Switch to Graphics Mode and go to File > Import. The Import dialog opens.

Artwork imported 
as vectors
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2 Select a folder and select a file type from the Files of Type list – e.g. CDR.

3 Click Import to open the vector artwork. 

Note: The Graphics Mode workspace contains the entire suite of CorelDRAW® 
drawing tools. This mode allows you to create and edit vector graphics using 
the Graphics Mode toolset which offers many sophisticated techniques for 
drafting outlines and shapes onscreen. The Switch and Convert toolbar 
provides options for converting graphics to embroidery and vice versa.

Related topics

 The user interface
Graphics Mode
Convert artwork to embroidery

Select required
format

Imported vector
artwork

Shared Switch and
Convert toolbar
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Open artwork from Design Library

Use the New From Selected command in Design Library to open selected graphic 
files in their own design tab ready for digitizing. In addition to other image file 
formats, you can also view and open CDR files directly from Design Library. Use the 
droplist to filter artwork by file type.

Copy & paste images

Use Manage Designs > New From Selected to create new design(s) based on the 
selected design(s) and/or bitmap(s) from a chosen template.

Click Standard > Copy to copy the selection and place it on the clipboard. This tool 
is also available via Edit menu.

Click Standard > Cut to cut the selection and place it on the clipboard. This tool is 
also available via Edit menu. 

Click Standard > Paste to paste contents of the clipboard. This tool is also available 
via Edit menu. 

Filter artwork 
by file type
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You can copy and paste an image into Hatch 
Embroidery by copying it directly from another 
embroidery design or graphics application and 
pasting it into your design. Simply select the image 
you want to copy and paste and press Ctrl+C. 
Open the design file into which you want to insert 
the image. Click the Paste icon or press Ctrl+V.

Note: You will need to resize the image to fit within 
the dimensions of the selected hoop.

View artwork

Hatch Embroidery provides a number of viewing modes to selectively display 
artwork. Use the Show Design menu to selectively view bitmap or vector artwork.

Use View > Show Design to show or hide design elements. Click to open a menu 
of view settings.

Selectively view 
bitmap and vector 
artwork
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Image transparencies
Support is provided for transparent backgrounds in 24 bit and 32 bit images.

If an image (PNG) contains a transparent background:

 The background is automatically excluded from auto-digitizing.
 The image is automatically cropped to its visible extents.
 Transparent images work with both Auto-Digitize and Color PhotoStitch tools.

Caution: Avoid using images that contain semi-transparent or transparent pixels 
within image color areas as these cause poor results when reducing the color 
count. The resulting pixels may end up as holes inside the image or significantly 
reduce color areas to the point where they are unnecessarily removed from the 
embroidery results.

Related topics

 Auto-Digitizing Prepared Artwork

Lock and dim artwork

Use Artwork > Lock to lock selected objects into position for protection. This tool is 
also available via Arrange menu.

Use Artwork > Unlock All to unlock all locked objects to remove protection. This tool 
is also available via Arrange menu. 

Use Artwork > Dim Artwork to dim graphic backdrops to show stitches more clearly 
when digitizing.

Artwork can include 
transparent 
backgrounds
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Lock artwork or other objects to prevent them from being moved or modified by 
accident by clicking the Lock icon or pressing K. For example, locking backdrop 
images holds them in place as you digitize, transform or reshape the embroidery 
objects near them. To dim a backdrop, click the Dim Artwork toggle. This can be 
useful when using artwork as a digitizing backdrop. 

Tip: While digitizing, you may want to hide artwork altogether. Use the View toolbar 
or simply press D to toggle on or off. Remember too to click Unlock All prior to using 
artwork with automatic digitizing methods. 

Related topics

 Digitize Objects

Dim artwork 
while digitizing
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Chapter 18

EDITING ARTWORK

The Artwork toolbox provides for editing electronic artwork as well as preparing it 
for automatic digitizing.

Backdrops can help you…

Digitize... Details

Manually You trace shapes and lines over the artwork using the appropriate Input 
methods. Using a bitmap image in this way is like using an enlargement 
drawing and digitizing tablet, except that everything is done on-screen.

Semi-automatically You click a shape in the artwork and Click-to-digitize artwork 
automatically determines the required stitches.

Automatically You select the image and Auto-Digitizing Prepared Artwork automatically 
determines the shapes and stitches needed to digitize the design.
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Edit artwork

For both manual and automatic digitizing purposes, 
you may want to crop an image before digitizing. 
You can do this within Hatch Embroidery or using a 
third-party graphics application. Sometimes, you 
may want to save backdrops as separate files after 
scanning or cropping.
For both manual and automatic digitizing purposes, 
‘clean’ images, sometimes referred to as ‘cartoons’, 
work best. Scanners introduce noise, while graphics 
applications perform ‘dithering’ and ‘anti-aliasing’ to 
improve print quality.

Size artwork

Before you begin working with design images, you will normally size them for their 
intended purpose. Use the Width and Height settings in the Context toolbar to set 
image size – either as an exact dimension or as a percentage of the current size. 
Use the locking toggle to maintain proportional scaling.

Alternatively, use the sizing buttons to resize by 10% increments.

Use Context > Size +10% to increase the size of selected objects in 10% increments.

Use Context > Size -10% to decrease the size of selected objects in 10% increments.

Size image as exact 
dimension or percentage 
of current size

Use sizing 
controls on 
Context toolbar
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Caution: Limit the amount of resizing done in Hatch Embroidery so as to retain as 
much image information as possible. If an image is too large for its intended 
purpose, resize and re-sample it in any linked CorelDRAW® or external graphics 
applications before applying auto-digitizing techniques. This will generally 
produce a better result. 

Related topics

 Import artwork
 Edit artwork externally

Crop artwork

The design software allows you to crop images prior to use. Before using bitmap 
images for design purposes, crop them to remove unnecessary detail and save 
processing time. After an image has been cropped, you can reshape and 
transform the cropping outlines in the same way as you reshape and transform 
lettering. 

To crop a bitmap for digitizing...
1 Scan or load the image you want to use. See also Supported artwork.

Use Context > Rectangular to crop bitmap artwork using the Rectangular crop tool.

Use Context > Oval to crop bitmap artwork using the Oval crop tool.

Use Context > Heart to crop bitmap artwork using the Heart crop tool.

Use Context > Star ‘n’ point to crop bitmap artwork using the star crop tools.

Use Context > Curve to crop bitmap artwork using the Curve crop tool.

Use Select > Reshape to reshape an object outline, edit stitch angles, or adjust entry 
and exit points.
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2 Select the image and click one of the crop options.

3 Drag the cropping marquee around the shape to be cropped.

Select cropping 
option from droplist

Drag cropping 
marquee around 
target area



Chapte r  18    Ed it ing Ar t work 412

4 Reshape or transform the cropping marquee with the Reshape tool.

5 Right- or left-click to add reshape nodes.
6 Switch from corner to curve points by selecting the node and pressing 

Spacebar.
7 Press Esc to finish.

Tip: To remove a cropping area, select all reshape nodes and press Delete.

Related topics

 Import artwork

Edit artwork externally

Use Artwork > Edit Artwork to edit selected bitmap artwork in the pre-selected 
graphics application, which can be changed in the General tab of User Interface 
Settings dialog.

Reshape cropping 
marquee with 
Reshape

Press Esc to 
finish
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Sometimes you need to edit images directly in a third-party graphics package. 
You would normally do this in order to eliminate backgrounds, flood-fill solid areas 
with color, close gaps, add outlines, or reinforce outlines. You may also want to 
resize and resample images, particularly photographs, before applying 
auto-digitizing techniques. This will generally produce a better result.

From within Hatch Embroidery you can open images directly in Paint, Corel 
PHOTO-PAINT, or Paint Shop Pro. Images updated in this way are automatically 
re-imported into Hatch Embroidery.

Note: Integration with CorelDRAW® is automatically activated depending on your 
product model. For the full range of image adjustment techniques, use Corel 
PHOTO-PAINT®. If installed, the Edit Artwork option is available. If you have 
CorelDRAW® installed on you computer together with Hatch Embroidery, it will be 
available via Graphics Mode.

To edit an image in a graphics application...
1 Optionally, right-click Edit Artwork to pre-select your preferred graphics 

package.

Edit images in 
third-party graphics 
application

Select third-party 
graphics 
application
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2 Select the image. The image opens in the current graphics package.
3 Edit and save.
4 Select File > Update document. The image displays in your software overlaid 

with stripes. This means that it is still open in the graphics package.

5 Select File > Exit and return to document to exit the graphics package and show 
the updated image. The stripes will disappear.

Related topics

 Import artwork

Modify vector properties
Hatch Embroidery lets you set colors for vector outlines as well as fills. Coloring 
makes vector objects easier to interpret. For example, a solid fill color might 
suggest satin or tatami, while a fill pattern may be interpreted as Motif Fill or 
Embossed Fill.

Image still open 
in graphics 
package

Edit vector
outlines and fills
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Related topics

 Import artwork
 Edit artwork externally

Prepare artwork for auto-digitizing

The Auto-Digitize tools provide everything necessary to automatically digitize 
electronic artwork and photographs. Results depend greatly on the resolution, 
color depth, and quality of source images. For best results, use crisp images with 
well-defined subjects and strong contrasts. In addition a degree of preparation is 
needed. This may involve preparation using third-party graphics applications or 
Graphics Mode if you have it activated. Tools are also available within Embroidery 
Mode.

Even if your artwork looks ready to stitch when inserted into Hatch Embroidery, it 
will need to be image-processed before conversion. Processing makes it easier for 
the software to recognize distinct areas in the artwork. These areas then become 
the embroidery objects of the finished design. Image processing does the 
following:

 Reduces colors to a specified number
 Reduces each block to a single color
 Removes anti-aliasing, noise and dithering
 Sharpens outlines.
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Tip: Depending on the quality of the scanned image, you may need to touch it up 
manually before processing in your software You would normally do this in order to 
eliminate backgrounds, flood-fill solid areas with color, or add outlines, close gaps, 
or reinforce outlines. See also Edit artwork.

Prepare artwork for auto-digitizing

Use the Prepare Artwork for Embroidery tool to prepare images for automatic 
digitizing. This function automatically flattens colors, sharpens outlines, and 
reduces noise. Areas enclosed by a defined outline are reduced to a single color. 

To prepare bitmap images...
1 Scan or import the image to use. See also Supported artwork.
2 Unless you have already done so, use the Context toolbar to size your artwork 

to its intended dimensions.

3 Depending on the source, you may find dithering, anti-aliasing, or other sources 
of ‘noise’ in the image. If the image contains outlines, these will generally be 
‘blurred’ by anti-aliasing.

Use Artwork > Prepare Artwork for Embroidery to prepare selected bitmap artwork 
for automatic digitizing.

Adjust artwork 
dimensions

Outlines ‘blurred’ 
by anti-aliasing
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4 Select the image and click the Prepare Artwork for Embroidery icon. The image 
appears in both ‘before’ and ‘after’ preview panels.

5 Check the number of colors in the processed bitmap. Hatch Embroidery 
suggests a color count and shows a preview of the resulting image. If there 
appear to be too many, the image probably contains noise.

6 Use the scroll button on your mouse to zoom in and inspect details.

7 Adjust the overall color count as necessary:
 If there appear to be too many colors to render the design as threads, use 

the Colors slider to decrease color count.
 If there appear to be too few colors to provide all the detail you want, use 

the Details slider to increase color count.
8 Manually locate and merge like-colors as necessary:
 Holding the Ctrl key, click like-colors to select.
Click and hold Locate to preview.

‘Before’ and 
‘after’ previews

Adjusted color 
count

Color count of
source image

Zoom to inspect 
details

Use sliders to 
adjust color count
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Click Merge to merge like-colors into a single color.

9 Click OK to process the image. Image colors should be reduced as per the 
preview. The artwork can now be auto-digitized. See Auto-digitize artwork for 
details.

Prepare photos for auto-digitizing

Use Switch and Convert > Switch to Graphics Mode to import, edit or create vector 
artwork as a backdrop for embroidery digitizing, manual or automatic.

Use Artwork > Adjust Bitmap to adjust image brightness and contrast in preparation 
for auto-digitizing.

Use Context > <Crop method> to crop bitmap artwork for use with auto-digitizing.

Select and merge 
similar colors to 
reduce thread 
count

Outlines 
sharpened for 
better recognition
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A degree of preparation is needed for any of the photographic auto-digitizing 
techniques. Results greatly depend on image quality. For best results, use crisp 
images with well-defined subjects and strong contrasts. You may want to spend 
time preparing the photo in a third-party graphics editing environment such as 
CorelDRAW®. 

To prepare photos for auto-digitizing
1 Scan or insert the photo you want to use. For best stitching results, images are 

better imported via the Graphics Mode than Embroidery Mode.

2 Size the image for its intended purpose. 400mm (16”) is the limit. When using 
Color PhotoStitch, you will be prompted to resize if the image is too large.

Scan or insert 
image
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Caution: Limit the amount of resizing done in Hatch Embroidery so as to retain 
as much image information as possible. If an image is too large for its intended 
purpose, resize and re-sample it in any linked CorelDRAW® or external graphics 
applications before applying auto-digitizing techniques. This will generally 
produce a better result.

3 Optionally, use Graphics Mode for bitmap pre-processing. 

For instance, resize the image for its intended purpose. Try resampling the 
image while resizing. Crop the image as necessary. Try adjusting brightness and 
contrast as well as reducing color depth – e.g. 24 bit. Try saving as PNG to 
reduce file size. Experiment to find the best method for the particular image.

Tip: For the full range of image adjustment techniques, use a dedicated 
graphics program like Corel PHOTO-PAINT®. If installed, the Edit Artwork option 
is available.

Edit artwork for 
auto digitizing
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4 If you can’t see the image in Embroidery Mode, turn on Bitmap Artwork.

5 Optionally, crop the image in Embroidery Mode using any of the available crop 
options.

Turn on artwork

Turn off background 
fabrics or articles

Select cropping 
option from droplist
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6 Optionally, use Adjust Bitmap to adjust basic lightness and contrast. 

7 Try clicking Auto Adjust to allow Hatch Embroidery to optimize image settings. 
This works well most of the time. 

8 Use Brightness and Contrast settings to sharpen the image further.
9 Choose between image variations:

Tip: Use the Reset button at any stage to return to default values. Use the Undo 
and Redo buttons to back-step through previous adjustments.

10 Click OK to confirm.

Related topics

 Import artwork
 Scan artwork
Crop artwork
 Auto-Digitizing with Photos

Option Function

Sepia In photographic terms, ‘sepia’ refers to the dark-brown color of old-fashioned 
prints. Originally the process involved adding a pigment made from cuttlefish 
ink during development.

Gray Grayscale images are ones composed exclusively of shades of gray, varying 
from black at the weakest intensity to white at the strongest.

Adjust image 
lightness and 
contrast
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Save processed artwork

All images placed in the design window, whether by scanning, pasting or inserting 
from hard disk, are saved together with the embroidery design in the EMB file. After 
editing in Hatch Embroidery or third-party graphics application, you may want to 
save the image out as a separate file.

To save a backdrop as a separate file...
1 Select the image.
2 Click the Save Artwork icon. The Save Bitmap dialog opens.

3 Select a folder and a file format from the Save as type droplist.
4 Enter a new file name and click Save.
5 This file is not referenced by the EMB file. Any external changes to it will not be 

reflected in the embedded image.

Use Artwork > Save Artwork to save currently selected bitmap artwork.

Save image as 
bitmap file
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PART VII
AUTO-DIGITIZING

Hatch Embroidery supports the automatic and semi-automatic digitizing of both 
bitmap images and vector drawings. The Auto-Digitize toolbox provides tools for 
the automatic digitizing of prepared artwork and photos. There are also 
dedicated techniques for auto-digitizing photographs, both colored and 
grayscale.
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Chapter 19

AUTO-DIGITIZING PREPARED 
ARTWORK

Hatch Embroidery supports the automatic and semi-automatic digitizing of both 
bitmap images and vector drawings. The Auto-Digitize toolbox provides tools for 
the automatic digitizing of prepared artwork and photos.

Hatch Embroidery can automatically convert properly prepared artwork for one 
of the auto-digitizing methods. Artwork is ‘batch processed’ to create the many 
embroidery objects that make up a design. Hatch Embroidery can recognize 
shapes in artwork – bitmap and vector – and choose suitable stitch types to use. It 
can also determine a stitching sequence based on closest join. The auto-digitizing 
tools become available when an image is selected. Only one image can be 
selected at a time.
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Auto-digitizing tools comparison

Choose the auto-digitizing tool based on the effect you want to achieve and the 
type of artwork you are working with as per table below:

Tool Purpose Best artwork Sample Result

Auto-digitize 
Instant 
Embroidery

Convert artwork to 
embroidery designs 
based on default 
conversion settings.

Images made up of 
simple shapes

Auto-digitize 
Embroidery

Convert artwork to 
embroidery designs 
based on user-defined 
conversion settings.

Images made up of 
simple shapes

Color 
PhotoStitch

Create embroidery from 
photos and other raster 
images. This technique 
produces variegated 
stitching using multiple 
thread colors.

Photos and images 
that have 
well-defined 
subjects / shapes 

Reef 
PhotoStitch

Create embroidery from 
photos and other raster 
images. The effect is like a 
coral reef, hence the 
name.

High contrasting 
photos and images 
with clearly defined 
subjects and 
shapes
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Assign threads for auto-digitizing

Artwork can be inserted, pasted or scanned into Hatch Embroidery for use as 
digitizing backdrops. For both manual and automatic digitizing purposes, ‘clean’ 
images, sometimes referred to as ‘cartoons’, work best. The auto-digitizing tools 
handle both bitmap and vector formats.

PhotoFlash Create embroidery from 
color or grayscale photos. 
The effect resembles the 
output of a line printer.

High contrasting 
photos and images 
with clearly defined 
subjects and 
shapes

Click-to-tools Convert artwork shapes to 
embroidery. Techniques 
include:
• Click-to-fill
• Click-to-fill without holes
• Click-to-turning fill
• Click-to-outline
• Click-to-centerline

Images made up of 
simple shapes 
requiring targeted 
conversion 
techniques

Tool Purpose Best artwork Sample Result

Use Auto-Digitize > Color Matching Method to select a matching method: a) add 
image colors to the color palette for manual thread matching, b) add closest matches 
from selected thread charts to the color palette, or c) use closest matches from the 
color palette.
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To assign threads for auto-digitizing...
1 Scan, insert, or paste the artwork you want to use. See Import artwork for details.

2 Whether you’re working with bitmap or vector graphics as input, you may want 
to prepare them first:
 If you are using a bitmap image, it can be image-processed before 

conversion. See Prepare artwork for auto-digitizing for details.
 If you are using a vector graphic, you can remove overlapping objects by 

‘merging’ them. This eliminates overlapping stitching when vector objects 
are converted. See Holes for details.

3 Unless you have already done so, use the Context toolbar to size your artwork 
to its intended dimensions. See Edit artwork for details.

4 Optionally, select Design > Auto Fabric to apply preferred fabric settings. See 
also Fabrics & densities.

5 Optionally, click Color Matching Method to determine how you want thread 
color matching to be handled.

You have three options:

Insert artwork to 
auto-digitize

Adjust artwork 
dimensions

Preset how you want 
bitmap colors to be 
handled
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 Add bitmap colors directly to the design palette (default).
Choose a chart and match bitmap colors to actual threads. Click the Select 

Thread Charts button to access thread charts.
Or, match bitmap colors to the nearest colors in the design palette.

Tip: Various techniques are available for changing design colors from the 
Design Colors toolbar. See also Design colors.

Related topics

 Supported artwork
 Import artwork
 Prepare artwork for auto-digitizing
 Holes
 Edit artwork
 Fabrics & densities
 Design colors

Auto-digitize artwork

The quality of auto-digitized designs greatly depends on the type and quality of 
the original artwork. Generally speaking, vector drawings preserve picture quality 
when resized, whereas bitmap images cause problems of pixelation and image 
degradation when enlarged or scaled down. In order to make bitmap images 
more suitable for automatic digitizing, Hatch Embroidery also provides image 
processing capabilities and links to graphics packages.

Instant embroidery

In essence, creating an embroidery design with the Auto-Digitize Instant 
Embroidery tool is simply a matter of selecting the image you want to convert, and 
clicking the tool. Hatch Embroidery automatically determines colors to treat as fills 
or outlines, or omit altogether. And it chooses the most suitable stitch types to 
apply with default settings. The tool handles both bitmap and vector formats. Even 
without image preprocessing, Auto-Digitize Instant Embroidery automatically 
processes and converts it.

Use Auto-Digitize > Color Matching Method to select a matching method: a) add 
image colors to the color palette for manual thread matching, b) add closest matches 
from selected thread charts to the color palette, or c) use closest matches from the 
color palette.

Use Auto-Digitize > Auto-Digitize Instant Embroidery to automatically digitize whole 
embroidery designs from imported artwork, vector or bitmap.
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To auto-digitize ‘instant embroidery’...
1 Scan or insert the artwork you want to use. See Assign threads for auto-digitizing 

for details.

2 Click Auto-Digitize Instant Embroidery and study the result.

Insert artwork to 
auto-digitize

Artwork colors 
added to palette
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By default, artwork colors are added to the palette. If you have chosen to 
match artwork colors, you might obtain a result like this...

3 Edit the result as preferred – e.g. change colors, change stitch types, delete any 
unwanted background stitching, etc. 

Related topics

 Import artwork
 Stitch Types & Effects
 Design colors
 Stitch angles
 Sequence objects

Auto-digitize embroidery

For more control over object conversion, use the Auto-Digitize Embroidery 
method. This can recognize shapes in artwork and allow you to choose suitable 
stitch types for conversion. The tool handles both bitmap and vector formats.

Use Auto-Digitize > Auto-Digitize Embroidery to automatically digitize embroidery 
designs from imported artwork, vector or bitmap, with user-defined presets.

Artwork colors 
matched to palette
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To auto-digitize embroidery...
1 Scan or insert the artwork you want to use. See Assign threads for auto-digitizing 

for details.
2 Select the image and click Auto-Digitize Embroidery. If you have not yet 

prepared the image, you will be prompted to do so. 

3 Make any further adjustments necessary and click OK. See Prepare artwork for 
auto-digitizing for details.
Hatch Embroidery will attempt to classify image colors as fills or details. Details 
may take the form of outlines or ‘pickout runs’, such as the eyelashes in the 
artwork shown here.

Tip: The artwork may include outlines as part of the image. However, the 
software itself can generate outlines around color blocks in the design.

You are prompted to 
process the image

Image analyzed and 
thread colors assigned
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4 Select a color in the list and use the Locate button to preview.

5 Having located the colors, decide if you want to change the software defaults. 
You can treat colors as fills or details, or omit them altogether. 

6 Use the ‘Move’ buttons to re-sort the color sequence as preferred. Fills should 
be stitched first, details last.

To assign color matching method and stitching options...
1 Select a conversion method for color matching:

You have three options:

Click Locate to 
view selected color

Assign color as
fill or outline

Promote or demote colors 
in the stitching sequence

Select conversion 
method for thread color 
matching
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 Add bitmap colors directly to the design palette (recommended).
Choose a chart and match bitmap colors to actual threads. Click the Select 

Thread Charts button to access thread charts.
Or, match bitmap colors to the nearest colors in the design palette.

2 Select stitching options for handling details, outlines, and borders:

You have three options:

See examples below.

To generate and inspect the result...

Click OK to process the image.

Option Purpose

Details Handle details as a centerline, satin line, or a satin fill. Select an option from 
the droplist.

Outlines Add outlines to all detected color blocks. Tick Outlines and select a thread 
color from the droplist.

Border Add a satin border to the entire design. Again, pick a color from the droplist.

Specify details as 
centerline, satin line, 
or satin fill

Outlines and details 
generated from 
artwork
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 The artwork here includes its own outlines. An alternative method is to allow the 
software to generate outlines. The Outlines option reinforces all color blocks 
with continuous, branched running stitches. Here we omit the artwork outlines 
and details, and turn on Outlines stitching option.

 Additionally, you can generate a border around the entire design with Border 
stitching option.

Auto-generated outlines
added to design

Border added to 
auto-digitized 
design
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 Editing techniques are available to further refine the auto-digitized image. The 
editing capabilities may be limited depending on the level of Hatch 
Embroidery you own.

Note: Details created from auto-digitizing are treated as branched objects. If 
you want to change stitch type to, say, Satin, Raised Satin, Zigzag or Blanket, 
the object needs to be unbranched before these stitch types can be applied.

Related topics

 Import artwork
 Stitch Types & Effects
 Design colors
 Stitch angles
 Split objects
 Sequence objects

Click-to-digitize artwork

The Click-to-Design tools provide everything necessary to digitize shapes in 
artwork automatically without using manual digitizing methods. These tools are 
useful for quickly creating embroidery objects from images without having to 
manually digitize shapes. The tools handle both bitmap and vector formats.

Caution: It is easy with the Click-to-Design tools to double-click and inadvertently 
create double-layers of stitching. Check everything you do in the Sequence 
docker and delete any unnecessary objects.

Details treated 
as branched 
objects
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Auto-digitize fills

Click-to-Fill tools can be used to create ‘closed’ tatami fill objects, as well as 
objects with turning satin fills. Current properties are applied. You can modify these 
as required before or after using the tools. The tools handle both bitmap and 
vector formats.

To digitize fills with Click-to-Fill...
1 Scan or insert the artwork you want to use. See Assign threads for auto-digitizing 

for details.

2 Select the appropriate Click-to-Fill input method and hover the cursor over the 
shape you want to digitize. The area is detected and a cross-grid appears.

3 Click the shape. It is instantly digitized and assigned a thread color.

Use Auto-Digitize > Click-to-Fill to digitize large artwork shapes with tatami fill, 
preserving any holes within.

Use Auto-Digitize > Click-to-Fill without Holes to digitize large artwork shapes with 
tatami fill, ignoring any holes within.

Use Auto-Digitize > Click-to-Turning Fill to digitize narrow column artwork shapes 
with satin stitch.

Insert artwork to 
auto-digitize

Click-to-Fill to create 
‘closed’ tatami fill 
objects
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4 If you want holes ignored, use the Click-to-Fill without Holes tool.

5 Use Click-to-Turning Fill to digitize narrow column shapes with turning satin 
stitching.

6 Optionally, use Reshape to edit generated objects, in particular, stitch angles. 

7 Optionally, use Smooth Shapes to apply curve ‘smoothing’ to generated 
embroidery objects.

Use Click-to-Fill 
without Holes to 
ignore unwanted 
holes

Use 
Click-to-Turning 
Fill for turning satin

Edit stitch angles 
as necessary
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8 Stitches are generated according to current stitch settings. These can be 
further modified as necessary.

Related topics

 Insert artwork as bitmaps
 Stitch Types & Effects
 Stitch angles
 Sequence objects

Auto-digitize lines

Both Click-to-Outline and Click-to-Centerline can be used to automatically 
generate run stitch outlines and details. The method is the same as digitizing fills 
with Click-to-Fill. These tools, however, are designed for use with narrow 

Use Auto-Digitize > Click-to-Outline to digitize boundaries of shapes with run 
stitching using current properties.

Use Auto-Digitize > Click-to-Centerline to digitize centerlines in artwork with run 
stitching using current properties.

Matched to palette Using existing colors
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column-like objects. Results may be unsatisfactory if you use them on larger 
objects. 

Tip: It is a good idea to turn off Match-to-Palette with the outlining tools. Generally 
you will want to select a dark color from the palette to emphasize outlines.

To auto-digitize lines...

 Use Click-to-Outline to detect boundaries in shapes with no existing outlines.

Outlines automatically 
generated

No existing
outlines

Outline
generated
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 Use Click-to-Centerline to trace existing artwork outlines. This tool will always 
find the center of the line no matter how thick it is. By contrast, you may obtain 
double-lines with Click-to-Outline.

Note: Details created from auto-digitizing are treated as branched objects. If 
you want to change stitch type to, say, Satin, Raised Satin, Zigzag or Blanket, 
the object needs to be unbranched before these stitch types can be applied.

Related topics

 Import artwork
 Stitch Types & Effects
 Design colors
 Split objects
 Sequence objects

Convert artwork to embroidery

Hatch Embroidery has a single ‘design space’ but when integrated with 
CorelDRAW GEM for Hatch Embroidery, you may interact with it via the Switch and 
Convert toolbar. The Graphics Mode workspace contains the entire suite of 
CorelDRAW software drawing tools. This mode allows you to create and edit 

Centerline 
detected

Double outlines 
generated



Chapte r  19    Auto -D igi t iz ing Prepa re d Ar t work 442

vector graphics using the Graphics Mode toolset which offers many sophisticated 
techniques for drafting outlines and shapes onscreen.

Graphics Mode allows you to convert vector graphics directly to embroidery 
objects using a variety of techniques. Similarly, you can convert embroidery 
designs or objects to vector graphics. You can also quickly convert between 
different embroidery objects.

Tip: If you are using a vector graphic, you can remove overlapping objects by 
‘merging’ them. This eliminates overlapping stitching when vector objects are 
converted. See Holes for details.

Convert vector objects in Embroidery Mode

Use Auto-Digitize > Auto-Digitize Instant Embroidery to automatically digitize whole 
embroidery design directly from the imported bitmap artwork.

Use Auto-Digitize > Click-to- tools to automatically convert vector objects to 
embroidery fills or outlines.

Use Edit Objects / Digitize > Add Stitch Angles to add stitch angles to selected closed 
objects with or without holes.

Switch between 
operating modes
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You can also convert vector objects to embroidery objects using the Auto-Digitize 
Instant Embroidery and Click-to- tools. Import the artwork and make sure the 
Vector Artwork is activated in the Show Design droplist.

Note: Untick the As Bitmap checkbox to insert the artwork as vectors. Not all vector 
formats support this option. See Insert artwork as vectors for details.
The Auto-Digitize Instant Embroidery tool can be applied to vector artwork like 
bitmap artwork. Simply select the design you want to convert, and click the tool. 
With vector artwork, there is no need for preprocessing. Delete any unwanted 
background stitching. Edit stitch colors and types as preferred.

If you want more control over the conversion process, the Click-to- tools can also 
be used to covert vectors to ‘closed’ tatami fill objects, as well as objects with 

Make sure vector 
artwork is turned 
on

Vector artwork 
converted to 
embrodery
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turning satin fills. Current properties are applied. You can modify these as required 
before or after using the tools.

Another technique for converting vectors to embroidery is provided by the Add 
Stitch Angles tool. Simply select the vector object to convert, and click the tool. 
You are prompted to add stitch angles. Press Enter to confirm. Stitches are 
generated according to current settings.

Related topics

 Insert artwork as vectors
 Instant embroidery
Click-to-digitize artwork
 Holes
 Sequence objects
 Stitch angles
 Stitch Types & Effects

Vector artwork 
selectively converted 
to embrodery

Select vector objects 
and add stitch angles 
directly
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Convert artwork to embroidery with CorelDRAW®

If you have CorelDRAW GEM for Hatch Embroidery installed on your system, Hatch 
Embroidery provides another option for converting graphics to embroidery 
designs and vice versa. Individual objects or whole designs can be converted. 
Both vector graphics and bitmaps can be used. Use the Switch and Convert 
toolbar to switch between Embroidery Mode and Graphics Mode in the software. 
The Convert functions are also located on this toolbar. Behavior depends on 
operating mode.

To convert artwork with CorelDRAW®...
1 Scan or insert the artwork you want to use. See Import artwork for details.

Click Switch and Convert > Switch to Graphics Mode to import, edit or create vector 
artwork as a backdrop for embroidery digitizing, manual or automatic.

Use Artwork > Insert Artwork to import vector or bitmap artwork into current design 
as a backdrop for manual or automatic digitizing.

Use Switch and Convert > Convert Artwork to Embroidery to convert selected vector 
artwork to embroidery objects.

Use Switch and Convert > Convert Embroidery to Artwork to convert selected 
embroidery objects to vector artwork.

Use Switch and Convert > Keep Graphic Objects to preserve artwork during the 
conversion process.

Use Switch and Convert > Match to Embroidery Palette to determine color matching. 
When toggled off, graphic colors are added to the embroidery design palette. When 
toggled on, graphic colors are matched to palette colors.

Use Switch and Convert > Show Embroidery to show or hide embroidery 
components.
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2 In Graphics Mode, use the Convert Artwork to Embroidery tool to convert 
selected graphics – vector or bitmap – directly to embroidery.

3 Selected objects or the entire design are displayed in Embroidery Mode. Here 
you can edit generated embroidery objects, recolor, resize, change stitch 
types, and so on.

Convert artwork in 
Graphics Mode to 
embroidery

Vector graphics 
converted to 
embroidery
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4 In Embroidery Mode, use the Convert Embroidery to Artwork tool to convert 
embroidery to vector artwork. This tool gives you the option of converting 
embroidery objects to vectors or to ‘virtual embroidery’.

Note: Virtual embroidery creates a TrueView bitmap image of your design in 
Graphics Mode. This can be saved to file for reference purposes or even printed 
on fabric.

Tip: In Graphics Mode, the Tag as Appliqué button allows you to tag selected 
vector objects for conversion to appliqué. This is available to customers have 
purchased CorelDRAW GEM for Hatch Embroidery or already have a 
compatible version of CorelDRAW software.

Related topics

 Supported embroidery files
 Insert artwork as vectors
Convert vector graphics to appliqué

Convert embroidery 
to vectors or ‘virtual 
embroidery’

‘Virtual embroidery’ can 
be printed to resemble 
real embroidery
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Chapter 20

AUTO-DIGITIZING WITH PHOTOS

Hatch Embroidery provides dedicated techniques for auto-digitizing photographs, 
both colored and grayscale.

Auto-digitize with PhotoFlash

Use PhotoFlash to create embroidery from photographs or other images, color or 
grayscale. PhotoFlash designs consist of rows of stitches of varying spacing settings. 
The effect resembles the output of a line printer.

Method Purpose

PhotoFlash Create embroidery from color or grayscale photographs. The effect 
resembles the output of a line printer.

Reef PhotoStitch Create embroidery from photographs and other bitmap images. The effect 
is reminiscent of a coral reef, hence the name.

Color PhotoStitch Create embroidery from photographs and other bitmap images. This 
technique produces variegated stitching using multiple thread colors.

Use Auto-Digitize > PhotoFlash to create rows of Photo Satin stitching of varying 
spacing in current color for selected photographs or other bitmap artwork. The effect 
resembles the output of a line printer.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.
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To auto-digitize with PhotoFlash...
1 Scan or insert the photo you want to use. For best results, use crisp images with 

well-defined subjects and strong contrasts. See Prepare photos for 
auto-digitizing for details.

2 Select a thread color and, with the image selected, click the PhotoFlash icon.

Scan or insert 
image

PhotoFlash object 
generated
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3 The Object Properties > Fill tab gives you control over settings such as grain or 
orientation, stitch angle, density or resolution, as well as background contrast.

4 Turn off the image – press D – for a better view. Experiment with settings for 
optimum effect against your chosen background.

5 Select a resolution – low, medium, high, or extra high. The coarser the resolution, 
the more spacing between rows.

6 The option you select usually depends on whether the fabric is light or dark. The 
dark option produces an image negative.

Adjust Photo Satin 
stitch properties
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7 Adjust the grain angle to set the overall angle of stitch lines.

8 Adjust the stitch angle to run complementary to the grain angle as preferred.

9 Select a background option as preferred. ‘Dark’ produces a negative image.

Grain angle - 
horizontal vs 
vertical

Adjust stitch angle 
independent of grain 
angle
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Related topics

 Insert artwork as bitmaps
 Prepare photos for auto-digitizing

Auto-digitizing with Reef PhotoStitch

Reef PhotoStitch expands on the PhotoFlash auto-digitizing method to convert 
photos and images to monochrome embroidery design. Automatically fill large 
areas with open stitching reminiscent of a coral reef. The technique produces 
embroidery with a low stitch count based on the color contrast present in the 
image. It works best with images containing clearly defined areas with 
high-contrast colors.

To auto-digitize with Reef PhotoStitch...
1 Scan or insert the photo you want to use. For best results, use crisp images with 

well-defined subjects and strong contrasts. See Insert artwork as bitmaps for 
details.

Note: Reef PhotoStitch does not generate stitches with images copied and 
pasted from Paint or ESP artwork inserted with ‘As bitmap’ ticked.

2 Size the image for its intended purpose. 400mm (16”) is the limit.

Caution: Limit the amount of resizing done in Hatch Embroidery so as to retain 
as much image information as possible. If an image is much too large for its 
intended purpose, resize and resample it in any linked CorelDRAW® or external 
graphics applications before applying auto-digitizing techniques. This will 
generally produce a better result. See also Edit artwork externally.

Use Auto-Digitize > Reef PhotoStitch to turn photographs into a single embroidery 
field resembling a coral reef.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.
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3 With the image selected, click Reef PhotoStitch. The Reef PhotoStitch dialog 
opens. This provides interactive control over bitmap and stitch settings.

4 Use the zoom buttons to examine the image preview in detail. Alternatively, 
zoom in and out with the mouse wheel.

Preview of adjusted 
bitmap

Image settings

Current color/ 
thread paletteStitch settings

Image viewing
controls

Undo/Redo controls

Click and drag to 
pan at high zoom 
factors

Use zoom controls
to examine details
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5 Use Preview to generate temporary stitching with default settings. Move the 
dialog as necessary in order to preview the result in the design window.

6 Adjust grayscale image settings as preferred:

7 Optionally, select a thread color from the droplist.

8 Again, use Preview to generate temporary stitching without closing the dialog. 
Artwork is hidden during preview.

Setting Usage

Auto adjust Allow the software to optimize image settings for automatic 
digitizing.

Invert colors Create an image negative. Toggle the button to return to normal.

Brightness / Contrast Further differentiate stitched and unstitched areas.

Grayscale threshold Further filter the number of gray tones in the image.

Reset Return the adjusted bitmap to default grayscale values.

Select color from 
current palette
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Tip: Use the Reset button at any stage to return to default values. Use the Undo 
and Redo buttons to back-step through previous adjustments.

9 Once you have obtained the grayscale settings you want, try adjusting stitch 
settings in combination with Preview. 

These settings allow you to achieve a balance between overall stitch count 
and optimum coverage:

10 Experiment with Style of stitching – light or heavy.

11 When you achieve the desired result, click OK to confirm.
12 Turn off the image – press D – for a better view. Edit the results – e.g. thread color 

– for optimum effect against your chosen background.

Caution: Be careful if, after processing a larger image, you decide to reduce 
the design size. Stitches may be too closely bunched and cause needle breaks.

Setting Usage

Density Create more dense or more open stitching, similar to Loop Spacing in stipple 
stitching. The highest density (lowest value) may result in thread breaks.

Length Adjust length settings for greater or lesser precision. Shorter length will result 
in greater detail at the cost of a higher stitch count.

Min length Min length less than 0.8 may cause needle and/or thread breaks.

Trim... Adjust ‘Trim if next...’ setting for more or fewer connectors. The higher the 
value, the more connectors but fewer trims. Too many connectors will 
interfere with the clarity of the generated stitching. Too many trims will slow 
down the machine.

Adjust stitch
settings
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Related topics

 Insert artwork as bitmaps
 Prepare photos for auto-digitizing

Auto-digitize with Color PhotoStitch

Use Color PhotoStitch to create embroidery from photographs and other images. 
While PhotoFlash and Reef PhotoStitch produce designs single-color stitching, 
Color PhotoStitch produces variegated stitching using multiple thread colors. For 
best results, use crisp images with well-defined subjects and strong contrasts. The 
goal is always the same – the fewest colors/threads possible for a good result.

 For a grayscale photo, 5-6 shades which gradually change from white/light 
gray to dark gray/black are usually enough for a good stitching result.

 For a simple color photo, 7-10 colors may be enough. If a color occupies more 
than 5% of the whole area, it will be included by default.

 For a complicated photo with many different colors, 14-16 colors may be good 
enough. Try to limit colors to no more than 20 as every thread change counts.

In addition, you are seeking to obtain a good result with the fewest possible 
stitches and trims.

Use Auto-Digitize > Color PhotoStitch to automatically turn grayscale or color 
photographs into embroidery.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.

Use Edit Objects > Sequence >> to open the Sequence docker. Click again to close. 
Also available via Windows > Dockers menu.
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To auto-digitize with Color PhotoStitch...
1 Scan or insert the photo you want to use. For best results, use crisp images with 

well-defined subjects and strong contrasts. See Insert artwork as bitmaps for 
details.

2 Size the image for its intended purpose. 400mm (16”) is the limit.

Caution: Limit the amount of resizing done in Hatch Embroidery so as to retain 
as much image information as possible. If an image is much too large for its 
intended purpose, resize and resample it in any linked CorelDRAW® or external 
graphics applications before applying auto-digitizing techniques. This will 
generally produce a better result. See also Edit artwork externally.

Scan or insert 
image
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3 With the image selected, click Color PhotoStitch. The Color PhotoStitch dialog 
opens. This provides interactive control over color and stitch settings.

4 Use the zoom buttons to examine the image preview in detail. Alternatively, 
zoom in and out with the mouse wheel.

Preview of 
adjusted bitmap

Color and thread 
settings

Captured colors
Stitch

settings

Image viewing
controls

Click and drag to 
pan at high zoom 
factors

Use zoom controls
to examine details
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5 Use Preview to generate temporary stitching without closing the dialog. Move 
the dialog as necessary in order to preview the result in the design window. 
Artwork is hidden during preview.

To adjust color settings...
1 Study the preview panel. The software analyzes the photo and generates a 

default color list based on image colors. The dialog provides various methods 
to adjust the color list.

Click to generate preview 
with current settings

Adjust thread
matching
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Note: If your image includes a transparent background, this will be ignored by 
Color PhotoStitch.

2 Use Flatten to condense the photo to solid color blocks. Depending on image 
quality – e.g. low-resolution or pixelated images – this may affect resulting 
detail. Again click Preview to visualize the output.

Tip: The result above is better with Flatten ticked. Most photos, however, work 
better with Flatten off (the default).

Click to flatten 
image colors

Adjust lightness 
and contrast
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3 You can make adjustments to image lightness and contrast via Adjust. Start by 
clicking Auto Adjust. This works well for some photos.

Tip: Use the Reset button at any stage to return to default values. Use the Undo 
and Redo buttons to back-step through previous adjustments.

4 Optionally, use the Colors field to increase color count to draw out more detail. 
In some cases, you may want to decrease color count to reduce numbers of 
similar shades. 

Further adjust image 
brightness and contrast 
for better stitchability

Image auto-adjusted 
for greater contrast

Click to auto-adjust 
image settings

Experiment with 
color variations

Experiment with color
count for greater or

lesser detail
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5 Optionally, click the Color adjustment swivel to experiment with color variations. 
These are generated automatically so you cannot select specific colors at this 
stage. If a color occupies more than 5% of the total area, it will be included by 
default.
The goal is the same for any photo – to employ the fewest colors/threads to 
obtain the fewest stitches and trims for a good result. There will be a point a 
diminishing returns where more colors do not necessarily result in greater design 
clarity or stitchability.

6 Finally, when you have a color combination that works for you, use the Color 
Matching button to assign actual threads to bitmap colors.

Tip: To match the result most closely to the source bitmap, leave the default 
‘Add bitmap colors to palette’ setting unchanged. After the design is created, 
you can then pick a thread for each color prior to production.

Note: You can preset Color Matching Method to determine how you want 
thread color matching to be handled. The technique is the same. See Assign 
threads for auto-digitizing for details.

7 Again, click Preview to test your settings.

Preset how you want 
bitmap colors to be 
handled

Actual threads substituted 
for image colors
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Tip: Use the Reset button at any stage to return to default values. Use the Undo 
and Redo buttons to back-step through previous adjustments.

To adjust stitch settings...
1 Once you have obtained the desired color settings, try adjusting stitch settings 

in combination with Preview. These allow you to achieve a balance between 
overall stitch count, trim count, and optimum coverage. You are always 
seeking to obtain a good result with the fewest possible stitches and trims.

There is no particular workflow associated with these fields. The table below 
summarizes the function of each. It’s a matter of testing values in conjunction 
with Preview to arrive at a satisfactory result.

Field Function

Length / Min 
length

Color PhotoStitch color blocks are comprised of run stitching. The 
minimum and maximum stitch lengths allowable in a design determine 
the outside limits as measured between needle penetration points. 
Generally speaking, the shorter the length, the smoother the curves, at 
the expense, however, of increased stitch count.

Spacing Spacing is generally defined as the space between two consecutive 
needle penetrations on the same side of a column. The smaller the 
value, the greater the stitch density. For more open stitching, use larger 
values.

Coverage This setting affects overall stitch density. Lower percentages result in 
less dense coverage.

Color blending This setting affects overlapping areas of color. Reducing this value will 
generally result in greater color block separation.

Definition This setting affects the sharpness of image details. Reducing this value 
will generally result in greater image definition.

Trim if next... Trims are inserted if the next connector exceeds the length you specify.

Trims This setting affects the number of trims and tie-offs in the design. 
Reduce trim count by increasing trim length and decreasing the trim 
percentage setting, at the expense, however, of more connecting runs.

Adjust stitch
settings
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2 For instance, use the Color blending setting to increase or decrease 
overlapping colors. Reducing this value will generally result in greater color 
block separation.

3 Use Coverage to adjust overall stitch density. Lower percentages result in less 
dense coverage. This may be desirable in order to reduce stitch count 
depending on background color.

Adjust separation 
of color blocks

Coverage can be
further adjusted for

each thread
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Note: Coverage can be further adjusted for each thread by double-clicking a 
field in the Coverage column. Differential values can be used to enhance 
foreground details or diminish background colors.

4 Adjust Length settings for greater or lesser precision. Shorter length will result in 
greater detail at the cost of a higher stitch count.

5 Adjust Spacing settings for greater or lesser density. Again, closer spacing will 
result in greater detail at the cost of a higher stitch count.

Tip: You can reduce stitch count by increasing stitch length and stitch spacing, 
reducing overall and individual coverage % settings.

Default (3mm) Adjusted (6mm)

Default (0.4mm) Adjusted (1mm)
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6 Adjust trim settings for greater or fewer trims. The higher the value, the more 
connectors but fewer trims.

7 Keep experimenting until you achieve the desired result. Click OK to confirm.

Note: Both stitch and trim counts can only be checked after the Color 
PhotoStitch dialog is closed. While you remain in the same design window, 
current settings are retained except for thread coverage. This returns to the 
default 100%. Note these settings if you want to return to the Color PhotoStitch 
dialog. Note that any changes to the photo are also retained.

To edit the results...

 Review the results. Things to check for:
 No obvious holes in coverage
 Number of trims
Overall stitch count.

Caution: Be careful if, after processing a larger image, you decide to reduce 
the design size. Stitches may be too closely bunched and cause needle breaks.

Default (2mm) Adjusted (8mm)
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 Turn off bitmap artwork and check the results with TrueView.

 It’s useful to check needle penetrations with TrueView off as holes/gaps and 
stitch density can be easily seen.

Adjust view 
settings to inspect 
result

Connectors and 
trims on

Needel points on, 
stitches off
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 Hide unused colors. Click and hold each color slot in turn to view associated 
stitching. 

 Fine-tune thread color selection as preferred. Choosing the right thread is key 
to a good result. If you have added RGB colors to the color palette, open the 
Threads docker. Select a chart from the Thread Charts dialog. Here you can 
manually or automatically match threads to palette colors.

Click and hold color slot 
to view in isolation

Manually substitute 
thread colors as 
preferred

Automatically 
match threads to 
colors
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 Try cycling through used colors for some interesting effects.

Optionally, manually merge thread colors in the Sequence docker for reduced 
thread color changes.

Related topics

Choosing threads
Change color schemes

Merge similar 
colors as preferred
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PART VIII
MANUAL DIGITIZING

The Digitize toolbox provides all the digitizing tools necessary to create 
embroidered shapes. Digitizing tools are used in conjunction with stitch types to 
create embroidery objects. The tools are similar to drawing tools in a graphics 
application except that the objects you create have stitch properties as well as 
general properties. Hatch Embroidery also provides special tools for cutting holes, 
removing excess stitching, as well as filling holes.
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Chapter 21

DIGITIZE OBJECTS

In Hatch Embroidery, you build designs from basic shapes or ‘embroidery objects’. 
The process is called ‘digitizing’. Digitizing tools are used in conjunction with stitch 
types to create embroidery objects. The tools are similar to drawing tools in a 
graphics application except that the objects you create have stitch properties as 
well as general properties.

The Digitize toolbox provides all the digitizing tools necessary to create 
embroidered shapes. With filled objects you can set a stitch angle for the entire 
object. Alternatively, you can add multiple stitch angles with the Add Stitch Angles 
tool. There are also stitch settings for stabilizing large areas as well as reinforcing 
outlines.
Tools such as Freehand can be used to create designs with a hand-drawn 
appearance, something which is difficult to achieve through conventional 
digitizing methods.
Motif stamps are ready-made design elements, such as hearts, leaves or 
geometric patterns which are contained in libraries or ‘sets’. You can choose any 
of these patterns to use as ‘motif stamps’.
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Input methods

In Hatch Embroidery, you build designs 
from basic shapes or ‘embroidery 
objects’. Embroidery objects have 
general properties such as color, size, 
position, and so on. They also have 
embroidery properties such as stitch type 
and density. Properties are defined as you 
digitize but they can be modified at any 
stage. The most important property for an 
embroidery object is its stitch type. 
Different stitch types are suited to different 
shapes.

Digitize open & closed shapes

Different digitizing tools are suited to different shapes or design elements such as 
fills, outlines, details. Shapes may be closed or open. If closed, stitching may be 
comprised of fills or outlines. When you select a tool, different stitch types become 
available. The Context toolbar also changes to modify what can be done. The 
input method for all digitizing tools is basically the same. 

To digitize open or closed shapes...
1 For manual digitizing, you will generally want to import artwork as a digitizing 

backdrop. See also Import artwork.
2 Select a digitizing tool from the Digitize toolbox – either open line or closed 

shape.
3 Choose a color from the Design Colors toolbar. See also Design colors.
4 Choose a ‘fill’ or ‘outline’ method from the Context toolbar. This will determine 

whether the object is digitized as a fill or as an outline. Fills of course only apply 
to closed shapes.

Use Digitize > Digitize Open Shape to digitize open shapes with left and right mouse 
clicks for straight lines and curves.

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.

Use Context > Outline to outline closed shapes with the current line stitch type.

Use Context > Fill to fill closed shapes with the current fill stitch type.
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5 Select a suitable stitch type from the Object Properties docker. This can always 
be modified later.

6 Create boundaries using left and right mouse clicks to mark reference points – 
left-clicks for curve points, right-clicks for corners.
 If you make a mistake, press Backspace to delete the last point as you 

digitize.
 To constrain a line to 15° increments, hold down Ctrl as you digitize.

7 Press Enter to finish digitizing a line or shape.

Usage tips
 By default, objects are joined by the Closest Join method. If deactivated, all 

newly digitized objects are joined by the As Digitized method. Press Enter to 
accept default entry and exit points, or follow the prompts in the Status Bar to 
manually digitize them. See also Design settings.

 Use Auto Scroll to scroll automatically within the design window while digitizing. 
See Auto-scroll behavior for details.
 Hold down the Alt key to temporarily deactivate Auto Scroll.
 Use the Ctrl+Shift+A key combination to toggle Auto Scroll on/off.

 To change object properties, double-click an object to open the Object 
Properties docker. Change line or fill types via the docker.

 If you decide to close an open object, use Edit > Close Shape... commands to 
close using straight or curved points. Alternatively, use the tools on the Context 
toolbar.

 If you want to change a corner point to curve point, or vice versa, select the 
point and press Spacebar.

 Use the Undo/Redo tools on the Standard toolbar to undo or redo commands.

Open object Close object -
Curve Line

Close object - 
Straight Line
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 Press Esc to undo all new points. Press Esc again to exit digitizing mode. 
Alternatively, click the Cancel button on the Standard toolbar.

Control points
The reference points you mark when digitizing a shape become its ‘control points’. 
These vary slightly with object type. Most points can be added, deleted, or moved. 
Corner and curve points can be interchanged via the Spacebar. Some control 
points such as entry and exit points cannot be deleted but they can be moved.

Join method
When you are digitizing closed objects, the Closest Join method automatically 
calculates connectors. See the second example below.

This method can be toggled off via the Embroidery Settings > Design tab from the 
Software Settings menu.

Tool Function

Use Standard > Undo to undo previous action.

Use Standard > Redo to redo previously undone action.

Use Standard > Cancel to cancel the current process and deselect any selected 
objects. Same as <Esc> key.

Entry point

Exit point

Corner reshape node

Curve reshape node

Stitch angle points

Closest Join 
applied

Closest Join 
deactivated
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Related topics

 Design settings
Closest joins

Outlines

Hatch Embroidery provides tools for creating outline 
stitching of varying thicknesses and styles. Digitize outlines 
with both open and closed shape methods. Lines of 
varying thickness are typically used to add borders, 
outlines, and details to shapes. See also Outline stitches.

Parallel fills

Use the Closed Shape tool to digitize large and 
complex shapes generally with fixed rather than 
turning stitch angles. Most shapes can be digitized 
with this tool. Digitize the boundary in the same way 
you digitize run lines. Follow the prompts in the Status 
Bar to help you digitize. If you make a mistake, press 
Backspace to delete the last reference point, then 
continue digitizing. To complete a digitized object, 
press the Enter key.

Turning fills

Use Digitize > Digitize Open Shape to digitize open shapes with left and right mouse 
clicks for straight lines and curves.

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.

Use Digitize > Digitize Blocks to digitize column shapes of varying width, setting the 
stitch angle at each pair of points.
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Use the Digitize Blocks tool to digitize columns of 
varying width with turning stitches. With this tool, 
you create the shape by marking reference points 
on alternate sides of the column. 

To digitize turning fills...

Click to enter corner points. Right-click to enter 
curve points. 

Mark a pair of points wherever the outline 
changes, and wherever you want the stitch 
angle to change.

 The control points in a pair do not have to be 
the same type. For example, one can be a corner point, the other a curve.

 If you make a mistake, press Backspace to delete the last reference point, then 
continue digitizing.

 Press Enter to keep the last stitch and place the exit point at the last reference 
point you digitized, or

 Press Spacebar to omit the last stitch and place the exit point on the opposite 
side of the column.

 If you are joining two columns, omit the last stitch on the first column so that the 
exit point is close to the entry point of the next column.

Circles & squares

Digitize circles and ovals, squares and rectangles with a few clicks. With the 
addition of a third reference point, the Circle tool can create oval shapes. If you 
only want a perfect circle, press Enter twice. You can use any fill stitch type. When 
in doubt, follow the prompts in the Status Bar.

Use Digitize > Rectangle / Square to click 2 corners of a rectangle, or press <Ctrl> 
for a square.

Use Digitize > Circle / Oval to click the center point plus 2 size points for an oval, or 
press <Ctrl> for a circle.

Center Center
1

2

1

2

3
Press 

Enter twice
Press 
Enter
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When using the Rectangle / Square tool, you only require two points. To create a 
perfect square, hold down Ctrl as you drag the pointer.

Standard shapes

The Digitize toolbox also provides a dedicated Standard Shapes tool which allows 
you to quickly create design objects from a library of preset shapes. You can apply 
the full range of outline and fill stitch types. These can be useful when creating logo 
designs or embroidered badges. Available shapes are exactly the same as for 
preset borders. Use Ctrl and Shift keys, alone or in combination, to maintain aspect 
ratio and center point.

Note: When using Standard Shapes, some irregular shapes may cause a larger 
offset than expected. Once created, you can select and resize the shape to the 
desired size.

Stitch reinforcement

Embroidery appearance and quality depends a lot on underlay which serves as a 
foundation for cover stitching. Without an underlay, embroidery lies flat on the 
underlying fabric which can often show through. New digitizers might be tempted 
to increase stitch density but it is much more effective to apply an automatic 
underlay. Although it increases the stitch count, underlay helps to stabilize fabrics 
and reduce puckering and pulling especially on larger designs. It also provides 

Use Digitize > Standard Shapes to digitize standard shapes. Press <Ctrl> to keep the 
proportions of the shape. Press <Shift> to center at the first point entered.

1

2

1

2
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‘loft’, raising cover stitches and preventing them from sinking into soft fabrics. It is 
also used to prepare a napped fabric by flattening it.

Automatic underlay

The Underlay tool is a toggle button that allows you to apply automatic underlay 
to new or selected objects. Underlay is selected by default. Use the toggle to turn 
it off for selected objects, as needed. For instance, when applying an effect, such 
as Gradient Fill, you will probably want to turn off underlay altogether.

When turned on, default underlay settings adjust to suit the selected stitch type 
and object shape. Underlay stitching provides similar settings to cover stitch 
except that default stitch spacing is much wider.

Default underlay values are determined by selected auto fabric or template. 
While defaults are usually sufficient for most types of work, Hatch Embroidery lets 
you adjust values for different fabrics, lettering appearance and size. Larger areas 
and stretchy fabrics such as knits and pique generally need more underlay than 
smaller areas and firm fabrics such as drill or leather. At times, when you want a full 

Use Context > Underlay to apply or exclude automatic underlays to new or selected 
objects. Right-click for settings.

Stitch spacing: 3.0 mm Stitch spacing: 1.5 mm
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design with extra lift under the stitches, a tatami or double-tatami underlay is 
preferable. On knits, edge run is best. 

To change underlays...
1 Double-click a filled object or select and right-click the Underlay icon. The 

Object Properties docker opens.
2 If not already open, go to the Stitching tab and open the Underlay settings 

group.

3 If not already checked, tick the relevant Underlay checkbox and make a 
selection from the droplist. You have a choice two layers of underlay – 
Underlay 1 and Underlay 2. This allows you to apply dual underlays to design 
objects. A typical combination might be Edge Run with Tatami or Zigzag for 
larger objects. As a rule of thumb...

Underlay type Purpose

Center Run 
underlay

Use to stabilize narrow columns – e.g. 
2-3mm wide.

Edge Run 
underlay

Use to stabilize somewhat larger 
shapes such as letters.

Zigzag 
underlay

Use Zigzag underlay stitching to 
support wide columns. You can set 
stitch length properties for Zigzag 
underlay. The stitch length is the 
length of each zigzag stitch.

Set one or two 
layers of underlay 
as needed
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Tip: In addition to the predefined auto fabric settings, you can create custom 
fabric settings to suit particular needs. These can include preferred underlay 
settings.

Related topics

Choose auto fabrics
Manage fabrics

Pull compensation
Embroidery stitches tend to pull fabric inwards where the needle penetrates. This 
can cause fabric to pucker and gaps to appear in the embroidery. Experienced 
digitizers can manually compensate for pull by overlapping objects as they 
digitize. Automatic pull compensation, however, counters the pull effect by 
‘overstitching’ outlines of filled shapes on the sides where the needle penetrates.

The Auto Fabric you choose applies a calculated amount of pull compensation 
automatically. However, you can adjust overstitching yourself in the Object 
Properties dialog. This is handy if you want to override auto fabric settings to 
compensate for varying degrees of stretch.

Tip: Applying underlay stitching, and using appropriate backing and topping 
when stitching out can also reduce the push-pull effect.

Tatami 
underlay

Tatami underlay is used to stabilize 
large, filled shapes. It resembles an 
extremely open tatami fill stitch, where 
rows of stitches are placed across the 
object to create the support.

Underlay type Purpose

Pull
compensation

Digitized outline

Calculated outline

Set nominal 
pull 
compensation
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Related topics

Choose auto fabrics
Manage fabrics

Reinforce outlines

Use Backtrack and Repeat to reinforce outlines while specifying the direction of 
the stitching.

To reinforce outlines...
1 Select the object (or objects) to reinforce. Both tools are enabled when Single 

Run Lines, Triple Run Lines, or Satin Lines are selected.
2 Choose the best tool for the task, depending on whether you have chosen an 

open or closed object. Generally:

3 The object is duplicated and placed on top of the original. It is the same color 
and is positioned after it in the stitching sequence.

4 Check that the object has been duplicated by the following means:
Check the stitch count in the Status Bar.
 Use Stitch Player or travel through the stitches. 

Use Digitize > Backtrack to reinforce an outline, stitching it in the reverse direction to 
the original.

Use Digitize > Repeat to duplicate an outline in the same direction. Normally used 
with closed shapes.

Backtrack Stitches in reverse direction to the original. It is typically used to make 
run stitch outlines thicker without creating unwanted connecting 
stitches. 

Repeat Duplicates the original stitch direction and is typically used with 
closed shapes. If you use it with open shapes, a connecting stitch is 
inserted from the end to the start of the object. This will require 
trimming.

Backtrack for 
open shapes

Repeat for closed 
shapes
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Related topics

 Status bar
 View stitching sequence

Freehand

The Freehand Embroidery feature lets you create 
designs with a hand-drawn appearance, something 
which is difficult to achieve through conventional 
digitizing methods. The aim is to mimic designs 
formed on an embroidery machine by freehand 
motion. The difference is that the fabric is secured in 
an embroidery hoop, allowing the needle to ‘draw’ 
on the fabric surface, exactly as you have drawn 
on-screen. The Freehand Embroidery tools can be 
operated with a mouse or some WACOM pens.

Create freehand shapes

As with other digitizing tools, freehand tools can be used in conjunction with all 
available stitch types. With these tools, however, you draw objects directly on 
screen. It is thus possible to produce artistic effects similar to free-motion machine 
embroidery or ‘thread painting’.

To create freehand shapes...

Click and drag Freehand Open Shape to create free-flowing lines. Most line 
stitch types are available.

Use Digitize > Freehand Open Shape to click and hold to draw freehand open 
shapes. Adjust smoothing control for preferred result.

Use Digitize > Freehand Closed Shape to click and hold to draw freehand closed 
shapes. Adjust smoothing control for preferred result.
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Click and drag Freehand Closed Shape to create closed shapes. Most fill stitch 
types are available.

 To erase a portion of a line, press and hold the Shift key while dragging 
backward over the line. Alternatively, press Backspace to delete control points.

 Release the mouse to finish. Or press Esc to cancel input of the object.

Freehand techniques
Techniques include stitching on top of 
photographic images or detailed line drawings. 
For example, use the tools to manually trace a 
color photo-stitch design. This technique 
requires accuracy and control of corners, 
similar to the CorelDRAW® Polyline tool.
Alternatively, designs resembling pencil or 
charcoal sketches can be quickly digitized. Use 
the tools to create ‘doodle’ type drawing 
effects without following detailed artwork – for 
example, adding to a basic clipart design or 
decorative text and so on.

Adjust line smoothness
The Freehand Embroidery tools have a special 
cursor. This is designed to provide a spacing 
guide as you use the tools. 

To adjust line smoothness...
1 Use Show Guide to toggle the digitizing guide. This provides more control over 

‘freehand’ drawing than the default pointer.

2 Use the Guide Inner Circle Radius to set the size of the center circle.
3 Use Number of Guide Circles to set the number of circles.
4 Adjust the smoothness of freehand lines by means of the Smoothing control. 

Specify, as a percentage, how closely smoothed outlines follow the original.

Click and drag to 
create closed 
shapes
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Tip: View and edit the control points generated by Freehand Embroidery tools 
in Reshape mode.

Calligraphic freehand stitching

The Freehand tools can be used with Satin line and the Calligraphy setting to 
create truly calligraphic freehand effects. Generally you will use this setting with 
Freehand Open Shape but it can also be applied to Freehand Closed Shape with 
Outline stitching selected.

Use Digitize > Freehand Open Shape to click and hold to draw freehand open 
shapes. Adjust smoothing control for preferred result.

Use Object Properties > Outline > Satin to create thicker borders or columns of even 
thickness.

With smoothing Without smoothing

Use Calligraphy 
setting to create 
thick-thin satin lines
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The possibilities offered by these options for creative, artistic expression are limitless. 
Especially when used with stylus pen tablets. You can even use these settings to 
create embroidered calligraphy.

Motif stamps

Motif stamps are ready-made design elements, such as hearts, leaves or 
geometric patterns which are contained in libraries or ‘sets’. You can choose any 
of these patterns to use as ‘motif stamps’. There are many to choose from. Once 
added to your design, stamps can be edited, resized or transformed. You can 
define your own stamps for individual use or for use in motif runs or fills. See also 
Custom objects.

Select & insert stamps

Use the Motif Stamp tool to create decorative effects in your designs. Rotate, 
scale, or mirror them as you add them or edit them like any other object.

Use Digitize > Motif Stamp to add motifs to design one-by-one. Rotate, scale with 
<Shift>, or mirror with right-click as you add, or press <Enter> to accept default 
position and settings. Press <Esc> to stop adding motifs.
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To select and insert stamps...

Click the Motif Stamp tool.

 Select a category from the droplist. You can use any motif as an embroidery 
stamp, including user-defined motifs.

 Select a motif from the display panel and click OK.
Move the pointer and click to mark the anchor.

Move the pointer until the stamp is in the angle you need. Hold down Ctrl to 
constrain the anchor point to 15° increments.

Click again to mark the guide. Press Enter.

Select a category 
and select a motif

Rotate motif into 
position and click 
to mark guide
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 Repeat to insert the stamp again. Press Esc to finish.

Rotate stamps

You can rotate, flip and scale stamps as you add them to your design using the 
keyboard and mouse. You can also scale, rotate and flip stamps later just like any 
other object.

To rotate the stamp...

Move the pointer until the rotation angle is correct, then click again.
 Hold down Ctrl to constrain rotation angles.
 To flip the stamp, right-click.
 Alternatively, use the rotation controls in the Context toolbar.
 Press Esc to finish.

Use Select > Select Object to select an object or group. Or drag a selection marquee 
to select multiple enclosed objects or groups.
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Scale stamps
You can scale stamps interactively as you digitize. Press Shift, move the pointer until 
the stamp outline shows the required size, then click again.

Alternatively set an exact size using the Context toolbar. Enter precise dimensions 
in mm or as a percentage of the original.

Use Context 
controls to size 
and rotate motifs
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Chapter 22

ADVANCED DIGITIZING

Hatch Embroidery provides special tools for cutting holes, removing excess 
stitching, as well as filling holes.

Branching is an advanced feature that you can apply to similar, overlapping 
objects – e.g. the fingers of a hand, sections of a custom letter – without having to 
think about the most efficient stitching sequence and joins.
The Carving Stamp feature allows you to define a pattern of needle penetrations 
using a ‘carving stamp’ as a template. 
The Motif Stamp feature offers ready-made design elements, such as hearts, 
leaves or geometric patterns, contained in libraries or ‘sets’. You can define your 
own for individual use or for use in motif runs and fills. Similarly, you can create your 
own borders for use in monograms.

Holes

Hatch Embroidery provides special tools for cutting holes in objects, removing 
underlying stitching, as well as filling holes. Use them to prevent a build-up of 
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stitches, eliminate areas of unwanted stitching, or create new objects based on 
the holes in a source object.

Create holes in objects

Use the Digitize Holes tool to cut holes in objects to eliminate areas of unwanted 
stitching or for effect. 

To create holes in objects...
1 Select any closed object in which you want to cut a hole.

2 Select the Digitize Holes tool and digitize the shape you want to cut.
3 Press Enter twice to remove stitches from the digitized area.
4 Use the Remove Holes tool to restore any selected objects with holes.

Related topics

 Remove underlying stitching

Use Digitize > Digitize Holes to digitize holes in a selected filled object.

Use Digitize > Remove Holes to remove holes from a selected object.
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Fill holes in objects

The Fill Holes function does the opposite as Digitize Holes. Use the tool to fill holes 
in closed objects by creating new objects based on existing holes.

To fill holes in objects...

 Select the source object.

Optionally, right-click the Fill Holes tool to access the Embroidery Settings > 
Overlap tab. Set a nominal overlap margin. Softer fabrics may require more 
overlap to prevent gaps from forming.

 To cover holes exactly, accept the default value of 0.00.
 To overlap the filled holes and the original object, enter a positive offset – 

e.g. 1.00. Overlapping objects prevent gaps forming.
 To leave a gap between the filled holes and the original object, enter a 

negative offset – e.g. -1.00.

Use Digitize > Fill Holes to fill holes via creating new objects based on the hole 
boundaries of selected object with the current fill stitch type.

Select source 
object

Set nominal 
overlap margin

Set negative value 
to create 
‘underlap’
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 Hole boundaries are converted to closed objects with the same fill stitch 
settings, stitch angle, stitch effects and thread color as the source object. Edit 
as necessary.

Related topics

Overlap settings

Branching

Connectors link objects in a design. They can be 
run stitches or jumps. You can use automatic 
settings to generate connectors, trims and 
tie-offs, or add them manually. If you prefer to 
add tie-offs and trims as you digitize, you can 
turn off automatic connectors altogether.
Hatch Embroidery also allows you to create 
‘branched’ or ‘redwork’ objects. Selected 
objects are sequenced, connectors minimized, 
components grouped, and stitches 
regenerated. Underlay can be applied to all.
Branching is an advanced feature which lets you 
digitize similar, overlapping objects – e.g. the 
fingers of a hand, sections of a custom letter – 
without having to think about the most efficient 
stitching sequence and joins. Apply the 
command to join selected objects to form a 
single compound object. Components are sequenced, connectors minimized, 
and stitches regenerated. All component objects are grouped and selectable as 
one.

Apply branching

Apply Branching to selected objects. These become a single branched object.

Use Digitize / Edit Objects > Branching to automatically sequence and group 
selected embroidery objects.
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To apply branching...
1 Select the objects to sequence. Note any long connectors between objects.

2 Click Branching.
3 Digitize entry and exit points or press Enter twice to accept the defaults. 

Component objects are grouped and share the color of the first.
4 Travel through the object to check stitching. Note that objects are sequenced, 

connectors minimized, and stitches regenerated.

Select 
like-objects to be 
branched

Connectors 
external to 
unbranched objects

Objects grouped 
into a single 
branched object

Connectors 
included in 
branched object
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Tip: When entry and exit points coincide, there will be two layers of outline 
stitching. If they are different, the path between entry and exit points may 
include multiple passes.

Included objects

Branching works with most objects.

Branched objects preserve their original settings while sharing the color of the first 
object in the sequence. Incompatible objects, such as motif runs and fills, are 
excluded from the sequence.

Use Digitize / Edit Objects > Branching to automatically sequence and group 
selected embroidery objects.

Select objects 
to be branched

Compatible 
objects branched, 
incompatible 
excluded
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Edit branched objects

Branched objects remain editable. They can be reshaped. There is one entry and 
one exit point, but all component objects have individual reshape points. The 
object properties of a branched object can be accessed and modified via 
Object Properties. If necessary, branched objects can be returned to their 
component objects using the Break Apart tool. See also Split objects.

Redwork

Hobby users do a lot of ‘redwork’ – also known as blackwork, bluework, greenwork 
– by hand embroidery. Similar to Branching, the one-click Redwork tool creates 
two stitching passes.

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split 
composite objects – monograms, appliqués, lettering, etc – into components. Allows 
each to be edited individually. This tool is also available via Edit menu.

Select and break 
apart to return to 
component objects

Branched object 
includes one entry 
and exit point
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Create redwork

The Redwork tool allows you to create realistic redwork similar to what can be 
achieved with hand embroidery. Redwork is created with outline stitches, no filled 
objects. The most common stitch types used to create a hand-embroidery look 
are Single Run, Triple Run, Backstitch and Stemstitch. 

To create redwork...
1 Digitize your outlines making sure they touch or cross over. The order doesn’t 

matter.
2 Select the outlines and click the Redwork tool. Follow the prompts in the Status 

bar. In redwork, the entry/exit point coincides, so you only need to digitize a 
single point.

3 Click where you want the stitching to start. It will end at this same location after 
stitching two passes of each outline. If your redwork includes multiple colors, 
apply Redwork to each color in turn.

Use Digitize / Edit Objects > Redwork to automatically sequence and group selected 
embroidery objects to create a redwork object with its entry and exit points at the 
same position.

Select outlines to 
include in redwork
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4 Object appearance does not change but note in the Sequence docker that 
the selected outlines have been combined into a single ‘redwork object’.

Usage tips
 If you are working with a design that includes filled objects, use the Branching 

feature in preference to Redwork, or a combination of both.
 If filled objects are used, more than one run may occur on the first pass. Similarly, 

if lines are not touching or crossing, you may have more than one run.
Whichever stitch type you choose will applied in the last pass. The first pass will 

always be a single run.
 Sometimes you may want to turn off ‘closest join’ as this can override the start 

position. It may even give you more than two passes in some instances.
 After you finish, turn off TrueView to double-check there are no jump stitches.

Edit redwork objects

Change colors as preferred – red, blue, green, black, it doesn’t really matter. You 
can use whatever color you like on the machine. Check the stitching sequence 

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split 
composite objects – monograms, appliqués, lettering, etc – into components. Allows 
each to be edited individually. This tool is also available via Edit menu.

Outlines combined 
into single redwork 
object
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with Stitch Player. Note that each outline of the redwork object is stitched twice. 
Outlines not included in the selection are stitched separately.

When editing a redwork object in Reshape mode, both entry and exit markers are 
grouped and cannot be ungrouped. They can be selected and moved together.

When a redwork object is broken apart, it changes to a branched object. Entry 
and exit markers are ungrouped and can be selected and moved separately in 

View stitching 
sequence with Stitch 
Player

Entry and exit 
points coincide
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Reshape mode. You can break apart the resulting branched object again to 
access the component objects.

Usage tips
 After checking your results, use Reshape if you want to make changes.
 If you want to re-do the redwork, click Break Apart twice and then start the 

process over again.
 If the redwork contains more than two passes, turn off Closest Join, break apart, 

and then re-apply Redwork.

Carving stamps

The Carving Stamp feature allows you to define a pattern of needle penetrations 
using a ‘carving stamp’ as a template. A carving stamp can be any vector or 
embroidery shape.

Redwork object 
breaks apart, to 
branched object
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Tip: It’s best to work with carving stamps in TrueView.

Carving Stamp docker

The Carving Stamp docker contains four tabs:

Apply predefined patterns
The Use Pattern tab lets you select and apply pre-defined 
stamp patterns. You can start with or without embroidery 
objects selected. If one or more objects is selected, 
stamps are only applied to selected objects. If no object 
is preselected, stamps can be applied to any objects.

To apply pre-defined patterns...
1 Select Carving Stamp with or without embroidery objects preselected. If 

preselected, stamps will apply only to these objects.
2 Select a pattern set from the Set list – e.g. ‘Carving Stamps’. The droplist 

contains predefined as well as custom sets.
3 Select a pattern and click the Use Stamp button.
4 Move the mouse pointer over the target object/s. Right-click to mirror the 

stamp. Press Shift to prevent Auto Scroll.
5 Click to set the anchor point and swivel the pattern to the desired orientation.

Use Digitize > Carving Stamp to show Carving Stamp docker. Use to create needle 
penetrations with a 'carving stamp' as template.

Use Pattern Select and apply pre-defined stamp patterns to 
selected objects.

Use Object Select object outlines in the design window for 
use as a temporary stamp.

Digitize Digitize custom splits ‘on the fly’.

Appearance Soften or intensify the effect.

Pattern applied 
to selected 
object
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6 Optionally, with the Shift key pressed, resize the stamp while moving the mouse 
pointer. Click the mouse button.

7 If you have preselected an object or objects, the stamp pattern is applied only 
to those objects.

8 With no objects preselected, the stamp pattern is applied to all underlying 
objects.

9 Press Esc to exit.

Use objects as carving stamps
The Use Object tab allows you to select object outlines from the design window 
and apply them directly as stamps or save them to a library for future reference. 
You can use vector or embroidery objects as a basis for stamps. 

To use an object as a carving stamp...
1 Choose an embroidery object or vector object to serve as your stamp.
2 Click the Carving Stamp icon and select the Use Object tab.
3 Click the Start Selecting button and click to select or drag a selection marquee.

4 Hover the mouse over any target object in the design window.
5 Click the Use Stamp button to apply the selection as a carving stamp.

6 Optionally, click the Add to Library button to add the selection to the library for 
future reference.

Use selected 
object as carving 
stamp
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Usage tips
CorelDRAW® comes with a complete suit of clipart libraries. Many of these can 

be used as input to the Carving Stamp feature. If you have it installed, see your 
CorelDRAW® documentation for details.

 If you want to use a bitmap image, you can convert to vector format in 
Graphics Mode using the Bitmaps > Outline Trace command set.

 You can also use lettering, embroidery or TrueType, as an input to stamp 
creation.

Digitize custom splits

The Digitize tab allows you to digitize split lines and 
directly apply in situ or to any applicable objects in 
the design window.

To digitize custom splits...
1 Open the docker and select the Digitize tab.

Use Digitize > Carving Stamp to show Carving Stamp docker. Use to create needle 
penetrations with a 'carving stamp' as template.

Use digitized object 
as carving stamp
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2 Optionally, select embroidery objects. If preselected, stamps will apply only to 
these objects.

3 Click the Start Digitizing button. You are prompted to enter a starting point.
4 Digitize split lines. Press Enter once to complete a boundary. Press BkSp to 

correct mistakes.
5 Press Enter again to finish. Alternatively, press Esc to cancel the operation and 

start again.
6 Click the Stamp button to apply the stamp to selected or applicable objects.
7 Click the Use Stamp button to position the stamp. You are prompted to enter 

an anchor point as with predefined patterns.

8 Optionally, click the Create Stamp button to add the selection to the library for 
future use. See below for details.

Add stamps to a library

This procedure starts when you click the enabled Create Stamp button either on 
the Use Object tab or Digitize tab in the Carving Stamp docker.

Use Digitize > Carving Stamp to show Carving Stamp docker. Use to create needle 
penetrations with a 'carving stamp' as template.

Digitize split 
lines
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To add a stamp to a library...
1 Select the Use Object tab.

2 Click Start Selecting and select the target object.
3 Click the Create Stamp button. The dialog opens.

4 Select a set from the droplist or click the Create button to create a new one.
5 Enter a name for the new stamp and click OK. You are prompted to digitize the 

first reference point.
6 Digitize two points as prompted. These will be used during stamp placement. 

Alternatively press Enter to accept the defaults.

7 Click OK. The newly created stamp is displayed in the stamp list when the Use 
Pattern tab is selected.

8 The Rename and Delete buttons are enabled in the Use Patterns tab whenever 
a custom stamp is selected.

Select object to 
save as carving 
stamp

Click ‘Create 
Stamp’ to save

Select a 
category and 
enter name

Digitize reference 
points
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Adjust stamp appearance

The Appearance tab of the Carving Stamp docker provides settings which will 
soften or intensify the effect. Click the Clear Stamps button to remove all existing 
stamps from selected objects.

Usage tips
Carving stamps can be moved, rotated, scaled, reshaped, and deleted 

individually in Reshape mode. 
 As you transform carving stamps, needle penetrations in the underlying object 

are automatically updated. 
 To reshape a carving stamp, select an embroidery object in Reshape mode 

with carving stamps applied. Selection handles appear. 
 Use these to scale, rotate, or stretch the stamp. 
Click the stamp outline again to display control points. Use these to reshape the 

stamp.

Custom objects

Motif stamps are ready-made design elements, such as hearts, leaves or 
geometric patterns which are contained in libraries or ‘sets’. You can choose any 

Use Edit Objects / Select > Reshape to reshape an object outline, edit stitch angles, 
or adjust entry and exit points.

Click stamp outline 
to display control 
points
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of these patterns to use as ‘motif stamps’. You can define your own stamps for 
individual use or for use in motif runs or fills.

Create motifs

The Create Motif function lets you save your own motif shapes for future use. 
Create your own ‘motif sets’ to organize and classify your motifs. See also Motif 
stamps.

To create motifs...
1 Select the object you want to use as a motif.
2 Select Create Motif from the Context toolbar.

3 Select a category from the droplist and enter a name in the Pattern field. 
Optionally, click New to create a new category.

Note: Custom motifs can only be saved to custom categories, not those 
installed with Hatch Embroidery.

4 If you want to preserve machine functions such as color changes, leave the 
Remove Functions checkbox unticked. Otherwise, to remove unwanted 
machine functions, tick the checkbox.

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.

Use Context > Create Motif to create a custom motif pattern for future use.

Choose or create a 
category and enter 
name
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5 Click OK.
6 Click to mark two reference points. These determine default motif orientation in 

motif runs and fills. Reference point 1 becomes the anchor point in the final 
motif. Reference point 2 becomes the rotation point.

7 Reference points also determine the spacing between motifs.

8 Click OK. The motif is ready to use and will appear in the Pattern Gallery.

Manage motifs
Once you have created your own motifs, you can manage them via the Software 
Settings menu. Select the Manage Motifs command to access the dialog. Use this 
to rename or delete individual motifs or entire custom categories.

Choose a category, 
select a motif, and 
rename or delete
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Note: Only custom motif categories can be modified, not those installed with 
Hatch Embroidery.

Create borders

The Create Border function allows you to create your own borders for use with 
monograms. Simple shapes work best. See also Add monogram borders.

To create borders...
1 Digitize the border with the Closed Shape tool or select an existing closed 

shape. Outlines or fills can both be used. This can be changed once the border 
is selected for use. Don’t use satin line as this results in a double border.

2 Select Create Border from the Context toolbar.

Note: Custom borders can only be saved to custom categories, not those 
installed with Hatch Embroidery.

3 If need be, create a new category to contain custom borders.
4 Digitize two reference points.

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.

Use Context > Create Border to create a custom border pattern for future use.

Use Context > Outline to outline closed shapes with the current line stitch type.

Use Context > Fill to fill closed shapes with the current fill stitch type.

Choose or create a 
category and enter 
name
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5 Click OK when the confirmation message appears.

Manage borders
Once you have created your own borders, you can manage them via the 
Software Settings menu. Select the Manage Borders command to access the 
dialog. Use this to rename or delete individual borders or entire custom categories.

Note: Only custom border categories can be modified, not those installed with 
Hatch Embroidery.

Choose a category, 
select a border, and 
rename or delete
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PART IX
EMBROIDERY HOOPING

Fabrics must be hooped before stitching out on the machine. Hatch Embroidery 
allows you to select from a wide range of standard factory-supplied hoops. If your 
project contains a large design or a number of smaller designs, you may need to 
use multiple hoopings. If you have a hoop which does not appear in the list, you 
can define a custom hoop from scratch or based on a standard hoop.
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Chapter 23 

HOOPING DESIGNS

Fabrics must be hooped before stitching out on the machine. Hatch Embroidery 
allows you to select from a wide range of standard factory-supplied hoops. If your 
project contains a large design or a number of smaller designs, you may need to 
use multiple hoopings. If you have a hoop which does not appear in the list, you 
can define a custom hoop from scratch or based on a standard hoop.

This section describes how to choose and display hoops in Hatch Embroidery. It 
covers creating and modifying custom hoops. It also deals with hooping large 
designs.

Hooping concepts

There are five main cases when hooping designs in Hatch Embroidery:

 A single design that fits within a single frame.
 A single design that will not fit within a single frame but can fit within a 

multi-position hoop. Multi-position hoops generally consist of 2 or 3 overlapping 
sewing fields within the one frame.

 A single design that fits within a single frame, but which is repeated 
continuously.

 A large work-piece layout involving multiple designs each requiring its own 
hooping.



Chapte r  23    Ho op ing D esi gns 512

 A single design that will not fit within a single hooping but requires multiple 
hoopings.

With each hooping, there is generally only one important reference point – the 
hoop center. This is particularly so where machines automatically center the 
design. When designs are located on a large work piece, like a table cloth, design 
extents and geometric center become important for positioning.

Single designs in single hoopings
As a beginner, you will generally use designs that fit entirely within the available 
hoops for your particular machine. You will mostly use default settings both in the 
software and the machine. The hoop center becomes the reference point for all 
designs you do in this manner. This technique provides the basis for all other 
techniques you will use. See Stitch out single designs for details.

Single designs in multi-position hoopings
As an intermediate user, you’ll no doubt want to try laying out larger designs using 
multi-position hoops. These allow you to utilize a larger area of fabric to combine 
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several designs or split large designs. Design components are sewn in different 
sewing fields without the need to re-hoop the fabric.

Continuous embroidery
Continuous embroidery consists of a single design, repeated continuously, that fits 
within a single hoop. In Hatch Embroidery, continuous embroidery can be 
achieved in one of two ways:

Manual continuous embroidery consists of a single design with manually 
inserted basting stitch markers or graphic markers at start and end of design for 
alignment. See Manual continuous embroidery for details.
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 Automatic continuous embroidery consists of multiple design repeats 
combined with multi-hooping to create output files with automatic registration 
marks. See Automatic continuous embroidery for details.

Single hoop work-piece layouts
As an intermediate user, you may want to create design layouts on large work 
pieces. Each design will still fit in a single hoop but there may be multiple designs 
in the layout. Each hooping has its own reference point that is used with the hoop 
template to accurately place the design at the correct orientation. As there is only 
one design per hooping, there is no need for secondary placement points. The 
main benefit of this technique is that the complete layout can be 
accommodated within a single design file with the work piece as reference and 
all components included. See Stitch out work-piece layouts for details.

Multi-hooped designs
If your design is too large or involves a large work area, you have the option of 
splitting it into multiple hoopings. The Multi-Hooping toolbox lets you strategically 
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position hoops until you obtain the least number of hoopings necessary to 
accommodate the whole design layout.

Each hooping contains an object or group of objects that can be stitched out on 
their own. Hoopings are stitched consecutively to form the whole design. See 
Create multi-hoop designs for details.

Hoop selection

Hoops are needed to hold the fabric tight while stitching on your machine. They 
are available in different sizes. An outline to represent the sewing field of the 
selected hoop is displayed in the design window. This provides a guideline for sizing 
and positioning designs. You can show or hide the hoop at any time.
Depending on the selected hoop type, the boundary of the working area within 
the hoop may be displayed as a thin red, blue, or dotted line. If any part of the 
design lies outside the stitching area, a warning appears when saving. This 
prevents you from accidentally stitching outside this area and damaging your 
machine by hitting the hoop with the needle.

Note: If your embroidery is too large or contains a number of designs spaced 
around an article, you can split it into multiple hoopings. Each one contains an 
object or group of objects that can be stitched out in a single hooping. See also 
Multi-Hooping.

Reposition and 
rotate hoops to 
completely cover all 
objects
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Hoops & templates
When it comes to stitching out, it is important to align the fabric squarely in the 
hoop, with even pressure on all sides, and fabric patterns and weaves running 
perpendicular to the hoop. Otherwise, fabric bias allows stretch. This can distort 
stitching and result in puckering. Each hoop contains vertical and horizontal 
centering marks on the frames. These help with aligning both the fabric and the 
design.

Many hoops also come with a clear plastic template overlay. These include 
alignment lines, with tiny holes which allow you to create positioning marks. Hoop 
template display can be toggled on or off independently of the hoop itself. Uses 
in the software...

 Templates include alignment and registration guide markings. These can help 
you align the design in the hoop.

 Templates can also be printed with alignment and registration markings. This 
allows you to cut out the printed design and align it in the hoop with the 
physical template.

Select & display hoops

Click View > Show Hoop to show or hide hoop. Right-click for settings.

Click View > Show Hoop Template to show or hide hoop template.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Hoops and templates
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The Hoop List on the Context toolbar shows which hoop is currently active in the 
design window. The list is filtered according to the selected machine brand and 
model/type which may include hoops you have created.

To select and display a hoop...
1 Change hoops at any time via the Context toolbar droplist.

Tip: Always aim to select the smallest hoop which will accommodate your 
design.

2 Toggle the Show Hoop button on the View menu to display the current hoop.

Tip: Change background color of the hoop via the Customize Design > 
Background and Display Colors dialog.

Choose a supported
hoop from the hoop list

Select smallest hoop 
to accommodate 
design
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3 Optionally, click the Machine & Hoop Options button to change hoop selection 
or modify the list at any time.

4 Optionally, turn on the hoop template display via the Show Hoop Template 
toggle. The template may be used to help position your design within the hoop.

Usage tips
 You can include the hoop template in the design worksheet, together with 

alignment and registration guide markings. This allows you to cut out the printed 
design and align it within the hoop. Use the template markings to align it to 
physical hoop template.

 The selected hoop is saved with the design in native EMB file format. When the 
machine reads the machine file, the stitching area is limited by the selected 
hoop type.

Choose from 
filtered hoop list

Use template to help 
position design within 
hoop
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 If you have a hoop which is not listed, you can define your own. 

Related topics

 Print multi-hooped designs
Create custom hoops
Machine selection
Configure hoop list

Center hoops

By default Hatch Embroidery will open your design in the hoop position it was last 
saved with. If you are creating a single hooping, it’s a good idea to turn on 
automatic centering to check that the design will fit within the selected hoop. You 
can, however, use the fixed option to lock the hoop position. This means it won’t 
automatically center while you are digitizing. 

To set the hoop center...
Click the Machine & Hoop Options button to access machine and hoop settings. 
Or right-click the Show Hoop icon.

Click View > Show Hoop to show or hide hoop. Right-click for settings.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Click Context > Center All to center the whole design and hoop at the (0,0) position 
and display them in the design window.

Set hoop
center
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The Hoop position panel gives you these options:

Usage tips
 Some embroidery machines will always center the design. Set your software to 

match the exact behavior of the machine.
 The Fixed hoop position can be used in conjunction with the Start needle 

position in hoop option for machines that use the start connector to position the 
design.

When you want to position objects within the hoop, Start needle position in 
hoop can be used with machines like Janome that use the start connector to 
position the design.

Option Purpose

Fixed Allows manual placement of the design anywhere in the hoop. Only 
suitable for machines which allow off-centering of designs within the 
hoop.

Set hoop center Allows an arbitrary hoop center to be created by digitizing a point in the 
design window. If you select this option, click a point in the design 
window where you want to center the hoop.

Automatic centering The hoop always centers itself around the design center.

Set fixed start
point

Use with machines that
use start connector for

design positioning

Embroidery Settings > 
Machine & Hoop

Auto Start and End

Hoop position auto 
centered

Hoop position fixed Fixed position with 
hoop start point
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 Use the Context > Center All command to center the embroidery design and 
hoop at the (0,0) position in the design window. This means you can reposition 
the hoop around the design after you have finished digitizing without the need 
for auto-centering.

Note: The Center All command effectively moves the entire design such that 
the embroidery is centered at 0,0. If, for instance, we digitize only one of the 
flowers in the above image and then click Center All, the flower alone is 
centered around 0,0, not the artwork.

 Some hoops such as the Janome No. 1 & 3 (126 x 90) are offset at the (0,0) 
position. If you apply Center All, these hoops are automatically centered at 
the(0,0) position. You can still use it if the design is centered in the embroidery 

Design and hoop 
centered in design 
window
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field. The start connector still goes to the center of the hoop rather than the 
center of the design.

Related topics

 Design settings

Rotate hoops

The Rotate Hoop tool allows you to rotate the hoop for ease of digitizing. The 
attachment mechanism is indicated, both on screen and printed worksheets. You 

Use Context > Rotate Hoop Left 15° to rotate the first hoop, or the currently selected 
hoops in multi-hooping mode, in 15° increments to the Left.

Use Context > Rotate Hoop Right 15° to rotate the first hoop, or the currently selected 
hoops in multi-hooping mode, in 15° increments to the Right.

Use Context > Rotate Hoop to rotate by a specified amount - positive or negative 
- in degrees.

Hoop offset at 
(0,0) position
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can thereby tell the orientation of the design with respect to the hoop and decide 
how to position it. Rotate the current hoop by means of the icon or popup menu.

Multi-position hoops

Multi-position hoops allow you to utilize a larger area of fabric to combine several 
designs or split large designs. Design components are sewn in different sewing 
fields without the need to re-hoop the fabric. Many proprietary and third-party 
hoops are available.

Multi-position hoops generally consist of two or three overlapping sewing fields 
within the one frame. There are two main types:

Hoop type Characteristics

Multi-position These hoops have one bracket with multiple positions to place the hoop. 
Most hoops in this category have three (3) sewing fields, generally referred 
to as position 1, position 2, position 3 or position A, position B, position C.

Multi-position 
rotating 

Most of these hoops have two brackets and generally only two (2) sewing 
fields. However, there are some specialty hoops that may have more 
sewing fields. After stitching a field, you take the hoop off the machine and 
rotate it for the second.
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Note: Multi-position hoops work differently to Multi-Hooping where designs are split 
into smaller machine files for separate stitchout on a standard hoop.

Object splitting
If your level of Hatch Embroidery supports Multi-Hooping, you will be able to split 
objects to work with multi-position hoops. Otherwise, each embroidery object must 
fit within a single sewing field as shown...

Multi-position hoop output
The fact that there are multiple sewing fields has no effect until outputting designs 
for machine. In most cases Hatch Embroidery will only create one file. However, if 
a return to a previous hoop position is required, the software will create two (or on 
rare occasions, more) files.
To export to a format recognized by your selected machine, you use the Export 
Design function. The results vary depending on the machine file format. For 
example, PES should create a single file containing multiple parts. DST or EXP will 
create multiple files. Currently split files are not supported for VIP/VP3 formats.

Popular multi-position hoops
Popular multi-position hoops include...

 Brother/Babylock Jumbo Small 100(W) x 172(H) (3 position)
 Brother/Babylock 360(W) x 360(H) (rotating) 
 Husqvarna/Viking/Pfaff 350(W) x 360(H) mm (rotating)
 Janome/Elna Hoop MA (200x280) (2 positions)

Split objects can 
straddle two or more 
positions

Each object fits 
entirely into a single 
hoop position
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 Brother/Babylock Extra Large 130(W) x 300(H) (3 positions)
 bernette/Janome/Elna Hoop D (220 x 190) (Giga Hoop) (rotating)

Note: Hatch Embroidery allows you to define your own multi-position hoops and 
save for later use. See Custom hoops for details.

Output for multi-position hoops

Hatch Embroidery supports multi-position hoops 
which expand the available sewing area of the 
machine for which they are supplied. The two 
sewing fields are shown in red and blue. When 
digitizing, each embroidery object must fit entirely 
into one or other hoop position unless your product 
level includes Multi-Hooping functionality.
The behavior of the multi-position hoops during 
loading and editing of embroidery designs is 
exactly the same as for normal rectangular hoops. 
The fact that there are two (or more) sewing fields 
has no effect until you save the design or output to 
machine. In most cases Hatch Embroidery will only 
create one file as the multiple hoop positions are 
saved in a single EMB file. However, if a return to 
hoop position 1 is required, Hatch Embroidery will 
create two (or more) files.

To output a design for a multi-position hoop...
1 Open the design to output to machine. The sewing fields are shown in red and 

blue. 
 If your product level includes Multi-Hooping functionality, objects can 

straddle different hoop positions. Otherwise, each object must fit entirely 
within a single hoop position. See also Split objects between hoopings.

 Sizes are shown in mm for a 1:1 display. At other display scales, values are 
scaled proportionally.

2 To export to a format recognized by your selected machine, click the Export 
Design icon. If you have not already split objects between hoop positions, 
Hatch Embroidery determines whether there are any that do not lie wholly 
within one of the hoop’s two (or more) positions:

Use Output Design > Export Design to export the current design to a machine file for 
stitching.
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 If so, they are selected in the design window and you are prompted to edit, 
split, or delete them. Otherwise Hatch Embroidery determines how many 
hoopings are needed.

 If only one is needed, or two with the upper position first, Hatch Embroidery 
creates a single EMB file containing these hoopings.

Otherwise it calculates the number of position changes required and 
prompts you to proceed. It will then create multiple EMB files.

3 Click OK.
The EMB file names are numbered with a hyphen – ‘My Flower- 1’ and ‘My 
Flower- 2’. When the machine loads the first of the multiple EMB files, it stitches 
the upper-position first, then prompts you to move the hoop to the lower 
position. Always have the hoop in the upper position when the machine starts 
stitching a new EMB file unless you are explicitly prompted to shift frame. This 
may be necessary in cases where a hooping pair must be split because it has 
too many stitches or too many color changes.

Output for multi-position rotating hoops
Hatch Embroidery supports multi-position 
rotating hoops. These are two- or 
three-position hoops which expand the 
available sewing area of the machine for 
which they are supplied. Sewing fields are 
shown in red and blue. The red area is 
normally stitched first. Then, after rotating the 
hoop, the blue area is stitched.
The physical embroidery area of multi-position 
hoops is represented by the solid line. 
However, any rotation of the hoop may cause 
a small positioning gap. To avoid this, a margin 
of 5mm is allowed on both sides. This is 
represented by the dashed line. We 
recommend you stay within the dashed area.

Caution: If objects in the blue area are sequenced before the red, you cannot 
save as a multi-position hoop design. That is, you cannot create a single EMB file 
which has its start in the second hoop position. This would require more than a 
single EMB file which is not allowed.

To output a design for a multi-position rotating hoop...
1 Open the design to output to machine. The sewing fields are shown in red and 

blue.
2 To export to a format recognized by your selected machine, click the Export 

Design icon. If you have not already split objects between hoop positions, 
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Hatch Embroidery determines whether there are any that do not lie wholly 
within one of the hoop’s two (or more) positions:
 If so, they are selected in the design window and you are prompted to edit, 

split, or delete them.
 If the design can be stitched in the hoop, the Export Machine File dialog 

opens.
 If the design will not stitch as a single hoop design – i.e. more than one hoop 

rotation would be required – a warning message is displayed.
3 Select the design name and click the Save All Now button.

Depending on your machine format, the software may save all split designs to 
a single file that your machine can read. Or it may save each one to its own file, 
with the sewing order indicated as a suffix to each file name.

Custom hoops

If you are using a hoop size that is not in the hoop list, you can define your own and 
save it for later use.

Custom hoop types
You can create or edit eight types of hoop:

 Rectangle
 Round rectangle
 Square
Oval
Circle
 2 position
 2 position rotating
 3 position
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Rectangular and square hoops
Set height and width according to the dimensions of the hoop you are using. With 
rounded rectangle hoops, set a corner radius in addition to height and width 
values.

Oval and circular hoops
Set heights and width or diameter values according to the dimensions of the hoop 
you are using.

Multi-position hoops
Two and three-position hoops allow large designs to be split manually and stitched 
without the usual registration problems. Sewing fields are in fixed positions with 
known dimensions, making it easy to register objects stitched in each position. In 

Height

Width

Radius

Height

Width

Rectangle 
height

Diameter
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the software, they are displayed as colored rectangles – red, blue, or green. 
Define your own multi-position hoop according to the dimensions of the hoop you 
are using. 

Create custom hoops

Hatch Embroidery allows you to define your own hoops and save for later use. 
Custom hoops are needed because new hoops become available for sewing 
machines more frequently than the software is updated. Also some machines 
include hoop adapters for third-party hoops which need to be defined in Hatch 
Embroidery. There are several types of hoop that can be defined or edited in 
Hatch Embroidery. Pre-installed hoops cannot be edited. Hoop types include:

To create a custom hoop...
1 Click the Machine & Hoop Options button to access the dialog.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Click View > Show Hoop to show or hide hoop. Right-click for settings.

Height

Sewing 
field

Width

Custom hoop 
types
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2 Click the Add/Remove Hoops button to associate a custom hoop list with the 
selected machine brand.

3 Click the Create button. The Create Hoop dialog opens. 

4 Select the required format for your hoop from the droplist – e.g. rectangle, 
circle, etc.

Create hoop for
selected machine

Click to configure hoop list 
for selected machine model

Enter hoop 
characteristicsSave custom

hoop

Select hoop
template from

droplist
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5 Give your hoop a meaningful title in the Name field – e.g. ‘Rectangle 180x120’.
6 In the Stitching Area Dimensions panel, enter the dimensional characteristics of 

the stitching area. For instance...
 Rectangle: Rectangular stitching areas require Height and Width 

dimensions.

Oval: Oval stitching areas require three dimensions – Total Height, Rectangle 
Height, and Width.

Caution: Even if your unit of measurement is in inches, dimensions in the Create 
Hoop dialog are specified in millimeters. This is because hoops on the machine 
are specified in millimeters. If you are not sure of the hoop size in millimeters, 
check your machine manual. Sizes are generally listed in the machine parts 
and accessories list.

Enter required
dimensions

Enter required
dimensions
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7 Similarly, use the Create Hoops dialog to define multi-position hoops – 2 position, 
2 position rotating, and 3 position. Again, use the Stitching Area Dimensions 
panel to enter dimensional characteristics of the stitching area. For instance...

8 Click Save Hoop to save your custom hoop to the hoop list. It is automatically 
placed in the Machine hoops panel and is available for use along with other 
predefined or custom hoops you have selected.

Usage tips
Once your new hoop is saved, it can be edited or removed via the available 

buttons in the Add/Remove Hoop dialog.

 Any custom hoop you create can also be associated with other machine 
brands.

Enter required
dimensions

Edit or remove custom
hoop as needed
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 If you open an EMB file which contains a custom hoop not included in the hoop 
list, or if the hoop has the same name as a listed one but different type and/or 
settings, Hatch Embroidery creates a new custom hoop with the same 
characteristics and tags it with a system-generated name.

Positioning & production techniques

To facilitate the accurate positioning of designs in more complex cases, Hatch 
Embroidery uses a combination of:

 Design layout templates
 Design worksheets with printed location markers
 Positioning markers – either stickers or basting stitches
 Hoop templates.
Where the final output requires multiple hoopings, positioning and alignment of 
multiple hoopings at sewing time, or repeats of the same design, can be tricky. It 
takes practice to obtain accurate alignment where a design requires re-hooping.
As an advanced user, you may want to produce designs larger than any available 
hoop. This could be a single large design or a continuous embroidery design with 
repeating patterns. Continuous embroidery is similar to the ‘endless embroidery’ 
function available on some machines.

Stitch out single designs
As a beginner, you will generally use designs that fit entirely within the available 
hoops for your particular machine. You will mostly use default settings both in the 
software and the machine. The hoop center becomes the reference point for all 
designs you do in this manner. This technique provides the basis for all other 
techniques you will use.

To stitch out a single design...
1 Insert or open a design.
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 The hoop automatically centers around design extents, as it does on most 
machines.

 Using the hoop template instead of the grid, you can ensure that the hoop 
center always aligns with the hoop template grid as the hoop centers 
around the design.

2 Optionally, adjust the design size or change hoops to suit the design. 
3 Print a design worksheet. The worksheet can include the hoop position marker. 
4 Send the design to machine. The design is automatically centered on the 

machine. 
5 Fix the design worksheet to the fabric.

Select smallest hoop 
to accommodate 
design

Use template to help 
position design within 
hoop
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6 Hoop the fabric. Align the worksheet hoop position marker with the hoop 
template centerlines.

7 Start the machine. The needle will move to the hoop center. 
8 Stitch out the design.

Related topics

 Hoop selection
Center hoops
 Print designs
 Save & export designs

Stitch out work-piece layouts
As an intermediate user, you may want to create design layouts on large work 
pieces. Each design will still fit in a single hoop but there may be multiple designs 
in the layout. Each hooping has its own reference point that is used with the hoop 
template to accurately place the design at the correct orientation. As there is only 
one design per hooping, there is no need for secondary placement points. The 
main benefit of this technique is that the complete layout can be 

Align worksheet hoop 
position marker with hoop 
template centerlines
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accommodated within a single design file with the work piece as reference and 
all components included.

To stitch out a work-piece layout...
1 Insert or open a design. The hoop automatically centers around design extents, 

as it does on most machines.
2 Optionally, adjust design size or change the hoop to suit the design. 
3 Create a design layout by combining designs and design elements.
 There are various features within the software for creating geometric design 

layouts quickly and easily – Mirror-Merge, Layouts, etc. 
 Alternatively, place designs manually.
Optionally, include a background for a garment or large work piece. 

4 Use multi-hooping in order to automatically place hoops for each design 
location. You can use the automatic feature to generate hoopings even in 
large layouts. 
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5 Print out the layout template with the design worksheet. Large layouts can be 
printed on small format printers and then pieced together. This establishes all 
hoops in the correct spatial relationship. 

6 Piece together the design worksheet to show the entire layout. The worksheet 
shows the hoop position marker. Each hoop position marker has a number 
indicating the hooping sequence. 

7 Send the design to machine. The design is automatically centered in the 
machine. 

8 Fix the layout template to the work piece. Optionally, remove the non-stitched 
sections of the design worksheet to make the work piece easier to work with.

9 Hoop the work piece using the printed design layout template and hoop 
template. Align the worksheet hoop position marker with the hoop template 
centerlines.

10 Once hooped, remove the layout template and stitch the design component 
for that hooping. 
 The hoop location number is included on the hoop position marker.
When sent to machine, designs have the hoop location number added to 

the design layout file name.
11 Stitch out the design.
12 Locate the next hoop in the sequence and repeat.

Usage tips
With work-piece layouts, you don’t need to include registration marks, but you 

do need the hoop position markers for each hoop location. This will show the 
position and orientation of each design in the layout.
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 Turn on hoop position marker via Print Preview > Options.

Related topics

 Background articles
 Design Layouts
 Scale objects
Create multi-hoop designs
 Print multi-hooped designs
Output multi-hooped designs

Automatic continuous embroidery
Automatic continuous embroidery consists of the following elements:

Multiple design repeats in a single file using automatic layout features.
Multi-hooping to create the output files with automatic registration marks.

To create automatic continuous embroidery...
1 Insert or open your source design.
2 Create your design repeats.

Tip: Use the Copy Reflect function to automatically generate continuous 
embroidery designs. 

3 Set the number of columns and rows required for the finished item.
4 Open the Multi-Hooping toolbox and use automatic hooping to cover all 

objects in the design. Hoops should be placed with at least a 3cm overlap for 
good registration mark generation.

5 Send the multi-hoop design to machine. 

Related topics

Mirror objects
Create automatic hoopings
Output multi-hooped designs
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Manual continuous embroidery
Manual continuous embroidery consists of the following elements:

 Single design in file.
Manually inserted basting stitch markers or graphic markers at start and end of 

design for alignment.
Manually repeated design on the machine using manual reference markers to 

align each hooping.

To create manual continuous embroidery...
1 Insert or open your source design.
2 Move the design into the required position in the hoop. Start and end 

connectors are fixed to the center of the hoop.

3 Optionally, adjust design size or change the hoop to suit the design.
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4 Use the Basting Stitch Marker command to insert basting stitch markers – two 
near the top at either side of the design, and two near the bottom.

5 Align the associated basting stitch marker with the bottom left-hand corner of 
the design extents:
 Select the bottom left-hand basting stitch marker.
 Using the Ctrl key, select the design.
Click Arrange > Align > Bottom followed by Arrange > Align > Left.

6 Repeat for each of the other basting stitch markers to place them in each 
corner.

7 Select the two basting stitch markers at the top. Using the Sequence docker, 
move them to the start of the design. Make sure the two bottom-most basting 
stitch markers are sequenced at the end of the design.

8 Print a design worksheet showing the hoop position marker. Each marker has a 
number indicating the hooping sequence.

9 Send the design to machine. The design is positioned at the same location as 
shown on screen. It uses start and end connectors to locate the design from the 
center of the hoop. The machine will start stitching at the hoop center. 

10 Fix the design worksheet to the fabric in the required position for the first part of 
the endless embroidery.

11 Hoop the fabric. Align the worksheet hoop position marker with the hoop 
template centerlines.

12 Step past the first two basting stitch markers as these are only needed for 
second and subsequent designs. Stitch out the design.

13 Hoop a piece of sticky-back stabilizer for the second hooping.
14 Stitch the first two basting stitch markers on the stabilizer.
15 Place the fabric on the sticky stabilizer lining up the basting stitch markers on the 

fabric with those stitched on the stabilizer. Press the fabric into place.
16 Stitch the next repeat of the design.
17 Repeat the process until all repeats are complete.

Add basting 
stitch markers
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Tip: Inserting graphics for the physical reference markers could be substituted 
for the basting stitch markers. These can be aligned to the center of the design 
and the design and reference marker rotated as needed.

Related topics

 Add registration marks
 Print designs
 Save & export designs
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Chapter 24

MULTI-HOOPING

If your embroidery is too large or contains a 
number of designs spaced around an 
article, you can use the Multi-Hooping 
toolbox to split it into multiple hoopings.
The aim is to strategically position hoops 
until you obtain the least number of 
hoopings necessary to accommodate the 
whole design layout. These can be 
stitched consecutively to form the whole 
design. They can be sent directly to 
machine or saved to file.

Create multi-hoop designs

Hatch Embroidery provides a multi-hoop function which allows you to create 
multiple hoop positions. This means you can stitch out embroidery designs that are 
larger than can be accommodated within a single hoop. The aim is to add hoops 
and move them around until you get the least number of hoopings necessary to 
accommodate the entire design. These are then stitched out consecutively. Since 
a given stitchout can use only one size of hoop, you need to choose a hoop that 
will cover the largest object in the design.

Select a hoop

Click Customize Design / Context > Machine & Hoop Options to view hoop settings 
and set up custom hoop lists.

Click View > Show Hoop to show or hide hoop. Right-click for settings.

Click Context > Center All to center the whole design and hoop at the (0,0) position 
and display them in the design window.
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First choose the hoop you want to use via the View or Context toolbars. 
Alternatively, click Machine & Hoop Options or right-click the Show Hoop icon to 
access the Embroidery Settings dialog. Since a given stitchout can use only one 
size of hoop, you need to choose a hoop that will cover the largest object in the 
design, if not the entire design.

Related topics

 Hoop selection

Create automatic hoopings

The easiest way to work out hoop positions is with the Automatically Add Hoops 
tool. Bear in mind that this method uses a purely rule-based software algorithm. It 
works best with simple designs.

To create automatic hoopings...
1 It’s always a good idea to reduce the number of potential color changes in a 

design before creating automatic hoopings. You can either run the Optimize 

Use Multi-Hooping > Automatically Add Hoops to add hoops automatically to cover 
the entire design.

Use Multi-Hooping > Preview Hoopings to calculate object distribution and 
registration marks for given hoop positions and display hooping thumbnails in a 
docker. Clicking on one of the hooping thumbnails in the docker will only show that 
hooping in the design window.

Select 
available hoop
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Color Changes command or activate the color optimization setting in the 
Multi-Hooping tab. 

2 Use the Automatically Add Hoops tools to add hoop positions automatically. 
These are calculated according to the object sequence.

3 Use the Preview Hoopings tool to preview hoop positions in the Hooping 
Sequence docker. Click and hold to locate hoopings in the design window.

Preview hoop 
positions
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4 Hatch Embroidery always attempts to include whole objects within sequential 
hoopings. Where this is not possible, it will split objects between hoopings. 
Although split lines are only visible in Multi-Hooping, they are maintained when 
switching to other modes. They do not affect object integrity.

5 The same hoop position may be repeated, depending on the object 
sequence. Moving a hoop slightly to cover an excluded object may reduce 
repeat hoopings. Alternatively, try adjusting the stitching sequence.

6 Each hooping contains an object or group of objects that can be stitched out 
in a single hooping. These are stitched consecutively to form the whole design.

7 You are now ready to save the design to one or more files.
8 Optionally, print a copy of the design showing the hoop positions to help you 

stitch it in the correct hooping order.

Related topics

 Split objects between hoopings
 Print multi-hooped designs
Output multi-hooped designs

Create manual hoopings
When you enter multi-hooping mode, covered objects – those that fit wholly within 
a hoop – display as green stitches. Uncovered objects – those that do not fit – 
display as black stitches. If you are planning to add hoops manually, select a hoop 
outline, and drag it till it covers the largest object in the design. Click to access 
rotation handles, and rotate into position as necessary.

Note: It is important to reduce the number of potential color changes in a design. 
If you are adding hoops manually, it’s a good idea to first run color optimization.

Objects that fit 
within hoop appear 
in green
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Related topics

 Design colors

Add more hoop positions

Use the Add Hoop tools to add more hoop positions. As soon as a hoop is moved 
or joined by others, automatic centering is deactivated, meaning that the hoop 
no longer centers itself automatically around objects in the design.

Use Multi-Hooping > Add Hoop to add a new hoop to a multi-hooping layout.

Use Multi-Hooping > Add Hoop Right to place a new hoop position to right of the 
selected hoop. Allow 10mm overlap between sewing fields.

Use Multi-Hooping > Add Hoop Up to place a new hoop position above the selected 
hoop. Allows 10mm overlap between sewing fields.

Use Multi-Hooping > Add 4 Hoops Around to place four hoops around a selected 
hoop's perimeter. Allows a 10mm overlap between sewing fields.

Use Multi-Hooping > Add 8 Hoops Around to place eight hoops around a selected 
hoop's perimeter. Allows a 10mm overlap between sewing fields.

Add more hoop 
positions



Chapte r  24    Mu lt i - Ho op ing 547

Note: The Add Four Adjacent Hoops and Add Eight Hoops Around commands 
become available when a single hoop is selected in the design window. Clicking 
the associated icon causes four or eight hoopings to be added around hoop’s 
perimeter, starting from the top and continuing in a clockwise direction, with a 
10mm overlap between sewing fields.

Adjust hoop positions

Reposition additional hoops and, if necessary, rotate them so that they completely 
cover all objects in the design. Nudge selected hoops into position using the arrow 
keys. Use the Rotate Hoop buttons on the Context toolbar to rotate hoops in 15° 
increments or by a specified amount. Alternatively, click twice to activate rotation 
handles and drag to rotate. Use the Delete Hoop button to remove any unwanted 
hoopings.

Use Context > Rotate Hoop Left 15° to rotate the first hoop, or the currently selected 
hoops in multi-hooping mode, in 15° increments to the left.

Use Context > Rotate Hoop Right 15° to rotate the first hoop, or the currently selected 
hoops in multi-hooping mode, in 15° increments to the right.

Use Context > Rotate Hoop to rotate by a specified amount - positive or negative 
- in degrees.

Use Multi-Hooping > Delete Hoop to remove a selected hoop from multi-hoop layout.

Reposition and rotate 
hoops to completely 
cover all objects
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Note: While a design may be entirely covered by separate hoop positions, some 
objects may remain uncovered, as indicated by black stitching. The Add Splitting 
Line tool allows you to split objects that would not otherwise fit within a hooping.

Related topics

 Split objects between hoopings

Check manual hoopings

The following guidelines apply when manually placing hoops. The Automatically 
Add Hoops command optimizes hoop placement according to the current object 
sequence. It also attempts to optimize colors in each hooping. See also Create 
automatic hoopings.

Calculate hoopings

Click the Calculate Hoopings icon to evaluate the hoopings that will result from the 
current hoop layout. Bear in mind that a calculated ‘hooping’ is not necessarily 
the same as a ‘hoop position’.

Hatch Embroidery always preserves the original stitching sequence. However, 
hoop placements which follow the object sequence will reduce the number of 
calculated hoopings. The time taken to calculate hoopings depends more on 
number of objects and hoop positions than actual stitch count. Designs converted 
from EXP, PES, HUS, etc, will in general result in a larger number of objects than a 
native embroidery designs. Hence, these designs will take longer to calculate. 
However, even with pure EMB files, if the design is complex, large, and contains 
many hoop positions, calculation can take time.
The file is split into at least as many files as there are hoopings, depending on 
whether you have split some objects between hoopings. You are now ready to 
save the design to one or more files. See also Output multi-hooped designs.

Use Multi-Hooping > Calculate Hoopings to calculate hoopings that will result from 
current layout.
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Note: Print a copy of the design showing the hoop positions to help you stitch it in 
the correct hooping order. See also Output multi-hooped designs.

Check design sequence

Knowing the design object sequence helps you place hoops in the best possible 
hooping sequence. A good technique is to use the Sequence tool. As you select 
objects or color blocks from the list, they are highlighted in the design. This will help 
you understand the order in which objects are sewn, and hence the order in which 
they should be hooped.

Note: The Sequence docker cannot be used in Multi-Hooping mode, only in 
normal view. Thus, study the stitching sequence carefully before you attempt to 
multi-hoop the design.
Another useful tool is Stitch Player. When you run Stitch Player, you are checking to 
see if the start and end point of a particular object may have a bearing on the 
number of hoopings. For example, if you split a large object but the first half is in 
the second hoop, this may result in an additional hooping. With Stitch Player, you 
are aiming to make sure that any split objects are split between adjacent 

Use Edit Objects > Sequence >> to open the Sequence docker. Click again to close. 
Also available via Windows > Dockers menu.

Use View > Stitch Player to simulate embroidery design stitchout onscreen in either 
stitch or TrueView.

Study stitching 
sequence in relation 
to multiple hoopings
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hoopings (both in terms of position and hoop placement sequence) and that the 
object starts stitching in the earlier hoop.

Adjust design sequence
While correct hoop placements reduce the number of calculated hoopings, 
sometimes the design object sequence may not be ideal for multi-hooping. You 
may find that the only way to reduce the number of hoopings is to re-sequence 
the design itself. 

Usage tips
 Stock designs which have been created for a single hoop are generally 

sequenced by color in order to reduce the number of color changes. This is 
important for single needle machines.

 Enlarging a stock design to the point where it requires multiple hoopings may 
require the design sequence to be changed in order to reduce the number of 
hoopings.

 Since a given stitchout can use only one size of hoop, choose a hoop that will 
cover the largest object in the design.

 Always try to place hoops as near as possible to the order of the actual design 
object sequence.

Split objects between hoopings

With Stitch Player, see if 
you can split objects 
between adjacent 
hoopings

Use Multi-Hooping > Add Splitting Line to digitize one or more guides in a multi-hoop 
layout to split objects between hoopings.
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The Add Splitting Line tool allows you to split objects that would not otherwise fit 
within a hooping. In effect, it allows you to digitize one or more split lines in a 
multi-hooped design prior to outputting to file, machine or memory card. Splitting 
becomes necessary when, although a design is fully hooped, objects which are 
unable to fit within a single hooping still appear in black.

Digitize split lines in the normal way, using right-clicks for curves and left-clicks for 
corner points. As long as splits occur within the sewing field of overlapping 
hoopings, the resultant ‘split objects’ are displayed in green. Objects will not be 
split in the design file but they will be split on output. The split will not necessarily be 
along the digitized line. Instead, it will be made as inconspicuous as possible. The 
resulting objects will preserve their original object type, stitch angle, parameters 
and color.

Long stems not 
covered by 
hoopings

Objects not split in the 
design file but split on 
output
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Note: Although split lines are only visible in multi-hoop mode, they are maintained 
when switching to other modes. Split lines do not affect object integrity and you 
can still reshape and transform split objects as before.

Print multi-hooped designs

If there is more than one hooping in the design, you have the option of printing 
hoops in multi-hooping view in their correct color sequence. The Hooping 
Sequence option shows the objects in each hooping.

Note: When aligning a multi-hooped design for stitchout, make sure you know 
where the true center of the overall design is. This should guide you in the 
placement of your first hooping. Bear in mind that the center of the design will not 
generally coincide with the center of the first hooping. This is not a problem if you 
are stitching onto a piece of fabric which is to be cut and sewn onto something 
else. But if you are stitching directly onto a ready-made item, it is critical. To help in 
your placement of the first hooping, print out a worksheet which includes a 
background image of the article. See also Add backgrounds.

Use Output Design / Standard > Print Preview to preview design worksheet. Print 
from preview window.

Use Output Design / Standard > Print Design to print the current design.
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To print multi-hooped designs...
1 Select File > Print Preview.

2 Click the Options icon. Default view does not include hoop elements. Choose 
whether to include hoop, hoop template, and/or hoop position marker.

Optionally include 
hoop, hoop template, 
and/or hoop position 
marker
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Hoop template and hoop position marker are both selectable but you would 
probably choose one or other but not both.

3 Optionally, choose the Hooping Sequence checkbox.

Hoop, hoop template, 
and hoop position 
marker all included

Optionally, include 
hooping sequence
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You can choose to print the hooping sequence with or without the design 
worksheet itself included.

If you untick the thumbnails option, you will print a separate hooping per page 
at actual size.

Output multi-hooped designs

When working with designs that are larger than the available physical hoop, Hatch 
Embroidery will split them into parts, each containing an object or group of 
objects. When a multi-hooped design is output, each part is stitched separately 
after the fabric has been re-hooped. When outputting to machine file, 
multi-hoopings and split lines are applied. Hooping Sequence mode is activated, 
showing the separate hoopings.

Hooping 
sequence printed 
as thumbnails

Hooping 
sequence printed 
at actual size
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Note: When aligning a multi-hooped design for stitchout, make sure you know 
where the true center of the overall design is. This should guide you in the 
placement of your first hooping. Bear in mind that the center of the design will not 
generally coincide with the center of the first hooping. This is not a problem if you 
are stitching onto a piece of fabric which is to be cut and sewn onto something 
else. But if you are stitching directly onto a ready-made item, it is critical. To help in 
your placement of the first hooping, print out a worksheet which includes a 
background image of the article. See also Add backgrounds.

Hoopings vs output files
It is important to realize the numbers of hoopings in a multi-hooped design do not 
necessarily correspond to the number of output files. It all depends on the layering 
of objects within the design. In order to preserve the digitized stitching sequence, 
the same hooping may need to be visited more than once. Take the simple 
scenario illustrated here. Here we have one design with three objects and two 
hoopings. Object #1 gets stitched first. But then a change of hooping is required 
to stitch Object #2. To stitch Object #3, we need to return to our first hooping. 
That’s how we come to have more output files than we have hoopings.

Add registration marks

In order to help you correctly align multiple hoopings during stitchout, Hatch 
Embroidery can stitch out registration marks for each hooping. These do not form 
part of the design and are not saved with the design file. However, they are added 
during output and are viewable in the Hooping Sequence dialog.

Use Multi-Hooping > Multi-Hooping Options to change multi-hooping options in the 
Multi-Hooping tab of the Embroidery Settings dialog.

Hooping 1 Hooping 2

1
2

3
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To set registration marks

Click the Multi-Hooping Options icon to access the Multi-Hooping tab.

Choose Add registration marks and set a margin. The larger the margin, the 
greater the distance between the registration mark and the maximum 
embroidery area of the hoop. This makes it easier to align but there may be 
some trade-off in the precision of your registration.

Choose your preferred type of registration mark – 5-point or 6-point. 5-point 
marks will work for most machines and are easy to remove. 6-point marks are 
sturdier. They can also be used if the machine cannot stitch the 5-point mark.

 To check that registration marks have been added, activate the hooping list in 
Print Preview. 

Related topics

Multi-hooping settings
 Print multi-hooped designs

Usage tips
 Use the 5-point registration mark if possible as this will have fewer needle 

penetrations.
 Run a test on your machine to see how it manages the registration marks. 

Check whether...
 Threads are trimmed
 Threads are pulled out before the next registration mark.

Note: Some machines will pull the thread harder than others and hence the 
5-point may pull out when moving from one point to the next. In this case, try 
the 6-point.

 Do all registration marks appear on the machine interface? If not, change to 
the 6-point mark. These will have additional needle penetrations because your 
machine adds tie-ins and tie-offs. This is not something you can prevent but you 
can try turning off trims on the machine.

 It is important that your fabric does not stretch or warp when stitching. To 
achieve this, you must take extra hooping precautions.

Optionally, add 
registration marks 
and set margin
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 If using knit, stabilize the back first so it does not stretch.
 Use a sticky-back stabilizer or a good spray adhesive. Most recommend using 

a sticky-back tear-away stabilizer, heavy enough so that the registration marks 
do not tear the stabilizer. 

 Use pins through the registration marks of one hooping to align the 
corresponding marks of the next hooping.

Correct alignment of multi-hooped designs requires some practice. Training 
programs are available via Hatch Academy which demonstrate correct 
technique. 

Optimize color changes for auto-hooping

It is important to reduce the number of potential color changes in a design. You 
can manually run the Optimize Color Changes command for an entire design. 
However, if you activate color optimization in the Embroidery Settings > 
Multi-Hooping tab, color optimization is automatically applied to an entire design 
when generating automatic hoopings.

Related topics

Multi-hooping settings

Export multi-hooped design as machine files

When you want to output multi-hooped designs as machine files, you have a 
choice of using the Export Design function or writing designs to USB. In either case, 
you are prompted to split the design into separate files for each hooping. 

To save a multi-hooped design...
1 Create or open your multi-hooped design. See also Create multi-hoop designs.

Use Multi-Hooping > Multi-Hooping Options to change multi-hooping options in the 
Multi-Hooping tab of the Embroidery Settings dialog.

Use Output Design > Export Design to export the current design to a machine file for 
stitching.

Optionally, optimize 
color changes when 
adding hoops

https://academy.hatchembroidery.com/
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2 Click the Export Design icon. The Export Machine File dialog appears allowing 
you to browse to any folder.

3 Choose a machine file type from the droplist.
4 Change the export file name as required and choose a destination folder. The 

system checks that all embroidery objects are covered. You will be warned if 
they are not.

All hoopings needed to stitch the design are calculated and displayed in the 
Hooping Sequence dialog. Hoopings are named as files with the chosen file 

Export multi-hooped 
design as selected 
machine file
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extension. Any split lines which may have been applied are calculated and 
objects split between their respective hoopings.

5 Select a hooping and click Save Selected Now. Alternatively, click Save All Now 
to save all files in the list, named as indicated in the Hooping Sequence panel. 
Hatch Embroidery outputs the hoopings to their individual files.
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6 Optionally, click Zoom to Selected Hoop to view a closeup of each hooping. If 
you have activated registration marks, you will be able to see them clearly 
marked in red.

7 Click Close to return to the normal design window.

Stitch out multi-hoop designs
Each hooping contains an object or group of objects that can be stitched out on 
their own. Hoopings are stitched consecutively to form the whole design. They can 
be sent directly to machine or saved to file.

To stitch out a multi-hoop design...
1 Create a large design combining many design elements.
2 Add hoops via Multi-Hooping to cover each design element in the layout. You 

can use the automatic feature to generate hoopings even in large layouts. 
3 Optionally, include a background for the garment you are using. 
4 Print out the layout template from the software. Large layouts can be printed 

on small format printers and then pieced together. This establishes all hoops in 
the correct spatial relationship.

5 Fix the template to the garment. Remove the unnecessary pieces of the layout 
to isolate individual hoopings.

6 Hoop the fabric (or garment) and stitch out the first hooping. Registration marks 
are stitched last. Use the hoop position marker to locate and rotate the 
garment using the physical hoop template.
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7 Un-hoop the fabric.
8 Hoop a piece of sticky backed stabilizer and remove the protective paper.
9 Stitch the registration marks at the start of the next hooping onto the stabilizer.
10 Align the last-stitched registration marks with the marks on the stabilizer, and 

smooth the fabric onto the sticky back. To assist, stick sewing pins through the 
center of the registration marks.

11 Stitch the next hooping. 
12 Repeat until the design is complete.

Related topics

 Background articles
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PART X
HATCH ADVANCED

Appliqué is an important craft in home sewing, and the Appliqué toolbox provides 
an easy way to create high quality work. Automatically create all the stitching you 
need for most simple work using the available tools. If available, the Create 
Layouts toolbox lets you easily combine designs and design elements by inserting 
the contents of one file into another. You can also add to designs quickly by 
copying or duplicating existing objects. In some product levels, there are special 
tools to help you create larger design layouts as well as buttonholes.
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Chapter 25

APPLIQUÉ

Appliqué is an important craft in home sewing, and the Appliqué toolbox provides 
an easy way to create high quality work. Automatically create all the stitching you 
need for most simple work using the available tools. Up to four layers of stitching – 
placement lines, cutting lines, tack stitches and cover stitches – can be generated 
for any appliqué object, depending on current settings. Choose a fabric or plain 
color to assign to your appliqué patches.

Additionally, by using the Partial Appliqué tool, you can create overlapping 
appliqué objects with partial cover stitching without doubling-up borders.

Tip: Print a copy of appliqué patterns to use in cutting out fabric pieces. Each 
appliqué pattern piece in a Hatch Embroidery appliqué design is numbered 
according to the stitching sequence. See also Print designs.
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Digitize appliqué

Use the Appliqué tools to produce all the stitching 
you require for appliqué objects. Up to four layers of 
stitching – placement lines, cutting lines, tack 
stitches and cover stitches – can be generated. 
When you stitch out an appliqué object, the 
machine stops between layers. You can also set a 
frame-out position which shifts the hoop from under 
the needle, making it easier to place and trim 
appliqué patches. The object below has been 
broken apart to show four layers of stitching...

When you stitch out an appliqué object, the machine stops between layers. The 
table below summarizes each...

Element Purpose

Placement 
lines

These are the first appliqué layer to be stitched. Optionally, they are used to 
position pre-cut appliqué patches on the background material.

Cutting lines Cutting lines form a guide for trimming the fabric of an appliqué patch when 
using the ‘Trim-in-place’ style.

Generated appliqué 
includes up to four 
stitching layers
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Create appliqué objects

Use Digitize Appliqué to generate all the stitching you require for normal appliqué. 
Up to four layers of stitching can be generated. The digitizing method is the same 
as for normal closed shapes. 

To create appliqué objects...
1 Insert an image for use as a digitizing backdrop and click Digitize Appliqué. The 

Object Properties > Appliqué tab opens.
2 Define up to four layers of stitching – placement line, cutting line, tack and 

cover stitch.

Tack This is a zigzag or other stitch type placed after placement and cutting lines. 
It is to fix appliqué patches to the background fabric before cover stitching is 
applied.

Cover stitches Cover stitch is the border around an appliqué shape. You can control various 
settings including cover stitch type – Satin, Blanket, Zigzag, Run, or None.

Frame-out By default, a ‘frame out’ is automatically set to ‘Place under cover stitches’. 
During stitchout, it causes the hoop to shift out from beneath the needle, 
making it easier to place and trim appliqué shapes.

Use Appliqué > Digitize Appliqué to show Appliqué tab of Object Properties docker. 
Digitize appliqué objects with up to four layers of stitching – placement line, cutting 
line, tack stitches, and cover stitches.

Element Purpose

Appliqué tab divided into 
six functional areas – 
fabric, style, tack stitch, 
cover stitch, offsets, and 
frame-out
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Tip: Use Style settings to specify whether to pre-cut your appliqué or trim it in 
place. See Appliqué styles for details.

3 Digitize the appliqué boundary, marking reference points around the perimeter 
– left-click for corner points, right-click for curve points.

4 If you make a mistake, press Backspace to delete the last reference point. 
5 Press Enter to close the shape. 

Create appliqué with holes

The Digitize Appliqué tool digitizes normal appliqué objects with a single boundary. 
However, there may be instances where you want to create appliqué objects with 
one or more holes. For instance...

Use Appliqué > Digitize Appliqué with Holes to show Appliqué tab of Object 
Properties docker. Digitize appliqué objects with holes with up to four layers of 
stitching – placement line, cutting line, tack stitches, and cover stitches.

Appliqué with 
holes
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To create appliqué objects with multiple boundaries...
1 Select the Digitize Appliqué with Holes tool and digitize the appliqué boundary, 

marking reference points around the perimeter – left-click for corner points, 
right-click for curve points.

2 Press Enter. You will be prompted to digitize another boundary. 
3 When you have finished digitizing the second boundary, press Enter again to 

complete the process.
4 Double-click the object to edit object properties. 

Convert to appliqué

As an alternative to digitizing appliqué objects from scratch, you can convert 
regular embroidery objects of various types. Even vector objects can be 
converted to closed appliqué.

To convert to appliqué...
1 Use the Convert to Appliqué tool to turn closed embroidery objects to appliqué 

with up to four layers of stitching – placement lines, cutting lines, tack stitches, 
and cover stitches. Separate outlines will convert to separate appliqué 
objects...

Use Appliqué > Convert to Appliqué to use to convert selected closed objects into 
individual appliqués.
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2 Filled shapes with holes will convert to a single appliqué object with holes...

3 Double-click generated objects to access appliqué properties.

4 If you have chosen ‘Manual’ as your preferred frame-out option, the behavior 
of the Convert to Appliqué tool changes.

Access appliqué 
properties

Choose ‘Manual’ 
frame-out option
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5 A delimiting box appears around the object you are converting to appliqué. 
Follow the prompts in the Status bar at the bottom of the screen.

6 You will be prompted to enter three points – entry, exit, and frame-out position. 
Click to enter each one in turn or press Enter to accept the system defaults.

7 Use the Reshape tool on the Select toolbar to change the frame-out position as 
necessary.

Related topics

 Set frame-out position

Convert vector graphics to appliqué

Use Switch and Convert > Tag as Appliqué to tag selected vectors for conversion to 
appliqué embroidery.

Delimiting box 
appears around 
appliqué object

Manually enter entry, 
exit, and frame-out 
position
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In Graphics Mode, the Tag as Appliqué button allows you to tag selected closed 
vector objects for conversion to appliqué. This is available to customers have 
purchased CorelDRAW GEM for Hatch Embroidery or already have a compatible 
version of CorelDRAW software. 

To convert a vector graphic to an appliqué object...
1 Create or open a vector graphic in Graphics Mode and select it.
2 Click Tag As Appliqué. The object is tagged for conversion with a thick dotted 

outline. The CorelDRAW® Object Manager also indicates which objects have 
been tagged as appliqué.

3 Click Convert Artwork to Embroidery. Hatch Embroidery automatically converts 
the vector object to appliqué and switches to Embroidery Mode. 

Use Switch and Convert > Convert Artwork to Embroidery to convert selected vector 
artwork to embroidery objects.

Object appears 
with thick dotted 
outline

Red appliqué cover 
stitch generated

Fill color remains the 
same



Chapte r  25    Ap pl iqué 572

Note: When present, vector fill properties are maintained in Embroidery Mode 
to give the appearance of a fabric patch. Otherwise, fills are rendered in gray.

Note: The success of the conversion can be affected by font size as a 
proportion of cover stitch width. Where the cover stitch is too thick for the 
resulting object, it may be ignored.

Related topics

 Appliqué stitch settings
 Export cutting lines

Appliqué styles

You can specify whether to pre-cut your appliqué or trim it in place:

 Use the ‘pre-cut’ style if the appliqué shape has already been cut on an 
appliqué cutter or by some other means.

Pattern fill Texture fillGrey fill

Use Appliqué > Digitize Appliqué to show Appliqué tab of Object Properties docker. 
Digitize appliqué objects with up to four layers of stitching – placement line, cutting 
line, tack stitches, and cover stitches.

Use Appliqué > Digitize Appliqué with Holes to show Appliqué tab of Object 
Properties docker. Digitize appliqué objects with holes with up to four layers of 
stitching – placement line, cutting line, tack stitches, and cover stitches.
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 Use the ‘trim-in-place’ style if you want to cut the appliqué fabric on the 
machine.

To specify appliqué style...

 Select and double-click the appliqué object. The Appliqué tab is divided into 
six functional areas – fabric, style, tack stitch, cover stitch, offsets, and 
frame-out.

 Use the ‘pre-cut’ style if the appliqué shape has already been cut on an 
appliqué cutter or by some other means. This option includes a placement line 
as a guide to position pre-cut fabric patches prior to tack down. 

Check appliqué layers using the Stitch Player. Note that ‘pre-cut’ includes three 
elements – placement line, tack stitch, cover stitch...

Choose an 
appliqué style

Check pre-cut style 
with Stitch Player

Three elements –
placement line, tack

stitch, cover stitch
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 In addition to a placement line, the trim-in-place style adds a cutting line to 
hold fabric in place and provide a cutting guide. Use this option if you want to 
cut the appliqué fabric in place.

Appliqué stitch settings

The Object Properties docker gives you control over a number of appliqué settings. 
Use it to adjust the border around your appliqué shapes. Change cover stitches as 
preferred. Placement line and tack offset can be independently controlled. 
Control the orientation of any Blanket stitch you may use. Turn Automatic Corners 
on/off as preferred.

Fine-tune appliqué stitch settings

Trim-in-place style 
adds cutting line

Four elements – placement
line, cutting line, tack stitch,

cover stitch

Use Appliqué > Digitize Appliqué to show Appliqué tab of Object Properties docker. 
Digitize appliqué objects with up to four layers of stitching – placement line, cutting 
line, tack stitches, and cover stitches.
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The cover stitch is the border around an appliqué shape. You can control various 
cover settings including stitch type – Satin, Blanket, Zigzag, etc. Tack stitch, as the 
name suggests, secures the appliqué piece after it has been placed in position. 
Different usage scenarios require different settings. Carefully adjust them to 
achieve the desired outcome.

To fine-tune tack stitch settings...

 Select a tack stitch type as required – e.g. Run, Blanket, Zigzag, etc. Choose 
‘None’ to exclude altogether. If used, the choice of tack stitch will be 
determined by roughness of fabric edge and possibly weight. You have control 
over tack stitch width and spacing. Width is constrained by width of cover 
stitch, if used.

Use Appliqué > Digitize Appliqué with Holes to show Appliqué tab of Object 
Properties docker. Digitize appliqué objects with holes with up to four layers of 
stitching – placement line, cutting line, tack stitches, and cover stitches.

Select tack 
stitch type
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To fine-tune cover stitch settings...

 Select a cover stitch as required – e.g. Satin, Zigzag, etc. Choose ‘None’ to 
exclude altogether. You have control over cover stitch width and spacing.

 If you choose Blanket as cover stitch, an additional Orientation setting is 
available. This allows you to switch stitching orientation as shown...

Select cover 
stitch type

Switch Blanket
orientation as preferred
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To fine-tune offset stitch settings...

 Use Offsets to offset cover stitch relative to appliqué boundary – inside or 
outside. Tick the checkbox to lock placement line and tack offset to the cover 
stitch.

 Tack and placement line offset controls are also available when the checkbox 
is selected. Placement line and tack offset can be independently set.

 Flipping Blanket stitch orientation does not affect the offset relative to the 
digitized curve.

Offset ranges are constrained to ±10 mm.
 There is only one cover offset value rather than separate offsets for each cover 

type.
 The Partial Appliqué tool is disabled if a selection contains appliqué with a 

cover offset beyond ±½ the cover stitch width.
When saving to an earlier format, appliqué objects with a cover offset beyond 

the range ±½ width are first broken apart.

Appliqué fabrics

The Object Properties > Appliqué tab contains a Fabric panel which allows you to 
choose a fabric or plain color to assign to your appliqué patches. Each appliqué 
object in a design can have a different fabric. Choose from amongst the included 
‘factory’ swatches or choose a scanned sample of the fabric you want to use. 

Use Appliqué > Digitize Appliqué to show Appliqué tab of Object Properties docker. 
Digitize appliqué objects with up to four layers of stitching – placement line, cutting 
line, tack stitches, and cover stitches.

Use Appliqué > Digitize Appliqué with Holes to show Appliqué tab of Object 
Properties docker. Digitize appliqué objects with holes with up to four layers of 
stitching – placement line, cutting line, tack stitches, and cover stitches.

Fine-tune offsets of 
components relative 
to appliqué boundary
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To place a fabric...
1 Double-click or right-click an appliqué object.

2 Click Appliqué Fabric. The dialog opens. Choose a fabric or plain color in the 
dialog to assign to your appliqué patch.

Choose fabric or plain 
color to assign to 
appliqué patch



Chapte r  25    Ap pl iqué 579

3 Alternatively, use the Custom setting to select from a range of installed fabric 
swatches in the Hatch Pictures folder.

4 Use the Appliqué Fabric toggle to turn appliqué fabrics/colors display on/off.

Set frame-out position

Use Appliqué > Frame-out Options to access frame-out options in the Appliqué tab 
of Embroidery Settings dialog.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.

Alternatively, 
assign fabric 
sample to appliqué 
patch

Turn on appliqué 
fabric to view
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In Hatch Embroidery, the ‘frame-out’ is placed under appliqué cover stitches by 
default. You can select frame-out markers in Reshape mode and reposition as 
needed. 

On some machines, wherever the frame (hoop) moves, the needle will form a 
tie-off. When it starts up again, it will add a tie-in. To avoid unwanted needle 
penetrations and ‘knots’ appearing in your fabric, various presets are available via 
Frame-out Options.
Use the ‘place under cover stitches’ option (the default) when you don’t want to 
move the needle at all. This conceals unwanted tie-ins and tie-offs. In addition to 
automatic frame-out, you have the option of setting it manually. If you choose 
Manual, you are prompted to digitize a frame-out after pressing Enter. This may be 
desirable where the hoop attaches to the machine. 
Depending on your machine type, specific functions may be needed to initialize 
the machine or trigger a frame-out. Frame-outs are specified as ‘Stop’ or ‘Color 
Change’ functions...

Tip: While Hatch Embroidery allows you to turn on or off trims and tie-offs, some 
machines will override this whenever they encounter a color change.

Related topics

 Appliqué settings

Use Select > Reshape to reshape an object shape, edit stitch angles, or adjust entry 
and exit points.

Reposition frame-out 
marker as needed

Alternative 
frame-out presets

Choose required 
frame-out function
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Automatic corners for appliqué

Automatic Corners work with appliqué. You can turn the effect on/off in both 
appliqué and normal embroidery.

Combined appliqué

Frequently, an appliqué design will contain 
two or more appliqué objects. Each object 
can be assigned its own fabric. Where objects 
overlap, borders can be removed to avoid 
doubling-up. Generally you will want to stitch 
out appliqué elements together rather than 
object-by-object. For instance, it is more 
efficient to stitch out all placement lines, tack 
stitching, and cover stitching together. To 
achieve this you have a choice of breaking 
apart appliqué objects and resequencing 
elements as you wish, or allowing Hatch 
Embroidery to resequence elements for you.
That said, always take into consideration the 
fabric you are stitching on and the size of 
appliqué. While it is more efficient to stitch all 
elements together, if the design is large and the fabric tends to stretch, this 
technique may create too much pull-push effect. In these situations, you will want 
to complete each appliqué before moving to the next. This should be taken into 
consideration as part of your design plan before digitizing.

Use Context > Automatic Corners to turn automatic corners on or off. When turned 
on, the corners in line objects will be mitred or capped automatically depending on 
how sharp the corner turns. Can be turned on or off on an object by object basis.

Apply Automatic 
Corners to appliqué 
as preferred
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Remove overlaps

Use the Remove Overlaps tool to remove 
underlying layers of stitching in overlapping 
objects. This helps to reduce the stitch count 
and prevent a build-up of stitches where 
they are not needed. See also Holes.

Partial cover appliqué

Using the Partial Appliqué tool, you can create overlapping appliqué objects with 
partial cover stitching without doubling-up borders. The lower layers will have 
partial appliqué applied to them. 

To create partial cover appliqué...
1 Select overlapping appliqué objects.

2 Click the Partial Appliqué tool. Cover stitches are removed where objects 
overlap, leaving only the secondary objects – tack, placement and cutting 

Use Appliqué > Remove Overlaps to remove stitches that are covered by the 
selected objects. Overlap value can be changed in the Overlap tab of Embroidery 
Settings dialog.

Use Appliqué > Partial Appliqué to remove unwanted cover stitching from underlying 
appliqué objects.

Select appliqué 
objects to apply partial 
cover stitching
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lines. In the image below, the lower layer has been temporarily moved to better 
view the partial cover.

Note: The cutting object for partial appliqué does not have to be an appliqué 
object itself.

Tip: To revert partial appliqué to regular appliqué, select the object and click 
the Digitize Appliqué with Holes tool. Press Enter to confirm.

Combine appliqué

Use Appliqué > Combine Appliqué to break apart appliqué into component objects 
and recombine and resequence for efficient stitchout.

Cover stitches 
removed where objects 
overlap

Cutter does not 
have to be 
appliqué
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The Combine Appliqué tool breaks apart multiple appliqué objects into their 
components – placement lines, cutting lines, tack stitches and cover stitches – and 
combines and resequences them for efficient stitchout. The end result is that the 
placement line for all appliqué objects is stitched in a single pass, followed by the 
tack stitch and then cover stitch. A single frame-out movement occurs after 
placement line and tack stitch components. A message warns that the appliqué 
objects will be broken apart. It’s a good idea to save a copy of the design before 
proceeding.

Note: The Combine Appliqué tool is disabled when non-appliqué objects are 
included in the selection.

Break apart appliqué

If you want more control when combining appliqué objects, you may prefer to use 
the Break Apart tool to break apart multiple appliqué objects and resequence 

Use Edit Objects, Appliqué or Lettering / Monogramming > Break Apart to split 
composite objects – monograms, appliqués, lettering, etc – into components. Allows 
each to be edited individually. This tool is also available via Edit menu.
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manually. This method also allows you to insert non-appliqué objects into the 
stitching sequence which cannot be done via the Combine Appliqué method.

Break apart multiple 
appliqué objects to 
resequence 
manually
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Chapter 26

DESIGN LAYOUTS

If available, the Create Layouts toolbox lets you easily combine designs and 
design elements by inserting the contents of one file into another. You can also 
add to designs quickly by copying or duplicating existing objects. Group selected 
objects or entire designs to keep them together for moving, scaling or transforming 
purposes. In some product levels, there are special tools to help you create larger 
design layouts as well as buttonholes.

The Ambience Quilting feature is used to create ‘echo’ quilting designs. Quickly 
create outline stitching around selected objects or entire designs with Single, Triple 
or Satin Line. Explore the topics in this section.
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Mirror-copy objects

The Mirror-Copy tools allow you to duplicate and transform selected objects, as 
well as merge them into a single object. Use them to create wreaths or decorative 
borders. Or use them to create perfectly symmetrical objects.

Mirror selections horizontally & vertically

Use Create Layouts > Mirror-Copy Horizontal to mirror and copy selected objects 
horizontally. 

Use Create Layouts > Mirror-Copy Vertical to mirror and copy selected objects 
vertically. 

Use Create Layouts > Mirror-Copy Both to mirror and copy selected objects around 
a center point.

Use Context > Outline to outline closed shapes with the current outline stitch type. 
Right-click for settings.
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Use the Mirror-Copy Horizontal or Vertical tools to duplicate and mirror selections 
simultaneously. Simply select objects and click a tool to duplicate and mirror in any 
plane. Move the pointer to position duplicates. Click or press Enter to confirm.

If duplicates overlap the original, you are prompted to merge them. Use this 
feature to merge duplicates into a perfectly symmetrical object. Apply Context > 
Outline to apply the current outline stitch to create outlined shapes.

Usage tips
 Press Esc to cancel the operation.
 Use the Branching tool to automatically sequence and group selected 

embroidery objects in a single selectable object. See Branching for details.

Use Mirror-Copy tools to 
duplicate and mirror 
selections simultaneously

Mirror and merge 
duplicate objects
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Create multiple reflections

Use the Copy Reflect tool to duplicate and mirror designs simultaneously. Set any 
number of rows or columns. The feature is often used in making fashion or textile 
designs. The limit for allowable wreath points is 100. 

To create reflected objects...
1 Select the object or design.
2 Click the Copy Reflect icon. The Context toolbar appears.

3 Adjust the number of columns and rows required. Enter them directly or use the 
droplists.

Use Create Layouts > Copy Reflect to duplicate and mirror objects or designs. Use 
to create decorative borders.

Use Context 
controls to set row 
and column counts
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4 Move the pointer to position duplicates. Click or press Enter to confirm.

Usage tips
 Press Esc to cancel the operation.
 Press Shift to disable Auto-Scroll while using Copy Reflect. See Auto-scroll 

behavior for details.

Create wreaths

Use the Circle Layout tool to duplicate objects around a center point. The Mirror 
Alternate toggle mirrors the selection as well. 

To create wreaths...
1 Select the object or design.

Use Create Layouts > Circle Layout to duplicate selected objects around a center 
point. Specify how many copies and if alternate copies are mirrored in the Context 
toolbar.

Click to generate 
pattern array
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2 Click the Circle Layout icon. The Context toolbar appears.

3 Enter the number of wreath points. Enter them directly or use the droplist.
4 Move the pointer to position duplicates. Hold down Ctrl to constrain the 

reference line to 45° increments.
5 Click to mark the reflection point or press Enter to confirm. The selection is 

duplicated and distributed around the center point.

Usage tips
 If the duplicates overlap the original, you are prompted to merge objects.

Enter number of 
wreath points

Selection duplicated 
and distributed 
around center point
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 If you enter an even number of wreath points, the Mirror Alternate toggle is 
activated. This allows you to mirror duplicates.

 Press Esc to cancel the operation.
 Press Shift to disable Auto-Scroll while using Copy Reflect. See Auto-scroll 

behavior for details.

Create design arrays

Use the Copy Array tool to create multiple copies of designs, such as badges, 
spaced in rows and columns for faster stitchouts.

Use Create Layouts > Copy Array to duplicate designs, such as badges, 
automatically resequencing color blocks for efficient multiple design stitchouts.

Enter even number 
of wreath points to 
use Mirror Alternate
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To create design arrays...
1 Select the object or design.

2 Click the Copy Array icon. The Context toolbar appears. As you move the 
pointer, duplicate outlines move accordingly.

3 Set the number of columns and rows.
4 Move the pointer to position duplicates.

Use Context 
controls to set 
row and column 
count
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5 Click to mark the anchor point or press Enter to confirm. Color blocks are 
automatically sequenced to eliminate unnecessary color changes.

Usage tips
 Press Esc to cancel the operation.
 Press Shift to disable Auto-Scroll while using Copy Reflect. See Auto-scroll 

behavior for details.

Work areas

The Work Area feature allows you to arrange multiple embroidery elements on an 
item or fabric to be sewn. Elements are copied, rotated and placed in a 
pre-defined work area. You can also print out the layout with Reference Markers. 
Use them to physically lay out designs on the item or fabric you wish to embroider. 
You can also print a template to position each of the hooped portions of the 
design.

Note: When used in conjunction with the Multi-Hooping toolbox, you can place 
multiple hoops around a single layout. See also Multi-Hooping.

Define work area

Color blocks 
sequenced for 
efficient stitchout

Use Create Layouts > Define Work Area to define the shape, size, color and view of 
the work area.
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Before you can create a design layout, you first need to define a work area 
corresponding to the item or fabric you intend to sew on. Work areas can be 
defined as rectangular or circular spaces. Hatch Embroidery allows you to define 
a work area up to 3m x 3m.

To define a work area...
1 Click the Define Work Area button to open the dialog.

2 Select a rectangular or circular work area and enter the dimensions.
3 Set a background color for the layout matching the fabric you intend to use.
4 Make sure Show Work Area is activated.
5 Insert and size artwork or embroidery design as required.

Use Customize Design / Standard / Create Layouts > Insert Design to insert an 
existing embroidery design into the current design. This tool is also available via File 
menu.

Use Create Layouts > Auto Center to Work Area to automatically move selected 
object/s to center of the work area (0,0).

Define size and 
shape of work 
area

Click Auto Center 
to center design in 
work area
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6 With the design or artwork selected, click the Auto Center tool and press Enter 
to center it in the work area.

Activate work area

Use the Show Design droplist to activate or deactivate the work area as needed. 
A W shortcut key is also available to toggle the work area on or off.

Create rectangular layout

Create rectangular layouts with selected design/s and/or object/s. Designs are 
automatically copied, rotated and placed in the work area.

To create rectangular layout...
1 Define your work area according to purpose.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.

Use Create Layouts > Mirror-Copy to Work Area to automatically mirror and copy 
selected object/s around the center (0,0) of the work area.

Use Create Layouts > Auto Center to Work Area to automatically move selected 
object/s to center of the work area (0,0).

Activate work area
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2 Insert a design, size it, and position it within the work area. Use Auto Center to 
Work Area if you want to center it in the work area.

3 Add the second design element, size it, color it, and position carefully within the 
work area.

Insert design, size, 
and center within 
work area

Add another design 
element and position 
within work area
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4 Select the Mirror-Copy to Work Area method. Each copy is mirrored about the 
vertical or horizontal plane. Press Enter to confirm.

5 Press Enter to confirm.

Copy and mirror to 
extremities of work 
area
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6 Insert or create additional design elements as required.

Tip: If you want the selected objects to sew out in separate hoopings, make sure 
they are grouped before proceeding. Otherwise, they will be color-optimized 
for a single stitchout – i.e. color-block by color-block.

Create circular layout

Instead of the Mirror-Copy to Work Area method, try defining a circular work area 
and using the Circle Layout method to mirror ornaments around the perimeter. The 

Use Create Layouts > Define Work Area to define the shape, size, color and view of 
the work area.

Use Create Layouts > Circle Layout to Work Area to automatically create copies of 
selected object/s (specified by Number of Copies in the Context toolbar) around 
center of the work area. 
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technique is essentially the same, except that you can specify the number of 
copies in a spin box.

Press Enter to confirm. Insert or create additional designs as required.

Specify number
of copies

Position source 
object within work 
area

Design element 
duplicated around 
circular work area



Chapte r  26    Design Layo uts 601

Optimize color changes

Once you have created your layout, check the stitching sequence using the 
Travel tools and/or Sequence docker. The Mirror-Copy functions will not optimize 
the color changes for you.

If you combine designs or design elements, you will also want to ensure that 
like-colors are sewn together. The Sequence docker provides various techniques 
for sequencing objects or entire color blocks. See also Split objects.

Buttonholes

Hatch Embroidery allows you to insert preset buttonholes. You can specify their size 
and merge them into a design. Buttonholes are usually formed with satin column 
stitches bordering a slit that is slightly longer than the length of the button diameter, 

Use Edit Objects > Sequence >> to open the Sequence docker. Click again to close. 
Also available via Windows > Dockers menu.

Use Sequence > Sequence by Color to resequence selected color blocks in the 
Sequence docker toolbar. Hold down <Ctrl> and click colors to select.

Use Sequence by
Color to optimize

stitching sequence
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depending on the thickness of the button. The satin stitch border protects the slit 
from fraying. The buttonhole consists of a bead of satin stitches with a bar tack.

Add buttonholes

Add a line of evenly spaced buttonholes to a design with the Add Buttonholes tool.

To add buttonholes...
1 Open or create a design requiring buttonholes. Or open a product backdrop.
2 Select the Buttonholes tool.

Use Create Layouts > Buttonholes to show Buttonholes tab of Object Properties 
docker. Use the Place Buttonholes button to place a string of buttonholes with all the 
necessary stitching.

Choose from 
palette of 
buttonhole types

Adjust buttonhole 
characteristics
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3 Enter the number of the buttonholes your design requires and click Place 
Buttonholes.

4 Click to place the first buttonhole and drag a line – horizontal or vertical – to the 
last buttonhole position.

5 Use the measure tooltip as a guide and click to complete.
6 Buttonhole orientation can be adjusted in Object Properties.

Change buttonhole settings

Buttonhole types can be changed at any time. They are simply properties of a 
buttonhole object. Other properties include ‘slit length’ as well as stitch spacings.

Use Edit Objects > Object Properties to show Object Properties docker. Use to preset 
properties for new embroidery objects or adjust properties for selected embroidery 
objects.

Drag horizontal or 
vertical line to place 
buttonholes

Set buttonhole 
orientation
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To change current buttonhole type...
1 Double-click a buttonhole object to open Object Properties.
2 Click to select a preferred type from the gallery.

3 Adjust slit length according to your button size.

4 Adjust bead stitch spacings as preferred. Different values are available for 
different buttonhole types. For some, independent settings are available for 
bead stitch and end stitch spacing.

Adjust bead and
end spacing
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Quilted embroidery

Hatch Embroidery provides tools and 
techniques for expanding flat embroidery 
surfaces into raised or ‘sculpted’ surfaces.
Quilting creates dimension by stuffing or 
filling areas to produce a raised surface. 
The quilting feature consists of two 
components: Raised Satin to create ‘puffy 
embroidery’, and Trapunto Outlines to turn 
puffy embroidery designs into trapunto 
designs.
The Outlines & Offsets tool is sometimes used 
to create ‘echo’ quilting designs. However, 
there are limitations with this method. The 
Ambience Quilting feature provides a 
better alternative.

Trapunto embroidery

Quilted embroidery creates dimension by 
stuffing or filling areas to produce a raised 
surface. It employs a technique known as 
‘trapunto’, also referred to as ‘stuffed 
embroidery’. There are a number of techniques 
for creating trapunto designs.

Trapunto techniques
Traditional hand trapunto involves sewing two 
layers of fabric together with a motif outline. The 
underside is then slit and stuffed with yarn or 
cotton. Another technique – sometimes called 
machine trapunto or cut-away trapunto – is to 
mark the design pattern on top of the quilt fabric 
with a water soluble marker. A layer of batting is 
then pinned to the underside of the fabric and 

Use Object Properties > Outline > Raised Satin to create raised satin borders – can 
be used with trapunto for quilting effects.

Use Object Properties > Fill > Raised Satin to create raised surfaces – can be applied 
to lettering or used with trapunto for quilting effects.

Use Create Layouts > Create Trapunto Outlines to use in conjunction with Raised 
Satin to create stitching for a raised 'quilted' look.
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two layers are stitched together. The batting is trimmed close to the stitching to 
create the embossed design. The quilt is then constructed by sewing the quilt top 
to the quilt back with another layer of batting in between.

Raised satin
Yet another technique is to use layers of thread instead of stuffing or batting to 
create dimension. The embroidery design consisting of multiple layers of satin 
stitching is first stitched onto Aqua Mesh water-soluble stabilizer. Then a top and 
bottom layer of fabric are added before the final outline is stitched around the 
design. Recommended settings for best loft are 0.36mm manual for satin spacing 
with 3 layers.

Quilting design work relies on two main tools:

 Raised Satin: This allows you to create ‘puffy embroidery’. Outlines can be used 
for lettering and special calligraphy effects.

 Trapunto Outlines: This allows you to turn puffy embroidery designs into trapunto 
quilting designs.

The puffy embroidery component allows you to create raised embroidery 
consisting of multiple layers of satin stitches. This is as an alternative to stuffing with 
yarn or batting. The trapunto component allows you to stitch layers of fabric over 
the raised satin. The Trapunto Outlines feature is used exclusively with Raised Satin 
to create a ‘quilted’ look. When activated, this feature always defaults to the next 

Use Raised Satin as 
batting for puffy 
embroidery
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unused color so as to force the machine to stop before trapunto outlines are 
stitched. This allows you to place the covering fabric.

Study the quilting design included in the designs folder. Try stitching it out to 
practice the techniques involved. Check your machine documentation.

Ambience quilting

Open the design you want to include within a quilting block. The Ambience 
Quilting feature is activated when the design window contains one or more 
embroidery objects.

To generate quilting stitch...
1 Specify your preferred measurement system – metric or US. You can, if you 

prefer, specify measurements on the fly by typing the value and unit of measure 
– e.g. ‘mm’ – directly into the field.

Use Context > Measurement Units to change measurement units within software 
without changing operating system settings.

Use Create Layouts > Ambience Quilting to use to create 'echo' quilting designs.

Create trapunto 
outlines for 
quilting
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2 Click Ambience Quilting. The dialog is grouped into four functional areas: Block 
Size, Design Size, Stitching, and Block Center.

3 Set your quilt block size in the Block Size panel.
4 Height and Width fields define the boundary used to generate the echo 

pattern. Lock proportions with the Proportional Sizing checkbox. The Design Size 
panel displays height and width of the embroidery design as a reference when 
defining the block size.

5 Use the Stitching panel to determine stitching characteristics:

6 Use the Block Center panel to center the design within the quilting block:

7 Click OK to generate stitching.

Parameter Description

Quilting type Choose from a variety of quilt patterns: Echo, Scroll, etc.

Design margin Set gap between echo quilting and the design.

Block margin Set gap between echo quilting and the block boundary.

Line spacing Set distance between each quilting line or loop spacing for the stipple 
fill.

Color Choose a color for generated quilting stitches. The default is the last 
color used in the design.

Parameter Description

Use design 
center

Place the design at the center of block outline and generate the quilt 
pattern around it.

Digitize center Digitize the quilting block center. Choosing this option attaches an 
outline of the block size with cross hairs to the cursor. Left-click to 
place the block center where you choose on the design, and generate 
the quilt pattern around it.

Four functional areas: 
Block Size, Design 
Size, Stitching, and 
Block Center
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Tip: All spatial controls can switch between millimeters and inches, depending 
on the chosen measurement system.

Quilting types

There are three basic types of quilting stitch – Echo, Scroll, and Stipple.

In all cases, generated stitching starts with the shape of the center design and 
radiates out to the boundary defined by the block size – usually somewhere 
between 8" and 12". On the face of it, Echo and Scroll produce similar results. Turn 
on connectors to see the difference...

Echo stitching generates separate lines around the design. Each line is tied off and 
trimmed. Scroll, on the other hand, produces one continuous stitching line with 
jumps between separate quadrants of the design. Generally, Scroll produces a 
more efficient stitchout.

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.
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With Echo or Scroll clipping, the outer edges of the radiating stitching are clipped 
at the outside boundary of the block. Both methods produce a similar number of 
tie-offs and trims.

Raised embroidery

In addition to normal satin stitching, Hatch Embroidery 
also provides raised satin, both for outlines and fills. The 
resulting embroidery consists of multiple layers of satin 
stitching which adds dimension and a raised tactile 
surface to your designs. Of course it also uses a lot 
more stitches.
There are a number of techniques for creating 
trapunto designs. Traditional hand-trapunto involves 
sewing two layers of fabric together with a motif 
outline. The underside is then slit and stuffed with yarn 
or cotton. Another technique is to use Raised Satin 
instead of stuffing or batting in order to create 
dimension.

Create Raised Satin

Typically, Raised Satin is used to create extra body in narrow satin objects for visual 
effect and to provide a raised or ‘sculpted’ surface. It is used to mimic the padded 
satin stitch which is manually done on machine. It can also be used with delicate 

Use Object Properties > Fill > Raised Satin to create raised surfaces – can be applied 
to lettering or used with trapunto for quilting effects.

Use Object Properties > Outline > Raised Satin to create raised satin borders – can 
be used with trapunto for quilting effects.
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handcraft- and heirloom-type designs. When done by hand, these all employ a 
narrow satin padded fill.

Use Raised Satin outline for narrow lines of even width.

Raised Satin is best applied to objects 7mm wide or less. This is a safe average for 
most machines. Indicative settings for best ‘loft’ are 0.30mm manual for satin 
spacing with 3 or 4 layers. Or rely on Auto spacing for most object shapes.

Caution: The width of a raised satin object must be less than maximum width your 
machine can stitch. This will be different for some machines. If in doubt, refer to 
your machine documentation.

Create trapunto outlines

Traditionally, quilted embroidery creates dimension by stuffing or filling areas to 
produce a raised surface. It employs a technique known as ‘trapunto’, also 

Use Create Layouts > Create Trapunto Outlines to use in conjunction with Raised 
Satin to create stitching for a raised 'quilted' look.

Use Raised Satin to create
extra body in satin objects

Indicative Raised
Satin settings
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referred to as ‘stuffed embroidery’. A similar effect can be achieved using two 
software tools:

 Raised Satin: This allows you to create ‘puffy embroidery’ as an alternative to 
stuffing with yarn or batting.

 Trapunto outlines: The trapunto component allows you to stitch layers of fabric 
over top.

The Create Trapunto Outlines feature is used exclusively with Raised Satin to create 
a ‘quilted’ look. When activated, this feature always defaults to the next unused 
color so as to force the machine to stop before trapunto outlines are stitched. This 
allows you to place the covering fabric. 

To create trapunto outlines...
1 Digitize the design using Raised Satin and select all objects you want to include.

2 Use the Create Trapunto Outline tool to create trapunto outlines. Preset color, 
offset, and outline type as preferred.

Digitize design 
using Raised Satin

Trapunto outlines 
generated
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3 Stitch the design on a backing fabric or heavy cutaway stabilizer.
4 Next, cover the design with the main fabric and stitch the trapunto outline.
5 Trim the stabilizer or backing close to the design stitching on the back.

Outlines & offsets

Hatch Embroidery provides tools for 
quickly generating outlines based on 
existing boundaries. Use the Outlines & 
Offsets tool to highlight details – e.g. small 
satin objects – or create seamless borders. 
Auto-outline designs in backstitch, 
stemstitch, pattern run, as well as 
sculpture stitch and zigzag. Any closed 
shape can be used.

Create outlines

The Outlines & Offsets feature allows you to quickly create outline stitching around 
selected objects or entire designs with a variety of outline styles.

Use Create Layouts > Create Outlines & Offsets to create outlines and offsets for 
selected embroidery object(s).
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To create outlines...
1 Select the source object or objects.

2 Click the Outlines & Offsets icon. The dialog opens. This dialog allows you to add 
outlines and offsets in a single process.

3 Tick Object outlines.
4 Choose your outline type. The Type droplist includes the full range – Single Run, 

Triple Run, etc.
5 Choose your outline color. The Color droplist defaults to the current color in the 

design palette.

Select source 
object

Add outlines in 
single process
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6 Choose an overlap option:

7 Click OK to apply. Hatch Embroidery generates an outline around the source 
object/s and inserts them immediately afterwards in the stitching sequence.

8 Generated outlines are independent objects and can be further modified as 
desired.

Create offsets

 Select the source object/s if not already selected.

Outline type Notes

Individual All generated outlines are full outlines.

Common Intersecting outlines are combined into a single outline.

Trimmed Overlapped portions are trimmed by overlapping objects.

Use Create Layouts > Create Outlines & Offsets to create outlines and offsets for 
selected embroidery object(s).
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 Tick Offset outlines.

 Select color and stitch type as for object outlines.
 In the Offset Count field, enter the number of offset objects required, and enter 

an offset in millimeters. When you set multiple borders, the offset you specify is 
calculated from the previous border. The offset determines spacing between 
all borders.

Choose an offset option:

Click OK to apply. Hatch Embroidery generates offset objects and adds them 
to the end of the stitching sequence.

Offset type Notes

Individual All generated offsets are full outlines.

Common Intersecting offsets are combined into a single outline.

Add offsets in 
single process
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Generated offsets are independent objects and can be further modified as 
desired.

 Include holes as preferred.

Tip: You can use the Outlines & Offsets tool with open objects to create closed 
offsets as shown. Select rounded or squared corners as preferred.

Laydown stitch

The Laydown Stitch feature automatically generates a light fill to flatten the nap of 
textured fabrics like terry toweling and fur so that embroidery is not lost in the nap. 
An example would be the creation of a monogrammed terry toweling bath robe. 
The tool includes a new stitch type that can have one (1) or two (2) layers with 
adjustable stitch spacing, length and angle.
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Generate laydown fills

The Laydown Stitch feature automatically generates a light fill to flatten the nap of 
textured fabrics like terry toweling and fur so that embroidery is not lost.

To create a laydown fill...
1 If you intend to create a laydown fill for an entire design, simply click the 

Laydown Stitch icon. Alternatively, select a specific object or objects first.

2 Choose a laydown offset – e.g. 2mm. This allows a margin between selected 
object/s and layout boundary.

3 Choose a laydown style:

Use Create Layouts / Context > Laydown Stitch to generate a light fill to flatten the 
nap of textured fabrics like terry toweling and fur for subsequent embroidery.

Choose 
laydown style

Choose 
laydown offset

Choose 
between one or 
two layers

Choose 
laydown stitch 
color
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 If Offset shape is selected, a laydown fill will be generated conforming to the 
boundary of the design or selected object/s. Optionally, include holes if you 
want the nap to show through the non-embroidered sections.

 If Standard shape is selected, choose one from the border gallery.

Note: When using Standard Shapes, some irregular shapes may cause a larger 
offset than expected. Once created, you can select and resize the shape to 
the desired size.

Holes excluded Holes included



Chapte r  26    Design Layo uts 620

4 Choose the number of layers you want to include in the laydown fill. This will 
depend on the density of the fabric nap.

5 Adjust the Spacing and Length settings for a more or a less dense fill. This again 
will depend on nap density.

Note: If 2 layers is selected, the second layer will take the same stitch settings as 
the first but the stitch angle will be determined by Angle 2.

6 Optionally, adjust opposing angle settings if using two layers of stitching. The 
default is 90° (perpendicular).

Tip: Laydown stitch angles can be adjusted at any time via the Object 
Properties > Fill tab. The Stitch Angle setting under the Stitching tab has no 
effect on laydown stitching.

One layer Two layers

More dense fill Less dense fill

Adjust angle 
difference between 
opposing layers
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7 Choose a laydown stitch thread from the Color droplist. Generally, you will want 
your laydown fill to blend with the intended fabric. Alternatively, if you choose 
a standard border shape for instance, you may want to highlight the shape in 
a contrasting color.

8 Optionally, click Preview to generate the fill without closing. Move the dialog as 
necessary. Persist until you are happy with the result. 

9 Click OK to confirm and regenerate. The resultant laydown object is placed at 
the start of the stitching sequence.

Note: Laydown Stitch ignores motif shapes when generating stitching for motif 
outlines or borders in monogramming objects. Instead, stitching is generated 
based on the object outline. You may need to manually resize to obtain the 
result you want.

Caution: Laydown Stitch can also be applied to keyboard design collections. 
However, it may not always give you the desired effect, particularly if letters 
contain a lot of open spaces. Sometimes you can increase Laydown Stitch 
offset to obtain the desired effect.

Laydown fill placed 
at start of stitching 
sequence

Laydown fill generated 
within object outline

Laydown fill resized to 
cover motif border



Chapte r  26    Design Layo uts 622

Related topics

Monogramming
 Use KDCs as lettering fonts

Create laydown fills manually

As an alternative to the Laydown Stitch tool, use manual digitizing techniques to 
create shapes and fill them with the Laydown Stitch type available from the Fill tab 
of the Object Properties docker.

Use Digitize > Digitize Closed Shape to create closed shapes using either outline or 
fill stitching. Left-click for corner points, right-click for curves.

Use Context > Fill to fill closed shapes with the current fill stitch type.

Use Object Properties > Fill > Laydown Stitch to generate a light fill to flatten the nap 
of textured fabrics like terry toweling and fur for subsequent embroidery.

Choose Laydown 
stitch fill type

Adjust stitch settings 
as necessary
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Stitch settings
Object properties are the same as stitch settings available in the Laydown Stitch 
dialog. Adjust density for lighter or heavier naps. In two-layer fills, default stitch 
angles are set at 90° (perpendicular) to each other. Adjust as preferred.

Other settings
Any object with laydown stitch type will also have the Connectors, Automatic Trims 
and Auto Jump settings available in the Stitching tab of Object Properties docker. 
In Reshape mode, you can adjust object boundaries as well as entry and exit 
points.

Note: The Stitch Angle setting under the Stitching tab has no effect on laydown 
stitching. Stitch angles are controlled via the Fill tab.

Adjust Laydown 
Stitch settings for 
more or less dense 
fills

Adjust object boundaries,
entry/exit points, and

connector settings like any
embroidery object
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Reference markers

Reference markers are sometimes needed for continuous embroidery and 
possibly work-piece layouts. Hatch Embroidery includes two types of reference 
marker:

 Basting stitch markers of various shapes and sizes.
Graphic reference markers representing the different styles of positioning 

stickers available on the market.

Usage tips
 Stitch out basting stitch markers first to help align the fabric in the hoop.
 Sequence them to the start of the design.
 Attach physical adhesive stickers to the fabric to indicate hoop location and 

orientation or print them with the worksheet as a template.
 Use the basting stitch reference markers to match these stickers.

Add basting stitch markers

Use the Basting Stitch Marker tool to insert the basting stitch marker and place it 
before the embroidery design so it stitches first. If you want to manually create a 
multi-hoop design or continuous embroidery design, optionally insert basting stitch 
markers or bitmap markers at the end of the design. Click the Basting Stitch Marker 
tool in the Create Layouts toolbox to access the dialog. Various sizes and shapes 
are available.

To use basting stitch markers...
1 Insert the design. Group if not already grouped.
2 Change to a new color not use used so your markers will be a different color.

Use Create Layouts > Basting Stitch Marker to insert a reference marker at any angle 
and position.
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3 Click the Basting Stitch Marker tool in the Create Layouts toolbox.

4 Select the desired marker and click OK.
5 Click in the design where you want to place the marker. Move the mouse to 

rotate it as necessary.
6 Click a second time to anchor the marker.
7 Continue to click to add more markers as needed. When finished, press the 

Enter key.
8 At this time, the basting stitch markers will be in the last sewing position. Use the 

Sequence docker to move them to the first sewing position at the top.
9 Group the basting stitch with the embroidery.
10 Print the design layout template and use a physical position marker sticker at 

the same location and orientation as the basting stitch marker.
11 Export the machine file. The basting stitch marker will stitch first.
12 Move the start needle position to the center of the sticker on the work piece.
13 Start stitching the basting stitch marker to confirm the location and orientation. 

Adjust as needed.
14 Stitch out the design.

Note: If you turn on registration marks with multi-hooped designs, markers are 
automatically generated. See Output multi-hooped designs for details.

Add graphic markers

Graphic reference markers are only image files and there is no stitching involved. 
They are used in printouts to help with your placement when sewing.

To use graphic markers...
1 Group the embroidery design if not already grouped.

Use Create Layouts > Insert Graphic Marker to insert a graphic marker representing 
adhesive stickers attached to the fabric to indicate location and orientation.

Select requried 
marker
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2 Use the Insert Graphic Marker tool to insert markers as required. You’ll find a 
selection under the Hatch Pictures > Graphics Markers folder as shown.

3 Select both and use align centers.
4 Group the graphic and the embroidery.
5 Position and rotate as needed in the design.
6 Print the graphic with the design in Print Options.
7 Print the design layout template and use a physical position marker sticker at 

the same location and orientation as the position marker graphic.
8 Export the machine file.
9 Move the start needle position to the center of the physical sticker.
10 Stitch out the design.

Select and insert 
graphic marker
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PART XI
APPENDICES

Embroidery design with Hatch Embroidery consists of turning basic artwork shapes 
into embroidery designs. Hatch Embroidery gives you the flexibility of creating 
embroidery objects using artwork as backdrops, or of directly converting digital 
artwork. You can take a mixed mode approach as well, doing the bulk of the 
design by means of automatic conversion, followed by touch-ups and edits using 
the suite of Hatch Embroidery embroidery digitizing tools.
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Appendix A

FEATURE COMPARISON TABLE

The table below itemizes features which are relevant to each product level. Product levels for this release include:

Note: While every effort has been made to maintain this table up to the current release, late changes may not be 
precisely reflected. For purchasing advice, please visit the website or talk to a Wilcom representative.

Product level Capabilities

Hatch Organizer O Find, manage, customize, and output designs quickly and easily.

Hatch Personalizer P All ‘Organizer’ features plus lettering and monogramming.

Hatch Composer C All ‘Personalizer’ features plus editing and auto-digitizing.

Hatch Digitizer D All ‘Composer’ features plus world-class manual digitizing and appliqué tools.

Capability Feature Products Reference

D C P O

Software settings Software Settings

Select machine model / type * ● ● ● ● Select machine model or type
Create custom brand * ● ● ● ● Create custom brand
Set start and end points * ● ● ● ● Set start & end points
Set background colors ● ● ● ● Background colors
Eliminate small stitches ● ● ● ● Eliminate small stitches
Calibrate monitor ● ● ● ● Monitor calibration
Display rulers, grids, and guides ● ● ● ● Rulers & guides

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3

https://www.wilcom.com/Products.aspx
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Measure distances on screen ● ● ● ● Design measurement
Change measurement units ● ● ● ● Change measurement units
Adjust system preferences – auto-save, 
auto-scroll, etc

● ● ● ● System preferences

Manage designs Design Library Manage Designs

Open design library ● ● ● ● Open Design Library
Browse designs ● ● ● ● Browse designs
Open or copy design files ● ● ● ● Open or copy designs
Open blank designs ● ● ● ● Open blank designs
Transfer selected designs ● ● ● ● Transfer selected designs
Convert selected designs ● ● ● ● Convert multiple designs
Print selected designs ● ● ● ● Print selected designs
Print selected designs to catalog ● ● ● ● Print design catalogs
Export design lists ● ● ● ● Export design lists
Manage design folders ● ● ● ● Manage design folders

View designs View Designs

Display backdrops ● ● ● ● Display backdrops
Zoom and pan designs ● ● ● ● Zoom & pan designs
View colors and objects Sequence ● ● L View colors & objects
View by color View by Color ● ● View by color
Design overview Design Overview ● ● ● ● Design overview
View stitching TrueView ● ● ● ● View stitching
View connectors * ● ● ● ● View connectors
Simulate design stitchout Stitch Player ● ● ● ● Simulate design stitchout
Travel through designs ● ● L L Travel through designs

Customize designs Customize Designs

View design information ● ● ● ● View design information
Estimate thread usage ● ● ● ● Thread usage estimates
Access object properties ● ● Access object properties
Set background and display colors ● ● ● ● Add backgrounds

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Choose auto fabrics ● ● ● ● Choose auto fabrics
Manage auto fabrics ● ● Manage fabrics
Adjust stitch spacing ● ● ● ● Adjust stitch densities
View color blocks ● ● ● ● View color blocks
Pick and apply existing colors ● ● ● ● Pick & apply colors
Customize design colors ● ● ● ● Customize design palette
Add threads to design palette ● ● ● ● Add threads to design palette
Change color schemes Cycle Used Colors, 

Color Wheel
● ● Change color schemes

Customize design environment Background and Display 
Colors

● ● ● ● Customize design environment

Customize design fabric settings Auto Fabric ● ● ● ● Customize design fabric settings
Preset object properties ● ● ● Preset object properties
Save settings to template ● ● ● ● Save settings to template
Revert to default settings ● ● ● ● Revert to default settings
Modify thread charts ● ● ● ● Modify thread charts
Create new thread chart ● ● ● ● Create new thread chart

Outline stitches Outline stitches

Simple lines Single / Triple Run ● ● Simple outlines
Satin lines Satin / Raised Satin ● ● Satin outlines
Motif lines Motif ● ● Motif outlines
Backstitch lines Backstitch ● Backstitch outlines
Stemstitch lines Stemstitch ● Stemstitch outlines
Sculptured runs Sculpture ● Sculpture outlines
Zigzag lines Zigzag ● Zigzag outlines
Blanket lines Blanket ● Blanket outlines

Fill stitches Basic Stitch Types

Satin fills Satin / Raised Satin ● ● Satin fills
Tatami fills Tatami ● ● Tatami fills

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Decorative fills Decorative Stitch Types

Embossed fills Embossed ● ● Embossed fills
Contour fills Contour ● Contour fills
Ripple fills Ripple ● Ripple fills
Motif fills Motif ● ● Motif fills
Stipple fills Stipple ● Stipple fills
Cross stitch Cross Stitch ● Cross stitch fill

Stitch effects Stitch Effects

Florentine fills Florentine Effect ● Florentine fills
Radial fills Radial Fill ● Radial fills
Elastic embossed fills Elastic Embossed Fill ● Elastic embossed fills
3D Warp 3D Warp ● 3D Warp
Hand stitch effects Hand Stitch ^ ● Handstitch effects
Feathered edge effects Feather Edge ● ● Feathered edges
Gradient fill effects Gradient Fill ● ● Gradient fill effects

Embroidery editing Embroidery Editing

Select objects ● ● ● L Select objects
Copy, cut and paste ● ● ● ● Copy & paste objects
Duplicate objects Duplicate / Clone ● ● ● ● Duplicate & clone objects
Arrange objects Align / Space ● ● ● ● Arrange objects
Transform objects Scale / Rotate / Skew / 

Mirror
● ● ● ● Transform objects

Reshape objects Reshape * ● ● Reshape objects
Adjust entry and exit points Reshape ● ● L Adjust entry & exit points
Add or adjust stitch angles Add / Remove Stitch 

Angles
● ● L Stitch angles

Sequence objects Sequence * ● ● Sequence by objects
Sequence by selection order Sequence ● ● Sequence by selection order
Sequence by color list Sequence ● ● Sequence by color list
Sequence by color block Sequence by Color ● ● Sequence by color block

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Optimize color changes Optimize Color Changes ● ● ● ● Optimize color changes
Apply automatic connectors Always Tie-Off & Trim ● ● ● Automatic connectors
Apply closest joins Apply Closest Join ● ● Closest joins
Control corner stitching Automatic Corners ● ● Corner stitching
Create color blends Create Color Blend ● ● Color blending
Break apart composite objects Break Apart ● ● Break apart composite objects
Cut shapes manually Knife ● ● Cut shapes manually
Combine objects Weld ● Combine objects
Apply curve smoothing Smooth Shapes ● ● Apply smooth curves
Remove underlying stitching Remove Overlaps ● ● Remove underlying stitching
Edit stitches Stitch Edit ● ● Edit stitches

Embroidery lettering Lettering

Create lettering Lettering * ● ● ● Create lettering
Edit letter angle, baseline angle and line 
spacing of lettering objects

Lettering * ● ● ● Advanced settings

Apply baselines – horizontal, vertical, etc ● ● ● Lettering layouts
Lettering stitch types ● ● ● Lettering stitch types
Lettering underlay ● ● ● Lettering underlay
Scale lettering ● ● ● Scale lettering
Rotate lettering ● ● ● Rotate lettering
Reshape baselines ● ● ● Reshape baselines
Reshape letters ● ● ● Reshape letters
Insert special characters ● ● ● Insert special characters
Use flair script ● ● ● Flair script
Use monogram fonts ● ● ● Monogram fonts
Keyboard design collections Keyboard Design 

Collection
^ ● L L Keyboard Design Collections

Monogramming Monogramming

Select monogram designs * ● ● ● Select monogram designs
Add monogram letters ● ● ● Add monogram letters
Add monogram ornaments ● ● ● Add monogram ornaments

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Add monogram borders * ● ● ● Add monogram borders
Break apart monograms ● ● Break apart monograms

Artwork Using Artwork

Scan artwork ● ● Scan artwork
Insert artwork as bitmaps ● ● Insert artwork as bitmaps
Insert artwork as vectors * ● ● Insert artwork as vectors
View artwork (bitmap / vector) ● ● ● ● View artwork
Lock / dim artwork ● ● Lock and dim artwork
Size artwork ● ● Size artwork
Crop artwork ● ● Crop artwork
Edit artwork externally ● ● Edit artwork externally
Modify vector properties ^ ● Modify vector properties
Prepare artwork for auto-digitizing * ● ● Prepare artwork for auto-digitizing
Prepare photos for auto-digitizing Adjust Bitmap ● ● Prepare photos for auto-digitizing
Save processed artwork ● ● Save processed artwork

Auto-digitizing Auto-Digitizing

Assign threads for auto-digitizing Color Matching Method ● ● Assign threads for auto-digitizing
Auto-digitize artwork Auto-Digitize 

Embroidery
* ● ● Auto-digitize embroidery

Auto-digitize fills Click-to-Fill ● ● Auto-digitize fills
Auto-digitize outlines Click-to-Outline ● ● Auto-digitize lines
Convert vectors to embroidery Click-to- ^ ● Convert vector objects in Embroidery 

Mode
Convert artwork to embroidery CorelDRAW® * ○ ○ Convert artwork to embroidery with 

CorelDRAW®
Auto-digitize with PhotoFlash PhotoFlash ● Auto-digitize with PhotoFlash
Auto-digitize with Reef PhotoStitch Reef PhotoStitch ^ ● Auto-digitizing with Reef PhotoStitch
Auto-digitize with Color PhotoStitch Color PhotoStitch * ● Auto-digitize with Color PhotoStitch

Manual digitizing Manual Digitizing

Digitize open and closed shapes Digitize Open / Closed 
Shape

* ● Digitize open & closed shapes

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Close open shapes with straight or curved 
lines

Close Shape with 
Straight / Curved Line

* ● Digitize open & closed shapes

Create turning fills Digitize Blocks ● Turning fills
Create circles and squares Rectangle / Oval ● Circles & squares
Create standard shapes Standard Shapes * ● Standard shapes
Apply automatic underlay Underlay ● ● Automatic underlay
Apply pull compensation Pull Compensation ● ● Pull compensation
Reinforce outlines Backtrack / Repeat ● Reinforce outlines
Create freehand shapes Freehand... ● Create freehand shapes
Insert motif stamps Motif Stamp ● Motif stamps
Digitize holes in objects Digitize / Remove Holes ● Create holes in objects
Fill holes in objects Fill Holes ● Fill holes in objects
Apply branching Branching ● ● Branching
Convert to redwork Redwork ● Redwork
Carving stamps Carving Stamp ● Carving stamps
Create / manage motifs Create Motif ● Create motifs
Create / manage borders Create Border ● Create borders

Digitize appliqué Appliqué

Visualize appliqué fabrics ● ● ● ● Appliqué fabrics
Create appliqué objects Digitize Appliqué ● Create appliqué objects
Create appliqué with holes Digitize Appliqué with 

Holes
● Create appliqué with holes

Convert to appliqué Convert to Appliqué * ● Convert to appliqué
Convert vectors to appliqué Tag as Appliqué ^ ○ Convert vector graphics to appliqué
Partial cover appliqué Partial Appliqué ● Partial cover appliqué
Combine appliqué Combine Appliqué ● Combine appliqué

Design layouts Design Layouts

Mirror-copy objects Mirror-Copy ● ● Mirror-copy objects
Define work areas ● ● Work areas
Add buttonholes Buttonholes ● Buttonholes
Create ambience quilting Ambience Quilting ● Ambience quilting

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Create automatic outlines and offsets Create Outlines & 
Offsets

● Outlines & offsets

Create trapunto outlines Trapunto Outlines ● Create trapunto outlines
Generate laydown fills Laydown Stitch ^ ● ● Generate laydown fills
Add basting stitch markers Basting Stitch Marker ● ● Add basting stitch markers
Add graphic markers Graphic Marker ● ● Add graphic markers

Embroidery hooping Embroidery Hooping

Configure hoop list * ● ● ● ● Configure hoop list
Select and display hoops * ● ● ● ● Select & display hoops
Center hoops Center All ^ ● ● ● ● Center hoops
Rotate hoops ● ● ● ● Rotate hoops
Multi-position hoops ● ● L L Multi-position hoops
Create and edit custom hoops ● ● ● ● Custom hoops
Create automatic hoopings Automatically Add 

Hoops
* ● ● Create automatic hoopings

Create manual hoopings Add Hoop * ● ● Create manual hoopings
Calculate hoopings Calculate Hoopings ● ● Calculate hoopings
Split objects between hoopings Add Splitting Line ● ● Split objects between hoopings
Print multi-hooped designs ● ● Print multi-hooped designs
Add registration marks Multi-Hooping Options * ● ● Add registration marks
Optimize color changes for auto-hooping ● ● Optimize color changes for 

auto-hooping
Export multi-hooped design as machine 
files

Export Design ● ● Export multi-hooped design as machine 
files

Output designs Output Designs

Save designs ● ● ● ● Save designs
Small stitch removal ● ● ● ● Small stitch removal
Export designs Export Design ● ● ● ● Export designs
Export cutting lines Export Cutting * ● ● ● ● Export cutting lines
Transfer designs to machine folder ● ● ● ● Transfer designs
Print designs ● ● ● ● Print designs

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Capture design images Capture Design Image ● ● ● ● Capture design images
Print design layouts ● ● ● ● Print layouts

Cross-Stitch GEM ○ Hatch Cross Stitch

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Appendix B

QUICK REFERENCE

Hatch Embroidery uses toolbars and shortcut keys to 
provide quick and easy access to common commands. It 
can be opened via the desktop icon or MS Windows® Start 
menu. For a summary of software tools and keyboard 
shortcuts available in Hatch Embroidery, refer to the topics 
below.

Note: The tools and commands described here are all 
available in the highest product level. Not all are 
applicable to other product levels.

Menus

The main menu is normally docked at the top of the screen above the design 
window. Use it to access common commands. As you get more familiar with them, 
you can speed things up using Keyboard shortcuts. Many of these commands are 
also available as toolbar buttons. Some may not appear in the list or may be 
inactive depending on the level of software you own.

Note: Most standard MS Windows® Alt key shortcuts apply. Use the Alt key with the 
letter underlined in the menu. To cancel an operation, press Esc twice or click on 
the Esc icon on the toolbar.
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File menu

Command Tip Shortcut

New blank design Create new blank design based on default template, 
fabric and background settings.

<Ctrl+N>

New from template Create new design based on selected template as well 
as fabric and background settings.

New from design Create new design based on an existing design.

Open design Open an existing embroidery design from hard disk or 
network drive.

<Ctrl+O>

Open recent design Open design from a list of recently opened designs.

Open backup 
design

Open directly onto the backup folder for quick access 
to backup files in case of software failure.

Insert design Import embroidery design files into the current design.

Insert artwork Import vector or bitmap artwork into current design as 
backdrop for manual or automatic digitizing.

Save design Save current design. <Ctrl+S>

Save design as Save current design with different name, location or 
format.

Save as template Save current design as design template for future use.

Export design Save current design as production file for use by 
machine.

Export cutting Export current design or selected objects to SVG file 
format for cutting.

Print preview View worksheets on screen. Print worksheets from 
this window.

Print design Print active design using current settings. <Ctrl+P>

Cross Stitch Access the Cross Stitch application.

Capture design 
image

Save design image as bitmap according to settings in 
the Capture Design Image dialog.

Close design Close current design tab.

Close all designs Close all design tabs.

Sign out and 
release license

Exit program and sign out of Hatch account.

Exit program Close all open designs and exit program. <Alt+F4>
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Edit menu

Command Tip Shortcut

Undo / Redo Standard Windows commands. Cancel or re-apply 
preceding command or series of commands.

<Ctrl+Z/Y>

Cut / Copy / Paste Standard Windows commands. Cut or copy selection 
and place on Clipboard. Paste contents to design 
window.

<Ctrl+X/C/V>

Duplicate Duplicate selection without placing it on clipboard. <Ctrl+D>

Duplicate with offset Duplicate with preset offset. Create regular patterns of 
duplicates. Adjust setting via Embroidery Settings > 
Edit dialog.

<Ctrl+Shift+D>

Delete Delete selection without placing it on clipboard. <Del>

Select / deselect all Select or deselect all objects in current design. <Ctrl+A> / <X>

Close shape with 
straight line / curved 
line

Close selected open outlines with straight or curved 
line.

Optimize color 
changes

Optimize design by reducing color changes to a 
minimum, while maintaining color layers.

Apply closest join Join selected objects at closest point. Re-apply 
closest join after editing.

<J>

Sequence >> Toggle display of Sequence docker. Sequence objects 
and color blocks in current design.

<Shift+L>

Sequence by 
selection order

Hold down <Ctrl> and click to select objects in current 
design. Select command to sequence objects in order 
of selection.

Break apart Split composite objects – monograms, appliqués, 
lettering, etc – into components. Allows each to be 
edited individually.

<Ctrl+K>

Remove color 
change

Remove color changes in selected objects which have 
been manually inserted while traveling through 
design.

Regenerate stitches Manually regenerate stitches for selected objects. <G>

Recognize stitches While machine files are generally not suited to 
modification, the software can ‘recognize’ object 
outlines, stitch types and spacing from stitch data. 
After opening a machine file, run the Recognize 
Stitches command to recognize stitch blocks as 
objects.

Adjust stitch 
spacing

Manually override stitch densities of selected objects 
or entire designs.
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View menu

Arrange menu

Object properties 
>>

Open Object Properties docker to preset properties or 
adjust them for selected objects.

Copy object 
properties

Make properties of selected object current for the 
design.

Apply object 
properties

Apply current settings to selected objects.

Command Tip Shortcut

TrueView Toggle simulation of stitched embroidery. <T>

Show design Toggle display of design elements. Click to open 
droplist of view settings.

Show hoop Toggle hoop display. <Shift+H>

Show hoop 
template

Toggle display of hoop template as an alternative to 
grid lines. Align design at correct location and 
orientation.

Show grid Toggle grid display. <Shift+G>

Show rulers Toggle display of rulers and guides. <Ctrl+R>

Stitch player Simulate embroidery design stitchout onscreen in 
either stitch or TrueView.

<Shift+R>

Measure tool Measure distances and angles on screen. <M>

Zoom Zoom in/out of workspace and zoom in on bounded 
areas to full window size. See also Zoom toolbar.

Pan Drag to pan across design at high zoom factors. <P>

Previous view Return to previous view. <V>

Center at current 
stitch

Center currently selected stitch in design window. <C>

Refresh screen Refresh screen display. <R>

Command Tip Shortcut

Group Combine multiple objects into one selectable object 
grouping.

<Ctrl+G>

Ungroup Split object grouping into component objects. <Ctrl+U>

Lock Lock selected objects to protect them during digitizing 
or editing.

<K>

Unlock selected Unlock locked objects selected in the Sequence 
docker.

Unlock all Unlock all locked objects in design. <Shift+K>

Command Tip Shortcut



Append ix  B     Q u ick  R efe rence 641

Machine menu

Design Settings menu

Software Settings menu

View by color View embroidery objects by color.

Hide selected Hide selected object/s from view.

Hide unselected Hide all objects apart from currently selected.

Unhide selected Unhide hidden objects selected in the Sequence 
docker.

Unhide all Restore all hidden objects to view.

Align Access commands to align selected object tops, 
bottoms, right sides, left sides, etc.

Space Access commands to distribute selected objects 
evenly down or across the screen.

Command Tip

Transfer design Transfer current design to preset design folder.

Transfer settings Preset file types required by selected machines, as well as file 
location on the network or PC.

Command Tip

Design information >> View design information such as size and number of stitches. Add 
comments to print on worksheet.

Background and 
display colors

Set colors, fabrics, or articles as design backgrounds and set display 
colors.

Auto fabric Modify design properties for stitchout on different fabric.

Auto start and end Set auto start and end points for entire design.

Remove small stitches Control automatic removal of small stitches. (Default set to 
‘Always’.)

Object properties >> Open the Object Properties docker to preset properties or adjust for 
selected objects.

Command Tip

User interface settings Preset user interface (GUI) settings for tools, grids and guides, view 
settings, and scrolling options.

Embroidery settings Preset default settings for machine file conversion, object 
duplication, overlap removal, appliqué, as well as hoop settings.

Manage auto fabrics Create custom fabric settings to suit particular needs.

Command Tip Shortcut
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Window menu

Help menu
Refer to the Help menu for the following sources of information...

 ‘Release Notes’ and a ‘Quick Start Guide’ can be viewed and downloaded via 
the Help menu.

Manage thread charts Create your own charts to represent the palette of threads you have 
available. Change code, name or chart for existing threads.

Manage motifs If you have created custom motifs, you can manage them via this 
command. Rename or delete individual motifs or entire custom 
categories.

Manage borders If you have created custom borders, manage them via this 
command.

Calibrate screen Calibrate your monitor so that designs at 1:1 scale appear at real 
size. Do this when you first install the software, whenever you 
change your monitor, or adjust your monitor’s horizontal or vertical 
controls.

Scanner setup Set up scanner to interact directly with the software.

Customer experience 
program

Opt out of the customer experience improvement program as 
preferred.

Command Tip

Tile horizontal / vertical Tile design windows with multiple designs.

Remove tiling Remove any open tiling.

Dockers Toggle display of dockers.

Toolbars Toggle display of toolbars.

Command Tip

Product help 
available online

Training material and 
courses available from 
Hatch Academy
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 Follow the link to Product Help to download a PDF of the entire Hatch 
Embroidery User Guide.

 A printed copy can also be ordered via Product Help.
 The Hints docker provides a valuable learning resource from within the 

software. It can be activated via the Help menu. Each hint includes a brief 
feature summary together with a link to a short video.

 Note that ‘just-in-time’ help for each tool can also be accessed via F1 keypress. 
Simply point to the tool and press F1.

 The Help menu also provides access to the Hatch Academy. This resource 
provides free and paid online courses from Hatch and embroidery experts. 
Resources include embroidery basics, Hatch software training and projects.

 Run the Check for updates command to check for periodic software updates.

Follow link for 
details

Download and 
install as preferred

https://hatch.embroideryhelp.net/v3/en/index.htm
https://hatch.embroideryhelp.net/v3/en/index.htm
https://profile.hatchembroidery.com/?return_url=https://academy.hatchembroidery.com/enrollments
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Toolbars

You access commands in your design window using toolbar buttons. To activate 
a tool, simply move the mouse pointer over it, and click with the left mouse button. 
Where applicable, right-click a tool to access settings.

Note: Not all tools and commands are applicable to all product levels.

Switch & Convert toolbar
Hatch Embroidery has a single ‘design window’ but you interact with it in different 
ways. The main operating modes are accessed via the Switch & Convert toolbar. 
See also The user interface.

Tool Tip

Home Revisit the Home screen to access tutorials and other product 
information.

Switch to 
Embroidery 
Mode

Digitize and edit embroidery designs. Display embroidery as well 
as artwork. View designs realistically in 3D simulation.

Switch to 
Graphics Mode

Import, edit or create vector artwork as backdrop for embroidery 
digitizing, manual or automatic.

Convert 
embroidery to 
artwork

Convert selected embroidery objects to vector artwork.

Convert artwork 
to embroidery

Convert selected vector artwork to embroidery objects in Graphics 
Mode.
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Design Colors toolbar
You change thread colors for embroidery objects from the Design Colors toolbar. 
This is the simplest way to customize a design. The design colors you set are saved 
with the current design. See also Design colors.

Tag as appliqué Tag selected vectors for conversion to appliqué embroidery.

Keep Graphic 
Objects

When toggled on, artwork will be preserved during the conversion 
process.

Match to 
embroidery 
palette

When toggled off, graphic colors are added to the embroidery 
design palette. When toggled on, graphic colors are matched to 
palette colors.

Show embroidery Toggle display of embroidery components in Graphics Mode.

Design Library Open Design Library window.

Tool Tip Shortcut

Current color View current design color.

Pick color Pick a color from design window and make it current.

Apply color Apply current color to embroidery objects.

Add design color Add color to end of the design palette.

Remove design 
color Remove unused color from end of the design palette.

Hide unused 
colors

Toggle display of all unused colors in the design 
palette.

Discard unused 
colors Remove all unused colors from the design palette.

Threads >> Toggle display of Threads docker. Find threads from 
different charts and change design colors. <Alt+T>

Tool Tip
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Select toolbar
Use the Select toolbar to select or reshape objects.

Standard toolbar
Use the Standard toolbar for commonly used functions such as opening, saving, 
and printing designs.

Tool Tip Shortcut

Select Select an object or group. Or drag selection marquee 
to select multiple enclosed objects or groups. <0>

Polygon select Select an object or group by digitizing polygon line 
around them. <Ctrl+L>

Reshape Reshape an object shape, edit stitch angles, or adjust 
entry and exit points. <H>

Tool Tip Shortcut

New blank 
design

Create new blank design based on default template, 
fabric and background settings. <Ctrl+N>

New from design Create new design based on an existing design.

Open design Open existing embroidery design from hard disk or 
network drive. <Ctrl+O>

Open recent 
design Open design from list of recently opened designs.

Insert design Insert existing embroidery design into current design.

Insert artwork Import vector or bitmap artwork into current design as 
backdrop for manual or automatic digitizing.

Save design Save current design. <Ctrl+S>

Export design Export current design to machine file for stitching.

Transfer design Transfer current design to design folder. Right-click for 
settings.
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Status bar
A Status Bar at the bottom of the design window provides continuous display of 
current cursor position status as well as instructions for use of selected tools.

Print design Print current design. <Ctrl+P>

Print preview Preview worksheets. Print from preview window.

Cut Cut the selection and place on clipboard. <Ctrl+X>

Copy Copy the selection and place on clipboard. <Ctrl+C>

Paste Paste contents of the clipboard. <Ctrl+V>

Undo Undo previous action. <Ctrl+Z>

Redo Redo previously undone action. <Ctrl+Y>

Cancel Cancel current process and deselect any selected 
objects. <Esc>

Field Notes

Prompt message To guide you through use of selected functions.

Design size Width (W) and height (H).

Coordinates Current needle position (X/Y), and length (L) and angle (A) of current 
stitch. See also Design measurement.

Stitch count Total number of stitches in design.

Current fabric Fabric settings take into account the type of fabric you are stitching on. 
See also Fabrics & densities.

Grade of design Native EMB designs are classified in four grades depending on how the 
file was created. See Supported embroidery files for details.

Tool Tip Shortcut
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Travel toolbar
Use the Travel toolbar for design checking.

View toolbar
Use the View toolbar to set design view settings and other commonly used 
functions. 

Tool Tip

Select while 
traveling

Toggle on to select stitches, objects, or colors while traveling 
through a design. Only enabled when Stitch Edit tool is activated.

Travel backward Travel backwards through design.

Travel forward Travel forwards through design.

Jump by object Use in conjunction with Forward and Back icons to travel to 
previous or next objects.

Jump by color Use in conjunction with Forward and Back icons to travel to 
previous or next color change.

Jump to start/end Use in conjunction with Forward and Back icons to travel to start or 
end of design.

Tool Tip Shortcut

TrueView Toggle simulation of stitched embroidery. <T>

Show design Toggle display of design elements. Click to open 
droplist of view settings.

Show hoop Toggle hoop display. Right-click for settings. <Shift+H>

Show hoop 
template Toggle hoop template display.
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Zoom toolbar
Use the Zoom toolbar to zoom and pan across designs.

Show grid Toggle grid display. Right-click for settings. <Shift+G>

Show rulers & 
guides

Toggle display of rulers and guides. Right-click for 
settings. <Ctrl+R>

Stitch player Simulate embroidery design stitchout onscreen in 
either stitch or TrueView. <Shift+R>

Tool Tip Shortcut

Pan Pan across design at high zoom factors. <P>

Zoom 1:1 Display design at actual size. <1>

Zoom in Zoom in for more design detail. <+>

Zoom out Zoom out for broader view. <->

Zoom to fit Display whole design in design window. <0> (zero)

Zoom Zoom on a specific area of design window. <B>

Use Zoom Scale to display design at a specific scale, 
or zoom to article or hoop.

Tool Tip Shortcut
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View (Manage Designs) toolbar
The View (Manage Designs) toolbar contains functions for quick search, sort, and 
location of designs on your company network.

Context toolbar

Hatch Embroidery includes a Context toolbar which changes according to the 
selected tool. If you have no tools selected, you will see a custom hoop list. Here 
you can also change hoop settings, rotate hoop, set your measurement units – 
Metric or U.S. – as well as adjust screen background settings.

Tool Tip

Layout Toggle display of navigation pane, details pane, and/or preview 
pane.

Design 
information >>

View design information such as size and number of stitches. Add 
comments to print on worksheet.

Keyboard Design 
Collection

Toggle display of Keyboard Design Collection docker. Create, edit 
and manage keyboard design collections.

Change view Change current view of design lists.

Reset Detail 
Columns Reset columns displayed in details view to default layout.

Group by Group current design list by selected property and sort order.

Sort by Sort current design list by selected property and sort order.

Showing Filter current design list by file type. 

Search Filter designs based on specified search criteria – e.g. stitch range.

Ascending order

Sort designs in ascending or descending order. 
Descending 
order
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Design window tools
The following tools are available by default with nothing selected.

Droplist Tip

Select machine brand for current design.

Select from list of models or types – single or multi-needle – 
associated with selected machine brand.

Select from hoop list associated with selected machine and 
model or type.

Tool Tip

Machine & Hoop 
Options

Change machines, set up hoop lists, and define custom brands 
and hoops.

Rotate hoop left 
15°

Rotate first hoop, or currently selected hoops in multi-hooping 
mode, to the left in 15° increments.

Rotate hoop right 
15°

Rotate first hoop, or currently selected hoops in multi-hooping 
mode, to the right in 15° increments.

Rotate by specified amount – positive or negative – in degrees.

Background and 
display colors Change design background and display colors.

Laydown stitch Generate light fill to flatten the nap of textured fabrics like terry 
toweling or fur for subsequent embroidery.

Center all Center whole design and hoop at 0,0 position and display in the 
design window.

Measurement 
units

Change measurement units within software without changing 
operating system settings.
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Digitizing methods
The following tools are available when a digitizing method is selected. 

Tool Tip Shortcut

Outline Outline closed shapes with current line stitch type.

Fill Fill closed shapes with current fill stitch type.

Hand stitch Create hand-stitch effects which combine randomized 
stitch length, angle and count.

Feather edge Create rough edges, shading effects, or imitate fur and 
other fluffy textures in selected objects.

Gradient fill Create perspective and shading effects with stitch 
spacing varying between dense and open fill.

Radial fill
Create radial turning stitching with various stitch types 
including satin, tatami and program splits. Can be 
applied to ring shapes. 

Florentine effect Create custom curve-line stitching with single 
guideline.

Elastic 
embossed fill

Create decorative split patterns following stitch angles 
and scaled according to object width.

Automatic 
corners

Turn automatic corners on or off. When on, the corners 
in line objects will be mitred or capped automatically 
depending on corner angle. Turn on or off by object.

Always tie-off & 
trim

Trim connectors. When turned on, connectors will 
always be tied off and trimmed. Otherwise, the 
software will decide when to trim.

Underlay Apply or exclude automatic underlays to new or 
selected objects. Right-click for settings. <U>
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Object editing tools
The following tools are available when embroidery objects are selected. 

Custom object tools
The following tools are not editing tools as such but they are only available when 
an existing object is selected. 

Tool Tip Shortcut

Close shape with 
straight line

Close an open outline with straight or curved line.
Close shape with 
curved line

Duplicate
Duplicate selection in the same position. Duplicate is 
placed at end of stitching sequence. Also available via 
Edit menu.

Duplicate with 
offset

Duplicate selection in an offset position. Create regular 
patterns of duplicates. Right-click for settings. Also 
available via Edit menu.

Delete Delete selection. <Delete>

Group Group selection. Also available via Arrange menu. <Ctrl+G>

Ungroup Ungroup grouped selection. Also available via Arrange 
menu. <Ctrl+U>

Laydown stitch Generate light fill to flatten the nap of textured fabrics 
like terry toweling or fur for subsequent embroidery.

Center all Center whole design and hoop at 0,0 position and 
display in the design window.

Tool Tip

Create border Create custom border pattern for future use.

Create motif Create custom motif pattern for future use.
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Transform tools
The following tools are available when embroidery objects are selected. 

Align & space tools
The following tools are available when multiple embroidery objects are selected. 

Tool Tip

Size +10% Increase size of selected objects in 10% increments.

Size -10% Reduce size of selected objects in 10% increments.

Mirror X Flip selection horizontally.

Mirror Y Flip selection vertically.

Rotate left 15° Rotate selection in 15° increments to left.

Rotate right 15° Rotate selection in 15° increments to right.

Skew Skew selection by specified amount – positive or negative – in 
degrees.

Tool Tip

Align left Align left edges of selected objects.

Align centers 
vertically Vertically align centers of selected objects.

Align right Align right edges of selected objects.

Align top Align top edges of selected objects.

Align centers 
horizontally Horizontally align centers of selected objects.

Align bottom Align bottom edges of selected objects.
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Bitmap crop tools
The following tools are available when bitmap artwork is selected. 

Toolboxes

Toolboxes are like toolbars in that they contain software tools. However, each 
toolbox represents a typical scenario you will be engaged in, such as customizing 
designs or editing objects. Some tools may appear in more than one scenario. As 

Align centers Align centers of selected objects.

Space evenly 
across Evenly space 3 or more selected objects horizontally.

Space evenly 
down Evenly space 3 or more selected objects vertically.

Tool Tip

Rectangular Crop bitmap to rectangle.

Oval Crop bitmap to oval.

Heart Crop bitmap to heart shape.

Star ‘n’ point Crop bitmap to 4 to 12 point star shapes.

Curve Crop bitmap to free curves.

Tool Tip
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such, toolboxes are organized more or less in order of common operations, starting 
with managing your designs.

Note: Not all tools and commands are applicable to all product levels.

Manage Designs toolbox
The Manage Designs toolbox provides an integrated way to view and organize all 
your embroidery designs.

Tool Tip

New from 
selected

Create new design(s) based on selected design(s) and/or 
bitmap(s) from chosen template.

Open selected Open design(s) selected in Design Library window.

Convert selected 
designs

Convert design selected in Design Library window into different file 
types.

Transfer selected 
design Transfer selected design to default machine folder.

Print selected Print design selected in Design Library window.
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Customize Design toolbox
The Customize Design toolbox provides functions which allow you to make global 
adjustments to your designs.

Print selected to 
catalog Print selected designs to catalog.

Export design list Export text or CSV file containing list of visible design files and their 
properties.

Manage 
embroidery 
library locations

Add or remove existing folders to/from Design Library, enabling 
fast searching and filtering.

Tool Tip

Design 
information >>

View design information such as size and number of stitches. Add 
comments to print on worksheet.

Background and 
display colors Change design background and display colors.

Machine & Hoop 
Options

View machine settings and set up custom machine formats. Also 
view hoop settings and set up custom hoop lists.

Auto fabric Change properties of design for stitching on different fabric.

Auto start and 
end Set auto start and end points for entire design.

Adjust stitch 
spacing Manually override stitch densities for selected objects.

Select thread 
charts Select factory or custom thread charts to use in Threads list.

Threads >> Toggle display of Threads docker. Find threads from different 
charts and change design colors.

Match all design 
colors

Automatically match and assign threads in thread list to all colors 
in the Design Colors toolbar.

Insert design Insert an existing embroidery design into current design.

Tool Tip
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Lettering / Monogramming toolbox
The Lettering / Monogramming toolbox provides the tools needed to add high 
quality embroidery lettering to your designs as well as create monogram designs.

Cycle used 
colors Cycle through combinations of used colors. Left- or right-click.

Color wheel Test combinations of related colors.

Optimize color 
changes

Optimize design by reducing color changes to a minimum, while 
maintaining color layers.

Tool Tip Shortcut

Lettering >>
Create embroidery lettering using embroidery 
alphabets, Keyboard Design Collections or TrueType 
fonts, or edit selected lettering.

<A>

Monogramming 
>>

Create personalized monograms using selection of 
predefined styles, border shapes and ornaments.

Reshape Reshape an object shape, edit stitch angles, or adjust 
entry and exit points. <H>

Break apart
Split composite objects – monograms, appliqués, 
lettering, etc – into components. Allows each to be 
edited individually.

<Ctrl+K>

Knife Cut objects along digitized line, preserving stitch 
settings and colors.

Laydown stitch Generate light fill to flatten the nap of textured fabrics 
like terry toweling or fur for subsequent embroidery.

Tool Tip
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Artwork toolbox
The Artwork toolbox provides for importing electronic artwork into your embroidery 
software, editing it, and preparing it for automatic digitizing.

Auto-Digitize toolbox
The Auto-Digitize toolbox provides tools for the automatic digitizing of prepared 
artwork and photos.

Tool Tip Shortcut

Insert artwork Import vector or bitmap artwork into current design as 
backdrop for manual or automatic digitizing.

Scan artwork Scan artwork directly from an attached scanner into 
current design window.

Adjust bitmap Adjust selected bitmap in effect, brightness and 
contrast.

Edit artwork Edit bitmap artwork in preferred graphics application. 
(Preset in User Interface Settings > General tab.)

Prepare artwork 
for embroidery

Prepare selected bitmap artwork for automatic 
digitizing.

Save artwork Save currently selected bitmap artwork.

Dim artwork Dim graphic backdrops to show stitches more clearly 
when digitizing.

Lock Lock selected objects into position for protection. <K>

Unlock all Unlock all locked objects to remove protection. <Shift+K>

Tool Tip

Insert artwork Import vector or bitmap artwork into current design as backdrop 
for manual or automatic digitizing.

Auto-digitize 
instant embroidery

Automatically digitize whole embroidery design directly from 
imported bitmap artwork.

Auto-digitize 
embroidery

Automatically digitize prepared bitmap artwork, optionally with 
user’s choices.
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Edit Objects toolbox
The Edit Objects toolbox provides many tools for reshaping, resizing, rotating 
objects, as well as add or remove stitch angles.

Color PhotoStitch Automatically turn grayscale or color photographs into 
embroidery.

Reef PhotoStitch
Turn photographs into single embroidery field resembling coral 
reef. Depending on Automatic Trim settings, multiple objects may 
be created.

PhotoFlash >> Create rows of PhotoSatin stitching of varying spacing in current 
color for selected photos or other bitmap artwork.

Click-to-fill Digitize large artwork shapes with tatami fill, preserving any holes 
within.

Click-to-fill without 
holes

Digitize large artwork shapes with tatami fill, ignoring any holes 
within.

Click-to-turning fill Digitize narrow column artwork shapes with satin stitch.

Click-to-outline Digitize boundaries of shapes with run stitching using current 
properties.

Click-to-centerline Digitize centerlines in artwork with run stitching using current 
properties.

Smooth shapes Remove excess reshape-nodes from selected embroidery 
objects.

Color matching 
method

Select matching method: a) add image colors to color palette for 
manual thread matching, b) add closest matches from selected 
thread charts, or c) use closest matches from the color palette.

Tool Tip Shortcut

Object properties 
>>

Toggle display of Object Properties docker. Preset 
properties for new embroidery objects or adjust 
properties for selected embroidery objects.

Copy object 
properties Make properties of selected object current for design.

Apply object 
properties Apply current settings to selected objects.

Tool Tip
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Adjust stitch 
spacing Manually override stitch densities for selected objects.

Smooth shapes Remove excess reshape-nodes from selected 
embroidery objects.

Reshape Reshape an object shape, edit stitch angles, or adjust 
entry and exit points. <H>

Add stitch angles Add stitch angles to selected filled or lettering object.

Remove stitch 
angles

Remove stitch angles from closed objects with turning 
stitches.

Knife Cut objects along digitized line, preserving stitch 
settings and colors.

Weld Merge selected overlapping objects into single 
‘flattened’ object.

Break apart
Split composite objects – monograms, appliqués, 
lettering, etc – into components. Allows each to be 
edited individually.

<Ctrl+K>

Remove overlaps
Remove stitches that are covered by the selected 
objects. Overlap value can be changed in the Overlap 
tab of Embroidery Settings dialog.

Create color 
blend

Generate color blends, perspective effects and 
shading in selected objects.

Branching Automatically sequence and group selected 
embroidery objects. <I>

Redwork
Automatically sequence and group selected 
embroidery objects to create Redwork object with 
entry and exit points at same position.

<Ctrl+I>

Apply closest join Join selected objects at closest point. Re-apply closest 
join after editing. <J>

Sequence >> Open Sequence docker. Click again to close. Also 
available via Windows > Dockers menu. <Shift+L>

Sequence by 
selection order

Resequence objects in order of selection. Hold down 
<Ctrl> and click to select.

Stitch edit

Select individual or multiple stitches by clicking needle 
points holding <Ctrl> or <Shift>, or dragging selection 
marquee around them. Insert stitches at current stitch 
cursor position, and move or delete selected stitches.

<E>

Tool Tip Shortcut
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Digitize toolbox
The Digitize toolbox provides all the digitizing tools necessary to create 
embroidered shapes. See also Digitize Objects.

Tool Tip Shortcut

Rectangle / 
square

Click two corners of rectangle, or press <Ctrl> for 
square.

Circle / oval Click center point plus two size points for an oval, or 
press <Ctrl> for circle.

Standard shapes
Digitize standard shapes. Press <Ctrl> to keep 
proportions of the shape. Press <Shift> to center at 
first point entered.

Freehand open 
shape

Click and hold to draw freehand open shapes. Adjust 
smoothing control for preferred result.

Freehand closed 
shape

Click and hold to draw freehand closed shapes. Adjust 
smoothing control for preferred result.

Digitize open 
shape

Digitize open shapes with left and right mouse clicks 
for straight lines and curves. <Shift+N>

Digitize closed 
shape

Digitize closed shapes with left and right mouse clicks 
for straight lines and curves.

Digitize blocks Digitize column shapes of varying width, setting stitch 
angle at each pair of points.

Carving stamp 
>>

Toggle display of Carving Stamp docker. Create 
needle penetrations with a ‘carving stamp’ as 
template.

Motif stamp

Add motifs to design one-by-one. Rotate, scale with 
<Shift>, or mirror with right-click as you add, or press 
<Enter> to accept default position and settings. Press 
Esc to stop adding motifs.

Add stitch angles Add stitch angles to selected filled or lettering object.

Remove stitch 
angles

Remove stitch angles from closed objects with turning 
stitches.

Digitize holes Digitize holes in selected filled object.

Fill holes
Fill holes via creating new objects based on hole 
boundaries of selected object with current fill stitch 
type. Right-click for settings.
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Appliqué toolbox
The Appliqué toolbox provides an easy way to create all the stitching you need for 
most simple appliqué work. See also Appliqué.

Remove holes Remove holes from selected object.

Weld Merge selected overlapping objects into single 
‘flattened’ object.

Backtrack Reinforce an outline, stitching it in reverse direction to 
the original. <Ctrl+B>

Repeat Duplicate an outline in same direction. Normally used 
with closed shapes.

Branching Automatically sequence and group selected 
embroidery objects. <I>

Redwork
Automatically sequence and group selected 
embroidery objects to create Redwork object with 
entry and exit points at same position.

<Ctrl+I>

Tool Tip Shortcut

Frame-out 
options

Access frame-out options in Appliqué tab of 
Embroidery Settings dialog.

Convert to 
appliqué

Convert selected closed objects into individual 
appliqués.

Digitize appliqué 
>>

Show Appliqué tab of Object Properties docker. 
Digitize appliqué objects with up to four layers of 
stitching – placement line, cutting line, tack stitches, 
and cover stitches.

Digitize appliqué 
with holes >>

Show Appliqué tab of Object Properties docker. 
Digitize appliqué objects with holes with up to four 
layers of stitching – placement line, cutting line, tack 
stitches, and cover stitches.

Remove overlaps
Remove stitches that are covered by selected objects. 
Overlap value can be changed in Overlap tab of 
Embroidery Settings dialog.

Tool Tip Shortcut
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Create Layouts toolbox
The Create Layouts toolbox lets you easily combine designs and design elements 
by inserting the contents of one file into another. See also Design Layouts.

Partial appliqué Remove unwanted cover stitching from underlying 
appliqué objects.

Combine 
appliqué

Break apart appliqué into component objects and 
recombine and resequence for efficient stitchout.

Break apart

Split composite objects – monograms, appliqués, 
lettering, etc – into components. Allows each to be 
edited individually. This tool is also available via Edit 
menu.

<Ctrl+K>

Tool Tip Shortcut

Insert design Insert an existing embroidery design into current 
design.

Mirror-copy 
horizontal Mirror and copy selected objects horizontally.

Mirror-copy 
vertical Mirror and copy selected objects vertically.

Mirror-copy both Mirror and copy selected objects around a center 
point.

Copy array
Duplicate designs, such as badges, automatically 
resequencing color blocks for efficient multiple design 
stitchouts.

Copy reflect Duplicate and mirror objects or designs. Create 
decorative borders.

Circle layout
Duplicate selected objects around a center point. 
Specify how many copies and if alternate copies are 
mirrored in Context toolbar.

Define work area Define shape, size, color and view of the work area. <Ctrl+W>

Mirror-copy to 
work area

Automatically mirror and copy selected object/s 
around center (0,0) of the work area.

Circle layout to 
work area

Automatically create copies of selected object/s 
(specified by Number of Copies in Context toolbar) 
around center of the work area.

Tool Tip Shortcut
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Multi-Hooping toolbox
If your embroidery is too large or contains a number of designs spaced around an 
article, you can use the Multi-Hooping toolbox to split it into multiple hoopings.

Auto center to 
work area

Automatically move selected object/s to center of the 
work area (0,0).

Buttonholes >>
Show Buttonholes tab of Object Properties docker. 
Use Place Buttonholes to place a string of buttonholes 
with all necessary stitching.

Ambience 
quilting Create ‘echo’ quilting blocks.

Create outlines & 
offsets

Create outlines and offsets for selected embroidery 
object(s).

Create trapunto 
outlines

Use in conjunction with Raised Satin to create stitching 
for a raised ‘quilted’ look.

Laydown stitch Generate light fill to flatten the nap of textured fabrics 
like terry toweling or fur for subsequent embroidery.

Basting stitch 
marker Insert reference marker at any angle and position.

Insert graphic 
marker

Insert graphic marker representing adhesive stickers 
attached to fabric to indicate location and orientation.

Tool Tip

Multi-hooping 
options

Change multi-hooping options in Multi-Hooping tab of the 
Embroidery Settings dialog.

Automatically 
add hoops Add hoops automatically to cover entire design.

Add splitting line Digitize one or more guides in multi-hoop layout to split objects 
between hoopings.

Preview 
hoopings

Calculate object distribution and registration marks for given hoop 
positions and display hooping thumbnails in docker. Click hooping 
thumbnail in the docker to view in the design window.

Calculate 
hoopings Calculate hoopings that will result from current layout.

Tool Tip Shortcut
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Output Design toolbox
Using the Output Design toolbox you can output embroidery designs in a variety of 
ways – by printing as worksheets, as appliqué patterns, color sequence, or as 
thread charts. Hatch Embroidery also allows you to save your designs as images 
for use with fabric and garment applications. You can also send them directly to 
machine for stitching. When working with designs that are larger than the 
available physical hoop, you can split them into parts, each containing an object 
or group of objects. Hatch Embroidery automatically calculates which files are to 
be sent and shows you how they will look.

Add hoop Add new hoop to multi-hoop layout.

Delete hoop Remove selected hoop from multi-hoop layout.

Add hoop right Place new hoop position to right of selected hoop. Allow 10mm 
overlap between sewing fields.

Add hoop left Place new hoop position to left of selected hoop. Allow 10mm 
overlap between sewing fields.

Add hoop down Place new hoop below selected hoop. Allows 10mm overlap 
between sewing fields.

Add hoop up Place new hoop position above selected hoop. Allows 10mm 
overlap between sewing fields.

Add 4 hoops 
around

Place four hoops around selected hoop’s perimeter. Allows 10mm 
overlap between sewing fields.

Add 8 hoops 
around

Place eight hoops around selected hoop’s perimeter. Allows 10mm 
overlap between sewing fields.

Tool Tip Shortcut

Auto start & end Set auto start and end points for entire design.

Save design as Save current EMB design with different name or 
location.

Export design Export current design to machine file for stitching.

Tool Tip
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Export cutting Export current design or selected objects to SVG file 
format for cutting.

Transfer design Transfer current design to preset design folder. 
Right-click for settings.

Print preview Preview worksheets. Print from preview window.

Print design Print current design. <Ctrl+P>

Capture design 
image

Save design image as bitmap exactly as it appears on 
screen.

Tool Tip Shortcut
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Appendix C

KEYBOARD SHORTCUTS

Hatch Embroidery uses toolbars and shortcut keys to provide quick and easy 
access to common commands. This section provides a list of all keyboard shortcuts 
available in Hatch Embroidery, as well as short descriptions of the tools you will find 
in the toolbars. Not all shortcuts are applicable to all product levels.

Tip: In addition to shortcut keys, standard MS Windows® Alt key shortcuts apply to 
menu commands. Use the Alt key in combination with the letters underlined in the 
menus. For example, press Alt+F+O to access the Open Design command in the 
File menu.

General functions
Keyboard shortcuts are available for most general functions:

To... Press...

Activate ‘Digitize Open Shape’ and open Outline tab <Shift+N>

Activate Lettering and open Lettering docker <A>

Apply/select satin <Shift+I>

Apply/select tatami <Shift+M>

Create new design <Ctrl+N>

Close software <Alt+F4>

Define layout work area ^ <Ctrl+W>

Export machine file <Shift+E>

Open an existing design <Ctrl+O>

Print design <Ctrl+P>

Save design <Ctrl+S>

Toggle Design Colors toolbar <Ctrl+Shift+R>

Toggle Design Information docker <Alt+P>

Toggle grid <Shift+G>

Toggle rulers <Ctrl+R>

Toggle Overview window <Shift+V>

^ Press <Esc> to close
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Selection functions
Keyboard shortcuts are available for most selection functions:

Viewing functions
Keyboard shortcuts are available for most viewing functions:

Toggle Sequence docker <Shift+L>

Toggle Threads docker <Alt+T>

Toggle work area <W>

To... Press...

Add next object to selection <Ctrl+Tab>

Add previous object to selection <Ctrl+Shift+Tab>

Choose Select tool <O>

Deselect all objects <Esc> or <X>

Select range of objects <Shift>+left-click first and last objects

Select all objects <Ctrl+A>

Select multiple objects <Ctrl>+left-click

Select component within grouped object <Alt>+left-click

Select underlying object <2>+left-click

Select next object <Tab>

Select previous object <Shift+Tab>

To... Press...

Center at current stitch <C>

Measure distance on screen ^ <M>

Refresh screen display <R>

Previous view <V>

Toggle connectors <Shift+C>

Toggle function symbols <Shift+F>

Toggle hoop <Shift+H>

Toggle images <D>

Toggle needle points <.> (period)

^ Press <Esc> to close

To... Press...

^ Press <Esc> to close
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Zoom functions
Keyboard shortcuts are available for most zoom functions:

Travel functions
Keyboard shortcuts are available for most travel functions:

Toggle shapes <L>

Toggle Stitch Player <Shift+R>

Toggle stitches <S>

Toggle unselected <Shift+S>

Toggle vectors <Shift+D>

Toggle TrueView <T>

View by color <Alt+C>

Zoom box in Overview window <Shift+B>

Zoom to article <Ctrl+0>

To... Press...

Pan <P>

Zoom <B>

Zoom 1:1 <1>

Zoom in 1.25x <+>

Zoom out 1.25x <->

Zoom in 2x <Z>

Zoom out 2x <Shift+Z>

Zoom to fit <0> (zero)

Zoom to hoop </>

Zoom to selected <Shift+0> (zero)

Zoom factor <F>

To travel... Keyboard † Keypad ‡

To start of design <Home> <7>

To end of design <End> <1>

To next color <PgDn> <3>

† Press <Esc> first ‡ Num Lock OFF

To... Press...

^ Press <Esc> to close
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Editing functions
Keyboard shortcuts are available for most editing functions:

To previous color <PgUp> <9>

To next object <Ctrl+T>

To previous object <Shift+T>

100 stitches forward <+>

100 stitches backward <->

10 stitches forward ˅ <2>

10 stitches backward ˄ <8>

1 stitch forward > <6>

1 stitch backward < <4>

To... Press...

Add stitch angles <Ctrl+H>

Apply closest join to selected objects <J>

Apply Redwork to selected objects <Ctrl+I>

Break apart composite objects <Ctrl+K>

Copy selected objects <Ctrl+C>

Cut selected objects <Ctrl+X>

Delete last reference point (when digitizing) <Bksp>

Delete selected objects <Delete>

Duplicate selected objects <Ctrl+D>

Duplicate selected objects with offset <Ctrl+Shift+D>

Generate stitches for selected objects. <G>

Group selected objects <Ctrl+G>

Lock selected objects <K>

Mirror horizontally <Ctrl+1>

Mirror vertically <Alt+1>

Nudge selected objects Left-click+arrow keys

Paste selected objects <Ctrl+V>

Redo command <Ctrl+Y>

Remove overlaps <Ctrl+Shift+E>

Reshape selected objects <H>

To travel... Keyboard † Keypad ‡

† Press <Esc> first ‡ Num Lock OFF
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Digitizing functions
Keyboard shortcuts are available for most digitizing functions:

Toggle ‘Select While Traveling’ (Stitch Edit mode) <Q>

Toggle underlay of selected objects <U>

Undo command <Ctrl+Z>

Ungroup selected objects <Ctrl+U>

Unlock all <Shift+K>

To... Press...

Cancel command <Esc>

Create outlines and offsets <Ctrl+Shift+O>

Digitize appliqué <F7>

Toggle Auto Scroll <Ctrl+Shift+A>

Deactivate (temporarily) Auto Scroll <Shift> (hold)

To... Press...



Hatch E m bro id er y 3 Use r  G u ide 673

Appendix D

STANDARD FONTS

The table below includes all embroidery fonts that are standard with your Hatch 
Embroidery. Categories include:

Minimum & maximum sizes
For best results when stitching, do not exceed the recommended maximum or 
minimum sizes. Note, however, that recommended maximum and minimum 
heights refer to UPPER CASE letters. Most embroidery fonts are digitized from an 
original TrueType Font (TTF), some of which have lower-case letters – e.g. ‘a’ and 
‘c’ – which are about 70% the height of a capital letter. As a result, these letters 

Font style Description

Appliqué fonts Created especially for appliqué, containing all the required outline, tack 
and cover stitches. Great for use on large scale and to reduce stitch 
count.

Block fonts San-serif typeface style, very common with names and business logos. 
A great style for embroidery as it is clear and easy to read.

Fancy fonts Anything that is not ‘blocky’ can be used in a decorative way, depending 
on the style of logo.

Monogram fonts Especially designed for monogramming purposes – commonly used for 
creating initials popular with gifts such as towels and linen. 

Outline fonts Commonly used for sports wear, on back of jackets. Work best at larger 
scale.

Run stitch fonts Commonly used for small lettering, anything under 5mm and where 
satin column are not suitable. 

Script fonts Fluid strokes where characters connect, resembling a hand written 
style.

Serif fonts Older style font which includes an embellishment at the ends of the 
stroke, popular with sportswear.

Small fonts Fonts which are 6mm and below, including satin stitch columns with 
push and pull adjustments.

Special fonts Graphical, multi-colors and fill effects are some of the things that are 
associated with special fonts. Commonly used for decorative purposes.

Non-Roman fonts This category includes Cyrillic, Greek and Japanese fonts.
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may be too small to embroider neatly. You may need to increase the size of the 
lower-case characters to suit the embroidery.

Special characters
You can create special characters in each font by holding down the Alt key on 
your keyboard and typing 0 (zero), its code, using the numbers on the keypad. For 
example, to type ê with the code 234, type Alt+0234. The accented letter will 
appear when you release the Alt key. See also Insert special characters.

Note: Not all characters are available in all fonts.

Join method
The lettering join method is preset to give the best results for each font. Options 
include:

Join Purpose

Closest join CJ Letters are joined at the closest point. Use it to minimize trims.

As digitized AD Letters are joined as they were digitized. Use it with fonts combining 
different fill stitch types or special effects.

TrueType Font

Embroidery Letters
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If you break apart a lettering object, the join method is lost as the object is no 
longer a lettering object. For further details about join methods, see Split lettering.

Roman fonts

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

Appliqué fonts

College 
Appliqué 1.0 25 3.2 80 AD

Block fonts

Angle Block 0.4 10 1.2 30 CJ

Art Block 0.4 10 1.6 40 CJ

Avant Garde * 0.3 8 1.2 30 CJ

Bauhaus * 0.3 8 1.0 25 CJ

Block1 0.3 8 0.8 20 CJ

^ New to Hatch 3 * Hatch Digitizer only
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Block2 0.25 6 0.8 20 CJ

Block2-Auto 0.25 6 0.8 20 CJ

Castle 0.6 15 1.0 25 CJ

Endeavor ^ * 0.4 10 1.4 35 CJ

Folio 
Condensed 0.3 7 1.0 25 CJ

Futura 0.4 10 0.8 20 CJ

Helvetica 0.3 8 1.2 30 CJ

Microgramma 0.4 10 1.0 25 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Mystic ^ * 0.3 8 0.8 20 CJ

Narrow Block 0.7 18 2.5 65 CJ

Platinum ^ 0.4 10 1.4 35 CJ

Slim Block 1.0 25 5.0 125 CJ

Square Block * 0.4 10 1.4 35 CJ

Swiss * 0.4 10 1.2 30 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only



Append ix  D     Stand ard  Font s 678

Tahoma * 0.3 8 1.2 30 CJ

Text Block * 0.3 8 1.0 25 CJ

Urbane * 0.4 10 0.8 20 CJ

Verdana * 0.3 8 1.0 25 CJ

Fancy fonts

Addison ^ * 0.4 10 1.0 25 CJ

Anaconda * 0.4 10 1.0 25 CJ

Arnold * 0.5 12 0.6 17 CJ

Blacklight 0.4 10 0.7 18 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Carla * 0.4 10 1.0 25 CJ

Catalan ^ * 0.4 10 0.7 18 CJ

Charcuterie 0.8 20 1.6 40 CJ

Comics 0.4 10 1.0 25 CJ

Croissant * 0.3 8 0.7 18 CJ

Curly 0.7 18 1.6 40 CJ

Enviro * 0.6 15 1.6 40 CJ

Felt Tip 0.4 10 1.2 30 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Flash 0.3 8 1.0 25 CJ

Flourish Light * 0.8 20 1.2 30 AD

Fluky ^ * 0.4 10 1.4 35 CJ

Hana 0.6 15 0.8 20 CJ

Handicraft 0.4 10 1.0 25 CJ

Hobo * 0.3 8 0.8 20 CJ

Kids * 0.4 10 0.8 20 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Kindergarten 
Block 0.4 10 1.0 25 CJ

Lublik * 0.4 10 0.8 20 CJ

Mandarin 0.4 10 0.6 15 CJ

Old English 0.8 20 1.2 30 CJ

Orient Express * 0.4 10 0.8 20 CJ

Pacific North 
West 1.0 25 1.6 40 CJ

Racetrack ^ * 0.3 8 1.2 30 CJ

Racer * 0.4 10 0.6 15 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Speedy * 0.3 8 0.6 15 CJ

Staccato * 0.6 15 1.0 25 CJ

Swaddle ^ * 0.25 6 0.7 18 CJ

Woodstock 0.3 8 0.8 20 CJ

Monogram fonts

Fancy 
Monogram

0

2.0 50 4.0 100 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Octagon 
Monogram 0.7 18 2.4 60 CJ

Point 
Monogram 0.7 18 2.9 75 CJ

Seal 
Monogram 0.8 20 2.4 60 CJ

Outline fonts

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Dextor Normal 0.4 9 1.2 30 CJ

News Outline * 0.8 20 1.8 45 CJ

Run stitch fonts

Quilting Text * 0.2 5 1.0 25 AD

Run Block 0.2 5 0.5 12 AD

Run Cardigan * 0.2 5 0.5 12 AD

Run Freehand 0.2 5 0.5 12 AD

Run Liberty * 0.2 5 0.5 12 AD

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Run Murray 
Hill 0.2 5 0.5 12 AD

Run Script 0.2 5 0.5 12 AD

Script fonts

Ballantines 
Script 1.2 30 1.4 35 CJ

Book Script 0.4 10 1.2 30 CJ

Cayman * 0.4 10 1.0 25 CJ

Chancery * 0.6 17 1.0 25 CJ

Edwardian 
Script 1.2 30 1.4 35 CJ

Formal Script * 0.3 7 0.6 15 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Italian Script 0.6 15 1.0 25 CJ

Orlando ^ * 0.3 8 1.5 13 CJ

Poetic Script * 0.8 20 1.6 40 CJ

Pomander * 1.6 40 2.5 65 CJ

Script1 0.6 15 1.2 30 CJ

Script2 0.5 12 1.0 25 CJ

Script3 * 0.8 20 2.1 55 CJ

Script4

[

1.2 30 2.0 50 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Upright Script 0.8 20 2.0 50 CJ

Serif fonts

Algerian 0.4 10 0.6 15 CJ

Athletica 0.4 10 1.2 30 CJ

Bodoni 0.6 15 0.8 20 CJ

Casual Serif 0.4 10 1.4 35 CJ

Cheltenham 
Tall * 0.4 10 0.8 20 CJ

City Medium 0.3 8 0.8 20 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only



Append ix  D     Stand ard  Font s 688

College 0.4 10 0.8 20 CJ

Copperplate 0.4 10 0.8 20 CJ

Garamond 0.6 15 0.8 20 CJ

Schoolbook * 0.6 15 1.2 30 CJ

Seagull ^ 0.4 10 0.8 20 CJ

Serif1 0.3 8 0.6 15 CJ

Serif2 * 0.5 12 0.6 15 CJ

Serif3 * 0.4 10 1.2 30 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Souvenir * 0.3 8 0.8 20 CJ

Stencil Block 0.4 10 0.6 15 CJ

Times Roman * 0.6 15 1.0 25 CJ

Typewriter 0.4 10 1.0 25 CJ

Small fonts

Micro Block * 0.25 6 0.8 20 CJ

Miniature 
Block 0.25 6 0.6 15 CJ

Queensgate 0.25 6 0.8 20 CJ

Sm High Tower * 0.3 8 0.6 15 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only



Append ix  D     Stand ard  Font s 690

Small Block1 * 0.15 4 0.25 6 CJ

Small Block2 0.15 4 0.25 6 CJ

Small Serif 1 * 0.15 4 0.25 6 CJ

Sm Script 0.15 4 0.25 6 CJ

Times Small 0.4 10 0.6 15 CJ

Special fonts

2 Col Arial 
Shadow 0.6 15 1.0 25 AD

Antique Rose 1.6 40 2.4 60 AD

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Engraved Serif * 1.0 25 2.0 50 AD

Flair Script 0.4 10 1.6 40 CJ

3D Foam 
Impact * 0.8 20 1.0 25 AD

Invitation * 1.0 25 2.0 50 AD

Shadow Street * 0.6 15 1.0 25 AD

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Non-Roman fonts

Note: You can insert Japanese characters from the Insert Character dialog or use 
Google Translate and copy and paste into Hatch Embroidery via the Lettering or 
Monogramming tools.

Greek * 0.4 10 0.6 15 CJ

Heisei Kaisho ^ 0.3 8 2.7 70 CJ

Heisei Kantei ^ 0.4 10 2.7 70 CJ

Heisei Gosic ^ 0.4 10 2.7 70 CJ

Heisei Gyosho ^ 0.3 8 2.7 70 CJ

Heisei Maru 
Gosic 0.4 10 2.7 70 CJ

Heisei Mincho ^ 0.4 10 2.7 70 CJ

^ New to Hatch 3 * Hatch Digitizer only
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GLOSSARY

3D Warp:  3D Warp is used with 
Motif Fill to create three 
dimensional effects. You can 
make shapes appear concave 
or convex using Globe In or 
Globe Out. You can also create 
distance effects using 
Perspective.
Acetate:  A salt or ester of acetic 
acid of cellulose made into a 
synthetic filament, yarn, or fabric.
Anchor point:  A fixed point 
used when rotating, scaling, 
skewing or mirroring a design.
Appliqué:  Decoration or 
trimming cut from one piece of 
fabric and stitched to another to 
add dimension and texture. 
Designs with appliqué can be 
more economical than 
embroidery alone, if appliqué 
occupies a significant amount of 
the design, thereby lowering 
stitch count. In Schiffli 
embroidery, appliqué refers to an 
embroidered motif, hand-cut or 
aetzed away from base fabric.
Appliqué cutter:  A device that 
can cut fabric along a line, 
somewhat like old pen plotters. It 
requires a vector file as input. In 
MS Windows® they can be set up 
as a type of printer device.
Artwork:  Bitmap image or 
vector graphic used as a 
digitizing template. See also 
Bitmap image and Vector 
graphic.
Auto appliqué:  Auto Appliqué is 
an embroidery object 
associated with an appliqué 
which provides automatic 
stitching to place it, tack it down, 
and cover its edges.
Auto center:  Auto Center 
automatically centers the start 
and end points of a design.
Auto-digitizing:  Toolset used to 
create embroidery designs by 
automatically digitizing 

electronic images. 
Auto-digitizing tools convert 
vector outlines or bitmap images 
to fully digitized embroidery with 
little or no intervention. See also 
Auto-Digitizing.
Auto scroll:  The Auto Scroll 
feature automatically scrolls the 
screen while you are digitizing.
Auto spacing:  Auto Spacing 
only affects Satin stitch. It adjusts 
stitch spacing according to 
column width.
Auto split:  Auto Split only 
affects Satin stitch. When 
applied, it breaks any long Satin 
stitches into shorter ones. It also 
distributes needle penetrations in 
a random pattern so that they do 
not form a line in the middle of 
the shape. Used primarily to 
prevent long stitches in wide 
columns, it can also be used as 
an alternative to Tatami fill. Auto 
Split looks more Satin-like and 
works well with turning stitches, 
creating soft lines and a little 
more depth.
Auto start and end:  Before 
stitching, some embroidery 
machines require you to position 
the starting needle exactly 
above the first needle 
penetration point. Use Auto Start 
and End to connect the first and 
last stitches in the design. This 
makes it easy to position the 
needle before stitching, and 
reduces the chance of the 
needle hitting the side of the 
frame.
Automatic corners:  Sharp 
points in a shape may cause a 
bunching of stitches and needle 
penetrations which can create a 
hard spot in the embroidery and 
may damage the fabric or 
needle.
Automatic pull compensation:  
Embroidery stitches pull the fabric 
inwards where the needle 

penetrates. This can cause the 
fabric to pucker, and gaps to 
appear in the embroidery. 
Automatic pull compensation 
counters this effect by 
‘overstitching’ outlines of filled 
shapes on the sides where the 
needle penetrates. This means 
the design can be optimized for 
different fabrics. See also Pull 
compensation.
Automatic stitch shortening:  
Reduces stitch bunching at sharp 
corners. See also Stitch 
shortening.
Backdrop:  An electronic image 
used as a guide for digitizing 
designs on screen. Two types are 
used – vector or bitmap. Insert 
them from various file sources, or 
copy and paste them via the 
MS Windows® clipboard.
Background:  Hatch Embroidery 
lets you change the background 
color of the design window to 
match the color of your fabric. Or 
you can select a background 
fabric for more realistic previews 
and presentations. The 
background is saved with the 
colorway.
Backing:  Also known as 
‘stabilizers’, backings are woven 
or non-woven materials placed 
beneath the item or fabric being 
embroidered for stability and 
support. A backing can be 
hooped with the item or placed 
between the machine throat 
plate and hooped garment. The 
more stitches a design has, the 
heavier the backing required. 
Backings are available in various 
weights and types such as 
cut-away, tear-away and 
wash-away (soluble). 
Professional embroiderers use 
tear-away stabilizers for woven 
fabrics and cut-away stabilizers 
for knits. See also Topping.
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Backstitch:  Backstitch is a stitch 
type which can be used for 
delicate outlines. This stitch 
follows intricate curves well. It is 
also is the term used for every 
second row of stitches in a tatami 
fill.
Backtrack:  Use Backtrack and 
Repeat to reinforce outlines while 
specifying the direction of the 
stitching. Backtrack stitches in 
reverse direction to the original. It 
is typically used to make run 
stitch outlines thicker without 
creating unwanted connecting 
stitches. Repeat duplicates the 
original stitch direction and is 
typically used with closed 
shapes.
Backup:  The copying of files 
onto floppy disk or other storage 
media in order to duplicate and 
secure data. Usually two copies 
are made and kept separately.
Bitmap:  Also known as raster 
images, bitmaps are electronic 
images made up of dots or 
‘pixels’, in contrast to vector 
‘outlines’. Each pixel is mapped 
to a location in an image and 
has numerical color values. 
Typically created in paint 
programs, bitmaps have file 
extensions such as BMP, JPG, GIF, 
TIF and PCX. When enlarged or 
scaled down, vector drawings 
preserve image quality while 
bitmap images generally cause 
problems of pixelation and 
image degradation. See also 
Pixels.
Blackwork:  Blackwork gets its 
name from the black silk thread 
traditionally used in this form of 
embroidery. It can be used to 
decorate articles such as 
hankies, table napkins, table 
clothes, and doilies.
Blanket stitch:  Widely used for 
tacking down appliqués as a 
decorative border. The stitches 
form a comb pattern.
BMP:  MS Windows® bitmap 
image format. See also Bitmap.
Bobbin:  Spool or reel that holds 
the bobbin thread, which helps 
form stitches on the underside of 
the fabric.
Bobbin thread length:  This 
factor provides a simple 

mechanism for a more accurate 
bobbin thread length estimate. 
The default value (100%) is 
suitable for a design with a 
mixture of stitch types. If the 
design is all run stitches or all 
tatami, more bobbin thread will 
be used and the factor can be 
increased say to 125%. If the 
design is all satin stitch, the factor 
can be reduced to say 65%.
Border:  Single closed-curve 
object which can be optionally 
added to a monogram. Also, a 
strip of fabric that is joined to an 
inner quilt to enhance it.
Branching:  The Branching 
feature lets you digitize like 
objects – e.g. the fingers of a 
hand – without having to think 
about the most efficient stitching 
sequence and joins.
Candlewicking:  A traditional 
white-on-white embroidery 
technique, usually done on white 
linen or cotton fabric with heavy 
cotton threads.
Center at current stitch:  The 
object will be placed with its 
center at the needle position 
marker.
Center run underlay:  Center 
Run underlay places a row of 
stitches along the center of a 
column. It is used to stabilize 
narrow columns (e.g. 2-3 mm 
wide).
Checkbox:  A small square box 
that appears in a dialog box and 
that can be selected or cleared. 
When selected, a tick or a cross 
appears. A checkbox represents 
an option that you can set.
Click-and-drag:  Click to select, 
hold down the left mouse button, 
move the cursor and release.
Clipboard:  A temporary storage 
area in PC memory for what was 
last cut or copied. Images on the 
clipboard can be pasted into 
designs any number of times.
Color blending:  Digitizing 
technique which creates 
interesting perspective, shading 
and color effects by blending 
colored layers. Two colors are 
merged smoothly from one to 
another using a mixture of dense 
and open fill.

Color block:  A color block or 
‘element’ corresponds to a color 
change in the design. It may be 
comprised of one or more 
same-color objects. These may 
form a single group – e.g. ‘ropes’ 
– or more – e.g. ‘ropes and birds’. 
Each color block, or element, 
can be given a descriptive name 
for easy identification. These then 
appear on the production 
worksheet. The operator 
generally uses them to ensure 
correct colors are used during 
production. The Color-Object List 
provides a sequential list of 
objects as digitized, grouped by 
‘color block’. This list shows a 
separate icon for all color blocks 
and objects used in the design. 
The Color Palette Editor also 
shows a list of color blocks. 
Color depth:  Color depth, also 
called ‘pixel depth’, refers to the 
amount of color information 
available to each pixel in an 
image. An image with a color 
depth of 1-bit can display only 
two colors. As the color depth 
increases, more colors are 
available – 16 Colors (4 bit), 256 
Colors (8 bit), High Color (16 bit), 
True Color (24 bit).
Column:  Narrow, long, curving 
shape.
Command:  An instruction issued 
to the software in order to carry 
out an action. It may be as simple 
as ‘paste an object’ or as 
complex as ‘regenerate stitches’. 
It is usually activated via a menu 
item, toolbar icon, or command 
button in a dialog.
Confirmation message:  A 
message displayed by the 
software asking you if you are 
sure you want to proceed – e.g. 
when you want to delete a 
design.
Connectors:  Connector stitches 
link objects in a design. They can 
be run stitches or jumps. You can 
use automatic settings to 
generate connectors, trims and 
tie-offs, or add them manually.
Copy:  To place a copy of a 
selection onto the clipboard. See 
also Duplicate.
Control panel:  The panel on an 
embroidery machine by which 
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the operator sets up the machine 
for embroidery production.
Control points:  Control points 
are used to modify object 
shapes, stitch angles and entry 
and exit points. You can change 
the shape of an object by 
moving, adding or deleting 
control points on the outline. For 
most objects, you can also 
change control points from 
corner points to curves.
Contour stitch:  Contour is a 
curved fill stitch type – stitches 
follow the contours of a shape, 
creating a curved, light and 
shade effect. It only works on 
columnar shapes.
Copyright:  A right granted by 
the government or by 
international agreement giving 
the owner the exclusive privilege 
to publish and sell artistic work 
during the life of the creator plus 
50 years.
Cover stitch:  Cover stitch is the 
border around an appliqué 
shape. You can control various 
settings including cover stitch 
type – Satin or E Stitch – width, 
stitch spacing, as well as the 
offset.
Current settings:  Current 
property settings override the 
template defaults. Unless you 
deliberately change them, these 
take the default values. You 
generally change them to save 
time when digitizing. For 
example, you may preset Tatami 
stitch spacing to use a specific 
density for all new Tatami objects 
you create. See also Object 
properties.
Cutter:  See Appliqué cutter.
Cutting lines:  A second line of 
run stitches that forms a guide 
when trimming the fabric of an 
appliqué patch.
Default values:  predefined 
settings which determine object 
properties such as stitch spacing, 
as well as certain system settings. 
These are stored in the design 
template. They are automatically 
applied to any newly created 
objects. They remain ‘current’ 
unless you override them with 
new settings. See also Current 
property settings.

Design:  A ‘design’ is a file in the 
native embroidery format – e.g. 
EMB, JAN, ART – of embroidery 
digitizing software. The design 
source may be a stitch format 
design. The design contains 
stitching information such as 
fabric type in addition to stitched 
shapes.
Design colors:  The design 
colors toolbar contains a 
selection of thread colors tailored 
for each design. This color 
scheme, or ‘colorway’, 
represents the actual thread 
colors in which a design will be 
stitched. See also Thread chart.
Design elements:  The 
decorative design components 
that make up a monogram 
(including ornaments and 
borders).
Design file:  Design files, also 
known as ‘all-in-one’ or ‘outline’ 
files, are high-level formats which 
contain object outlines, object 
properties and stitch data. 
Examples include CND and GNC. 
When you open a design file in 
Hatch Embroidery, 
corresponding stitch types, input 
methods and effects are 
applied. Design files can be 
scaled, transformed and 
reshaped without affecting stitch 
density or quality. See also 
Machine file.
Design information:  Designs 
themselves have properties, 
some of which can be modified, 
others not. The most important 
design property is its source – 
Native Design, Imported Outlines, 
Processed Stitches, or Imported 
Stitches. Other properties include 
the software version number, 
stitch count, and so on. 
Colorways too are properties of 
the whole design.
Design source:  While 
embroidery files are broadly 
classified as ‘design’ (outline) or 
‘machine’ (stitch), Hatch 
Embroidery internally tags files as 
belonging to one of four types–
Native Design, Imported Outlines, 
Processed Stitches, or Imported 
Stitches. See also Design 
information.
Design template:  See 
Template.

Design window:  The window 
where designs are displayed for 
viewing, creation or 
modification.
Desktop:  MS Windows® 
terminology for the screen 
background on which program 
icons are displayed.
Destination folder:  The folder 
where you intend to copy or 
move one or more files.
Detail:  An outline, a border, or a 
small area of the design you 
want to be stitched out last when 
using auto-digitizing tools.
Dialog:  An onscreen box that 
either requests or provides 
information. Many dialogs 
present options to choose 
among before a command is 
carried out. Some dialogs 
present warnings or explain why 
a command cannot be 
completed.
Digitizer:  Usually refers to the 
person punching or digitizing the 
design. Digitizer can also refer to 
the digitizing tablet used by the 
digitizer. See also Digitizing 
tablet.
Digitizing:  Process of encoding 
a design. Artwork is converted 
into a series of ‘embroidery 
objects’ to be read and 
manipulated by a specialist 
CAD/CAM application. Before 
outputting to embroidery 
machine, it is converted into 
‘stitch data’.
Digitizing tool:  Digitizing tools, 
sometimes referred to as ‘input 
methods’, are similar to drawing 
tools except that the end result is 
an embroidery object rather 
than a vector object. Different 
digitizing tools are suited to 
creating different shapes or 
design elements.
Direct-to-garment printing:  
DTG is performed like most other 
printing from a PC. The print 
image is sent to the DTG printer 
through the MS Windows® print 
manager using a print driver. The 
image must have a transparent 
background for DTG printing. 
DTG printing requires heat fixing 
to make the images washable.
Disk:  See Floppy disk.
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Disk drive:  Computers usually 
have three types of disk drive: a 
hard disk (or fixed disk) which 
usually supports the mass storage 
of information and applications, 
a floppy disk drive, and a CD 
ROM drive.
Display:  A screen used to 
display the output of a computer. 
Also known as the monitor.
Docker:  A dialog which, while 
open, allows the user to select 
objects freely. Controls in the 
dialog change to conform to the 
values of selected objects, or 
show relevant system information 
when no object is selected. 
Changes made to settings in the 
dialog may be applied while it 
remains open. Other dialogs and 
commands may be opened and 
used while the modeless dialog 
remains open.
Dots per inch (DPI):  A 
measurement of screen or printer 
resolution, the number of dots in 
a line of 1".
Double-click:  Click the left 
mouse button twice without 
moving the mouse. 
Double-clicking carries out 
actions such as opening a 
program from an icon.
Download:  The process of 
transferring a copy of a file from a 
remote computer or the internet 
to a computer or other device 
such as an embroidery machine.
Drag:  An operation of the 
mouse. Holding the (left) mouse 
button while moving the mouse. 
Typically used for moving 
something on the screen.
Drawing object:  See Vector 
object.
Drawing package:  Software 
application that creates or allows 
you to edit vector graphics made 
up of separate individual vector 
objects. Vector graphics can be 
scaled with no loss of sharpness. 
Examples of vector editing 
programs are Adobe Illustrator, 
MacroMedia Freehand and 
Corel Draw. See also Graphics 
application.
Droplist :  A single-line dialog 
box control that opens to display 
a list of choices.

Duplicate:  When an object is 
duplicated, it is not copied to the 
clipboard. This leaves the 
clipboard free for you to cut or 
copy other objects.
Editing:  Changing aspects of a 
design via a computerized 
editing program. Most programs 
allow you to scale designs up or 
down, edit stitch-by-stitch or 
block-by-block, merge lettering 
with the design, move aspects of 
the design around, combine 
designs and insert or edit 
machine commands.
Electronic artwork:  There are 
two broad categories of artwork 
file, both of which can be 
imported into Hatch Embroidery 
for use as digitizing backdrops – 
vector and bitmap. To create 
good quality embroidery, you 
need to choose or create 
suitable artwork of either format.
Element:  An element, in 
software terms, is a color block 
consisting of sequential, 
same-color objects. You can 
assign names to elements which 
then appear on the production 
worksheet. The operator 
generally uses these to make sure 
colors are correct during 
production. See also Production 
worksheet.
EMB:  Design file format native 
to Wilcom ES. EMB designs 
contain a complete set of design 
information in a single ‘all-in-one’ 
file – object outlines and 
properties, actual stitches and 
machine functions, thread 
colors, a picture icon, summary 
information, and more. Even the 
original design bitmap image 
can be included in EMB format. 
Only native EMB files provide 
100% perfect scaling and 
transformation.
Embroidery:  Decorative 
stitching on fabric. Generally 
involves non-lettering designs, 
but can also include lettering 
and/or monograms. Evidence of 
embroidery exists during the reign 
on Egyptian pharaohs, in the 
writings of Homer and from the 
Crusaders of the 12th century. 
Has evolved from hand-work to 
manual sewing machines and 
from hand-looms and Schiffli 

machines with hundreds of 
needles to high-speed, 
computerized multihead 
machines.
Embroidery objects:  In 
embroidery design, you build 
designs from basic shapes or 
‘embroidery objects’. They are 
called ‘objects’ because they 
are discrete entities which can 
be selected and manipulated 
independently of each other. 
They are like ordinary vector 
objects in that they have certain 
characteristics or ‘properties’ 
such as color, size, position, and 
so on. They also have properties 
unique to embroidery such as 
stitch type and density. See also 
Vector objects.
Embroidery thread:  See 
Thread.
Entry point:  The entry point is 
the point where the thread enters 
the embroidery object. This 
should coincide with the exit 
point of the preceding object.
EPS (Encapsulated 
PostScript):  A standard file 
format for importing and 
exporting PostScript language 
files among applications in a 
variety of environments. An ESP 
file is a PostScript file which 
describes a single page, usually 
an illustration. In general, the 
purpose of the EPS file is to be 
included (encapsulated) in 
another PostScript file and can 
contain any combination of text, 
graphics and images. EPS files 
normally include a small, 
low-resolution TIFF, or 
vector-based MS Windows® 
metafile image preview, as it will 
appear on a printed page.
Exit point:  The exit point is the 
point where thread leaves the 
embroidery object. This should 
coincide with the entry point of 
the next object.
Fabrics:  Fabrics have many 
properties, the main one being 
elasticity or ‘fabric stretch’. 
Surface texture, if present, is 
another property that requires 
different underlay types. When 
you choose a fabric for use with a 
particular design, the system 
pre-loads settings optimized for 
that fabric. These can be 
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overridden on an 
object-by-object basis. See also 
Fabric settings.
Fabric settings:  predefined 
fabric settings include settings for 
all full-coverage stitch types. For 
each stitch type, spacing is 
preset. Additionally, the quality 
effects of pull compensation and 
underlay are also preset for each 
stitch type. Push, warping, and 
shearing are reduced by suitable 
underlay for the stitch type and 
fabric. Decorative effects such as 
Motif Fill are not affected when 
fabric settings are changed.
Fabric stretch:  Embroidery 
stitches pull the fabric inwards 
where the needle penetrates. 
This can cause the fabric to 
pucker, and gaps to appear in 
the embroidery. Use automatic 
pull compensation to counter this 
effect by ‘overstitching’ outlines 
of filled shapes.
Facing:  See Topping.
Factory settings:  These are the 
initial system settings as installed. 
They are a standard known 
setting that you can return to. 
Some customers want to create 
custom settings tailored to the 
exact fabric they are using most 
frequently. The ‘My Fabric’ 
settings are those retained in the 
design and can be saved to the 
template file.
File:  A named collection of 
specifically related information 
stored on a disk. Designs that 
have been saved are stored as 
files.
File extension:  The dot and 
three letters at the end of a 
filename such as ‘.BMP’. The 
extension identifies the file as a 
certain type, readable by certain 
applications.
Filename:  The name of a file, 
including the extension, e.g. 
Cat.BMP.
Fill stitch:  Series of running 
stitches commonly used to cover 
large areas. Different fill patterns 
can be created by altering the 
angle, length and repeat 
sequence of the stitches. Also 
known as Geflect stitch.
Finishing:  Processes done after 
embroidery is completed. 

Includes trimming loose threads, 
cutting or tearing away excess 
backing, removing facing or 
topping, cleaning any stains, 
pressing or steaming to remove 
wrinkles or hoop marks and 
packaging for sale or shipment.
Flagging:  Up and down motion 
of fabric under action of the 
needle, so named because of its 
resemblance to a waving flag. 
Often caused by improper 
framing of goods. Flagging may 
result in poor registration, 
unsatisfactory stitch formation 
and birdnesting.
Float:  Longer-than-normal Satin 
stitches that lay on top of a 
design, or the stitches made 
when the needle is 
disconnecting from the design, 
later removed.
Florentine effect:  With 
Florentine Effect you can curve 
Complex Fill along a digitized line 
to create flowing stitch effects. 
The stitches follow the digitized 
line but maintain uniform density 
and needle penetration 
patterns.
Folder:  A collection of files and 
subfolders that are stored 
together on a disk. Part of 
structure for organizing files on a 
disk.
Font:  A set of characters, 
including letters, numbers and 
other typographic symbols, of 
the same design and style. 
Sometimes called ‘alphabet’, 
even if it includes non-letter 
characters. See also Lettering.
Frame:  Holding device to 
secure fabric under an 
embroidery head for stitching. 
May employ a number of means 
to maintain stability during the 
embroidery process, including 
clamps, vacuum devices, 
magnets, or springs. See also 
Hoop.
Frame-out position:  When you 
stitch out appliqué objects, you 
can set a frame-out position. This 
shifts the hoop out from under the 
needle, making it easier to place 
and trim the appliqué shapes. 
The frame out settings determine 
the distance and direction of the 
hoop movement.

Free Line baseline:  Free Line is 
the only type of baseline which 
does not have a fixed or 
pre-determined length. When 
you choose Free Line, the 
baseline will extend as long as 
you keep adding letters. You only 
need to mark its start point. See 
also Baseline.
Fringe:  Threads that are cut and 
hang loosely from the edge of a 
design.
Function:  See Machine 
Function.
Graphics application:  Software 
application that creates or allows 
you to edit bitmap images 
and/or vector graphics. See also 
Paint package and Drawing 
package.
CorelDRAW Graphics:  An 
operating mode in which the 
CorelDRAW software application 
is active.
Gradient Fill:  An artistic stitch 
effect that gradually varies stitch 
spacing between dense and 
open fill along an embroidery 
object, producing shading and 
color effects which are difficult to 
achieve manually.
Grayscale:  A grayscale picture 
is made up of 254 different 
shades of gray, plus solid black 
and solid white for a total of 256 
different tones. Black and white 
photographs are grayscale.
Grid:  Grid lines provide visual 
cues to help you accurately 
place a design. When you start 
the software for the first time, grid 
lines appear by default.
Hard disk:  A device for mass 
information storage. Usually the 
disk is fixed inside the system unit, 
and a second hard disk can be 
added. When you store 
information on the hard disk it will 
remain there until you delete it. 
As it has a finite capacity, file 
management is required.
Hardware:  Computer 
componentry, including monitor, 
keyboard, digitizing tablet, 
printer, scanner, sewing 
machine, etc.
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Heirloom embroidery:  
Embroidered goods designed to 
be passed down from 
generation to generation.
Hoop:  Device made from 
wood, plastic or steel used to 
tightly grip fabric and stabilizer 
between an inner and outer ring. 
Designed to hold fabric taut 
against the machine bed for 
embroidering, it attaches to 
machine’s frame.
Hooping:  The process of 
placing the fabric and/or 
stabilizer into the embroidery 
hoop. One of the most common 
reasons for a poorly stitched 
design is improper hooping. 
I-beam:  One shape taken by 
the PC pointer, it indicates that 
text can be input at the point 
selected. The shape is like the 
capital letter ‘I’.
Icon:  Miniature picture used in 
the screen display instead of, or 
as well as, text. The file list can be 
displayed as icons with the 
filenames underneath. The 
toolboxes which appear in the 
left of the screen are composed 
of icons.
Image editing program:  See 
Graphics application.
Image preparation:  Cleaning 
up scanned images as input to 
embroidery digitizing. This may 
involve any one or a 
combination of the following 
techniques: reducing the 
number of colors, adding or 
emphasizing outlines, removing 
noise, dithering or anti-aliasing, 
eliminating unnecessary detail, 
cropping sections or eliminating 
backgrounds.
Imported outlines:  Designs 
read from non-EMB outline – CND 
or PCH – where stitches have 
been generated in Hatch 
Embroidery (or equivalent) from 
original outlines and stitching 
data.
Imported stitches:  Designs 
read from stitch or ‘expanded’ 
files, with or without outline 
recognition, but stitches have not 
been regenerated through stitch 
processing. Note that if you 
change a stitch design – e.g. add 
a lettering object – the status 

changes to ‘Processed Stitches’ 
even though the imported 
stitches may not have been 
regenerated.
Input method:  See Digitizing 
tool.
Jagged edge:  Technique for 
creating rough edges, to create 
shading effects, or to imitate fur 
or other fluffy textures in your 
design.
JPG:  JPEG file interchange 
bitmap image format.
Jump:  A frame or hoop 
movement without a needle 
penetration, commonly used to 
get from one point in a design to 
another.
Jump function:  Jump(M) 
functions cause frame 
movements without needle 
penetrations and are used to 
move smoothly from one part of 
a design to another.
Justification:  The position of 
lettering on the embroidery 
baseline.
Keyboard design collections:  
The Keyboard Design Collection 
feature allows you to map 
embroidery character designs to 
keyboard characters for quick 
and easy use in Hatch 
Embroidery.
Lacework:  Lacework involves 
the use of threads to produce 
overall embroidery of full-length 
fabrics. Most often used to 
embellish women's apparel and 
home fashions. Such work 
typically uses boring. It is the most 
widely used application for 
Schiffli machines.
Letter spacing:  The space 
between adjacent letters.
Letters:  Initials or name making 
up a monogram. Letters of a font.
Lettering:  Embroidery using 
letters or words. Lettering 
commonly called ‘keyboard 
lettering’ may be created from 
predefined font styles or fonts, 
allowing variance of size, height, 
spacing, density and other 
characteristics.
Lettering art:  Special effects 
applied to lettering objects to 

make them bulge, stretch or 
compress. 
Line art:  A drawing with only 
two colors – usually black and 
white.
Logo:  Name, symbol or 
trademark of a company or 
organization. Short for logotype.
Machine file:  Machine or 
‘stitch’ files are low-level formats 
for direct use by embroidery 
machines. They contain only 
stitch coordinates and machine 
functions. Machine files are 
generally not suited to scaling 
because stitches are not 
regenerated during rescaling. 
See also Design file.
Machine format:  Different 
embroidery machines 
understand different languages. 
They have their own control 
commands for the various 
machine functions. Before you 
can stitch a design, it must be in 
a format which can be 
understood by the target 
machine. Common formats 
include Barudan, Brother, 
Fortran, Happy, Marco, 
Meistergram, Melco, Pfaff, Stellar, 
Tajima, Toyota, Ultramatic and 
ZSK.
Machine function:  Machine 
functions are commands for a 
specific embroidery machine. 
These include color changes, 
thread trims, jumps, machine 
stops, needles in/out, and boring 
begin/end. Schiffli makes a 
distinction between ‘logical’ and 
‘physical’ machine functions. 
See also Logical machine 
functions and Physical 
machine functions.
Machine setup:  Before you can 
send designs for stitching, you 
must configure the machine in 
Hatch Embroidery. You can add 
machines, change settings for 
machines already set up, or 
delete machines that are no 
longer required.
Manual object:  When you open 
a stitch format file without outline 
recognition, it becomes a single 
‘manual’ object. This object 
consists of individual needle 
penetration points and has only 
general and connector 
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properties. When you transform 
(scale, rotate, mirror) a manual 
object, the original stitch density 
does not change.
Max/Min stitch length:   The 
minimum and maximum stitch 
lengths allowable in a design 
determine the outside limits as 
measured between needle 
penetration points. They are 
governed by the minimum and 
maximum frame movements that 
the machine can make.
Maximize button:  For windows, 
the small box in the center of the 
group of three at the right of the 
title bar. Click the Maximize 
button to enlarge a window to its 
maximum size.
Memory:  The place in the 
computer’s system unit that 
stores information while you are 
working with it. If you exit without 
saving information in memory, it 
will be lost.
Menu bar:  The menu bar 
contains dropdown menus of 
commands. Some of the same 
commands are available on the 
toolbar.
Minimum stitch length:  The 
minimum movement of the 
hoop. It is measured between 
needle penetration points. See 
also Max/Min stitch.
Mirror:  Duplication of an object 
in the Y and/or X axis. The 
location and orientation of the 
mirrored stitches are determined 
by location and angle of the axis 
of reflection relative to the 
position of the original stitches.
Mirror-merge:  Mirror-Merge 
Array can create multiple copies 
of designs, such as badges, 
spaced in rows and columns for 
faster stitchouts. Mirror-Merge 
Reflect can duplicate and mirror 
designs simultaneously. You can 
use it to quickly create borders or 
merge duplicates into a 
symmetrical object such as a 
heart. Mirror-Merge Wreath can 
duplicate objects around a 
center point. The Kaleidoscope 
tool works like Wreath but mirrors 
objects as well.
Monitor:  In computer terms, a 
device that accepts video 
signals from a computer and 

displays information. Monitors 
generally employ cathode-ray 
tubes or flat-panel displays to 
project images. In practice, the 
terms monitor and display are 
used interchangably. In digitizing 
terms, the monitor is where 
digitizing or stitching progress can 
be followed, stitch-by-stitch.
Monogram:  Embroidered 
design composed of one or more 
letters, usually the initials of a 
name. Can also consist of 
borders or designs to mark 
ownership of items such as 
clothing, caps, handkerchiefs, 
etc.
Motif:  predefined design 
elements, such as hearts, leaves 
or border patterns, that can be 
quickly inserted into a design. 
Motifs generally consist of one or 
more simple objects, and are 
stored in a special motif set.
Motif Fill:  Motif Fill is a 
decorative fill stitch with which 
you can fill larger shapes. 
Depending on your software’s 
capabilities, you can also create 
special or three dimensional 
effects.
Motif run:  Motifs which are 
linked together along a digitized 
line. You can create decorative 
outlines using any motif from the 
list. 
Motif set:  Motifs are stored in 
‘motif sets’ similar to fonts. There 
are two predefined motif sets. 
One contains single motifs for fills 
which use the same pattern in 
both forward and backward 
rows. The other set is intended for 
use with two-part motifs which 
use complementary patterns for 
forward and backward rows. You 
can also define your own ‘motif 
sets’ to organize and classify 
motifs of your own creation.
Mouse:  A device, equipped 
with control buttons and 
designed to roll about on the 
table next to the keyboard. As 
the mouse moves, its circuits relay 
signals that move a pointer on 
the screen.
Native file format:  A design 
saved in the original format of the 
application you are working with 
is said to be the ‘native’ file 

format. It can also refer to the 
machine file format required by a 
specific embroidery machine. 
When saved to another format, it 
is known as a non-native format.
Needle points:  You can view 
needle points in a design to 
check density or, for instance, to 
select stitches for editing.
Needle spacing:  Needle 
spacing is the distance between 
adjacent needles of a Schiffli 
embroidery machine. Typical 
values are 27.07 mm and 
27.04mm. The software lets you 
set up and adjust this value to suit 
the type of machine which will 
stitch the design.
Noise filtering:  Noise filtering 
means restoring the solid color 
blocks of original artwork in 
scanned images. This is achieved 
by merging different shades into 
one solid color. Noise filtering is 
important for automatic digitizing 
because it makes it easier for the 
software to identify solid color 
blocks which become 
embroidery objects in the 
resulting design. It also cleans up 
blurred or mottled areas of color.
NORMAL template:  The 
NORMAL template is the default 
template supplied with the 
software. It contains current 
property settings as well as a 
selection of preset styles. These 
styles include variations on the 
current property settings. For 
example, <PRESET_SATIN_1> and 
<PRESET_SATIN_2> contains 
different stitch spacing settings 
for Satin stitches. You can view 
and modify the settings for these 
styles at any time. See also 
Templates.
Objects:  In computer science, 
‘objects’ are regarded as any 
discrete item that can be 
selected and manipulated, such 
as an onscreen graphic. In 
object-oriented programming, 
objects include data and the 
procedures necessary to 
operate on that data. See also 
Embroidery objects.
Object properties:  All 
embroidery objects in Hatch 
Embroidery contain defining 
settings or ‘values’. The values 
stored with an object become its 
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‘properties’. All objects have 
certain properties in common 
such as size and position. There 
are other, more specific 
properties of objects which 
depend on the object type. The 
most important property of all 
embroidery objects is stitch type.
Object recognition:  See 
Outline recognition.
Object type:  An object has a 
type, shape, thread type and 
color, stitching settings and a 
position in the stitching order. The 
object type may or may not 
determine the intended final 
appearance of the stitching.
Offset Object:  Software 
function used to create new 
outlines from the outlines of 
selected objects.
Ornament:  A grouped 
embroidery design which may 
consist of one or more objects of 
any type and one or more colors. 
Ornaments may be placed in up 
to eight positions around letters, 
or centered behind letters.
Options:  Options provide 
software with extra functionality 
that can be purchased by 
registered owners of the product.
Outline file:  See Design file.
Outline recognition:  When you 
convert a machine file to outline 
format, Hatch Embroidery reads 
the data stitch-by-stitch 
according to the needle 
penetration points. The software 
then ‘recognizes’ stitch types, 
spacing and length values, stitch 
effects, and can determine 
object outlines.
Outline stitch:  Stitch such as 
Run or Satin used to outline an 
embroidery object.
Pan:  Use Pan to view parts of a 
design which are not currently 
visible in the design window. 
Partial appliqué:  Technique to 
create appliqué objects with 
partial cover stitching to create 
an overlapping effect without 
doubling-up borders.
Paste:  To insert an object, which 
has previously been placed on 
the clipboard by cutting or 
copying selected objects, into a 
design. You can paste from the 

clipboard as many times as you 
like.
PDF:  Portable Document 
Format. Used to view the Online 
Manual in Acrobat Reader.
Patchwork:  The composite of 
pieces sewn together to form a 
large piece, such as a quilt.
Pencil rub:  Low-cost way of 
producing an embroidery design 
sample. Consists literally of a 
piece of tracing paper placed 
over a stitchout and rubbed 
lightly with a pencil to produce 
an impression of the embroidery.
Pixel:  A dot. For example, dots 
of light that make up the image 
on a computer screen. The more 
pixels in a given area – that is, the 
smaller and closer together they 
are – the higher the resolution.
Pixelation:  An effect which 
occurs when a bitmap image is 
enlarged so that the individual 
pixels are obvious to the eye.
Placement lines:  Series of 
stitches used to align 
embroideries in multi-hooping 
situations or to assist in fabric 
placement for appliqué. It is the 
first appliqué layer stitched and is 
used to position the pre-cut 
appliqué patches on the 
background material. See also 
Appliqué.
Pointer:  A part of the screen 
display, the pointer can take 
various shapes. It is moved by 
moving the mouse and can be 
used to point to anything on the 
screen to make selections and 
indicate points for input. It also 
indicates when the computer is 
working and no input is possible.
Port:  A connection on a 
computer where you plug in the 
cable that carries data to 
another device. Ports which are 
used to attach peripherals have 
names like COM1 or LPT1 so that 
you can specify where the 
peripherals are attached.
Position:  The Position indicator 
shows position of the design (X, Y) 
in the design window.
Print preview:  Use to preview 
design and design information 
before printing a Production 

Worksheet. The design is 
displayed as it will be printed.
Processed stitches:  Designs 
read from stitch or ‘expanded’ 
files where stitches have been 
regenerated by processing.
Program:  A computer program 
or ‘application’ is generally used 
for a particular kind of work, such 
as word processing or database 
management.
Properties:  See Object 
properties.
Protocol:  The communications 
protocol depends on the 
connection type between the 
computer and the embroidery 
machine. This will be one of: 
standard serial, parallel, serial to 
parallel converted (DCi), or 
interface card.
PS:  Postscript vector format.
Puckering:  Result of the fabric 
being gathered by the stitches. 
Many possible causes include 
incorrect density, loose hooping, 
lack of backing, incorrect tension 
or dull needle.
Pull compensation:  Digitizing 
technique that takes into 
account the distortion of a 
design that will occur because of 
the interaction of thread with 
fabric. ‘Push and pull’ will cause 
a circle digitized perfectly round 
to sew with the sides pushed out, 
resulting in an egg shape. 
Generally, it is necessary to 
extend horizontal elements and 
reduce vertical elements. See 
also Automatic pull 
compensation.
Push-pull:  When any stitch is 
sewn into fabric, the tension in 
the thread between needle 
penetrations can build up and 
result in a ‘push-pull’ effect. This 
can cause distortions in your 
sewn designs, poor stitch 
registration and even the 
bunching of the fabric. The 
degree of distortion can be 
affected by the following factors: 
stitch density, fabric type, 
underlay, backing type, thread 
type and garment orientation. 
See also Stitch-Pull.
Quilting:  The stitching of 
patterns into the quilt layers to 
add strength and decoration to 
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a quilt – top, batting and backing 
– to form decorative patterns on 
the surface of the quilt and to 
hold the layers together. 
Read:  To open a design which 
has been written on a design 
card or to an embroidery 
machine.
Recognition:  See Outline 
recognition.
Reduce colors:  See Image 
preparation.
Reference point:  A point that 
can be aligned with the grid. For 
example, you can set the grid 
reference point to the design 
center. This is easier and faster 
than moving the whole design. 
Refresh screen:  The screen 
display is refreshed. This is useful 
when parts of the display have 
become obscured in the course 
of editing. See also Slow 
Redraw.
Registration:  Correct 
registration is achieved when all 
stitches and design elements line 
up correctly.
Repeat:  Layout used for making 
emblems or designs on a fabric 
span that are repeated at 
regular intervals. The design 
repeat is defined by the distance 
between needles – the point at 
which the design repeats itself.
Resequence:  You can change 
the position of a selected object 
by cutting it, then pasting it 
somewhere else in the stitching 
sequence, or by using the 
Resequence command. You can 
also resequence objects by color 
or using the Color-Object List. 
Resizing:   See Scaling.
Resolution:  Resolution 
determines the number of dots 
per inch (dpi) used to create an 
image. The higher the value, the 
clearer the image, but the more 
storage space required. A 
resolution of 75 dpi generally 
produces good results.
RGB:  RGB stands for red, green, 
and blue. It is the system used by 
computer monitors to create 
color.

Right-click:  To press and release 
the right mouse button. See also 
Click.
Ripple stitch:  Ripple stitch 
creates a single, continuous line 
of stitching that spirals around to 
fill the shape. Typically, it is used 
for rings and borders, but it is also 
suitable for other closed shapes. 
See also Contour stitch.
Rollover:  The point at which the 
fabric is shifted – loosened and 
reset – vertically to continue 
stitching. Common on long fabric 
Schiffli machines.
Rotation handles:  When you 
select an object, selection 
handles display at its extremities. 
If you click the object again, 
rotation and skew handles 
appear around the object. 
Rotation handles appear at the 
corners of the object and an 
anchor point displays at the 
object’s center. Skew handles 
are diamond-shaped and 
appear at the center-top and 
bottom of the object. See also 
Selection handles.
Run stitch:  Run stitch, also 
known as ‘Walk stitch’, places a 
single row of stitches along a 
digitized line. The needle 
penetrations are placed in 
consecutive order. Run is 
generally used for stitching 
outlines and connector stitches. 
Run stitch length can be set to 
automatically vary in order to 
follow tight curves.
Satin stitch:  Type of fill stitch. 
Formed by closely arranged 
zigzag stitches, it can be stitched 
at any angle and with varying 
lengths. The thread is laid across 
a shape with a zigzag sewing 
action where two stitches form a 
column. Hence it is only suitable 
for small or narrow shapes. As the 
stitches are almost parallel, Satin 
provides good coverage. It is 
often used for lettering, outlining, 
and details. Because there are 
generally no needle penetrations 
breaking up the fill, Satin stitch 
creates a glossy effect.
Save:  To store (design) 
information in a file. Each time 
you save a design, you replace 
the previous version using the 

filename. You should save your 
design frequently.
Scalability:  Ability to enlarge or 
reduce a design. In expanded 
format, most scaling is limited to 
10 to 20%, because the stitch 
count remains constant despite 
final design size. In condensed 
formats, on the other hand, scale 
changes may be more dramatic, 
because stitch count and density 
may be varied.
Scale factor:  This option allows 
you to automatically scale CND 
designs as you load them. For 
example, to scale the imported 
design to 120% of the original, 
you would enter a scale factor of 
1.2.
Scaling:  Ability to enlarge or 
reduce a design in size. In stitch or 
‘expanded’ format, most scaling 
is limited to ±5% because the 
stitch count remains constant 
despite final design size. In design 
or ‘outline’ formats, scale 
changes may be more dramatic 
because stitch count and density 
are recalculated.
Scanner:  A device that 
converts physical images into 
digital form so that they can be 
stored and manipulated by 
computer. Scanning allows you 
to take scanned images as a 
basis for embroidery design.
Scanning resolution:  Most 
scanners require you to enter 
scanning resolution information. 
Resolution determines the 
number of dots per inch (dpi) 
used to create a drawing. The 
higher the value, the clearer the 
image but larger the file. For 
digitizing purposes, use a 
maximum resolution of 300 dpi 
(dots per inch). A resolution of 72 
dpi (screen resolution) will usually 
be sufficient. Generally speaking, 
the smaller the source image 
and/or more detail it contains, 
the higher the resolution needs to 
be.
Screen calibration:  You need 
to calibrate your monitor so that 
designs at 1:1 scale appear at 
real size. Do this when you first 
install Hatch Embroidery, 
whenever you change your 
monitor, or adjust your monitor’s 
horizontal or vertical controls.
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Screen printing:  Screen 
printing is a more complex 
process than direct-to-garment, 
requiring the creation of a screen 
for each of the spot colors 
(Pantone) that make up the 
design. There may be multiple 
screens for each spot color, 
depending on how the design is 
layered. See also 
Direct-to-garment printing.
Screen resolution:  See Pixels.
Scroll bar:  The bar at the 
bottom and right edge of a 
window whose contents are not 
entirely visible. Each scroll bar 
contains a small box, called a 
scroll box, and two scroll arrows 
to allow different types of 
scrolling.
Segments:  Filled embroidery 
objects are generally built as 
several discrete ‘segments’. 
Travel runs are typically used to 
connect them. All segments, 
however, form part of the same 
object. Where they meet, the 
push-pull effect on the fabric 
during stitchout may cause gaps 
to appear.
Select:  To highlight an object or 
group of objects for the purpose 
of editing. Only selected items 
can be edited.
Selection handles:  Eight small 
squares that appear 
symmetrically at the corners and 
edges of a selected object. Use 
them to position and resize 
objects. See also Rotation 
handles.
Selection marquee:  The dotted 
rectangle that appears when 
you select a range of items.
Sequence:  See Stitching 
Sequence.
Serif:  In typography, serifs are 
semi-structural elements on the 
ends of strokes that make up 
letters and symbols. A typeface 
that has serifs is called a serif 
typeface. A typeface without 
serifs is called sans-serif.
Shortcut key:  A key stroke or a 
series of keystrokes you can use 
to perform a task instead of using 
the mouse. For example, Ctrl+C 
actions the Copy command.

Sizing handles:  See Selection 
handles.
Skew handles:  See Rotation 
handles.
Slow Redraw:  Use to redraw 
your design slowly. Slow Redraw 
lets you view the stitching and 
color sequence of a design in 
slow motion.
Small stitches:  Use the Small 
Stitch Filter to remove unwanted 
small stitches from a design 
automatically.
Software:  Programs, such as 
MS Windows® and Hatch 
Embroidery, which run your 
computer.
Spangles:  See Sequins.
Specialty threads:  Threads 
designed for effects such as 
shine, glitter, iridescence or 
thickness. The threads often are 
made from synthetic materials 
including rayon, mercerized 
cotton, metallics and textured 
nylon.
Split object:  You can split 
embroidery objects that were 
created with the Spalte A, 
Column B, and Column C tools, if 
Satin or Tatami, or Program Split is 
the selected stitch type.
Stabilizer:  See Backing.
Standard backstitch:  The rows 
are approximately parallel, with 
every backstitch row slightly 
shorter than the forward row. 
Because the rows are different 
lengths, there are fewer small 
stitches at the edge of the shape, 
reducing possible damage to the 
fabric. Standard backstitch is 
suitable for high density fills. See 
also Backstitch.
Standard contour:  Standard 
Contour creates rows of stitches 
across the shape, perpendicular 
to the digitized stitch angle. The 
number of stitch lines is constant, 
so the stitching is denser where 
the shape is narrower, and more 
open where the shape is wider. 
See also Contour stitch.
Status bar:  Provides information 
about the whole design: number 
of stitches, position of the design 
(X, Y), number of colors (C), 
number of stops (S), etc.

Stemstitch:  A detail stitch that 
can be used to outline items or fill 
in areas. It is used for stems and 
vines with other decorative 
stitches, or as an outline for Satin 
or Motif fills.
Stippling:  A method of creating 
a fill made of run stitches which 
meander around within a border. 
Often used in quilting.
Stitch:  A stitch is one needle 
penetration. It also refers to the 
thread laid down from one 
needle penetration to the next.
Stitch angle:  The stitch angle is 
the angle the overall stitching 
follows within a shape. The shape 
may have a fixed stitch angle – 
e.g. 45° to the horizontal – or 
multiple stitch angles.
Stitch bunching:  Standard 
stitch spacing is calculated at 
the outside edge of a shape. 
With sharp curves, spacing which 
provides adequate coverage on 
the outside edge may cause 
bunching along the inside edge. 
This may cause thread breakage 
when stitching out.
Stitch count:  Stitch count refers 
to the number of stitches in a 
design. In Hatch Embroidery one 
stitch is considered one machine 
revolution. See also Design 
information.
Stitch density:  The number of 
stitches per given area (or stitch 
lines per distance in a fill).
Stitch editing:  Digitizing feature 
that allows one or more stitches in 
a pattern to be deleted or 
altered.
Stitch file:  See Machine file.
Stitch length:  The distance 
between two needle 
penetration points. For maximum 
stitch length, the length is 
measured according to the X 
and Y co-ordinates, whichever is 
greater. Run stitch length can be 
set to automatically vary in order 
to follow tight curves. See also 
Max/Min stitch length.
Stitch processing:  The 
calculation of stitch information 
by means of specialized 
software, allowing scaling of 
expanded format designs with 
density compensation.
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Stitch-pull:  See Push-Pull.
Stitch type:  Three basic stitch 
types are available with 
lockstitch machines – Run, Satin 
and Tatami (Weave). Hatch 
Embroidery provides many 
variants of these.
Stitch shortening:  When a 
shape takes a sharp turn, the 
spacing of stitches on the inside 
of the shape decreases rapidly. 
This results in bunching on the 
inside and gaps on the outside of 
the shape. The longer the stitch, 
the worse the problem. 
Automatic Stitch Shortening 
solves this problem by eliminating 
thread bunching. The 
embroidery has smooth, even 
stitch spacing throughout. It also 
reduces thread breakages 
during production.
Stitch spacing:  Spacing 
between two consecutive 
needle penetrations on the same 
side of a column. The smaller the 
value, the greater the stitch 
density. For more open stitching, 
use larger values.
Stitching defects:  Stitching 
defects may appear in the form 
of gaps between filled areas, 
fabric show-through and thread 
breaks. These are often caused 
by incorrect stitching settings – 
e.g. setting pull compensation 
too small for the fabric 
stretchiness.
Stitch-to-machine:  The 
software may send a design for 
stitching directly to embroidery 
machine if connected to your 
computer. Not all machines can 
connect to Hatch Embroidery.
Stitching direction:  Stitching 
direction can affect embroidery 
quality because of the Push-Pull 
effect. Only closed embroidery 
objects can be reversed.
Stitching sequence:  The 
embroidery objects in a design 
form a stitching sequence. 
Initially, objects are stitched in the 
order in which they were created 
or the design assembled. You 
can change the position of a 
selected object by cutting it, 
then pasting it somewhere else in 
the sequence, or by using the 
Resequence command. You can 

also resequence objects by color 
or with the Color-Object List.
Stock designs:  Embroidery 
designs readily available on disk 
or proprietary embroidery card. 
Digitized embroidery designs that 
are commercially available for 
general use by embroiderers.
Stop code:  Stop codes are 
interpreted as ‘explicit stops’. The 
machine stops stitching.
Stop function:  If you want the 
embroidery machine to stop for 
any special reason while stitching 
a design, you need to insert a 
Stop function in the stitching 
sequence. If there are Stops in a 
design, these can be read into 
Hatch Embroidery as either a 
Color-change function or a Stop 
function.
Supported machine type:  A 
machine is ‘supported’ by the 
software either via a direct 
implementation in the software 
for a specific machine or via the 
MS Windows® operating system – 
e.g. a MS Windows® supported 
printer or MS Windows® 
supported cutter.
Swiss embroidery:  Satin stitch 
embroidery. Also recalls the 
origins of automated embroidery 
in Switzerland, where the Schiffli 
embroidery machine was 
developed in the 1800s by Isaak 
Groebli. Embroidery remains a 
government-supported industry 
in Switzerland today.
System administrator:  The 
System Administrator is 
responsible for the entire 
Enterprise Network and security. 
In smaller enterprises, the System 
Administrator is also usually 
responsible for database 
administrations.
System requirements:  What 
your computer’s hardware and 
software, operating together, 
can support. System 
requirements are printed on 
software packages, design disk 
cards and packs, CDs and other 
computer accessories. You need 
to know what your system can 
and cannot support, as 
sometimes a system is not 
capable of handling new 

software without adding memory 
or disk space.
Tackdown:  Zigzag stitch, 
placed after placement and 
cutting lines, and used to fix 
appliqué patches to the 
background fabric before cover 
stitching is applied.
Tatami stitch:  Series of run 
stitches, commonly used to cover 
large, irregular shapes. Stitches 
are laid in rows traversing back 
and forth across the shape. These 
can be parallel or slightly turning. 
Different fill patterns can be 
created by varying the stitch 
length, angle or sequence. Also 
known as Weave stitch.
Tatami underlay:  Tatami 
underlay is used to stabilize large, 
filled shapes. It resembles an 
extremely open Tatami fill stitch, 
where rows of stitches are placed 
across the object to create the 
underlay.
Templates:  Templates are 
special files used for storing styles 
and default property settings. The 
NORMAL template packaged 
with the software provides a 
selection of preset styles. You can 
modify these as required and 
save them back to the NORMAL 
template or to your own custom 
templates. Use these when 
digitizing frequently-used design 
types to save time re-adjusting 
the current property settings. For 
example, a custom template 
may include standard objects 
and sample lettering. It may 
simply have preferred stitch 
settings, lettering font and size, 
and colors set as current settings. 
Or it may have special density, 
pull compensation or underlay 
settings to suit different fabrics.
Tension:  Tautness of thread 
when forming stitches. Top 
thread tension, as well as bobbin 
thread tension, need to be 
correctly set. Proper thread 
tension is achieved when about 
one third of the thread showing 
on the underside of the fabric on 
a column stitch is bobbin thread.
Textured edge:  Use Textured 
Edge to create rough edges, to 
create shading effects, or to 
imitate fur or other fluffy textures 
in your design.
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Thread:  Fine cord or natural or 
synthetic material made from 
two or more filaments twisted 
together and used for stitching. 
Machine embroidery threads 
come in rayon (high sheen), 
cotton (duller finish), polyester 
(strong and colorfast), metallics 
(synthetic core wrapped with 
metal foil or thin slivers of metal 
foil) and acrylic (sheen similar to 
rayon).
Thread chart:  Thread charts are 
lists of predefined thread colors. 
They may be based on 
commercially available thread 
charts, or charts you define 
yourself. You can copy colors 
between different thread charts 
to create your own charts from 
existing colors. See also Color 
palette.
Thread code:  Code is the 
identification number of a thread 
color in a brand.
Thread density:  Different 
thread density systems are used 
by different thread 
manufacturers. Density A is 
normal embroidery thread 
(density 120/2, or 40). Density B is 
thicker, Density C is finer, and 
Density D is very fine.
Thread thickness:  See Thread 
density.
Thread type:  Embroidery 
thread varies in thickness. Types 
are A, B, C and D. Stitch density 
should be set according to the 
thread type. See also Thread 
thickness.
Tie-ins:  Tie-in stitches are 
inserted at the start of objects to 
prevent stitches from unraveling. 
They are inserted inside the 
shape on the second stitch. You 
generally use them when the 
previous connector is trimmed.
Tie-offs:  Tie-offs are generally 
placed before trims to prevent 
stitches from unraveling. You can 
adjust connector settings to 
automatically add tie-offs under 
certain conditions, or add them 
manually. You can also include 
trim functions so machines with 
trimmers cut the thread 
automatically.
Title bar:  The horizontal bar 
located at the top of a window 

and containing the title of the 
window. On many windows, the 
title bar also contains the Control 
menu box and Maximize and 
Minimize buttons.
Toolbar:  Toolbars provide quick 
and easy access to Hatch 
Embroidery commands. Click a 
toolbar button to activate a 
command or, where applicable, 
right-click to view and adjust its 
settings.
Topping:  Material hooped or 
placed on top of fabrics that 
have definable nap or surface 
texture, such as corduroy and 
terry cloth, prior to embroidery. 
The topping compacts the wale 
or nap and holds the stitches 
above it. It includes a variety of 
substances, such as plastic wrap, 
water-soluble plastic ‘foil’ and 
open-weave fabric that has 
been chemically treated to 
disintegrate with the application 
of heat. Also known as ‘facing’. 
See also Stabilizer.
Trapunto:  Trapunto is a general 
term for very open fill stitching, 
often used as a background or 
for filling large shapes. In Hatch 
Embroidery, Trapunto effect 
forces travel runs to the edges of 
objects so they do not show 
through open or loose stitching.
Travel runs:  Travel runs are 
typically used to connect 
segments of complex shapes. 
They can also connect adjacent 
objects. Because runs are not 
trimmed, they may be visible in 
the final embroidery. For this 
reason, they are less commonly 
used as connectors between 
objects than jumps. If objects are 
adjacent and connectors will be 
hidden, they can be used.
Traveling:  You generally check 
a design’s stitching sequence by 
‘traveling’ through it by stitches, 
segments, functions or objects.
Trim function:  If you are using a 
machine with an automatic 
trimmer, the trim code causes the 
thread to be cut after a tie-off. In 
the software, trims are 
represented by a triangle with a 
small circle at the point where 
stitching starts again. The 
trimmed connector appears as a 
dotted line. You can adjust 

connector settings to 
automatically add trims, or add 
them yourself.
Trimmers:  Devices built into an 
embroidery machine to 
automatically trim or cut 
remaining thread when the 
design jumps from one area to 
another or performs a color 
change.
Trimming:  Action of cutting 
loose thread, removing backing, 
etc, from the final embroidered 
product.
Triple Run stitch:  Triple Run 
repeats each Run stitch three (or 
more) times for a thick line. 
Typically used to add borders 
and pickout runs to designs.
Triple Satin:  Triple Satin is often 
used for folk designs to mimic 
handmade embroidery that uses 
thicker thread. If you require 
thicker stitches, set the Satin stitch 
to repeat itself multiple times. 
TrueType font:  Digital font 
technology designed by Apple 
Computer and now used by both 
Apple and Microsoft in their 
operating systems.
TrueView:  TrueView provides 
you with a preview of how your 
embroidery will look when 
stitched out. It gives the screen 
image a three dimensional look.
Turning stitches:  Embroidery 
objects can be filled with parallel 
or turning stitching. Turning 
stitches are columns of stitches 
which turn to follow the path 
defined by the object outline. By 
contrast, parallel stitching 
traverses the shape in one 
direction only – e.g. at 90° to the 
horizontal, 45°, or whatever is set. 
Objects can be created with 
turning stitching already 
applying, or multiple stitch angles 
can be added later. Turning 
stitches are best used with 
designs containing complicated, 
turning shapes such as trees, 
animals, or large filled areas. 
Turns generally occur at points 
where a shape changes 
significantly in direction or width.
Underlay:  Stitches sewn before 
other design elements to help 
stabilize fabrics. The stitching 
action that will attach the 
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backing to the fabric being 
embroidered. It also supports the 
top embroidery for a more lofty, 
dimensional look. Underlay 
stitches are made up of a series 
of single run stitches, usually with 
a very short stitch length, and are 
digitized manually or placed 
automatically under the column 
(satin) or fill stitch areas of your 
embroidery design.
USB-capable embroidery 
machine:  An embroidery 
machine which has a standard 
USB port built into the machine or 
machine control panel.
USB memory stick:  Standard 
USB memory stick or simply ‘USB 
stick’ used for storing and 
transporting files.
USB port:  Universal Serial Bus 
Connector – a connection on a 
computer where you plug in the 
dongle. 
Values:  The actual settings – 
letters and numbers – that you 
enter into dialogs. See also 
Object Properties.
Variable sizing:  Ability to scale 
a design to different sizes.
Variable stitch length:  The 
software can automatically 
calculate the best length for 
each stitch with the Variable Run 
Length option. A chord gap 
value controls how closely the 
stitches follow the digitized lines.
Vector graphic:  Unlike raster 
images, vector graphics contain 
vector data. This is a collection of 
geometric shapes and lines that 
combine to make an image. 
Rather than pixels, such data is 
recorded as a set of 
mathematical formulas defining 
shapes such as rectangles, 
ellipses, curves, polygon stars, 
etc. These are created using 
vector graphics programs such 
as CorelDRAW software. Vector 
graphics are scalable without 
distortion, and are usually much 
smaller than bitmap images. See 
also Bitmap image.
Vector object:  Vector objects 
are derived from vector graphics 
and can be created in Hatch 
Embroidery or imported. In Hatch 
Embroidery they can be 
converted to and from 

embroidery objects. You can set 
general properties such as size 
and position, and arrange and 
transform them in the same way 
as other objects. See also Vector 
graphics.
Vector text:  A text object 
created using the CorelDRAW 
software Text tool.
Weight:  When referring to 
T-shirts, the three standard weight 
divisions are mid-weight/value, 
heavyweight/premium, and 
super heavyweight.
WiFi device:  Device capable of 
connecting to a WiFi Router or 
wireless access point.
WiFi network name (SSID):  
Service Set Identifier (SSID) – the 
unique identifier attached to the 
information which is sent over a 
wireless local area network.
WiFi password (key):  
Password, passphrase or key 
(depending on the WiFi security 
type) that allows connection to 
the WiFi router or access point.
WiFi router:  Device that 
provides basic network 
infrastructure for a home or small 
office network. Provides a 
wireless access point for many 
wireless devices to connect to 
each other for access to the 
Internet as well as for file sharing 
and printing. Sometimes referred 
to simply as a Wireless Router.
WiFi USB machine network:  A 
network of wirelessly connected, 
USB enabled embroidery 
machines and PCs.
Windows domain:  a network of 
Windows PCs, also known as 
‘network domain’, in which 
computers rely on a centralized 
authentication database. Users 
log into the domain and the 
access privileges are served from 
the central database which is 
controlled by a network 
administrator.
Windows workgroup:  
‘Workgroup’ is Microsoft’s term 
for a peer-to-peer local area 
network. Computers running 
Microsoft operating systems in 
the same workgroup may share 
files, printers, or Internet 
connection.

Wireless Access Point (WAP):  
A wireless access point or ‘WAP’ 
is a hardware device on a local 
area network (LAN) that allows 
wireless capable devices and 
wired networks to connect.
WLAN:  Wireless Local Area 
Network or WiFi network.
WMF:  MS Windows® Metafile 
vector format.
Worksheet:  The worksheet is the 
link between design and 
embroidery machine. It contains 
a design preview as well as 
essential production information, 
including the design size, the 
color sequence and any special 
instructions.
Write:  To send design 
information to an embroidery 
disk, design card or embroidery 
machine for immediate stitchout 
or storage.
X/Y coordinates:  The horizontal 
(X) and vertical (Y) distances on 
a graph or computer screen. Use 
X values to measure width, and Y 
values to measure height.
Zigzag stitch:  Zigzag stitch is 
similar to Satin but is generally 
used where fewer stitches are 
required. The needle penetrates 
each side of the column, laying 
the thread across in an open 
zigzag pattern. The density is 
determined by the stitch spacing 
setting. The settings for Zigzag fill 
stitches are stored separately 
from Zigzag and Double Zigzag 
underlay settings.
Zigzag underlay:  Zigzag and 
Double Zigzag underlay stitching 
is used to support wide columns.
Zoom factor:  The scale at which 
the design is currently displayed.
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INDEX

Numerics
3D Warp stitching 265
4K high resolution monitors 81

A
Add

4 Hoops Around tool 546
8 Hoops Around tool 546
Design Color tool 166, 168
Hoop Right tool 546
Hoop tool 546
Hoop Up tool 546
Splitting Line tool 550
Stitch Angles tool 235, 297, 442

Adjust
Adjust Bitmap dialog 419, 457, 

459
Adjust Bitmap tool 418
Adjust Stitch Spacing tool 179

Align Centers tool 286
Alternating motifs 245
Always Tie-Off & Trim tool 314
Ambience quilting 607
Applique

Appliqué Fabric dialog 578
automatic corners 581
Break Apart 319, 355, 373, 385, 

495–497, 584
combined 581, 583
convert embroidery 568
Convert to Appliqué 568
convert vector graphics 570
cover stitches 566
cutting lines 565
digitize 565
Digitize Appliqué 566, 574–577
Digitize Appliqué with 

Holes 567
fabrics 577
Frame-out position 579
frame-out position 566
Partial Appliqué 582
Patterns 119
placement lines 565
Remove Overlaps 582
stitch settings 574
styles 572
tackdown 566
with holes 567

Apply
Closest Join tool 316
Color tool 164
Object Properties tool 176, 184

Artwork
adjust bitmap 418
auto-digitize 429, 431
color depth 397
color mode 396
color reduction 393
convert to embroidery 445
crop 410
dim artwork 406
edit artwork 409, 412
for auto-digitizing 416
image cleanup 392
Image preparation 394
Image quality 392
Insert Artwork tool 35, 399, 400, 

445
loading 400
Lock tool 406
noise filtering 394
outline sharpening 393
Prepare Artwork for 

Embroidery 34, 416
resolution 396
Save Artwork tool 423
Scan Artwork tool 398
scan images 395
sharpening 397
transparencies 406
Unlock All tool 406

Auto
Auto Center to Work Area 

tool 595–596
Auto Digitize dialog 432–434
Auto Fabric tool 19, 154–182
Auto Save settings 79
Auto Scroll settings 82
Auto Start and End dialog 67
Auto Start and End tool 66, 182

Auto-digitize
Auto-Digitize Embroidery 37, 

431
Auto-Digitize Embroidery 

tool 37
Auto-Digitize Instant 

Embroidery 37, 429, 442
Auto-Digitize Instant 

Embroidery tool 37
Automatic Resize dialog 419
Click-to-Centerline 439
Click-to-Fill 36, 437, 442
Click-to-Fill without Holes 437
Click-to-Outline 36, 439
Click-to-Turning Fill 437
Color Matching Method 427, 

429
Color PhotoStitch 456
convert photos 448
Insert Artwork 35, 399, 400, 445
PhotoFlash 448
Reef PhotoStitch 452
Smooth Shapes 324

Automatic
Corners tool 323, 581
Jumps 223
Splits 223

Automatically Add Hoops 
tool 543

B
Backdrops 15

inserting bitmap images 400
loading 400
show 126

Background and Display Colors
dialog 69, 148–152
tool 25, 69, 182

Backstitch 217
Backtrack tool 481
Basting Stitch Marker tool 624
Bitmap images, insert 400
Blackwork 251
Blanket Line 218
Block object 131
Branching

branched objects 131
Branching tool 492–494
edit brached objects 495

Break Apart tool 355, 373, 385, 
495, 497, 584

Buttonholes 601
Settings 603
Tool 602

C
Calculate Hoopings tool 548
Calligraphic stitching 221
Candlewicking 251
Carving stamps

add to library 503
appearance 505
Carving Stamp docker 500–

504
split lines 502
Use Object 501, 504
Use Pattern 500

Center All tool 519, 542
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Change Thread Chart 
dialog 188

Circle Layout
to Work Area tool 599
tool 590

Circle/Oval tool 236, 243, 476
Click-to-

Centerline tool 439
Fill tool 36, 437, 442
Fill without Holes tool 437
Outline tool 36, 439
Turning Fill tool 437

Color changes, optimize 601
Color Matching Method

dialog 457–459
tool 427–429

Color palette 154
Color PhotoStitch tool 456
Color Wheel dialog 173
Colors

color reduction 393
color sequence 119
depth 397
mode 396

Context
Align Centers 286
Always Tie-Off & Trim 314
Automatic Corners 323, 581
Background and Display 

Colors 25, 69, 148, 149, 151, 
152, 182

Center All 519, 542
Create Border 508
Create Motif 506
Crop tools 410
Duplicate 284
Duplicate with Offset 284
Elastic Embossed Fill 262
Feather Edge 270
Fill 472, 508, 622
Freehand Settings 483
Gradient Fill 271
Group 115, 279, 311
Hand Stitch 266
Laydown Stitch 618
Measurement Units 72, 78, 607
Mirror X 32, 243, 292
Mirror Y 32, 243, 292
Outline 221, 472, 508, 587
Radial Fill 260
Rotate Hoop 522, 547
Rotate Hoop Left 15° 522, 547
Rotate Hoop Right 15° 522, 547
Rotate Left 15° 25, 290
Rotate Right 15° 25, 290
Size +10% 24, 288, 409
Size -10% 24, 288, 409
Skew 291
Space Evenly Across 287
Space Evenly Down 287
Transfer Design 21
Underlay 309, 478
Ungroup 115, 279, 311

Contour Fill 236

Control points 474
Convert

Artwork to Embroidery 
tool 445, 571

Convert to Appliqué tool 568
Embroidery to Artwork tool 445
photos to embroidery 452
Selected Designs tool 117
vectors to embroidery 441–442

Copy
Copy Array tool 592
Copy Keyboard Design 

Collection dialog 375
Copy Object Properties 

tool 175, 184
Copy Reflect tool 589
Copy Thread Chart dialog 189
Copy tool 281, 404

CorelDRAW
convert artwork 445
Graphics design window 11, 

400
Cover stitches, appliqué 566
Create

Create Auto Fabric dialog 178
Create Border dialog 508
Create Color Blend tool 309
Create Hoop dialog 65, 529
Create Motif dialog 506
Create Outlines & Offsets 

tool 613, 615
Create Stamp dialog 504
Create Thread Chart 

dialog 189
Create Trapunto Outlines 

dialog 605, 612
Create Layouts

Ambience Quilting 607
Auto Center to Work Area 595, 

596
Basting Stitch Marker 624
Buttonholes 602
Circle Layout 590
Circle Layout to Work 599
Copy Array 592
Copy Reflect 589
Create Outlines & Offsets 613, 

615
Create Trapunto Outlines 605, 

611
Define Work Area 594, 599
Insert Design 32, 153, 155, 595
Insert Graphic Marker 625
Laydown Stitch 618, 622
Mirror-Copy Both 587
Mirror-Copy Horizontal 32, 587
Mirror-Copy to Work Area 596
Mirror-Copy Vertical 32, 587

Crop tools 410
Cross Stitch Fill 255
Current Color tool 156, 161
Curved stitching 236, 258

3D Warp 265
contours 236

elastic embossed 262
Florentine 258
Radial fills 260
Ripple 238

Custom hoops, create 527
Custom motifs

create 506
manage 507

Customer experience 
program 79

Customize Design
Adjust Stitch Spacing 179
Auto Fabric 19, 154–182
Auto Start and End 66
Background and Display 

Colors 25, 69, 148–152, 182
Background and Display 

Colors settings 69
Color Wheel 172
Cycle Used Colors 172
Design Information 140–145
Insert Design 32, 153, 155, 595
Machine & Hoop Options 62–

65, 529, 542
Match All Design Colors 158
Optimize Color Changes 307
Select Thread Charts 188, 189
Threads >> 182

Cut tool 281, 404
Cutting lines, appliqué 565
Cycle Used Colors tool 172

D
Define Work Area tool 594, 599
Delete Hoop tool 547
Design Colors

Add Design Color 166, 168
Apply Color 164
Current Color 156, 161
Discard Unused Colors 168
Hide Unused Colors 168
Pick Color 164
Remove Design Color 166, 168
Threads >> 19, 23, 161–166

Design files
file sources 90
imported outlines 91
imported stitches 91
native designs 91
processed stitches 91

Design Information
design details 142
docker 139
stitching details 145
summary 140
thread colors 143
tool 140–145

Design Library dialog 120, 122
Design Overview docker 133
Design types

design/machine 91
warnings 92

Design worksheet 119
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Dialogs
Adjust Bitmap 419, 457, 459
Ambience Quilting 607
Appliqué Fabric 578
Auto Fabric 177, 183
Auto Start and End 67
Auto-Digitize 432, 433, 434
Automatic Resize 419
Background and Display 

Colors 148–152
Change Thread Chart 188
Color Matching Method 428, 

430, 437, 457, 459
Color PhotoStitch 457, 459
Color Wheel 173
Copy Keyboard Design 

Collection 375
Copy Thread Chart 189
Create Auto Fabric 178
Create Border 508
Create Hoop 65, 529
Create Motif 506
Create Stamp 504
Create Thread Chart 189
Create Trapunto Outlines 605, 

612
Define Work Area 595
Design Library 120, 122
Edit Threads 188
Fabric Settings 178
Fill Holes 491
Guide Position 74
Indexing Options 57
Insert Character 333, 358
Insert Designs 153
Insert Graphic Marker 625
Insert Image 399
Length Calculation 147
Machine Details 116
Manage Auto Fabrics 178
Manage Borders 509
Manage Motifs 507
Manage Thread Charts 189
New Keyboard Design 

Collection 375
Open Options 94
Outlines & Offsets 614
Pattern Gallery 244
Prepare Artwork for 

Embroidery 416, 432, 433, 
434

Prepare Bitmap Colors 419
Print Catalog Options 120
Print Design 118
Remove Small Stitches 71
Revert to Factory Settings 187
Save as Template 186
Save Bitmap 423
Select Border 370
Select Fabric Pattern 578
Select Motif 486
Select Thread Charts 169
Thread Charts 188, 189
Touch Up 413

User Interface Settings 183
View by Color 133, 156

Digitize
Add Stitch Angles 235, 297, 442
Appliqué tool 566, 574–577
Appliqué with Holes tool 567
Backtrack 481
Blocks 224
Branching 492, 494
Carving Stamp 500
Circle/Oval 236, 243, 476
Closed Shape 225, 472–508, 

622
Digitize Blocks 224, 236
Digitize Closed Shape 225, 

229, 244
Digitize Open Shape 221, 241
Digitize Open Shape tool 472
Digitizing methods 472
Freehand Closed Shape 482
Freehand Open Shape 482
Holes tool 490
Motif Stamp 485
Open Shape tool 221
Rectangle/Square 243, 476
Redwork 496
Repeat 481
Standard Shapes 477
Weld tool 322

Dim Artwork tool 406
Discard Unused Colors tool 168
Dockers

Carving Stamp 500–504
Design Information 139
Design Overview 133
Keyboard Design 

Collection 375
Monogramming > Borders 370
Monogramming > Designs 362
Monogramming > Letters 364
Monogramming > 

Ornaments 366
Threads 161, 167, 169

Duplicate
tool 284
with Offset tool 284

E
Edit artwork 409

Edit Artwork tool 412
Edit Objects

Add Stitch Angles 235, 297, 442
Adjust Stitch Spacing 179
Apply Closest Join 316
Apply Object Properties 176, 

184
Branching 492, 494
Break Apart 319, 355, 373, 385, 

495, 497, 584
Copy Object Properties 175, 

184
Create Color Blend 309
Knife 321, 356

Object Properties 174, 180, 
314, 603

Redwork 496
Remove Overlaps 325
Remove Stitch Angles 297
Reshape 33, 220, 225, 235, 242, 

255, 273, 293, 295, 297, 298, 
311, 313, 321, 324, 495, 497, 
505

Sequence >> 130, 278, 301, 
456, 549, 601

Sequence by Selection 
Order 303

Smooth Shapes 324
Stitch Edit 327, 329
Weld tool 322

Edit Threads dialog 188
Effects

Elastic Embossed Fill 262
Feather Edge 270
Gradient Fill 272

Embossed fill
apply 229
offsets 231
orientation 235
pattern layouts 232, 248
pattern size 231
settings 230
spacing 231

Embroidery objects
convert to vector 442
inter-converting 441

Embroidery Settings
Design tab 115
Hoop tab 65, 519–529
Overlap tab 325

Export Design
List tool 121
tool 21, 193, 525, 558

F
Fabrics 154

appliqué 577
Fabric Settings dialog 178

Fancy stitches
Blackwork 251
Candlewicking 251
Lacework 251
Stemstitch 251

Feather Edge effect 270
File recognition 92

options 93
File types

design files 89
embroidery 88
file sources 90
machine files 89

Fill Holes dialog 491
Fill stitches

3D Warp 265
Auto-digitize 437
Contour 236
Curved 236, 258
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Elastic embossed 262
Embossed 229
Florentine effect 258
Gradient 271
Motif 244
Radial 260
Raised Satin 605, 610
Ripple 238
Satin 222
Tatami 225

Fill tool 472, 508, 622
Florentine Effect 258
Font list display 81
Frame-out, appliqué 566, 579
Freehand

Calligraphy 484
Closed object 131
Closed Shape tool 482
Line smoothness 483
Open Shape tool 482
Techniques 483

G
General interface options 83
Gradient fills 271

angles 273
create 271
spacing 273

Graphics, convert to 
appliqué 570

Group tool 115, 279, 311
Guide Position dialog 74

H
Hand Stitch effect 266
Hide Unused Colors tool 168
High resolution monitors 81
Holes

create 490
fill 491

Home screen 5
Hoops

create custom hoops 527
hoop position 519
hoop templates 516
hooping sequence 119
multi-position 523
position settings 519
settings 65, 529

I
Images

cleanup 392
insert bitmaps 400
load 400
outlined and non-outlined 392
preparation 394
quality 392
sharpening 397
transparency 406

Import
outlines 91

stitches 91
Indexing Options dialog 57
Input methods 472
Insert

bitmap images 400
Graphic Marker tool 625
Insert Artwork tool 35
Insert Character dialog 333, 

358
Insert Design dialog 153
Insert Design tool 32, 153, 155, 

595
Insert Graphic Marker 

dialog 625
Insert Image dialog 399

Instant embroidery
auto-digitize 429

J
Join method 474
Jump

by Color tool 138
by Object tool 138
to Start/End tool 138

K
Keep Graphic Objects tool 445
Keyboard Design Collection

docker 375
tool 375

Knife tool 321, 356

L
Lacework 251
Laydown Stitch tool 618, 622
Layouts

circular 599
rectangular 596
work areas 594

Length Calculation dialog 147
Lettering

Break Apart 319, 355, 373, 385, 
495, 497, 584

cut letters 321
height settings 73
Knife 356
Monogramming tool 30, 362–

370
Reshape 342, 343, 348, 350, 

351, 352, 353, 354, 356
tool 28–31, 333–340

Lock tool 406

M
Machine & Hoop Options 

tool 62–65, 529, 542
Machine Details dialog 116
Machine files

file recognition 92
file sources 90

Machine model / type, 

selection 62
Manage

Manage Auto Fabrics 
dialog 178

Manage Borders dialog 509
Manage Embroidery Library 

Locations 123
Manage Thread Charts 

dialog 189
Thread Charts dialog 189

Manage Designs
Convert Selected Designs 117
Export Design List 121
Manage Embroidery Library 

Locations 123
New From Selected 18, 22, 27, 

113, 404
Open Selected 18, 22, 27, 113
Print Selected 118
Print Selected to Catalog 120
Transfer Selected Design 116

Manage Motifs dialog 507
Markers, reference 624
Match All Design Colors tool 158
Match to Embroidery Palette 

tool 445
Measurement Units 74

tool 72, 78, 607
Mirror

X tool 32, 243, 292
Y tool 32, 243, 292

Mirror-Copy
Both tool 587
Horizontal tool 32, 587
to Work Area tool 596
Vertical tool 32, 587

Mode toolbar
CorelDRAW Graphics 11, 400
Home 5, 6, 11, 400
Show Embroidery 11

Monogramming
Borders tab 370
Break Apart 355, 373, 385, 495, 

497, 584
Designs tab 362
Letters tab 364
Monogramming tool 30, 362–

370
Ornaments tab 366

Motif fills 240–245
alternating 245
layouts 248
orientation 243
pattern settings 247
size / spacing 242

Motif lines 216, 240
outlines 241

Motif stamps
insert 485
rotate 487
scale 488

Motifs 239
create 506
manage 507
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patterns 240
Mouse-wheel settings 82
Multi-hooping

Add 4 Hoops Around 546
Add 8 Hoops Around 546
Add Hoop 546
Add Hoop Right 546
Add Hoop Up 546
Add Splitting Line 550
Automatically Add Hoops 543
Calculate Hoopings 548
Delete Hoop 547
Multi-Hooping Options 556, 

558
Options tool 556, 558
Preview Hoopings 543

Multi-position hoops 523

N
Native designs 91
New

New Blank Design tool 113
New from Design tool 22, 27, 

114
New from Selected tool 18, 22, 

27, 113, 404
New Keyboard Design 

Collection dialog 375

O
Object Properties

docker 314, 603
Fill > Raised Satin 605, 610
Laydown Stitch 622
Outline > Raised Satin 605, 610
tool 180

Object types
block 131
branched 131
filled shape 131
freehand closed 131
outline shape 131

Objects
convert 441
create design arrays 592
create reflections 589
create wreaths 590
mirror 587
mirror-copy 587

Offsets, create 615
Open designs

Open Design tool 22, 27, 113
Open Options dialog 94
Open Selected tool 18, 22, 27, 

113
Optimize Color Changes 

tool 307
Organic stitching

Feather edge 270
Hand stitch 266

Outline shapes 131
Outline stitches 214

Auto-digitize 439

Backstitch 217
Blanket 218
Motifs 216, 241
Satin 215, 219
Sculptured 217
Stemstitch 217
Trapunto 611
Zigzag 218

Outline tool 221, 472, 508, 587
Outlines & Offsets 613

Dialog 614
Output Design

Auto Start and End 66, 182
Export Design 21, 193, 525, 558
Print Design 552
Print Preview 21, 552
Transfer Design 21

P
Partial Appliqué tool 582
Paste tool 281, 404
Pattern Gallery dialog 244
Photo Satin stitching 448
PhotoFlash tool 448
Photos, auto-digitize with

Color PhotoStitch 456
PhotoFlash 448
Reef PhotoStitch 452

Pick Color tool 164
Placement lines, appliqué 565
Polygon Select tool 276
Prepare Artwork for Embroidery

dialog 416, 432, 433, 434
tool 34, 416

Prepare Bitmap Colors
dialog 419

Preview Hoopings tool 543
Print

Print Catalog Options 
dialog 120

Print Design dialog 118
Print Design tool 552
Print Preview tool 21, 552
Print Selected to Catalog 

tool 120
Print Selected tool 118

Processed stitches 91
Pull compensation 480

Q
Quilted embroidery 605

Trapunto 605

R
Radial Fill 260
Raised

embroidery 610
Raised Satin fill 222
Raised Satin line 215, 219
Raised Satin tool 605, 610
satin 606

Recognize stitches, machine 

files 93
Rectangle/Square tool 243, 476
Redwork objects, edit 497
Reef PhotoStitch

auto-digitize photos 452
tool 452

Reference markers 624
Remove

Remove Design Color tool 166, 
168

Remove Holes tool 490
Remove Overlaps tool 325, 

582
Remove Small Stitches 

dialog 71
Remove Stitch Angles tool 297

Repeat tool 481
Reshape tool 33, 342, 343, 348, 

350, 351, 352, 353, 354, 356, 410, 
495, 497, 505, 580

Resolution, scanning 396
Revert to Factory Settings 

dialog 187
Ripple Fill 238
Rotate

Left 15° tool 25, 290
Right 15° tool 25, 290

Rotate Hoop
Left 15° tool 522, 547
Right 15° tool 522, 547
tool 522, 547

S
Satin stitch 219

automatic jumps 223
automatic splits 223
calligraphic turning satin 221
fills 222
line thickness 220
lines 215
Satin fill 222
Satin line 215, 219
stitch quality 221
stitch spacing 220
turning satin 224

Save files
Save Artwork tool 423
Save as Template dialog 186
Save Bitmap dialog 423

Scan artwork 395–398
Scan Artwork tool 398
scanning resolution 396

Scroll settings 82
Sculpture Run 217
Select

Polygon Select 276
Reshape 33, 410, 580
Select Border dialog 370
Select Fabric Pattern 

dialog 578
Select Motif dialog 486
Select Object 286–293
Select Object tool 276, 348–
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352, 487
Select Thread Charts 

dialog 169
Select Thread Charts tool 158, 

168, 188, 189
Select While Traveling 329

Sequence
by Selection Order 303
Sequence by Color tool 601
Sequence tool 278, 301, 549, 

601
Show Color List 130, 278, 305
Show Less 130, 302
Show More 130, 302
Show Object List 130, 278, 301
tool 130, 456

Shading effects, Feather 
edge 270

Show
Color List tool 130, 278, 305
Design tool 18, 126, 149, 313, 

448–456, 579, 596, 609
Embroidery tool 11, 445
Grid tool 76
Hoop Template tool 76, 516
Hoop tool 26, 66–529, 542
Less tool 130, 302
More tool 130, 302
Object List tool 130, 278, 301
Rulers & Guides tool 74

Single Run 214
Size

+10% tool 24, 288, 409
-10% tool 24, 288, 409
artwork 409

Smooth Shapes tool 324
Snap to grid / guides 76
Software settings

Customer Experience 
Program 79

Embroidery Settings dialog 519
Space Evenly

Across tool 287
Down tool 287

Standard
Copy 281, 404
Cut 281, 404
Insert Artwork 35, 399, 400, 445
Insert Design 32, 153, 155, 595
New Blank Design 113
New From Design 22, 27, 114
Open Design 22, 27, 113
Paste 281, 404
Print Design 552
Print Preview 21, 552
Shapes tool 477

Stemstitch 217, 251
lines 217

Stipple
Backstitch 252
Reshape 255
Single Run 252
Stemstitch 252
values 253

Stitch angles
add 297
adjust 298

Stitch Edit tool 327, 329
Stitch length calculation 147
Stitch Player tool 20, 137, 549
Stitch types

Cross stitch 255
Fancy stitches 251
Motif 239
Motif fills 244
Outlines 214
Stipple 252
Tatami 225

Stitching details 145
Switch & Convert

Convert Artwork to 
Embroidery 445, 571

Convert Embroidery to 
Artwork 445

Home 5
Keep Graphic Objects 445
Match to Embroidery 

Palette 445
Show Embroidery 445
Switch to Embroidery Mode 6
Switch to Graphics Mode 11, 

400, 418
Tag as Appliqué 570

Switch to
Switch to Embroidery Mode 

command 6
Switch to Graphics Mode 445
Switch to Graphics Mode 

command 11, 400
Switch to Graphics Mode 

tool 418

T
Tackdown, appliqué 566
Tag as Appliqué tool 570
Tatami fills 225

apply 225
density 227

Threads
docker 161–169
Match All Design Colors 158
Select Thread Charts 158, 168
Thread Charts dialog 188, 189
Thread Colors, design info 143
tool 19, 161–182
usage calculation 147

Toolbars
icon settings 81
View (Manage Designs) 108

Touch Up dialog 413
Transfer designs

Transfer Design tool 21
Transfer Selected Design 

tool 116
Trapunto 605

outlines 611
Travel

Backward tool 138
Forward tool 138
Jump By Color 138
Jump By Object 138
Jump to Start/End 138
on Edges 273
Select While Traveling 329
Travel Backward 138
Travel Forward 138

Triple Run 214
TrueView command 134, 135
Turning fills 475

calligraphy 221
Satin 224

U
Underlay

Center Run 479
Edge Run 479
Tatami 480
tool 309, 478
Zigzag 479

Ungroup tool 115, 279, 311
Unlock All tool 406
User Interface Settings

dialog 76, 183
General tab 79
Grid tab 76
Scrolling tab 82

V
Vector graphics

convert to appliqué 570
loading 400

Vector objects
convert to embroidery 442

View
(Manage Designs) toolbar 108
by Color dialog 133, 156
Keyboard Design Collection 

tool 375
Show Design 18, 126, 134, 149, 

313, 405, 448, 452, 456, 579, 
596, 609

Show Grid 76
Show Hoop 26, 66–529, 542
Show Hoop Template 76, 516
Show Rulers & Guides 74
Stitch Player 20, 137, 549
TrueView 134, 135

W
Warnings, design types 92
Weld tool 322
Work area, define 594

Z
Zigzag line 218
Zoom tools 127
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