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GETTING STARTED

Welcome to Hatch Embroidery, Wilcom’s 
premier home embroidery software. 
Designed specifically for the hobbyist 
and home business, Hatch Embroidery 
includes all the features and tools you 
need to create simple or extravagant 
embroidery designs. It is the best 
machine embroidery software available 
today, featuring latest technology in an 
easy-to-use interface with 
add-as-you-go features.
A few of its amazing features...

 Select from powerful manual 
digitizing tools and an endless number of creative stitch types. Designs are only 
limited by your imagination.

 The Color PhotoStitch feature creates lasting gifts. Take a photo of a pet, baby 
or someone special and instantly convert it into embroidery. This takes 
personalization to another level.

 Redwork unlocks an ethereal artistic embroidery style. Available in multiple 
outline types, Hatch Embroidery will calculate the fastest and most efficient 
route to stitch out your designs.

Create appliqué by converting closed objects with a single click. This is truly 
automated. When done, export to SVG and prepare your cutting file in 
seconds.

 There are also special appliqué digitizing tools which allow you to choose how 
you want your appliqué to stitch. Select from one color or multiple color stops 
and optimize stitch order.

 Elastic Embossed fills and outlines turn with the shape of objects. Be even more 
creative whilst continuing to achieve accurate and clean designs.

 Alternating Motifs lets you combine two motifs into a single object. Now you 
can create unique patterns never seen before.

Hatch Embroidery really does it all. Some days you may simply want to resize or 
recolor a design, or just add some lettering. Other days you are in the mood to 
create a piece of art. All the tools are waiting at your fingertips, and of course, you 
have the Hatch Embroidery team and a helpful community to support you.
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Note: Hatch Embroidery is a downloadable product that you can buy all-in-one or 
start small and add modules when it’s right for you. For more product information 
and prices, please visit our website.

Introduction

If you are new to embroidery design 
software or machine embroidery, you 
are probably asking yourself ‘where do I 
start?!’
It’s safe to say that you will spend many 
hours learning how to get the most out of 
your embroidery machine and the 
design software which supports it. The 
two work together hand-in-hand and it 
takes practice and patience to master 
both the creation and production of fine 
embroidery.
The results, however, will speak for 
themselves, making the time you invest 
all the more valuable. With each project 
you complete, you will gain in experience and confidence and be ready to tackle 
the next challenge.

Working with embroidery
Let’s take a look at the scenarios that you will find yourself working with. Typically, 
you will be involved in one or all of the following:

 Take a ready-made design and sew it out
Make global changes to a design
Combine lettering with a design
Create a monogram design
 Adapt an existing design
Create embroidery from artwork using automated techniques
Create embroidery manually
 Use special embroidery features
Let’s look at those cases one-by-one. This section outlines the main uses you will 
make of Hatch Embroidery, together with references to sections of the User Guide 
where you can obtain more in-depth information.

Tip: For lots of great videos and ideas for using Hatch Embroidery, visit our online 
resource center.

https://help.hatchembroidery.com/hc/en-us/sections/360000025555-Getting-Started
https://www.wilcom.com/hatch
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The user interface

Hatch Embroidery can be opened via the desktop icon or MS Windows® Start 
menu.

Caution: You need to calibrate your monitor so that designs at 1:1 scale appear at 
real size. Do this when you first install Hatch Embroidery or whenever you change 
your monitor. See Monitor calibration, pg 64 for details.

Operating modes
Hatch Embroidery has a single ‘design window’ but you interact with it in different 
ways. The main operating modes you’ll be using are:

Double-click on the Windows Desktop to start Hatch Embroidery.

Mode Function

Home With this mode you can return to the Home screen to access new designs, 
or access tutorials and other product information.

Embroidery 
Mode

This mode allows you to create and edit embroidery objects using an 
embroidery digitizing toolset.

Graphics Mode When installed, this mode allows you to insert, create and edit artwork, 
vector and bitmaps, using the CorelDRAW software toolset.
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Note: The User Interface Settings > General tab allows you to preset the preferred 
default screen upon startup – Home, Design Library, or Embroidery Mode. See 
System preferences, pg 70 for details.

Integration with CorelDRAW®
Integration with CorelDRAW® is automatically activated depending on your 
product level. This is available for customers who already own compatible 
CorelDRAW software or have purchased CorelDRAW GEM for Hatch Embroidery. 
If you have CorelDRAW® installed on your computer together with Hatch 
Embroidery, you will be prompted to link it upon launching Hatch Embroidery. See 
also Graphics Mode, pg 11.

Note: CorelDRAW® integration is currently only available for certain models of 
CorelDRAW software and CorelDRAW GEM for Hatch Embroidery. And it only 
works with some levels of Hatch Embroidery. For more information, see FAQs on 
the Hatch Embroidery website. Note too that some CorelDRAW® functions may 
not be available in Graphics Mode.

Home screen

The Home screen loads when Hatch Embroidery starts, offering you quick access 
to recent new designs, as well as value-add content, including tutorial videos and 

Design Library This mode allows you to manage embroidery files and artwork.

Multi-hooping 
mode

If your embroidery is too large or contains a number of designs spaced 
around an article, you can split it into multiple hoopings in Multi-Hooping 
mode.

Click Switch & Convert > Home to revisit the Home screen to access tutorials and 
other product information.

Mode Function

Link Hatch 
Embroidery to 
CorelDRAW

https://help.hatchembroidery.com/hc/en-us/articles/360000537936-Which-Version-of-CorelDRAW-does-Hatch-v2-integrate-with-
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the latest Community Forum and Product Blog posts. You can also browse ‘My 
Hatch’ which provides details of your license, including product level and version.

In a nutshell, the Home screen provides the following:

Feature Benefits

Quick access to Hatch 
software features

• Links to the Design Space
• Links to the Design Library

Start Provides quick access to open:
• a new design
• an existing design
• a design from a list of recently opened designs.

My Hatch • Reports up-to-date product entitlement information such as: product 
level and version, font packs purchased, etc

• Indicates version status - whether up-to-date or not - plus links to latest 
version

• Links to upgrade path, depending on your current level
• Links to available font packs, again depending on current entitlements 

and available fonts

Hatch Academy Easy access to Hatch Academy website. Education is the key to 
getting more from your Hatch Embroidery software:
• Learn from over 170 quality embroidery lessons designed by Hatch 

Embroidery experts
• Get answers to your questions directly from the trainers.

Community Join a worldwide community of Hatch users to discuss:
• News and announcements
• General questions and shared ideas
• New features and suggestions
• Hatch lounge
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Embroidery mode

Hatch Embroidery has a single workspace or ‘design window’. This allows you to 
modify or create embroidery designs using the extensive toolset. You can have 
multiple designs open simultaneously and toggle between each via the design 
tabs.

Blog Access the Hatch Blog for:
• How tos
• Inspiration
• News

Help Access the Hatch Help for:
• General FAQs
• How To FAQs
• Technical FAQs
• Helpful videos
• Announcements

News and posts 
section

Provides access to:
• Latest Hatch News regularly updated by the Marketing Team
• List of latest Community Forum posts
• Latest blog posts.

Use Embroidery Mode to digitize and edit embroidery designs. Display embroidery 
as well as artwork. View designs realistically in 3D simulation.

Feature Benefits

Design 
tabs
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Menu & toolbars
The main menu and toolbars are normally docked at the top of the screen above 
the design window. Use both to access common commands. As you get more 
familiar with them, you can speed things up by using keyboard shortcuts. For a list 
of available toolbars, go to the Window menu...

Hatch Embroidery includes a Context toolbar which changes according to the 
selected tool. If you have no tools selected, you will see droplists for machine, 
machine model, and hoop. Here you can also set your measurement units – Metric 
or U.S. – and adjust screen background settings. See also Hoop selection (User 
Guide).

The Help menu provides easy access to online help and electronic 
documentation in the form of release notes and quick start guide. It also provides 
access to the Hatch Academy. This resource provides free and paid courses for 
both trial and registered users. Resources include ‘Getting Started’, ‘Orientation’ 

Available toolbars

Select preferred 
hoop

Select your machine 
and model

https://profile.hatchembroidery.com/?return_url=https://academy.hatchembroidery.com/enrollments
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and ‘Essentials’, plus projects, extra videos and other resources, all aimed at 
improving the learning journey.

Tip: Tooltips provide a brief summary of tool characteristics. Online help provides 
quick access to step-by-step instructions. Context-sensitive help is available for 
tools and dialogs by pressing the F1 key.

Toolboxes
Toolboxes are like toolbars in that they contain 
software tools. However, each toolbox represents 
a typical scenario you will be engaged in, such as 
customizing designs or editing objects. Some tools 
may appear in more than one context. As such, 
toolboxes are organized in order of common 
operations, starting with managing your designs. 
See also Manage Designs (User Guide).

Electronic
documentation

Hatch Academy

Press F1 for more 
information
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Dockers
Hatch Embroidery includes a number of ‘dockers’ for key functions. These include 
operations to do with thread selection, object sequencing, cutwork, ‘carving 
stamps’, as well as viewing and modifying object properties.

Dockers are normally docked to the right of the design window. They may also be 
‘floated’ by dragging the caption bar to the design window or double-clicking.

Available dockers

Design Information
docker
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Depending on your level of product, available dockers may include some of all of 
the following...

Status bar
A Status Bar at the bottom of the design window provides continuous display of 
current cursor position status as well as instructions for use of selected tools.

Information displayed includes...

Docker Purpose

Sequence This docker offers an easy way to selectively view and sequence 
color blocks and objects.

Design Overview This docker displays a thumbnail image of the design. Use it to pan 
and zoom the design when working at high zoom factors. Set view 
settings independently to the design window.

Object Properties This is an important docker if you are creating or editing 
embroidery objects. Use this together with the Context toolbar to 
access and modify the many properties of selected embroidery 
objects.

Design Information Use this docker to view and modify design details prior to design 
approval or stitchout.

Threads This docker allows you to select thread charts and assign threads 
to the current design. It works in conjunction with the Design 
Colors toolbar.

Keyboard Design 
Collection

Many hobbyists buy embroidery fonts from third-party suppliers. 
Use this docker to map these fonts to keyboard characters for use 
in Hatch Embroidery.

Hints This docker provides a valuable learning resource from within the 
software. When open, context-sensitive help appears, if available, 
whenever a feature is selected. Each hint includes a brief feature 
summary together with a link to a short video.

Field Notes

Prompt message To guide you through use of selected functions

Design size Width and height

Coordinates Current needle position (X/Y), and length (L) and angle (A) of current 
stitch. See also Design measurement, pg 63.

Stitch count Total number of stitches in design

Current fabric Fabric settings take into account the type of fabric you are stitching on. 
See also Fabrics & densities (User Guide).

Grade of design Native EMB designs are classified in four grades depending on how the 
file was created. See also Supported embroidery files, pg 85.
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Design Library
The built-in Design Library is a ‘virtual library’ in that any designs on your system can 
be located and displayed within the navigation tree. Hatch Embroidery doesn’t 
care where they physically reside on your hard disk or external storage devices. 
Any folder containing embroidery designs can be included in the navigation tree. 
The design library opens in its own tab on the design bar. It has five components – 
two toolbars, a toolbox, a navigation tree, a design display area, and an info 
panel. See also Browse designs (User Guide).

Graphics Mode

Use Switch & Convert > Graphics Mode to import, edit or create vector artwork as a 
backdrop for embroidery digitizing, manual or automatic.

Use Switch & Convert > Show Embroidery to show or hide embroidery components.
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Hatch Embroidery has a single ‘design window’ but when integrated with 
CorelDRAW®, you may interact with it via the Switch and Convert toolbar.

Graphics Mode contains the entire suite of CorelDRAW software drawing tools. This 
mode allows you to create and edit vector graphics using the Graphics Mode 
toolset which offers many sophisticated techniques for drafting outlines and 
shapes onscreen.

You can use Graphics Mode to insert or paste third-party vector graphics such as 
clipart for use in embroidery designs. Alternatively, insert, paste or scan bitmap 

Switch between 
operating modes

Menu bar

Status bar

Toolbox

Switch & Convert toolbar

Standard toolbar

Design window

Properties
docker

Property bar

Color
palette
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artwork for use as digitizing templates or ‘backdrops’. Here are some of the 
prominent Graphics Mode interface elements. 

In addition to the CorelDRAW software toolset, Graphics Mode provides 
capabilities to convert vectors and vector text directly to embroidery objects. 
Imported vector graphics or created text can be converted directly to 
embroidery designs. See Convert artwork to embroidery with CorelDRAW® (User 
Guide) for details.
For a detailed description of the CorelDRAW software interface, refer to the 
electronic User Guide available via the MS Windows® Start > Programs group. 
Alternatively, use the online help available from the Help menu.

Note: CorelDRAW® needs to be registered before it can be used by Hatch 
Embroidery. Registration provides CorelDRAW® Standard Membership which gives 
you access to content – clipart, fonts, stock photos, templates – via Corel 
CONNECT. It also gives you access to the latest CorelDRAW® updates.

Element Description

Menu bar This contains application menus such as File, Edit, View, etc.

Design window This contains the main work area where you create and edit graphics 
objects as well as embroidery objects when you switch to Embroidery 
Mode.

Switch & Convert 
toolbar

This contains the universal tools and icons which are visible in both 
Embroidery Mode and Graphics Mode windows.

Standard toolbar This contains commonly used tools and commands which are specific to 
and only visible in Graphics Mode.

Toolbox This contains the drawing/editing tools specific to and visible only in 
Graphics Mode.

Property bar This contains the commands and controls that relate to the active tool in 
the Toolbox or active object in the design window in Graphics Mode.

Properties docker In Graphics Mode, this contains graphics-specific dockers.

Color palette This contains the graphics color palette which is specific to and only visible 
in Graphics Mode.

Status bar This contains current status information visible only in the Graphics Mode.
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Multi-hooping mode
Here is a screen image from the 
multi-hooping workspace which is 
accessed via the Multi-Hooping toolbox. If 
your embroidery is too large or contains a 
number of designs spaced around an 
article, you can split it into multiple 
hoopings. This means you can create 
embroidery designs that are larger than 
can be stitched in a single hooping. The 
multi-hooping workspace allows you to set 
up the position and sequence of each 
hoop. See also Multi-Hooping (User 
Guide).

First things first

You don’t need experience to start using 
your software. You can simply open a 
design and send it to machine for 
‘stitchout’. And this is the best place to start. 
As you gain experience, you will be able to 
‘read’ designs and identify which are good 
and which may cause problems.

Rules of good embroidery
Keep the following points in mind when 
looking at embroidery designs, both your 
own and others:

 Stitches are neat, smooth and even
 Design looks good – shapes, colors, balance
 Shapes are filled with correct fill and outline stitches
 Stitches are angled to match shapes
 Shapes are stitched correctly – no unwanted gaps
 Details are clearly defined
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 Lettering is clear and easy to read.

The stitchout should also have the following characteristics:

 The design sews efficiently on the machine
 The fabric does not pucker around stitched areas
 The design is free of loose ends.

Tip: Good embroidery quality starts with good design. You then need a good 
quality machine to stitch it out. But even that is not enough if you do not use the 
correct fabric, threads, backings, tension, and so on. Consult your machine 
manual for advice and get as much advice from other embroiderers as you can.

Sources of artwork
Electronic artwork in both bitmap and vector formats can be inserted, pasted or 
scanned into Hatch Embroidery for use as digitizing templates or ‘backdrops’. 
Likely sources include:

 Internet and CD clipart libraries
 Business cards, post cards and wrapping paper
 Samples in the Design Library
 Books of embroidery patterns
Children’s story books
 Printed table cloths or tea towels
Original artwork – e.g. children’s drawings.
Unless you are an experienced digitizer, do not use complicated artwork. Also, be 
sure to check the copyright of any images you have not created yourself. If unsure, 
contact the relevant supplier to seek their permission.
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Sample designs & artwork
Hatch Embroidery contains many ready-to-stitch designs, samples and projects. 
These can be found in the built-in Design Library. The most valuable thing when 
starting out as a new user, is to spend some time exploring these designs and 
getting to know what’s available. See also Browse designs (User Guide).

There are also artwork files for use as digitizing backdrops. These are installed to 
your Pictures folder. See also Electronic Artwork (User Guide).

Select image file
type
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There are many other sources of ready-made embroidery designs which you can 
purchase online and adapt as you wish. Just be aware of any copyright issues that 
may be attached to designs you find on the web.

Note: You can only open CDR files if you have an approved version of 
CorelDRAW® installed and linked to Hatch Embroidery. Other graphic formats can 
be read via CorelDRAW®. Refer to your installed CorelDRAW® documentation. For 
more information, see FAQs on the Hatch Embroidery website.

CorelDRAW resources
Integration with CorelDRAW® is automatically activated depending on your 
product model. This is available for customers who already own compatible 
CorelDRAW software or have purchased CorelDRAW GEM for Hatch Embroidery. 
CorelDRAW® Standard Membership provides access to content – clipart, fonts, 
stock photos, templates – via Corel CONNECT. Clipart and other content can be 
accessed via the program group. It can also be accessed via the built-in 
CONNECT Content docker in Graphics Mode.

Go to Window > Dockers > CONNECT Content to open the docker.

Access CorelDRAW 
CONNECT to browse 
extensive collection of 
clipart and other assets

Access online content 
via the CONNECT 
Content docker

https://help.hatchembroidery.com/hc/en-us/articles/115002027887-What-file-formats-does-Hatch-Embroidery-read-and-write-
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Get familiar with the many clipart samples available to you. Many can be 
adapted for use with embroidery design, either as digitizing backdrops or direct 
conversion.

Caution: Included artwork (clipart) and embroidery designs are only available for 
personal use – i.e. they cannot be commercially sold in any form.

Stitch out a design

For many embroiderers, it is enough to take an existing design and stitch it out. This 
is certainly where most will start. Once you have found a design you like, you will 
want to preview it to see how it will sew out. A number of steps are involved. We 
outline the main ones here with reference to the User Guide.

Study sample designs

Open a design from your Embroidery Library. See also Open design files (User 
Guide).

Use Manage Designs > Open Selected to open the design(s) selected in the 
Design Library.

Use Manage Designs > New From Selected to create new design(s) based on the 
selected design(s) and/or bitmap(s) from a chosen template.
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Adjust view settings

Adjust viewing settings as preferred. See also View Designs, pg 198.

Change fabric type

Check the fabric type and change as necessary via the Customize Design toolbox 
or Design Settings menu. See also Fabrics & densities (User Guide).

Use View > Show Design to show or hide design elements. Click to open droplist of 
view settings.

Use Customize Design > Auto Fabric to change the properties of the design for 
stitching on a different fabric.

Select preferred 
viewing options

Selected target 
fabric type
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Assign threads

Go to Design Colors and check the thread colors. If necessary, change charts to 
suit one you are using. See also Design colors (User Guide).

Preview stitchout

Use Design Colors > Threads >> to toggle Threads docker display. Use it to find 
threads from different charts and change design colors. 

Use View > Stitch Player to simulate embroidery design stitchout onscreen in either 
stitch or TrueView.

Default palette
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Press Shift+R or click on the Stitch Player icon to preview the stitch-out so you 
understand how the design will sew on the machine. See also View stitching 
sequence (User Guide).

Preview a design worksheet

Use Output Design / Standard > Print Preview to preview design worksheet. Print 
from preview window.

Simulate design 
stitchout



22 Stitch out a design

Preview the design via the Standard toolbar or Output Design toolbox and print a 
design worksheet as preferred. See also Print designs (User Guide).

Output a design

Send the design to machine via data media (usually memory stick). Or by file 
transfer. See also Output Designs (User Guide).

Note: Check your machine documentation for steps involved after transferring the 
design to machine.

Use Output Design > Export Design to export the current design to a machine file for 
stitching.

Use Output Design / Context > Transfer Design to transfer current design to the 
design folder. Right-click for settings.

Design information 
provided on 
worksheet

Choose file format 
recognized by your 
machine
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Modify a design

Once you are used to the steps involved in sewing 
out designs – either clipart or ones you have 
purchased – you will soon want to make global 
design modifications such as resizing, or changing 
thread colors and fabric types. These are all 
relatively simple operations. We outline some of the 
common ones here with reference to the User 
Guide.

Open a design

Open the design you want to use. Press Ctrl+A to select all objects and press Ctrl+G 
to group them. See also Open design files (User Guide).

Use Manage Designs > Open Selected to open the design(s) selected in the 
Design Library.

Use Manage Designs > New From Selected to create new design(s) based on the 
selected design(s) and/or bitmap(s) from a chosen template.

Use Standard > Open Design to open an existing embroidery design.

Use Standard > New From Design to create a new design based on an existing 
design.
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Recolor a design

In addition to simple modifications such as resizing, many Hatch Embroidery users 
simply want to be able to recolor designs for different fabrics or articles. Hatch 
Embroidery provides many techniques for recoloring, including matching design 
colors to available thread charts. Recoloring by threads may involve either design 
files or machine files which include colors.

When you open an existing design, colors may have been already assigned to 
actual threads – e.g. ‘Isacord 40’. Adjust design colors as preferred. The simplest 
technique is to click objects in the design and select a color from the Design Colors 
toolbar. Many other techniques exist such as using the Sequence docker to select 
objects or entire color blocks. You can also select colors from different thread 
charts. See also Design colors (User Guide).

Resize a design

Use Design Colors > Threads >> to toggle Threads docker display. Use it to find 
threads from different charts and change design colors. 

Use Context > Size +10% to increase the size of selected objects in 10% increments.

Use Context > Size -10% to decrease the size of selected objects in 10% increments.

Default palette
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Check design dimensions, and resize as required. For example, if you are stitching 
a left chest design, maximum size will be approximately 4.25" or 108 mm square. 
See also Transform objects (User Guide).

Rotate object in a design

Select an object or entire design and click to activate rotation handles. Use these 
or the controls on the Context toolbar to rotate objects into position. See also 
Transform objects (User Guide).

Use Context > Rotate Left 15° to rotate selection in 15° increments to the left.

Use Context > Rotate Right 15° to rotate selection in 15° increments to the right.

Use Context
controls to scale

objects numerically

Use sizing handles 
to manually resize 
designs

Enter precise
rotation angle

Use rotation handles 
to manually rotate 
objects interactively



26 Modify a design

Visualize a design

Go to the Customize Design toolbox and use the Background and Display Colors 
tool to visualize the design on a garment or article. See Add backgrounds (User 
Guide) for details.

Hoop a design

Choose a hoop via the View toolbar or Context toolbar. Alternatively, right-click 
the Show Hoop icon to access the Embroidery Settings dialog. If possible, choose 

Use Customize Design / Context > Background and Display Colors to change design 
background and display colors.

Visualize design on 
product backdrop

Click View > Show Hoop to show or hide hoop. Right-click for settings.
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a hoop which covers the entire stitching area. See Hoop selection (User Guide) for 
details.

Add simple lettering

Once you are used to sewing out designs and resizing, changing colors and fabric 
types, you will certainly want to create your own lettering designs. While it takes 
practice to obtain a good quality stitchout, it is as simple as typing letters 
on-screen to create an attractive lettering design.

Open a design

Choose from 
filtered hoop list

Select your machine 
and model

Use Manage Designs > Open Selected to open the design(s) selected in the 
Design Library.

Use Manage Designs > New From Selected to create new design(s) based on the 
selected design(s) and/or bitmap(s) from a chosen template.

Use Standard > Open Design to open an existing embroidery design.
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Open a design. Typically you’ll want to add lettering to an existing design. Go to 
the Design Library via the tab or the Manage Designs toolbox. Choose from one 
of the many samples. See also Manage Designs (User Guide).

Add lettering to a design

Use Standard > New From Design to create a new design based on an existing 
design.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets or TrueType fonts, or edit selected lettering.
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Add embroidery lettering to designs quickly and easily, either on-screen using 
current settings or via ‘object properties’. See Create lettering (User Guide) for 
details.

Tip: For best results when stitching, do not exceed the recommended maximum or 
minimum sizes. Recommended maximum and minimum heights refer to UPPER 
CASE letters. Some lower case letters – e.g. a and c – are about 70% the height of 
a capital letter. Thus you may need to make these characters larger than the 
recommended minimum.

Adjust baselines and other settings
It’s then a simple matter to adjust baselines, formatting, spacing settings, and 
colors. See Lettering layouts (User Guide) for details.

Adjust lettering 
baselines for 
curved lettering
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Try stitching out your lettering design. Study the stitch quality. Be aware that 
different fonts sew out better at different sizes.

Advanced lettering

Once you have tried your hand at creating 
lettering designs and sewing them out, you 
will want to do more adventurous things, 
such as monograms, fancy lettering, flair 
scripts, raised lettering with trapunto, as well 
as special ‘elastic lettering’ effects. The 
creative possibilities are endless. Your 
appetite to try new things will be stimulated 
as you gain experience and confidence. 
Part of that involves becoming adept at 
using your sewing machine as well as 
sampling and checking design quality.

Tip: Remember to study the sample designs 
included with your Hatch Embroidery 
installation.

Monogramming

Hatch Embroidery makes the creation of monogramming designs simple with the 
Monogramming tool. Optionally include lettering, ornaments, and/or up to four 
concentric borders in your monograms. See also Monogramming (User Guide).

Flair script

Use Lettering / Monogramming > Monogramming to create personalized monograms 
using a selection of predefined styles, border shapes and ornaments.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets or TrueType fonts, or edit selected lettering.
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Flair script is a special font which 
allows you to add decorative flairs to 
the end of text objects, mimicking 
flamboyant handwriting flourishes. 
See Special lettering (User Guide) for 
details.

Lettering stitch effects

By default, lettering objects are filled with satin 
stitching. You can apply other fill stitch types, 
such as tatami or embossed fills, as with any 
embroidery object. See Stitch Types & Effects 
(User Guide) for details.

Lettering art

Use Context > Feather Edge to create rough edges and shading effects, or imitate 
fluffy textures.

Use Lettering / Monogramming > Lettering to create embroidery lettering using 
embroidery alphabets or TrueType fonts, or edit selected lettering.
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Apply ‘lettering art’ effects to embroidery lettering 
to make it bulge or arch, stretch or compress. See 
Lettering layouts (User Guide) for details.

Customize a design

Customizing designs is perhaps the most common scenario in embroidery. You will 
sometimes want to create a new design, usually from artwork, but more often you 
will want to take an existing design and ‘re-purpose’ it. We’ve already seen how 
to make global changes such as sizing, changing colors and fabrics. It won’t be 
long before you want to try more ‘invasive’ changes such as reshaping, removing, 
combining, duplicating, resequencing, changing stitch types and effects, etc. 
Here is a sampling of the things you may want to try.

Tip: Remember to study the sample designs included with your Hatch Embroidery 
installation.

Combine designs

One technique you will undoubtedly use 
is combining design elements. This will in 
turn teach you a lot about other editing 
operations such as resizing, positioning, 
rotating, sequencing objects, as well as 
removing underlying stitching. See Insert 
designs (User Guide) for details.

Use Customize Design / Standard / Create Layouts > Insert Design to insert an 
existing embroidery design into the current design. This tool is also available via File 
menu.
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Transform a design

Depending on the type of design work you are doing, you can make use of your 
software tools for duplicating, rotating, and mirroring designs to create wreathes, 
kaleidoscopes, and other effects. See also Transform objects (User Guide).

Reshape objects in a design

Use Context > Mirror X to flip selection horizontally.

Use Context > Mirror Y to flip selection vertically.

Use Create Layouts > Mirror-Copy Horizontal to mirror and copy selected objects 
horizontally. 

Use Create Layouts > Mirror-Copy Vertical to mirror and copy selected objects 
vertically. 

Use Edit Objects / Select > Reshape to reshape an object outline, stitch angles or 
enveloping.

Duplicate and 
mirror to create 
wreaths
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Reshaping operations may be called on for anything from minor modifications to 
object shapes to reshaping letters for special effects. In most cases, if it is 
selectable, it can be reshaped. See Reshape objects (User Guide) for details.

Add stitch effects

It won’t take long before you get bored with simple fills and outlines and want to 
try out some of the many artistic stitch types and effects your software provides. 
See Stitch Types & Effects (User Guide) for details.

Auto-digitizing

If you have graduated this far in exploring your machine and embroidery software, 
you are doing well. You can already achieve a great deal without having to 

Use Object Properties > Fill > Embossed to create decorative patterns of needle 
penetrations while keeping the appearance of solid stitching. Choose from a pattern 
library.

Use Object Properties > Fill > Motif to create decorative open fill stitching. Choose 
from a motif library.

Apply artistic 
stitch types and 
effects
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actually do your own digitizing. However, if you have got this far, that is probably 
exactly what you want to do!
One of the quickest ways to get started is to use the automated techniques that 
the software provides. While there are limitations to what can be done this way, 
auto-digitizing nevertheless allows you to prototype design ideas relatively simply 
and may be sufficient for your purposes. At least for now!

Using artwork

To create good quality embroidery, you need to choose suitable artwork. Possible 
sources include:

 samples in the Picture folder
 books of embroidery patterns and children’s story books
 printed table cloths or tea towels
 business cards, post cards and wrapping paper
 clipart libraries of your word processing or graphics program
 Internet or CD clipart libraries
 original artwork – e.g. children’s drawings.
Artwork that is not in digital format needs to be scanned correctly to produce 
good quality images. For both manual and automatic digitizing purposes, ‘clean’ 
artwork with a limited number of solid colors and well-defined outlines works best. 
The Artwork toolbar contains tools for inserting, scanning, and preparing artwork 
for automatic digitizing. See Electronic Artwork (User Guide) for details.

Tip: Unless you are an experienced digitizer, don’t use artwork which is too 
complicated.

Use Artwork > Prepare Artwork for Embroidery to prepare selected bitmap artwork 
for automatic digitizing.

Clean picture with 
well-defined outlines

Clean picture with 
well-defined color blocks

Complex picture, needs editing to 
create clean color blocks
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Insert artwork

You can load bitmap images of various formats for use as digitizing backdrops. Go 
to the Artwork toolbox and select Insert Artwork. See Electronic Artwork (User 
Guide) for details.

Click-to-fill artwork

Bitmap artwork consists of colored dots or pixels. When you zoom in on a small 
area, outlines become jagged and ‘pixelated’. The Click-to-Fill tools in the 

Use Artwork / Auto-Digitize / Standard > Insert Artwork to import vector or bitmap 
artwork into current design as a backdrop for manual or automatic digitizing. This tool 
is also available via File menu.

Use Auto-Digitize > Click-to-Fill to digitize large artwork shapes with tatami fill, 
preserving any holes within.

Use Auto-Digitize > Click-to-Outline to digitize boundaries of shapes with run 
stitching using current properties.

Select image
file type
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Auto-Digitize toolbox provide everything necessary to digitize bitmap shapes 
automatically. See also Click-to-digitize artwork (User Guide).

Auto-digitize artwork

An extension of this technology, Auto-Digitize makes decisions about the most 
suitable stitch types to use and can digitize whole designs. See also Auto-digitize 
artwork (User Guide).

Use Auto-Digitize > Auto-Digitize Instant Embroidery to automatically digitize whole 
embroidery design directly from the imported bitmap artwork.

Use Auto-Digitize > Auto-Digitize Embroidery to automatically digitize prepared 
bitmap artwork, optionally with user's choices.

Auto-digitize 
selected shapes

Auto-digitize 
entire design
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Next steps

If you have reached this point, you have 
already mastered 90% of the techniques that 
most embroiderers need. However, coming 
to grips with manual digitizing is the next step 
in becoming an embroidery master. You can 
start with quite simple projects and work your 
way up to more complicated designs with 
more complicated stitch effects. See also 
Digitize Objects (User Guide).

Special embroidery features
Once you have mastered manual digitizing, you are in a position to take 
advantage of the full range of stitch types and effects that the software offers. 
Many of them you will be familiar with, having already adapted existing designs 
for different purposes. Some of the many techniques supported by the software 
include:

 Freehand
 Embossed fills
Curved fills
 Buttonholes
Refer to the User Guide or the many online resources.

Happy embroidery!
Do good work with your machine and software. With this equipment you have 
everything you need to create top quality, fully professional embroidery.
Remember to make good use of the packaged designs and clipart. When in 
doubt, go back to first principles. And when you find you want to expand and 
extend your repertoire, study the sample designs carefully to see how it’s done.
All the best. And have fun!
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SOFTWARE SETUP

This section describes how to install your embroidery software and all required 
components.

Periodic updates
Periodically you will receive automatic updates to your software installation. These 
will include improvements and fixes to known problems. To update your 
embroidery software...

Connect your computer to the internet.
 Start your Hatch Embroidery software. It will automatically check for software 

updates.
 If it is not up-to-date, you will be prompted to start the update.
 The required file will be downloaded from a secure server.
Once download has completed, follow the prompts.
Once completed you will need to restart your PC for all changes to take effect.

Note: Automatic updates overwrite your ‘normal’ template. If you have made 
changes, you will need to save them to a custom template – e.g. ‘My Template’.
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System requirements

In order to run your software, you need to ensure that the following prerequisite 
system requirements are met.

Installation

Make sure you have the following before commencing with any installation...

 Hatch Embroidery user account
 Installation software
 Internet connection

Custom assets
Hatch Embroidery allows you to create files or ‘assets’ of various kinds during 
normal use. The most important of these are of course actual embroidery designs. 
There are other assets you may create such as design templates, custom motifs 
and borders, and keyboard design collections. These assets are preserved from 
installation to installation, whether installing a new version of Hatch Embroidery or 
an update patch. If you want to move your Hatch Embroidery to another PC, you 
will need to manually transfer any custom assets you have created or received 
from third parties. See Personal data, pg 87 for details.

Caution: When installing new or updated assets, such as design templates, custom 
motifs and borders, or keyboard design collections, the installation procedure will 

Component Minimum Recommended

CPU Intel® Core i3 (6th Gen) or AMD Ryzen 3 Latest Intel® i5/7 processor or AMD 
Ryzen 6/7

Operating 
system

Microsoft® Windows® 10 (64-bit edition) 
with latest updates

Microsoft® Windows® 11 (64-bit edition) with 
latest updates

Browser Microsoft Edge or later Microsoft Edge or later

Memory 8 GB 16 GB or more

Hard disk size 80 GB 256 GB or more (solid state drive)

Free disk 
space

40 GB 60 GB or more

Graphics card Support for Highest Color (32bit) and 
resolution (1920 x 1080)

Support for Highest Color (32bit) and 
resolution (2560 x 1440 or higher)

Monitor 1920 x 1080 screen resolution Dual monitors capable of displaying 2560 x 
1440 screen resolution

Sound Required for online video help Required for online video help

Internet 
connection

Required to sign in to Hatch Embroidery 3, receive software updates, and access online 
content. You can use Hatch Embroidery offline provided you connect to the Internet at least 
once every 30 days to validate your software license. You will not have access to all features 
while working offline.



Installation 41

not overwrite existing assets of the same name. If you do want to install new assets, 
remove or back up the old ones before updating your current installation.

Install the software
If you are installing on an operating system (OS) that is in a supported language, 
the installation process will run in that language.

To install the software...
1 Ensure your computer meets the system requirements.
2 Close all MS Windows® applications.

Note: When you install the software, you will be prompted to reboot your PC to 
complete the installation. Make sure you save any files and close all 
applications beforehand.

3 Run the installation.
4 Follow the onscreen instructions. You will be prompted to choose:
where the software will be installed on your PC (default location 

recommended)
which components to install – i.e. additional languages. English is the 

default.
which installed version you wish to merge user-defined settings with.

5 Reboot the PC when prompted.

Note: If you encounter problems with the installation, please contact Hatch 
Support.

Run the software
Once the PC has rebooted, you can run the software.

To run the software
1 Double-click the icon on the desktop to start the software for the first time.
2 When prompted, enter your Hatch Embroidery email and password in the fields 

provided.
3 Click OK and the software will connect to our activation server and the 

software will open.

Run Hatch Embroidery in other languages
If you want to install and run a specific language on an English OS, you will need 
to select it from the available languages during installation. The software will then 

https://help.hatchembroidery.com/hc/en-us/requests/new
https://help.hatchembroidery.com/hc/en-us/requests/new
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need to be ‘switched’ to the additional installed language from the Hatch 
Embroidery program group before it can be run in that language.

Run Hatch Embroidery on MAC computer
Hatch Embroidery has been developed for Windows operating system. However, 
many customers successfully run Hatch Embroidery on their MAC computers by 
using ‘Parallels’ and ‘Windows for MAC’. Parallels is designed to be installed on 
MAC computers to run Windows programs. For more information, see Parallels 
website. If you have a MAC with an M1 chip, see this FAQ.

Integration with CorelDRAW®
Integration with CorelDRAW software can be activated according to product 
level. It is available to customers who have purchased CorelDRAW GEM for Hatch 

Switch to additional 
language as 
preferred

https://www.parallels.com/
https://www.parallels.com/
https://help.hatchembroidery.com/hc/en-us/articles/4403994060047-How-to-Install-Windows-on-Mac-with-Apple-M1-Chip-using-Parallels-Desktop
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Embroidery or already have a compatible version of CorelDRAW software 
installed.

Usage tips
 Integration is currently only available with certain models of CorelDRAW 

software. For more information, see FAQs on the Hatch Embroidery website.
Currently, CorelDRAW software can be linked to Hatch Digitizer and Hatch 

Composer only.
 Hatch Embroidery only supports the MS Windows® version of CorelDRAW®. 
 You will be prompted to link upon launching Hatch Embroidery.

 Some CorelDRAW® functions may not be available in Graphics Mode. 
 To purchase CorelDRAW Standard 2021, visit the products page of the Hatch 

Embroidery 3 website.

Product key

You may have received a 5-part product key when purchasing from a Hatch 
Embroidery dealer in the form...
d566695e-zzxx-4417-a5e7-8326056cd267

https://help.hatchembroidery.com/hc/en-us/articles/4890730088079
https://hatchembroidery.com/coreldraw/
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The license can be activated on the Hatch Embroidery website or within the Hatch 
Embroidery software if already installed. If you download or purchase directly from 
the Hatch Embroidery website, you will not need a product key. It will 
automatically be assigned to your email that you used to create your Hatch 
Embroidery account. You will only receive a product key if you have purchased 
the software directly from a reseller at a show, retail shop, or included with your 
machine. Once you have input your product key, you never need to input it again. 
It has a one-time use. Once activated, it is assigned to your email.

Activate product from Hatch Embroidery website
 You will receive a unique link from your reseller. Use this link if you have a 

product key. The link will be unique to your reseller.
Choose Yes from among these options:
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 If you do not have a Hatch Embroidery online account, register and enter the 
5-part code:

 If you do have a Hatch Embroidery online account, log in with your email 
address and password:
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 Insert your 5-part Hatch Embroidery product key and click ACTIVATE:

Activate product from within Hatch Embroidery
 If you haven’t yet done so, download and install Hatch Embroidery. This can be 

done by clicking the download button on the top of the website at 
hatchembroidery.com.

 Launch Hatch Embroidery. The Sign In screen will appear.

 If you already have a Hatch Embroidery account, sign in with your registered 
email address and password. If you have already activated your product key 
on the website, Hatch Embroidery software will now launch. If you have not yet 
activated your product key, you will receive a verification email. See below.

https://www.hatchembroidery.com
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 If you have not yet registered a Hatch Embroidery account, click CREATE A 
NEW ACCOUNT. Enter your details to create a new account and click SUBMIT.

Click the ACTIVATE YOUR ACCOUNT link in the email sent from 
hatchsales@wilcom.com.
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 If you do not receive this email, click to RESEND VERIFICATION EMAIL as shown 
below. Check that the email is not caught by a spam filter or placed in the 
Promotions tab of your Gmail account.

Once clicked, the browser window will open with the following message. You 
are then able to open your software and click RETURN TO SIGN IN.
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Click the ‘Have a product key?’ link and continue to activate your Hatch 
Embroidery product key.

 Insert your 5-part Hatch Embroidery product key and click ACTIVATE. Once 
successful, wait for the activation to complete and Hatch Embroidery will 
launch with the product.

 Next time you restart Hatch Embroidery, simply sign into your account and the 
software will start. To avoid signing in each time, ensure ‘Keep me signed in’ has 
been selected.
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License management

Each licensed copy of the software is for a single user. It entitles you to use the 
software on one PC at a time. You may install Hatch Embroidery 3 on multiple 
computers but only one active session can be used at one time.

Resources
Here are more details about how to manage and release your Hatch Embroidery 
license...

 How do I release the Hatch 3 license on my computer to use it on another 
computer? See this article.

 If I uninstall the software does that does release my license? In short - No!
 How do I use Hatch Embroidery while not connected to the internet? On the 

Sign-in dialog, select ‘Keep me signed in’ and you will not have to re-connect 
to the Internet for 30 days.

Scanner setup

Your embroidery software supports TWAIN-compatible scanners. Peripheral 
devices can be connected to your computer via serial ports, parallel ports, a 
specialized network card or an Ethernet network.

To set up the scanner...
1 Connect the scanner using the accompanying instructions.
2 Set it up in MS Windows® using the accompanying instructions and/or the 

MS Windows® documentation.
3 Start Hatch Embroidery.
4 Select Software Settings > Scanner Setup. The Select Source dialog opens 

displaying a list of scanner drivers loaded on your computer.

5 Select the scanning driver to use, then click Select.

Note: If you have trouble with scanning after re-starting the software, there may 
be a conflict with previously installed scanner drivers. Re-install the software and 

https://help.hatchembroidery.com/hc/en-us/articles/4903749849871-How-do-I-release-the-Hatch-v3-license-on-my-computer-to-use-Hatch-v3-license-on-another-computer
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test the scanner. If the selected scanner driver does not work, select another 
scanner driver from the list. There are usually two installed for each scanner.

Machine connection

Hatch Embroidery supports various sets of machine model. Most machine models 
can read USB memory sticks. These are convenient portable memory devices 
which can hold large amounts of data.

Newer machine models are usually supplied with machine connection software. 
This can be configured so that the design passes straight from your embroidery 
software to machine. Or you can pass the design to the machine connection 
software for further processing. 

Tip: Some customers want to connect their embroidery software directly to 
machine. If your embroidery machine can be seen as an external drive in File 
Explorer, you may be able to send designs directly. For instance, some single 
needle Brother machines have a mode which enables them to be set up like this.

Related topics

 Transfer designs (User Guide)
 Hoop selection (User Guide)
 How to connect directly to embroidery machine

https://help.hatchembroidery.com/hc/en-us/articles/360000115375-How-to-connect-directly-to-my-embroidery-machine-
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Feedback reporter

Hatch Embroidery includes a feedback reporter, when connected to the internet, 
to provide direct contact with Hatch Support following a system crash...

Use the issue reporter to request assistance for specific issues. The reporter can also 
be run independently from the Hatch Embroidery program group.

Report an issue in the
event of a system

crash

Report an issue in 
the event of a system 
crash

https://hatchembroidery.com/support/
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SOFTWARE SETTINGS

Configure the Hatch Embroidery work environment to suit your working 
methodology. For instance, set up your personal hoop list, set design backgrounds, 
unit of measurement, and so on.

Machine selection

Different embroidery machines speak different languages. Before you can stitch a 
design, it must be in a file format which can be understood by the embroidery 
machine. When you select a machine format, Hatch Embroidery uses it to 
translate digitized designs into machine-readable form. The software supports 
various sets of machine model. Most machine models can read USB memory sticks. 
These are convenient portable memory devices which can hold large amounts of 
data.

Note: Some customers want to connect Hatch Embroidery directly to machine. If 
your embroidery machine can be seen as an external drive in File Explorer, you 
may be able to send designs directly. For instance, some single needle Brother 
machines have a mode which enables them to be set up like this. See Transfer 
designs (User Guide) for details. See also FAQs on the Hatch Embroidery website.

https://help.hatchembroidery.com/hc/en-us/articles/360000115375-How-to-connect-directly-to-my-embroidery-machine-
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Select machine model or type

Hatch Embroidery supports many machine brands and models. These are 
available from the droplists on the Context toolbar. Choose your machine brand 
from the droplist.

Choose your machine model or type from the accompanying droplist. When the 
Janome or Elna machine brand is selected, you can select one of the available 
machine models. When any other machine brand is selected, you have a choice 
of ‘single-needle’ or ‘multi-needle’ machine types.

Alternatively, use the Embroidery Settings dialog to preset machine brand and 
model. Click the Machine & Hoop Options button to access these settings.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Choose your 
machine brand

Choose your 
machine model

Choose your 
machine brand



Machine selection 55

Depending on the selected machine brand, you may have the option of selecting 
your machine type – single- or multi-needle. Different hoops are available for each 
of these machine types.

Note: With PES format specifically, the hoop code output for the same size hoop 
differs depending on whether the machine type is single or multi-needle.

Configure hoop list

The Hoop List on the Context toolbar shows which hoops are currently available for 
your selected machine. When you first run the software, the hoop list is populated 
with standard hoops for the selected machine. This list may be configured to 
include non-standard hoops you may wish to use.

To configure your hoop list...
1 Click the Machine & Hoop Options button to access the dialog.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Choose your 
machine type

Currently available
hoops
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2 Click the Add/Remove Hoops button to associate a custom hoop list with the 
selected machine. The dialog opens. The left-hand panel shows all hoops 
available for the selected machine.

3 Select hoops you own in the Available hoops list and transfer them via arrow 
buttons to the Machine hoops list. 

4 Click OK. The new hoop list is available for use. Whenever you select this 
machine, the hoop list is filtered according to your selection.

Tip: Hatch Embroidery allows you to define your own hoops and save for later 
use. Custom hoops are needed because new hoops become available for 
sewing machines more frequently than the software is updated. Also some 
machines include hoop adapters for third-party hoops which need to be 
defined in the software.

Custom hoop 
list

Click to configure hoop list 
for selected machine model

Choose hoops from
available hoops to

add to machine list

Currently available
hoops
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Related topics

 Hoop selection (User Guide)
Custom hoops (User Guide)

Create custom brand

Hatch Embroidery supports most domestic machine brands and models. However, 
if you have a different machine, you may need to set up a custom brand and 
hoop list.

To define a custom brand...
1 Right-click the Show Hoop icon to open the dialog.
2 Click the Create button in the Hoop panel. The Create Brand dialog opens.

Click Customize Design / Context > Machine & Hoop Options to change machines, 
set up hoop lists, and define custom brands and hoops.

Click Create to
create custom

brand

Enter name of new 
machine brand
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3 Enter a name for your new machine brand and click OK. The Add/Remove 
Hoops dialog opens.

Tip: Green hoop icons represent single-needle hoops while blue icons represent 
multi-needle hoops.

4 Select hoops you want to associate with the new brand from the Available 
hoops panel. Use the controls to transfer them to the Machine hoops panel and 
click OK.

Note: Once your new brand is saved, it can be edited or removed via the 
available buttons in the Machine & Hoop tab.

Set start & end points

Before stitching, some embroidery machines require you to position the hoop 
precisely in relation to the needle. Some machines require stitching to start in the 
center of the hoop, some at the periphery. Some machines require the needle to 
finish at the center, others at the last stitch.

Click View > Show Hoop to show or hide hoop. Right-click for settings.

Use Customize Design / Output Design > Auto Start and End to set start and end 
points for the entire design.

Select hoops for
new machine

brand

Click to create
custom hoop

Edit or remove custom 
brand as needed
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Note: The Hoop List on the Context toolbar shows which hoop is currently active in 
the design window. The list is automatically filtered according to the My Hoops list.

To set and end points...

 Turn on connectors via the Show Design droplist or press Shift+C. A green circle 
indicates the start point while a white square indicates the end point.

 Use the Auto Start and End shortcut in the Customize Design toolbox to access 
the dialog. The Design Settings menu also provides a link. By default, design start 
and end points are set according to the currently selected machine and hoop. 
These correspond to cross hairs on the hoop.

Start point

End point

Start and end points set 
according to current machine 
and hoop

Save to template
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 Sometimes you want to set your own start and end points for a particular design 
or hoop. Click Start position and End position to activate options. In the 
example below, start and end points are set to top left and bottom right 
respectively.

 Alternatively, digitize your own start and/or end points by choosing the Manual 
method. This is usually used to align embroidery with other components on the 
garment or article.
 By ticking the checkbox, you will be prompted to mark the start/end point 

after closing the dialog.
 By leaving it unticked, the software will use the previously-digitized position.
 Unticking the Start position and End position checkboxes will return settings 

to default values.
Click OK. Connecting stitches will be inserted as required before the first and 

after the last stitches of the design.
 Use the Save button to save your preference to the template. This becomes the 

default setting for all new blank designs.

Usage tips
 By setting manual start and end points, the hoop remains in a fixed position, 

similar to Brother PE-Design. This gives you the freedom to position objects 
anywhere within the hoop. It is especially useful for multi-position hoops as it can 
help to minimize re-hooping.

 The Manual method is also convenient if you want to prevent the hoop moving 
around while digitizing, as occurs with Automatic Centering. 

Set start point 
within hoop

Set end point 
within hoop
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 The Context > Center All command can be used to center the whole design 
and hoop at the (0,0) position. This means you can reposition the hoop around 
the design after you have finished digitizing without the need for 
auto-centering.

Design settings

Hatch Embroidery provides a number of 
global settings which apply to entire 
designs. The Auto Start & End feature is 
available to connect first and last 
stitches in a design. This is important for 
needle positioning. The Remove Small 
Stitches function automatically removes 
unwanted small stitches from a design 
either on opening or on output.

Background colors

Set the color inside the hoop to match the fabric you intend to stitch out on. You 
can also set a background color outside the hoop by way of contrast. 

To set background colors...

 Select Customize Design > Background and Display Colors or right-click the 
design window and select from the popup menu.

Use Customize Design / Context > Background and Display Colors to change design 
background and display colors.
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 To select a color inside the hoop, choose the Solid Color option. This allows you 
to set separate colors inside and outside the hoop. Select a color from the 
palette or mix your own.

 Set the color inside the hoop to match the color of the fabric you intend to 
stitch out on.

Related topics

 Add backgrounds (User Guide)

Eliminate small stitches
Small stitches can damage fabric and cause thread or needle breakage. Before 
you stitch out, unwanted small stitches can be automatically removed. The filter 
can be applied continuously, on output only, or never.

Set colors inside and
outside hoop
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To eliminate small stitches...

 Select Design Settings > Remove Small Stitches.

Choose your preferred option:
When set to Always, the filter will be automatically applied in the 

background whenever objects are edited or digitized.
When set to On Output, the filter is only applied when printing or outputting 

files.
 Enter the minimum Stitch length you want to preserve.
Click OK to confirm.
Check the Status Bar for the new stitch count.

Design measurement

Use grid and guide lines to help 
accurately align or size embroidery 
objects. The grid can be turned on or 
off and grid spacing changed as 
preferred.
In addition a ruler can be turned on 
or off for accurate measuring. The 
zero point of the ruler can be set to 
any point on the design or design 
window. The ruler scale depends on 
the zoom setting.
Together with the ruler, guides can 
be placed across the design window 
to help align objects. Each guide has 
a yellow handle on the ruler to move 
or delete it. Guides are displayed on 
top of the grid, if present, but ‘beneath’ design objects. Rulers must be displayed 
before a guide can be set.
You can use different measurement units within Hatch Embroidery without having 
to exit and change system settings. This is useful, for example, if you receive a 
request from somewhere that uses a different measurement system. For instance, 

Choose automatic 
small stitch removal 
option
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a US contact may request lettering in inches – say ¾" – while you are working in 
metric. Hatch Embroidery allows you to enter ‘3/4"‘ without having to do any 
mathematical conversion to mm yourself.

Monitor calibration
You need to calibrate your monitor so that designs at 1:1 scale appear at real size. 
Do this when you first install Hatch Embroidery or whenever you change your 
monitor. The first time you run Hatch Embroidery, the measurement system will 
default to whatever the operating system is using. 

To calibrate the monitor...
1 Choose the preferred measurement system via the droplist on the Context 

toolbar.

Tip: To get the most precise measurements for screen calibration, it is 
recommended you use the Metric setting.

2 Select Software Settings > Calibrate Screen.

3 Measure the width and height of the dialog box. Make sure you measure edge 
to edge.

4 Enter the precise measurements in the relevant fields.
5 Click OK to confirm.

Change measurement units

Use Context > Measurement Units to change measurement units within software 
without changing operating system settings.

Choose preferred 
measurement units

Measure width

Measure 
height
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The default unit of measurement – mm or inches – depends on the regional settings 
in the Windows Control Panel. The first time you run Hatch Embroidery, the 
measurement system will default to whatever the operating system is using. The 
measurement units can be changed via the droplist on the Context toolbar. 
Technically, when you select ‘U.S.’, you will get the imperial measurement system 
– inches, feet, and yards. The selected measurement system will default the next 
time you run the software.

Changing the measurement system will change the units used by most (but not all) 
controls. Stitch length and density controls will change to reflect the measurement 
system.

Tip: The Context toolbar is dynamically configured depending on which objects 
you have selected. The measurement droplist only appears when no objects are 
currently selected.

Specify units on-the-fly
As an alternative to changing the overall measurement system used in the 
software, you can specify units of measurement when typing values into a 
measurement control. When you include the unit of measurement, Hatch 
Embroidery automatically converts the entered value into the units of the control.

Say, for example, you are using the metric measurement system so your lettering 
heights are in mm. And say you receive a request for ¾" lettering. Simply enter 
‘3/4in’ or ‘3/4 in’ into the Lettering Height field and it is automatically converted to 
19.1mm.

Choose preferred 
measurement units

Specify unit of
measurement

on-the-fly

Height converted
to current units
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Tip: Hatch Embroidery supports both proper and improper fractions – e.g. ‘1 1/3’ 
as well as ‘4/3’. It does not, however, support mixed units – e.g. 1’3". Nor does it 
display values as fractions after they are entered, only during.

Supported units
Supported units include:

millimeters, mm
 inches, in
 feet, ft
 yards, yd
 centimeters, cm
meters, m
Hatch Embroidery also allows entering units in text form, both English and the 
language the software is currently running in.

Rulers & guides

Hatch Embroidery allows you to turn rulers on and off and create guides for more 
accurate digitizing. These make it possible to accurately position and size objects 
and whole designs.

To display rulers and guides...

 Turn on grids and rulers via the View toolbar.

Click View > Show Rulers & Guides to show or hide rulers and guides. Right-click for 
settings.

This button appears at the point where rulers intersect. Click to set the ruler zero 
point to the top left corner. Alternatively, drag to set a zero point in the design window.

Turn on grids 
and rulers
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 Alternatively, right-click a blank part of the design window to invoke the popup 
menu.

 Reset the ruler zero point by clicking and dragging the box in the top left-hand 
corner to a point on the design. This becomes the new zero point – X,Y (0,0). The 
grid always aligns with the rulers.

 To create a guide, click on either ruler – horizontal or vertical – and 
click-and-drag into position. Multiple guides can be created and just as easily 
removed.

Turn on grids 
and rulers

Click and drag
to reset zero

point

Click ruler to
create a

guideline
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 For more accurate positioning, double-click the yellow guide handle. In the 
Guide Position dialog, enter a precise distance from the zero point, and click 
OK.

 To remove a guide, drag the yellow guide handle off the design window.

Grids & hoop templates

Templates for all hoops are included in Hatch Embroidery. They can be used for 
positioning in place of the design grid. Alternatively, use grid lines to help 
accurately align or size embroidery objects. Grid and hoop template are mutually 
exclusive.

To display grid or hoop template...

 Adjust the background as preferred.
Click the Show Hoop Template icon to toggle hoop template display on or off.

Click View > Show Grid to show or hide grid. Right-click for settings.

Click View > Show Hoop Template to show or hide hoop template.

Enter precise 
distance from zero 
point



Design measurement 69

Click the Show Grid icon to toggle grid display on or off.

 Right-click the Show grid icon to access grid settings. Optionally, adjust grid 
spacing and turn on Snap to grid.

 You can adjust grid spacing in both horizontal and vertical directions. 
Sometimes you might want to set it for precise design work such as cross stitch.

Optionally, activate Snap to grid and Snap to guides. Reference points, control 
points or leading edges of objects ‘snap’ to grid lines during digitizing, sizing, 
reshaping, or positioning operations.

 Select the Set reference point checkbox to set the zero point of the rule. For 
example, you can set the grid reference point to the design center. This is easier 
and faster than moving the whole design. When you close the dialog, you are 
prompted to mark the zero point of your design.

Tip: To temporarily disable Snap to grid as you work, hold down the Alt key.

Adjust grid 
spacing
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Measure distances on screen

Measure the distance between two points on screen using the Measure tool. 
Measurements are shown in millimeters or inches, depending on current settings.

To measure distances on screen...

 Select View > Measure Tool or press M.
Click the start point and drag the mouse. The tooltip displays the length of the 

measured line. The angle shown is the angle of the measured line relative to the 
horizontal.

 Press Esc to finish.
 You can also check the width and height of your design in the status bar.

Tip: For more accurate results, zoom in before you measure. The measurement is 
always the actual size and is not affected by zoom factor.

System preferences

The User Interface Settings dialog allows you to set auto-save and scrolling 
preferences. Access the dialog via Software Settings > User Interface Settings. 
Alternatively, right-click a blank part of the design window to access the 
command from the popup menu.

Customer experience program
Hatch Embroidery includes a Customer Experience Program which is designed to 
provide Wilcom with valuable data concerning software usage patterns. The 

Use Context > Measurement Units to change measurement units within software 
without changing operating system settings.
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program is entirely anonymous and is aimed at improving the features and 
functions of Hatch Embroidery. However, you have the option of opting out of the 
program altogether by deactivating the checkbox in the dialog. Access the 
dialog via the Software Settings > Customer Experience Program command.

Automatic save options
Open the User Interface Settings dialog and choose the General tab. Save your 
work automatically at regular intervals using Auto Save to protect you from losing 
work in the event of hardware or software failure. Select the Auto-save design 
every checkbox and specify an auto-save frequency in minutes.

Note: The design will be saved in the BACKUP folder of your installation. It will have 
the same name as the original file with the extension BAK. Backup files remain in 
the Backup folder until you delete them. To prevent the folder from using too much 
hard disk space, delete unwanted files regularly. For more information, see FAQs 
on the Hatch Embroidery website.

Start screen options
The User Interface Settings > General tab allows you to preset the preferred default 
screen upon startup – Home, Design Library, or Embroidery Mode.

Set auto-save 
timing

Set preferred 
startup screen

https://help.hatchembroidery.com/hc/en-us/articles/115011355268-How-to-delete-recovery-files-in-Hatch
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Edit artwork options
Sometimes you need to edit images directly in a third-party graphics package. 
You would normally do this in order to eliminate backgrounds, flood-fill solid areas 
with color, or add outlines, close gaps, or reinforce outlines. The User Interface 
Settings > General tab allows you to pre-select your preferred graphics package 
– Paint, CorelPHOTO-PAINT, or Paint Shop Pro.

Font list display options
You can set the size of your font preview via the User Interface Settings > General 
tab. You can also adjust the number of recently used fonts.

Toolbar display options
Customize the user interface to suit your preference or monitor. The User Interface 
Settings > General tab allows you the choice of large or small tool icons, with or 
without short names.

Set preferred 
graphics package

Set font preview 
size

Set number of recent 
fonts shown in font list

Show large or
small icons
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You may wish to activate large icons for better visibility, especially when working 
with 4K high resolution monitors. Buttons are large enough to be seen while 
allowing effective use of the large design window.

Auto-scroll behavior
Use Auto Scroll to scroll automatically within the design window while digitizing. This 
can be more convenient than using panning or scroll bars, especially when 
working on large designs.

Auto scroll options include:

Option Purpose

Auto scroll Tick checkbox to enable automatic scrolling while digitizing.

Move pointer after 
scroll

Tick checkbox to force pointer to move with the current cursor position 
after each scroll.

Response time Enter smaller values to increase scrolling speed.

Set auto-scroll 
behavior
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The effect of the Auto Scroll setting only becomes apparent when you start to 
digitize. The design window automatically scrolls to follow the current cursor 
position. The Move Pointer option gives you the following choices:

Mouse-wheel behavior
The Scrolling tab also allows you to set four different mouse wheel behaviors based 
on your selection of default options. Whenever a setting is changed, the system will 
update other mouse wheel behaviors, but you have complete control to change 
as desired.

The same four options are available for use when deploying the mouse wheel on 
its own or in combination with Alt, Ctrl, and Shift keystrokes. That is, you can 
program the wheel to scroll horizontally, vertically, or zoom by preset factors. Tick 
Center pointer when zooming to ensure that the pointer stays centered on screen 
at all times.

Other general options
Miscellaneous other system settings available via the User Interface Settings > 
General tab.

Option Purpose

Center Center of the window. Use this setting for large movements.

Midway Halfway between the original pointer position and the center of the window. Use 
this setting for smaller movements – e.g. when zooming into a small area of the 
design.

Corner The edge of the screen. Use this setting for slow scrolling.

Hold down the <Shift> key to temporarily deactivate Auto Scroll while digitizing.

Set mouse 
wheel behavior

Set general 
behavior
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These options include:

Option Purpose

Show measure 
tooltip

Shows length and angle in a tooltip when measuring distances on 
screen. See also Design measurement, pg 63.

Enable mouse-click 
sound

Enables beeping sounds made by the software in response to mouse 
clicks and pressing <Enter> or <Spacebar> keys while digitizing.

Crosshair cursor Changes the default cursor pointer to crosshairs for more precise 
positioning. It is best used together with the grid.
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FILES & ASSETS

Hatch Embroidery allows you to create files or ‘assets’ of various kinds during 
normal use. The most important of these are your actual embroidery designs. There 
are other assets you may create, such as design templates, custom motifs and 
borders. These are preserved from installation to installation, whether installing a 
new version of Hatch Embroidery or an update patch.
This section details the types of files used and created by Hatch Embroidery as well 
as where they are stored on your computer system.

Embroidery files

There are two types of embroidery file format:

Design files are generally ones you open and modify in the software. Machine files 
are generally ones you send to machine for production. EMB is the native design 
format. Other ‘all-in-one’ formats such as ART and JAN are also supported. Hatch 
Embroidery supports many machine formats. There is some inter-convertibility 
between design and machine formats. Note that you can filter your design library 
between these two broad categories...

Note: Hatch Embroidery supports many machine formats such as JEF, SEW, DST, 
EXP, and others. See also Supported embroidery files, pg 85.

File type Function

Design Design files, also known as ‘outline’ or 'all-in-one' files, usually contain 
digitized shapes and lines, selected stitch types and stitch values and 
effects.

Machine Machine files, also known as ‘stitch’ files, generally contain stitches and 
machine functions and are only suited to specific embroidery machines.

Filter by design 
or machine files
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Design files
All-in-one design files are high-level formats which contain object outlines, object 
properties and stitch data. When you open a design file in the software, 
corresponding stitch types, digitizing methods and effects are applied. These can 
all be viewed in the Sequence docker. See also Viewing methods (User Guide).

Design files can be scaled, transformed and reshaped without affecting stitch 
density or quality. After modification, you can save your design to any supported 
file format. See also Machine file recognition, pg 82 and Output Designs (User 
Guide).

Machine files
Different embroidery machines speak different languages. Also known as ‘stitch’ 
files, machine files are low-level formats for direct use by machines. They contain 
information about the position, length and color of each stitch. When read by the 
software, machine files do not contain object information such as outlines or stitch 
types, but present as a collection of stitch blocks also known as ‘manual objects’. 
Stitch blocks consist entirely of individual stitches.

Manual objects
Manual objects are created wherever machine functions – e.g. color changes or 
trims – are detected in the design. They have only general and connector 
properties. Manual objects, in turn, consist of individual stitches, called ‘manual 

Design file contains 
objects each with 
object properties
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stitches’. In the Sequence docker, manual objects and manual stitches appear as 
one-and-the-same thing.

Scaling machine files
You can scale raw machine files, but because the stitch count does not change, 
the density increases or decreases with the design size. Thus you should not scale 
these designs by more than ±10% or some areas may be too thickly or too thinly 
covered.

Tip: You can, if you wish, manually adjust the stitch density of whole or selected 
parts of a design. See also Fabrics & densities (User Guide).

Machine file 
contains ‘manual 
objects’ with no 
object properties

Don’t scale machine
files by more than

±10%
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File sources

There are two types of embroidery file format:

Design types
While embroidery files are broadly classified as ‘design’ (outline) or ‘machine’ 
(stitch), Hatch Embroidery internally tags files as belonging to one of four types – 
native design (A), imported outlines (B), processed stitches (C), or imported 
stitches (D). These are summarized as follows:

File type Function

Design Design files, also known as ‘outline’ or 'all-in-one' files, usually contain 
digitized shapes and lines, selected stitch types and stitch values and 
effects.

Machine Machine files, also known as ‘stitch’ files, generally contain stitches and 
machine functions and are only suited to specific embroidery machines.

Grade Source Description

A Native 
design

Native EMB designs as well as ART and JAN files are all ‘Grade A’ 
design formats read and written by the software. They are called ‘Grade 
A’ because they contain a complete set of design information in a single 
file – object outlines, properties, stitches, thread colors, thumbnail 
image, and comments. It goes without saying that only Grade A files 
provide 100% perfect scaling and transformation.

B Imported 
outlines

Designs read from an outline format such as GNC and saved in ART / 
EMB / JAN format. Such designs cannot be read directly by the software 
but once converted, they are treated as Grade B designs.

C Processed 
stitches

Designs read from machine files – EXP, DST, PES, etc – where stitches 
have been converted to objects.

D Imported 
stitches

Designs read from machine files, where outlines may or may not have 
been ‘recognized’, but stitches have not been regenerated through 
stitch processing. Note, however, that if you change a stitch design – 
e.g. add a lettering object – the status changes to ‘Processed Stitches’ 
even though the imported stitches may not have been regenerated.
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For information about the source of an embroidery file, refer to the Design tab of 
the Design Information docker.

Design type warnings
By default, Hatch Embroidery displays a warning message whenever you open a 
non-native design.

Toggle off warning 
message as preferred



82 Machine file recognition

Alternatively, to toggle non-native design warnings on or off, access the Help > 
Show Design Warning options.

Machine file recognition

While machine files are generally not suited to scaling, Hatch Embroidery can 
derive object outlines, stitch types and spacing from raw stitch data with some 
success. The Sequence docker will generally display recognized designs as a 
mixture of ‘embroidery objects’ and ‘manual objects’. In other words, where it is 
unable to recognize objects, it leaves them as stitch blocks.

Processing is effective for most machine files but cannot produce the same level 
of quality as original outlines and may not handle some fancy stitches. When 
Hatch Embroidery ‘recognizes’ a machine file, it recognizes stitch types, spacing 
and length values, stitch effects, and can determine object outlines. Stitch types 
are assigned as satin or tatami depending on the pattern of needle penetrations.

Note: Recognized object outlines and stitch values are stored as object properties. 
This means you can scale and transform recognized designs in the usual way. 
Stitches are recalculated for recognized outlines but not for manual objects.

Toggle non-native 
design warnings on or 
off as preferred

‘Recognized designs’ 
contain mixture of 
‘embroidery objects’ 
and ‘manual objects’
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File recognition options
By default, machine files are converted to embroidery files upon opening. If you 
want machine files left as stitch blocks, or ‘manual objects’ upon opening, select 
the ‘Grade D’ option in the Embroidery Settings > Design tab.

Note: Opening machine files with object recognition turned on (EMB Grade C) 
may result in small discrepancies between object coordinates and stitch 
coordinates. It's normal for object extents to be slightly different from stitch extents 
because stitches will often extend beyond the object shape due to pull 
compensation, stitch effects, manual edits, and so on. However, the slight 
difference will make no difference on the machine.

Convert stitches on opening
If you want to convert machine files on a case-by-case basis, you can choose to 
convert at the time of opening via the Open Options dialog. This can be accessed 
via the Options button in the Open Design dialog.

Machine files 
recognized by default

Turn on stitch 
recognition via Open 
Options
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Convert stitches after opening
Even after opening a machine file, you can recognize stitch blocks as objects by 
selecting Recognize Stitches from the Edit menu.

Select objects on a case-by-case basis and apply the Recognize Stitches 
command. Recognized stitch blocks contain a mixture of ‘embroidery objects’ 
and ‘manual objects’.

Note: Even after recognition, the density of manual objects increases or decreases 
with design size. Thus you should not scale these designs by more than ±10% or 
some areas may be too thickly or too thinly covered.

Machine file opened 
without object 
recognition

Recognized stitch blocks 
contain mixture of 
‘embroidery objects’ and 
‘manual objects’
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Supported embroidery files

Details are provided here of the embroidery file types supported by Hatch 
Embroidery.

Note: Embroidery files fall into two broad categories – ‘all-in-one’ design files and 
machine files. Design files are generally ones you open and modify in the software. 
Machine files are generally ones you send to machine for production. There is 
some inter-convertibility between the two formats. Note that you can filter your 
design library between these two broad categories. See also Embroidery files, 
pg 77.

Embroidery files
Hatch Embroidery supports the following embroidery file formats:

Format File Description Read Write

Wilcom EMB 
design EMB Wilcom ‘all-in-one’ design file (up to & 

including e3.0) ● ●

BERNINA ART BERNINA ‘all-in-one’ design file ●

Janome JAN JANOME ‘all-in-one’ design file ●

Wilcom Cross 
Stitch EMX Wilcom Cross Stitch design file ●

Great Notions GNC Great Notions production file ●

Melco Condensed CND Melco ‘condensed’ design file ●

BERNINA / Melco EXP Melco embroidery design file. Also used for 
newer BERNINA embroidery USB format. ● ●

Tajima DST ‡ Used for main types of Tajima machines ● ●

BERNINA Cross 
Stitch ARX BERNINA cross stitch file ●

Deco / Brother / 
Babylock PES Deco, Brother, Babylock production file ● ●

Deco / Brother / 
Babylock PEC Deco, Brother, Babylock production file ● ●

Elna EMD Elna production file ● ●

Janome / Elna / 
Kenmore SEW JANOME/Elna/Kenmore production file ● ●

Janome JPX JANOME/Elna/Kenmore production file ● ●

Janome / Elna / 
Kenmore JEF JANOME/Elna/Kenmore production file ● ●

Janome / Elna / 
Kenmore JEF+ JANOME/Elna/Kenmore production file ●

‡ DST files can be read by MB-4 machine machines.



86 Supported embroidery files

Design templates
Hatch Embroidery supports the following design template formats:

JPX file format
The JPX production file format includes a JPG image, in addition to the 
embroidery, of any graphics included in the design. This provides you with a better 
means of visually aligning embroidery on a printed item when hooped in the 
machine.
Older machines display only thread codes and not the specific brand. This causes 
confusion as the same code across two (or more) different brands of thread may 
be completely different colors. With newer JANOME MemoryCraft machines, a 
thread brand ID identifying the thread chart is now recognized. The specific brand 
is displayed on the machine itself.

Husqvarna / Viking HUS Husqvarna/Viking/Pfaff production file ● ●

Husqvarna / Viking SHV Husqvarna/Viking/Pfaff production file ● ●

Husqvarna / Viking 
/ Pfaff VIP Husqvarna/Viking/Pfaff production file ● ●

Husqvarna / Viking 
/ Pfaff VP3 Husqvarna/Viking/Pfaff production file ● ●

Pfaff PCD Pfaff production file ● ●

Pfaff PCM Pfaff production file ● ●

Pfaff PCQ Pfaff production file ● ●

Pfaff PCS Pfaff production file ● ●

Singer / Poem / 
Huskygram CSD Singer / Poem / Huskygram production file ● ●

Singer XXX Singer production file ● ●

OESD Project ART42 OESD ‘all-in-one’ design file ●

Format File Description Read Write

‡ DST files can be read by MB-4 machine machines.

Format File Description Grade Read Write

Hatch Template JMT Hatch design template A ● ●

Wilcom Template EMT Wilcom design template A ●

Digitizer Template JMT JANOME design template A ●

BERNINA 
Template AMT BERNINA design template A ●
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Supported artwork

Artwork can be imported into Hatch Embroidery in both vector and bitmap 
formats. Generally speaking, vector images preserve the picture quality when 
resized, whereas bitmap images cause problems of pixilation and image 
degradation when enlarged or scaled down. However, any scaling required 
should be done before importing into the software as the importing operation 
automatically transforms vector images into bitmaps.

Supported vector formats
Embroidery mode supports the following vector formats:

Supported bitmap formats
Embroidery mode also supports the following bitmap formats:

Tip: If your Hatch Embroidery installation is linked to a supported version of 
CorelDRAW software, you can open many more formats, bitmap and vector, and 
bring them into Embroidery Mode.

Personal data

Hatch Embroidery allows you to create files or ‘assets’ of various kinds during 
normal use. The most important of these are your actual embroidery designs. But 
there are other assets you may create, such as design templates, custom motifs 
and borders. These are preserved from installation to installation, whether installing 
a new version of Hatch Embroidery or an update patch. However, it’s a good idea 
to familiarize yourself with the locations and file names of your custom assets for 
various reasons...

 In the first instance, you should back up your custom assets in case of computer 
crash.

 Also, you may want to share assets with other Hatch Embroidery users, or install 
third-party assets such as custom fonts.

Extension Format Read Write

EMF Enhanced Metafile ●

EPS Encapsulated PostScript ●

WMF Windows Metafile ●

Extension Format Read Write

BMP Windows Bitmap ● ●

JPG JPEG File Interchange ● ●

PNG Portable Network Graphics ● ●
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 Finally, if you want to install your software to a new computer, you will need to 
manually copy the contents of your asset folders to the new locations.

Tip: In order to preserve any custom assets, do not uninstall your existing version of 
Hatch Embroidery. Any new updates can be installed over top of your existing 
installation. If you want to move Hatch Embroidery to another PC, you will need to 
manually transfer any custom assets you have created or received from third 
parties.

Custom assets
Hatch Embroidery allows you to create files or ‘assets’ of various kinds during 
normal use. The most important of these are your actual embroidery designs. There 
are other assets you may create such as design templates, custom motifs and 
borders, and keyboard design collections. These assets are preserved from 
installation to installation, whether installing a new version of Hatch Embroidery or 
an update patch. For more information about custom assets, refer to...

Assets Description

Embroidery and 
other designs

The built-in 'embroidery library' makes it easy to search, sort and browse 
all embroidery designs on your system. Any folder containing embroidery 
designs can be included in the navigation tree. See also Manage design 
folders (User Guide).

Custom motifs and 
borders

Motif stamps are ready-made design elements, such as hearts, leaves or 
geometric patterns which are contained in libraries or 'sets'. You can 
define your own stamps for individual use or for use in motif runs or fills. 
Similarly, you can create your own borders for use in monograms. See 
also Custom objects (User Guide).

Keyboard design 
collections

Embroidery character designs are very popular. Many hobbyists buy 
embroidery fonts from third-party suppliers. Naturally, embroiderers want 
to be able to use them in Hatch Embroidery by mapping to keyboard 
characters. The Keyboard Design Collection (KDC) feature provides a 
convenient way to do this. See also Keyboard Design Collections (User 
Guide).

Carving stamps The Carving Stamp feature allows you to select object outlines from the 
design window and apply them directly as stamps or save them to a 
library for future reference. You can use vector or embroidery objects as 
a basis for stamps. See also Carving stamps (User Guide).

Design templates Templates are special files used to store fabrics, objects and default 
settings. Use templates when digitizing frequently-used design types so 
that you do not have to adjust current settings every time. See also 
Design templates (User Guide).
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Note: In order to preserve any custom assets, do not uninstall your existing version 
of Hatch Embroidery. Any new updates can be installed over top of your existing 
installation. If you want to move your Hatch Embroidery to another PC, you will 
need to manually transfer any custom assets you have created or received from 
third parties.

Custom asset locations
User data – including custom fabrics, templates, motifs, borders, and keyboard 
design collections – is stored in dedicated folders. Familiarize yourself with them so 
you know where all your custom assets are located. Go to...
..\ProgramData\Wilcom\Hatch Embroidery

Graphical data is stored in a separate library. Go to...

Thread charts The thread charts contained in the software represent the many different 
brands and colors of thread available. You can modify thread charts to 
reflect the threads you are currently using. You can even create your 
own. See also Manage thread charts (User Guide).

Custom hoops The software allows you to define your own hoops and save for later use 
or associate with a custom machine type. Custom hoops are needed 
because new hoops become available for sewing machines more 
frequently than the software is updated. See also Hoop selection (User 
Guide).

Custom assets Location File types

Auto fabrics \RES\AUTOFABRIC userdefined.autost

Hoops \RES\Hoops USRHOOPnS.DSC

Thread charts \RES\ThreadCharts *.TCH

Machines \RES\Machines UserMachineModels.txt

Motifs \MOTIFS *.ESA

Templates \TEMPLATE *.JMT

Carving stamps \STAMPS *.ESA

Borders \BORDERS *.ESA

Custom fonts \FONTS *.ESA

Keyboard design collections \FONTS *.KDC

Assets Description
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..\Users\Public\Public Pictures\Hatch Pictures

Note: Some data folders will only be created when Hatch Embroidery is opened 
for the first time after restarting your system.
In File Explorer, you can navigate to the precise location of your Hatch Embroidery 
assets using the navigation tree on the left of the window, or simply by typing or 
copying the path name into the address field and pressing Enter.

Whenever you install updates or upgrades to your existing software, the above 
folder structure, together with any custom assets, will be preserved. However, if 
you install your software to another PC, you will need to manually copy the 
contents of these folders to the new location. 

Note: The C:\ProgramData folder may be hidden on some PCs depending on the 
permissions of the user who is logged in. See also Show hidden folders, pg 91.

Personal designs & artwork
Amongst your most important assets are of course your embroidery designs and 
any artwork files you may use. These can potentially be saved anywhere on your 
system. By default however...

Custom assets Location File types

Articles \Articles *.PNG

Fabrics \Fabrics *.JPG, *.BMP
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 Any designs, cutting files, or machine files that you save from Hatch Embroidery 
will be saved by default to the My Embroidery folder at the location...
C:\Users\<USER>\My Embroidery\

 Similarly, any artwork you save from Hatch Embroidery will be saved by default 
to the My Pictures folder at the location...
C:\Users\<USER>\Pictures\My Pictures\

Note: Whenever you install updates or upgrades to your existing software, the 
above folders will be preserved. However, if you install your software to another 
PC, you will need to manually copy the contents of the My Embroidery and My 
Pictures folders to the new location.

Show hidden folders
If you need to manually copy the contents of your asset folders to a new location, 
you may find that the C:\ProgramData folder is hidden on your PC, depending on 
the permissions of the login you are using. To be able to view the folder structure, 
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open the View tab in File Explorer and tick the Hidden items option. This will reveal 
the ’ProgramData’ folder and all its contents.
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FEATURE COMPARISON TABLE

The table below itemizes features which are relevant to each product level. Product levels for this release include:

Note: While every effort has been made to maintain this table up to the current release, late changes may not be 
precisely reflected. For purchasing advice, please visit the website or talk to a Wilcom representative.

Product level Capabilities

Hatch Organizer O Find, manage, customize, and output designs quickly and easily.

Hatch Personalizer P All ‘Organizer’ features plus lettering and monogramming.

Hatch Composer C All ‘Personalizer’ features plus editing and auto-digitizing.

Hatch Digitizer D All ‘Composer’ features plus world-class manual digitizing and appliqué tools.

Capability Feature Products Reference

D C P O

Software settings Software Settings

Select machine model / type * ● ● ● ● Select machine model or type
Create custom brand * ● ● ● ● Create custom brand
Set start and end points * ● ● ● ● Set start & end points
Set background colors ● ● ● ● Background colors
Eliminate small stitches ● ● ● ● Eliminate small stitches
Calibrate monitor ● ● ● ● Monitor calibration
Display rulers, grids, and guides ● ● ● ● Rulers & guides
Measure distances on screen ● ● ● ● Design measurement
Change measurement units ● ● ● ● Change measurement units

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3

https://www.wilcom.com/Products.aspx
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Adjust system preferences – auto-save, 
auto-scroll, etc

● ● ● ● System preferences

Manage designs Design Library Manage Designs

Open design library ● ● ● ● Open the design library
Browse designs ● ● ● ● Browse designs
Open or copy design files ● ● ● ● Open or copy designs
Open blank designs ● ● ● ● Open blank designs
Transfer selected designs ● ● ● ● Transfer selected designs
Convert selected designs ● ● ● ● Convert multiple designs
Print selected designs ● ● ● ● Print selected designs
Print selected designs to catalog ● ● ● ● Print design catalogs
Export design lists ● ● ● ● Export design lists
Manage design folders ● ● ● ● Manage design folders

View designs View Designs

Display backdrops ● ● ● ● Display backdrops
Zoom and pan designs ● ● ● ● Zoom & pan designs
View colors and objects Sequence ● ● L View colors & objects
View by color View by Color ● ● View by color
Design overview Design Overview ● ● ● ● Design overview
View stitching TrueView ● ● ● ● View stitching
View connectors * ● ● ● ● View connectors
Simulate design stitchout Stitch Player ● ● ● ● Simulate design stitchout
Travel through designs ● ● L L Travel through designs

Customize designs Customize Designs

View design information ● ● ● ● View design information
Estimate thread usage ● ● ● ● Thread usage estimates
Access object properties ● ● Access object properties
Set background and display colors ● ● ● ● Add backgrounds
Choose auto fabrics ● ● ● ● Choose auto fabrics
Manage auto fabrics ● ● Manage fabrics

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Adjust stitch spacing ● ● ● ● Adjust stitch densities
View color blocks ● ● ● ● View color blocks
Pick and apply existing colors ● ● ● ● Pick & apply colors
Customize design colors ● ● ● ● Customize design palette
Add threads to design palette ● ● ● ● Add threads to design palette
Change color schemes Cycle Used Colors, 

Color Wheel
● ● Change color schemes

Customize design environment Background and Display 
Colors

● ● ● ● Customize design environment

Customize design fabric settings Auto Fabric ● ● ● ● Customize design fabric settings
Preset object properties ● ● ● Preset object properties
Save settings to template ● ● ● ● Save settings to template
Revert to default settings ● ● ● ● Revert to default settings
Modify thread charts ● ● ● ● Modify thread charts
Create new thread chart ● ● ● ● Create new thread chart

Outline stitches Outline stitches

Simple lines Single / Triple Run ● ● Simple outlines
Satin lines Satin / Raised Satin ● ● Satin lines
Motif lines Motif ● ● Motif lines
Backstitch lines Backstitch ● Backstitch lines
Stemstitch lines Stemstitch ● Stemstitch lines
Sculptured runs Sculpture ● Sculptured runs
Zigzag lines Zigzag ● Zigzag lines
Blanket lines Blanket ● Blanket lines

Fill stitches Basic Stitch Types

Satin fills Satin / Raised Satin ● ● Satin fills
Tatami fills Tatami ● ● Tatami fills

Decorative fills Decorative Stitch Types

Embossed fills Embossed ● ● Embossed fills
Contour fills Contour ● Contour fills

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Ripple fills Ripple ● Ripple fills
Motif fills Motif ● ● Motif fills
Stipple fills Stipple ● Stipple fills
Cross stitch Cross Stitch ● Cross stitch

Stitch effects Stitch Effects

Florentine fills Florentine Effect ● Florentine fills
Radial fills Radial Fill ● Radial fills
Elastic embossed fills Elastic Embossed Fill ● Elastic embossed fills
3D Warp 3D Warp ● 3D Warp
Hand stitch effects Hand Stitch ^ ● Hand stitch effect
Feathered edge effects Feather Edge ● ● Feathered edges
Gradient fill effects Gradient Fill ● ● Gradient fill effects

Embroidery editing Embroidery Editing

Select objects ● ● ● L Select objects
Copy, cut and paste ● ● ● ● Copy & paste objects
Duplicate objects Duplicate / Clone ● ● ● ● Duplicate & clone objects
Arrange objects Align / Space ● ● ● ● Arrange objects
Transform objects Scale / Rotate / Skew / 

Mirror
● ● ● ● Transform objects

Reshape objects Reshape * ● ● Reshape objects
Adjust entry and exit points Reshape ● ● L Adjust entry & exit points
Add or adjust stitch angles Add / Remove Stitch 

Angles
● ● L Stitch angles

Sequence objects Sequence * ● ● Sequence by objects
Sequence by selection order Sequence ● ● Sequence by selection order
Sequence by color list Sequence ● ● Sequence by color list
Sequence by color block Sequence by Color ● ● Sequence by color block
Optimize color changes Optimize Color Changes ● ● ● ● Optimize color changes
Apply automatic connectors Always Tie-Off & Trim ● ● ● Automatic connectors
Apply closest joins Apply Closest Join ● ● Closest joins
Control corner stitching Automatic Corners ● ● Corner stitching

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Create color blends Create Color Blend ● ● Color blending
Break apart composite objects Break Apart ● ● Break apart composite objects
Cut shapes manually Knife ● ● Cut shapes manually
Combine objects Weld ● Combine objects
Apply curve smoothing Smooth Shapes ● ● Apply smooth curves
Remove underlying stitching Remove Overlaps ● ● Remove underlying stitching
Edit stitches Stitch Edit ● ● Edit stitches

Embroidery lettering Lettering

Create lettering Lettering * ● ● ● Create lettering
Edit letter angle, baseline angle and line 
spacing of lettering objects

Lettering * ● ● ● Advanced settings

Apply baselines – horizontal, vertical, etc ● ● ● Lettering layouts
Lettering stitch types ● ● ● Lettering stitch types
Lettering underlay ● ● ● Lettering underlay
Scale lettering ● ● ● Scale lettering
Rotate lettering ● ● ● Rotate lettering
Reshape baselines ● ● ● Reshape baselines
Reshape letters ● ● ● Reshape letters
Insert special characters ● ● ● Insert special characters
Use flair script ● ● ● Flair script
Use monogram fonts ● ● ● Monogram fonts
Keyboard design collections Keyboard Design 

Collection
^ ● L L Keyboard Design Collections

Monogramming Monogramming

Select monogram designs * ● ● ● Select monogram designs
Add monogram letters ● ● ● Add monogram letters
Add monogram ornaments ● ● ● Add monogram ornaments
Add monogram borders * ● ● ● Add monogram borders
Break apart monograms ● ● Break apart monograms

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Artwork Using Artwork

Scan artwork ● ● Scan artwork
Insert artwork as bitmaps ● ● Insert artwork as bitmaps
Insert artwork as vectors * ● ● Insert artwork as vectors
View artwork (bitmap / vector) ● ● ● ● View artwork
Lock / dim artwork ● ● Lock and dim artwork
Size artwork ● ● Size artwork
Crop artwork ● ● Crop artwork
Edit artwork externally ● ● Edit artwork externally
Modify vector properties ^ ● Modify vector properties
Prepare artwork for auto-digitizing * ● ● Prepare artwork for auto-digitizing
Prepare photos for auto-digitizing Adjust Bitmap ● ● Prepare photos for auto-digitizing
Save processed artwork ● ● Save processed artwork

Auto-digitizing Auto-Digitizing

Assign threads for auto-digitizing Color Matching Method ● ● Assign threads for auto-digitizing
Auto-digitize artwork Auto-Digitize 

Embroidery
* ● ● Auto-digitize embroidery

Auto-digitize fills Click-to-Fill ● ● Auto-digitize fills
Auto-digitize outlines Click-to-Outline ● ● Auto-digitize lines
Convert vectors to embroidery Click-to- ^ ● Convert vector objects in Embroidery 

Mode
Convert artwork to embroidery CorelDRAW® * ○ ○ Convert artwork to embroidery with 

CorelDRAW®
Auto-digitize with PhotoFlash PhotoFlash ● Auto-digitize with PhotoFlash
Auto-digitize with Reef PhotoStitch Reef PhotoStitch ^ ● Auto-digitizing with Reef PhotoStitch
Auto-digitize with Color PhotoStitch Color PhotoStitch * ● Auto-digitize with Color PhotoStitch

Manual digitizing Manual Digitizing

Digitize open and closed shapes Digitize Open / Closed 
Shape

* ● Digitize open & closed shapes

Close open shapes with straight or curved 
lines

Close Shape with 
Straight / Curved Line

* ● Digitize open & closed shapes

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Create turning fills Digitize Blocks ● Turning fills
Create circles and squares Rectangle / Oval ● Circles & squares
Create standard shapes Standard Shapes * ● Standard shapes
Apply automatic underlay Underlay ● ● Automatic underlay
Apply pull compensation Pull Compensation ● ● Pull compensation
Reinforce outlines Backtrack / Repeat ● Reinforce outlines
Create freehand shapes Freehand... ● Create freehand shapes
Insert motif stamps Motif Stamp ● Motif stamps
Digitize holes in objects Digitize / Remove Holes ● Create holes in objects
Fill holes in objects Fill Holes ● Fill holes in objects
Apply branching Branching ● ● Branching
Convert to redwork Redwork ● Redwork
Carving stamps Carving Stamp ● Carving stamps
Create / manage motifs Create Motif ● Create motifs
Create / manage borders Create Border ● Create borders

Digitize appliqué Appliqué

Visualize appliqué fabrics ● ● ● ● Appliqué fabrics
Create appliqué objects Digitize Appliqué ● Create appliqué objects
Create appliqué with holes Digitize Appliqué with 

Holes
● Create appliqué with holes

Convert to appliqué Convert to Appliqué * ● Convert to appliqué
Convert vectors to appliqué Tag as Appliqué ^ ○ Convert vector graphics to appliqué
Partial cover appliqué Partial Appliqué ● Partial cover appliqué
Combine appliqué Combine Appliqué ● Combine appliqué

Design layouts Design Layouts

Mirror-copy objects Mirror-Copy ● ● Mirror-copy objects
Define work areas ● ● Work areas
Add buttonholes Buttonholes ● Buttonholes
Create ambience quilting Ambience Quilting ● Ambience quilting
Create automatic outlines and offsets Create Outlines & 

Offsets
● Outlines & offsets

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Create trapunto outlines Trapunto Outlines ● Create trapunto outlines
Generate laydown fills Laydown Stitch ^ ● ● Generate laydown fills
Add basting stitch markers Basting Stitch Marker ● ● Add basting stitch markers
Add graphic markers Graphic Marker ● ● Add graphic markers

Embroidery hooping Embroidery Hooping

Configure hoop list * ● ● ● ● Configure hoop list
Select and display hoops * ● ● ● ● Select & display hoops
Center hoops Center All ^ ● ● ● ● Center hoops
Rotate hoops ● ● ● ● Rotate hoops
Multi-position hoops ● ● L L Multi-position hoops
Create and edit custom hoops ● ● ● ● Custom hoops
Create automatic hoopings Automatically Add 

Hoops
* ● ● Create automatic hoopings

Create manual hoopings Add Hoop * ● ● Create manual hoopings
Calculate hoopings Calculate Hoopings ● ● Calculate hoopings
Split objects between hoopings Add Splitting Line ● ● Split objects between hoopings
Print multi-hooped designs ● ● Print multi-hooped designs
Add registration marks Multi-Hooping Options * ● ● Add registration marks
Optimize color changes for auto-hooping ● ● Optimize color changes for 

auto-hooping
Export multi-hooped design as machine 
files

Export Design ● ● Export multi-hooped design as machine 
files

Output designs Output Designs

Save designs ● ● ● ● Save designs
Small stitch removal ● ● ● ● Small stitch removal
Export designs Export Design ● ● ● ● Export designs
Export cutting lines Export Cutting * ● ● ● ● Export cutting lines
Transfer designs to machine folder ● ● ● ● Transfer designs
Print designs ● ● ● ● Print designs
Capture design images Capture Design Image ● ● ● ● Capture design images
Print design layouts ● ● ● ● Print layouts

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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Cross-Stitch GEM ○ Hatch Cross Stitch

Capability Feature Products Reference

D C P O

D Hatch Digitizer C Hatch Composer  P Hatch Personalizer O Hatch Organizer
● Included as standard  ○ Modular ‘GEM’ (or compatible version of CorelDRAW®)  L Limited functionality ^ New to Hatch 3 * Improved in Hatch 3
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QUICK REFERENCE

Hatch Embroidery uses toolbars and shortcut keys to 
provide quick and easy access to common commands. It 
can be opened via the desktop icon or MS Windows® Start 
menu. For a summary of software tools and keyboard 
shortcuts available in Hatch Embroidery, refer to the topics 
below.

Note: The tools and commands described here are all 
available in the highest product level. Not all are 
applicable to other product levels.

Menus

The main menu is normally docked at the top of the screen above the design 
window. Use it to access common commands. As you get more familiar with them, 
you can speed things up using Keyboard shortcuts. Many of these commands are 
also available as toolbar buttons. Some may not appear in the list or may be 
inactive depending on the level of software you own.

Note: Most standard MS Windows® Alt key shortcuts apply. Use the Alt key with the 
letter underlined in the menu. To cancel an operation, press Esc twice or click on 
the Esc icon on the toolbar.
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File menu

Command Tip Shortcut

New blank design Create new blank design based on default template, 
fabric and background settings.

<Ctrl+N>

New from template Create new design based on selected template as well 
as fabric and background settings.

New from design Create new design based on an existing design.

Open design Open an existing embroidery design from hard disk or 
network drive.

<Ctrl+O>

Open recent design Open design from a list of recently opened designs.

Open backup 
design

Open directly onto the backup folder for quick access 
to backup files in case of software failure.

Insert design Import embroidery design files into the current design.

Insert artwork Import vector or bitmap artwork into current design as 
backdrop for manual or automatic digitizing.

Save design Save current design. <Ctrl+S>

Save design as Save current design with different name, location or 
format.

Save as template Save current design as design template for future use.

Export design Save current design as production file for use by 
machine.

Export cutting Export current design or selected objects to SVG file 
format for cutting.

Print preview View worksheets on screen. Print worksheets from 
this window.

Print design Print active design using current settings. <Ctrl+P>

Cross Stitch Access the Cross Stitch application.

Capture design 
image

Save design image as bitmap according to settings in 
the Capture Design Image dialog.

Close design Close current design tab.

Close all designs Close all design tabs.

Sign out and 
release license

Exit program and sign out of Hatch account.

Exit program Close all open designs and exit program. <Alt+F4>
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Edit menu

Command Tip Shortcut

Undo / Redo Standard Windows commands. Cancel or re-apply 
preceding command or series of commands.

<Ctrl+Z/Y>

Cut / Copy / Paste Standard Windows commands. Cut or copy selection 
and place on Clipboard. Paste contents to design 
window.

<Ctrl+X/C/V>

Duplicate Duplicate selection without placing it on clipboard. <Ctrl+D>

Duplicate with offset Duplicate with preset offset. Create regular patterns of 
duplicates. Adjust setting via Embroidery Settings > 
Edit dialog.

<Ctrl+Shift+D>

Delete Delete selection without placing it on clipboard. <Del>

Select / deselect all Select or deselect all objects in current design. <Ctrl+A> / <X>

Close shape with 
straight line / curved 
line

Close selected open outlines with straight or curved 
line.

Optimize color 
changes

Optimize design by reducing color changes to a 
minimum, while maintaining color layers.

Apply closest join Join selected objects at closest point. Re-apply 
closest join after editing.

<J>

Sequence >> Toggle display of Sequence docker. Sequence objects 
and color blocks in current design.

<Shift+L>

Sequence by 
selection order

Hold down <Ctrl> and click to select objects in current 
design. Select command to sequence objects in order 
of selection.

Break apart Split composite objects – monograms, appliqués, 
lettering, etc – into components. Allows each to be 
edited individually.

<Ctrl+K>

Remove color 
change

Remove color changes in selected objects which have 
been manually inserted while traveling through 
design.

Regenerate stitches Manually regenerate stitches for selected objects. <G>

Recognize stitches While machine files are generally not suited to 
modification, the software can ‘recognize’ object 
outlines, stitch types and spacing from stitch data. 
After opening a machine file, run the Recognize 
Stitches command to recognize stitch blocks as 
objects.

Adjust stitch 
spacing

Manually override stitch densities of selected objects 
or entire designs.

Object properties 
>>

Open Object Properties docker to preset properties or 
adjust them for selected objects.
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View menu

Arrange menu

Copy object 
properties

Make properties of selected object current for the 
design.

Apply object 
properties

Apply current settings to selected objects.

Command Tip Shortcut

TrueView Toggle simulation of stitched embroidery. <T>

Show design Toggle display of design elements. Click to open 
droplist of view settings.

Show hoop Toggle hoop display. <Shift+H>

Show hoop 
template

Toggle display of hoop template as an alternative to 
grid lines. Align design at correct location and 
orientation.

Show grid Toggle grid display. <Shift+G>

Show rulers Toggle display of rulers and guides. <Ctrl+R>

Stitch player Simulate embroidery design stitchout onscreen in 
either stitch or TrueView.

<Shift+R>

Measure tool Measure distances and angles on screen. <M>

Zoom Zoom in/out of workspace and zoom in on bounded 
areas to full window size. See also Zoom toolbar, 
pg 115.

Pan Drag to pan across design at high zoom factors. <P>

Previous view Return to previous view. <V>

Center at current 
stitch

Center currently selected stitch in design window. <C>

Refresh screen Refresh screen display. <R>

Command Tip Shortcut

Group Combine multiple objects into one selectable object 
grouping.

<Ctrl+G>

Ungroup Split object grouping into component objects. <Ctrl+U>

Lock Lock selected objects to protect them during digitizing 
or editing.

<K>

Unlock selected Unlock locked objects selected in the Sequence 
docker.

Unlock all Unlock all locked objects in design. <Shift+K>

View by color View embroidery objects by color.

Command Tip Shortcut
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Machine menu

Design Settings menu

Software Settings menu

Hide selected Hide selected object/s from view.

Hide unselected Hide all objects apart from currently selected.

Unhide selected Unhide hidden objects selected in the Sequence 
docker.

Unhide all Restore all hidden objects to view.

Align Access commands to align selected object tops, 
bottoms, right sides, left sides, etc.

Space Access commands to distribute selected objects 
evenly down or across the screen.

Command Tip

Transfer design Transfer current design to preset design folder.

Transfer settings Preset file types required by selected machines, as well as file 
location on the network or PC.

Command Tip

Design information >> View design information such as size and number of stitches. Add 
comments to print on worksheet.

Background and 
display colors

Set colors, fabrics, or articles as design backgrounds and set display 
colors.

Auto fabric Modify design properties for stitchout on different fabric.

Auto start and end Set auto start and end points for entire design.

Remove small stitches Control automatic removal of small stitches. (Default set to 
‘Always’.)

Object properties >> Open the Object Properties docker to preset properties or adjust for 
selected objects.

Command Tip

User interface settings Preset user interface (GUI) settings for tools, grids and guides, view 
settings, and scrolling options.

Embroidery settings Preset default settings for machine file conversion, object 
duplication, overlap removal, appliqué, as well as hoop settings.

Manage auto fabrics Create custom fabric settings to suit particular needs.

Manage thread charts Create your own charts to represent the palette of threads you have 
available. Change code, name or chart for existing threads.

Command Tip Shortcut
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Window menu

Help menu
If you encounter a problem, refer to the Help menu for the following sources of 
product help...

Product help & training

 ‘Release Notes’ and a ‘Quick Start Guide’ can be viewed and downloaded via 
the Help menu.

Manage motifs If you have created custom motifs, you can manage them via this 
command. Rename or delete individual motifs or entire custom 
categories.

Manage borders If you have created custom borders, manage them via this 
command.

Calibrate screen Calibrate your monitor so that designs at 1:1 scale appear at real 
size. Do this when you first install the software, whenever you 
change your monitor, or adjust your monitor’s horizontal or vertical 
controls.

Scanner setup Set up scanner to interact directly with the software.

Customer experience 
program

Opt out of the customer experience improvement program as 
preferred.

Command Tip

Tile horizontal / vertical Tile design windows with multiple designs.

Remove tiling Remove any open tiling.

Dockers Toggle display of dockers.

Toolbars Toggle display of toolbars.

Command Tip

Product help 
available online

Training material and 
courses available from 
Hatch Academy
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 Follow the link to Product Help to download a PDF of the entire Hatch 
Embroidery User Guide.

 A printed copy can also be ordered via Product Help.
 The Hints docker provides a valuable learning resource from within the 

software. It can be activated via the Help menu. Each hint includes a brief 
feature summary together with a link to a short video.

 Note that ‘just-in-time’ help for each tool can also be accessed via F1 keypress. 
Simply point to the tool and press F1.

 The Help menu also provides access to the Hatch Academy. This resource 
provides free and paid courses for both trial and registered users. Resources 
include ‘Getting Started’, ‘Orientation’ and ‘Essentials’, plus projects, extra 
videos and other resources, all aimed at improving the learning journey.

 Run the Check for updates command to check for periodic software updates.

Follow link for 
details

Download and 
install as preferred

https://hatch.embroideryhelp.net/v3/en/index.htm
https://hatch.embroideryhelp.net/v3/en/index.htm
https://profile.hatchembroidery.com/?return_url=https://academy.hatchembroidery.com/enrollments
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Toolbars

You access commands in your design window using toolbar buttons. To activate 
a tool, simply move the mouse pointer over it, and click with the left mouse button. 
Where applicable, right-click a tool to access settings.

Note: Not all tools and commands are applicable to all product levels.

Switch & Convert toolbar
Hatch Embroidery has a single ‘design window’ but you interact with it in different 
ways. The main operating modes are accessed via the Switch & Convert toolbar. 
See also The user interface, pg 3.

Tool Tip

Home Revisit the Home screen to access tutorials and other product 
information.

Switch to 
Embroidery 
Mode

Digitize and edit embroidery designs. Display embroidery as well 
as artwork. View designs realistically in 3D simulation.

Switch to 
Graphics Mode

Import, edit or create vector artwork as backdrop for embroidery 
digitizing, manual or automatic.

Convert 
embroidery to 
artwork

Convert selected embroidery objects to vector artwork.

Convert artwork 
to embroidery

Convert selected vector artwork to embroidery objects in Graphics 
Mode.
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Design Colors toolbar
You change thread colors for embroidery objects from the Design Colors toolbar. 
This is the simplest way to customize a design. The design colors you set are saved 
with the current design. See also Design colors (User Guide).

Tag as appliqué Tag selected vectors for conversion to appliqué embroidery.

Keep Graphic 
Objects

When toggled on, artwork will be preserved during the conversion 
process.

Match to 
embroidery 
palette

When toggled off, graphic colors are added to the embroidery 
design palette. When toggled on, graphic colors are matched to 
palette colors.

Show embroidery Toggle display of embroidery components in Graphics Mode.

Design Library Open Design Library window.

Tool Tip Shortcut

Current color View current design color.

Pick color Pick a color from design window and make it current.

Apply color Apply current color to embroidery objects.

Add design color Add color to end of the design palette.

Remove design 
color Remove unused color from end of the design palette.

Hide unused 
colors

Toggle display of all unused colors in the design 
palette.

Discard unused 
colors Remove all unused colors from the design palette.

Threads >> Toggle display of Threads docker. Find threads from 
different charts and change design colors. <Alt+T>

Tool Tip
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Select toolbar
Use the Select toolbar to select or reshape objects.

Standard toolbar
Use the Standard toolbar for commonly used functions such as opening, saving, 
and printing designs.

Tool Tip Shortcut

Select Select an object or group. Or drag selection marquee 
to select multiple enclosed objects or groups. <0>

Polygon select Select an object or group by digitizing polygon line 
around them. <Ctrl+L>

Reshape Reshape an object shape, edit stitch angles, adjust 
entry and exit points, or customize envelopes. <H>

Tool Tip Shortcut

New blank 
design

Create new blank design based on default template, 
fabric and background settings. <Ctrl+N>

New from design Create new design based on an existing design.

Open design Open existing embroidery design from hard disk or 
network drive. <Ctrl+O>

Open recent 
design Open design from list of recently opened designs.

Insert design Insert existing embroidery design into current design.

Insert artwork Import vector or bitmap artwork into current design as 
backdrop for manual or automatic digitizing.

Save design Save current design. <Ctrl+S>

Export design Export current design to machine file for stitching.

Transfer design Transfer current design to design folder. Right-click for 
settings.
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Status bar
A Status Bar at the bottom of the design window provides continuous display of 
current cursor position status as well as instructions for use of selected tools.

Print design Print current design. <Ctrl+P>

Print preview Preview worksheets. Print from preview window.

Cut Cut the selection and place on clipboard. <Ctrl+X>

Copy Copy the selection and place on clipboard. <Ctrl+C>

Paste Paste contents of the clipboard. <Ctrl+V>

Undo Undo previous action. <Ctrl+Z>

Redo Redo previously undone action. <Ctrl+Y>

Cancel Cancel current process and deselect any selected 
objects. <Esc>

Tool Tip Shortcut

Field Notes

Prompt message To guide you through use of selected functions.

Design size Width (W) and height (H).

Coordinates Current needle position (X/Y), and length (L) and angle (A) of current 
stitch. See also Design measurement, pg 63.

Stitch count Total number of stitches in design.

Current fabric Fabric settings take into account the type of fabric you are stitching on. 
See also Fabrics & densities (User Guide).

Grade of design Native EMB designs are classified in four grades depending on how the 
file was created. See Supported embroidery files, pg 85 for details.
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Travel toolbar
Use the Travel toolbar for design checking.

View toolbar
Use the View toolbar to set design view settings and other commonly used 
functions. 

Tool Tip

Select while 
traveling

Toggle on to select stitches, objects, or colors while traveling 
through a design. Only enabled when Stitch Edit tool is activated.

Travel backward Travel backwards through design.

Travel forward Travel forwards through design.

Jump by object Use in conjunction with Forward and Back icons to travel to 
previous or next objects.

Jump by color Use in conjunction with Forward and Back icons to travel to 
previous or next color change.

Jump to start/end Use in conjunction with Forward and Back icons to travel to start or 
end of design.

Tool Tip Shortcut

TrueView Toggle simulation of stitched embroidery. <T>

Show design Toggle display of design elements. Click to open 
droplist of view settings.

Show hoop Toggle hoop display. Right-click for settings. <Shift+H>

Show hoop 
template Toggle hoop template display.

Show grid Toggle grid display. Right-click for settings. <Shift+G>
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Zoom toolbar
Use the Zoom toolbar to zoom and pan across designs.

View (Manage Designs) toolbar
The View (Manage Designs) toolbar contains functions for quick search, sort, and 
location of designs on your company network.

Show rulers & 
guides

Toggle display of rulers and guides. Right-click for 
settings. <Ctrl+R>

Stitch player Simulate embroidery design stitchout onscreen in 
either stitch or TrueView. <Shift+R>

Tool Tip Shortcut

Pan Pan across design at high zoom factors. <P>

Zoom 1:1 Display design at actual size. <1>

Zoom in Zoom in for more design detail. <+>

Zoom out Zoom out for broader view. <->

Zoom to fit Display whole design in design window. <0> (zero)

Zoom Zoom on a specific area of design window. <B>

Use Zoom Scale to display design at a specific scale, 
or zoom to article or hoop.

Tool Tip

Layout Toggle display of navigation pane, details pane, and/or preview 
pane.

Design 
information >>

View design information such as size and number of stitches. Add 
comments to print on worksheet.

Keyboard Design 
Collection

Toggle display of Keyboard Design Collection docker. Create, edit 
and manage keyboard design collections.

Tool Tip Shortcut
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Context toolbar

Hatch Embroidery includes a Context toolbar which changes according to the 
selected tool. If you have no tools selected, you will see a custom hoop list. Here 
you can also change hoop settings, rotate hoop, set your measurement units – 
Metric or U.S. – as well as adjust screen background settings.

Change view Change current view of design lists.

Reset Detail 
Columns Reset columns displayed in details view to default layout.

Group by Group current design list by selected property and sort order.

Sort by Sort current design list by selected property and sort order.

Showing Filter current design list by file type. 

Search Filter designs based on specified search criteria – e.g. stitch range.

Ascending order

Sort designs in ascending or descending order. 
Descending 
order

Tool Tip
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Design window tools
The following tools are available by default with nothing selected.

Droplist Tip

Select machine brand for current design.

Select from list of models or types – single or multi-needle – 
associated with selected machine brand.

Select from hoop list associated with selected machine and 
model or type.

Tool Tip

Machine & Hoop 
Options

Change machines, set up hoop lists, and define custom brands 
and hoops.

Rotate hoop left 
15°

Rotate first hoop, or currently selected hoops in multi-hooping 
mode, to the left in 15° increments.

Rotate hoop right 
15°

Rotate first hoop, or currently selected hoops in multi-hooping 
mode, to the right in 15° increments.

Rotate by specified amount – positive or negative – in degrees.

Background and 
display colors Change design background and display colors.

Laydown stitch Generate light fill to flatten the nap of textured fabrics like terry 
toweling or fur for subsequent embroidery.

Center all Center whole design and hoop at 0,0 position and display in the 
design window.

Measurement 
units

Change measurement units within software without changing 
operating system settings.
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Digitizing methods
The following tools are available when a digitizing method is selected. 

Object editing tools
The following tools are available when embroidery objects are selected. 

Tool Tip Shortcut

Outline Outline closed shapes with current line stitch type.

Fill Fill closed shapes with current fill stitch type.

Hand stitch Create hand-stitch effects which combine randomized 
stitch length, angle and count.

Feather edge Create rough edges, shading effects, or imitate fur and 
other fluffy textures in selected objects.

Gradient fill Create perspective and shading effects with stitch 
spacing varying between dense and open fill.

Radial fill
Create radial turning stitching with various stitch types 
including satin, tatami and program splits. Can be 
applied to ring shapes. 

Florentine effect Create custom curve-line stitching with single 
guideline.

Elastic 
embossed fill

Create decorative split patterns following stitch angles 
and scaled according to object width.

Automatic 
corners

Turn automatic corners on or off. When on, the corners 
in line objects will be mitred or capped automatically 
depending on corner angle. Turn on or off by object.

Always tie-off & 
trim

Trim connectors. When turned on, connectors will 
always be tied off and trimmed. Otherwise, the 
software will decide when to trim.

Underlay Apply or exclude automatic underlays to new or 
selected objects. Right-click for settings. <U>

Tool Tip Shortcut

Close shape with 
straight line

Close an open outline with straight or curved line.
Close shape with 
curved line
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Custom object tools
The following tools are not editing tools as such but they are only available when 
an existing object is selected. 

Transform tools
The following tools are available when embroidery objects are selected. 

Duplicate
Duplicate selection in the same position. Duplicate is 
placed at end of stitching sequence. Also available via 
Edit menu.

Duplicate with 
offset

Duplicate selection in an offset position. Create regular 
patterns of duplicates. Right-click for settings. Also 
available via Edit menu.

Delete Delete selection. <Delete>

Group Group selection. Also available via Arrange menu. <Ctrl+G>

Ungroup Ungroup grouped selection. Also available via Arrange 
menu. <Ctrl+U>

Laydown stitch Generate light fill to flatten the nap of textured fabrics 
like terry toweling or fur for subsequent embroidery.

Center all Center whole design and hoop at 0,0 position and 
display in the design window.

Tool Tip

Create border Create custom border pattern for future use.

Create motif Create custom motif pattern for future use.

Tool Tip

Size +10% Increase size of selected objects in 10% increments.

Size -10% Reduce size of selected objects in 10% increments.

Tool Tip Shortcut
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Align & space tools
The following tools are available when multiple embroidery objects are selected. 

Mirror X Flip selection horizontally.

Mirror Y Flip selection vertically.

Rotate left 15° Rotate selection in 15° increments to left.

Rotate right 15° Rotate selection in 15° increments to right.

Skew Skew selection by specified amount – positive or negative – in 
degrees.

Tool Tip

Align left Align left edges of selected objects.

Align centers 
vertically Vertically align centers of selected objects.

Align right Align right edges of selected objects.

Align top Align top edges of selected objects.

Align centers 
horizontally Horizontally align centers of selected objects.

Align bottom Align bottom edges of selected objects.

Align centers Align centers of selected objects.

Space evenly 
across Evenly space 3 or more selected objects horizontally.

Space evenly 
down Evenly space 3 or more selected objects vertically.

Tool Tip
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Bitmap crop tools
The following tools are available when bitmap artwork is selected. 

Toolboxes

Toolboxes are like toolbars in that they contain software tools. However, each 
toolbox represents a typical scenario you will be engaged in, such as customizing 
designs or editing objects. Some tools may appear in more than one scenario. As 
such, toolboxes are organized more or less in order of common operations, starting 
with managing your designs.

Note: Not all tools and commands are applicable to all product levels.

Tool Tip

Rectangular Crop bitmap to rectangle.

Oval Crop bitmap to oval.

Heart Crop bitmap to heart shape.

Star ‘n’ point Crop bitmap to 4 to 12 point star shapes.

Curve Crop bitmap to free curves.
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Manage Designs toolbox
The Manage Designs toolbox provides an integrated way to view and organize all 
your embroidery designs.

Customize Design toolbox
The Customize Design toolbox provides functions which allow you to make global 
adjustments to your designs.

Tool Tip

New from 
selected

Create new design(s) based on selected design(s) and/or 
bitmap(s) from chosen template.

Open selected Open design(s) selected in Design Library window.

Convert selected 
designs

Convert design selected in Design Library window into different file 
types.

Transfer selected 
design Transfer selected design to default machine folder.

Print selected Print design selected in Design Library window.

Print selected to 
catalog Print selected designs to catalog.

Export design list Export text or CSV file containing list of visible design files and their 
properties.

Manage 
embroidery 
library locations

Add or remove existing folders to/from Design Library, enabling 
fast searching and filtering.

Tool Tip

Design 
information >>

View design information such as size and number of stitches. Add 
comments to print on worksheet.

Background and 
display colors Change design background and display colors.

Machine & Hoop 
Options

View machine settings and set up custom machine formats. Also 
view hoop settings and set up custom hoop lists.

Auto fabric Change properties of design for stitching on different fabric.
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Lettering / Monogramming toolbox
The Lettering / Monogramming toolbox provides the tools needed to add high 
quality embroidery lettering to your designs as well as create monogram designs.

Auto start and 
end Set auto start and end points for entire design.

Adjust stitch 
spacing Manually override stitch densities for selected objects.

Select thread 
charts Select factory or custom thread charts to use in Threads list.

Threads >> Toggle display of Threads docker. Find threads from different 
charts and change design colors.

Match all design 
colors

Automatically match and assign threads in thread list to all colors 
in the Design Colors toolbar.

Insert design Insert an existing embroidery design into current design.

Cycle used 
colors Cycle through combinations of used colors. Left- or right-click.

Color wheel Test combinations of related colors.

Optimize color 
changes

Optimize design by reducing color changes to a minimum, while 
maintaining color layers.

Tool Tip Shortcut

Lettering >>
Create embroidery lettering using embroidery 
alphabets, Keyboard Design Collections or TrueType 
fonts, or edit selected lettering.

<A>

Monogramming 
>>

Create personalized monograms using selection of 
predefined styles, border shapes and ornaments.

Reshape Reshape an object shape, edit stitch angles, adjust 
entry and exit points, or customize envelopes. <H>

Break apart
Split composite objects – monograms, appliqués, 
lettering, etc – into components. Allows each to be 
edited individually.

<Ctrl+K>

Tool Tip
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Artwork toolbox
The Artwork toolbox provides for importing electronic artwork into your embroidery 
software, editing it, and preparing it for automatic digitizing.

Knife Cut objects along digitized line, preserving stitch 
settings and colors.

Laydown stitch Generate light fill to flatten the nap of textured fabrics 
like terry toweling or fur for subsequent embroidery.

Tool Tip Shortcut

Insert artwork Import vector or bitmap artwork into current design as 
backdrop for manual or automatic digitizing.

Scan artwork Scan artwork directly from an attached scanner into 
current design window.

Adjust bitmap Adjust selected bitmap in effect, brightness and 
contrast.

Edit artwork Edit bitmap artwork in preferred graphics application. 
(Preset in User Interface Settings > General tab.)

Prepare artwork 
for embroidery

Prepare selected bitmap artwork for automatic 
digitizing.

Save artwork Save currently selected bitmap artwork.

Dim artwork Dim graphic backdrops to show stitches more clearly 
when digitizing.

Lock Lock selected objects into position for protection. <K>

Unlock all Unlock all locked objects to remove protection. <Shift+K>

Tool Tip Shortcut



Toolboxes 125

Auto-Digitize toolbox
The Auto-Digitize toolbox provides tools for the automatic digitizing of prepared 
artwork and photos.

Tool Tip

Insert artwork Import vector or bitmap artwork into current design as backdrop 
for manual or automatic digitizing.

Auto-digitize 
instant embroidery

Automatically digitize whole embroidery design directly from 
imported bitmap artwork.

Auto-digitize 
embroidery

Automatically digitize prepared bitmap artwork, optionally with 
user’s choices.

Color PhotoStitch Automatically turn grayscale or color photographs into 
embroidery.

Reef PhotoStitch
Turn photographs into single embroidery field resembling coral 
reef. Depending on Automatic Trim settings, multiple objects may 
be created.

PhotoFlash >> Create rows of PhotoSatin stitching of varying spacing in current 
color for selected photos or other bitmap artwork.

Click-to-fill Digitize large artwork shapes with tatami fill, preserving any holes 
within.

Click-to-fill without 
holes

Digitize large artwork shapes with tatami fill, ignoring any holes 
within.

Click-to-turning fill Digitize narrow column artwork shapes with satin stitch.

Click-to-outline Digitize boundaries of shapes with run stitching using current 
properties.

Click-to-centerline Digitize centerlines in artwork with run stitching using current 
properties.

Smooth shapes Remove excess reshape-nodes from selected embroidery 
objects.

Color matching 
method

Select matching method: a) add image colors to color palette for 
manual thread matching, b) add closest matches from selected 
thread charts, or c) use closest matches from the color palette.
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Edit Objects toolbox
The Edit Objects toolbox provides many tools for reshaping, resizing, rotating 
objects, as well as add or remove stitch angles.

Tool Tip Shortcut

Object properties 
>>

Toggle display of Object Properties docker. Preset 
properties for new embroidery objects or adjust 
properties for selected embroidery objects.

Copy object 
properties Make properties of selected object current for design.

Apply object 
properties Apply current settings to selected objects.

Adjust stitch 
spacing Manually override stitch densities for selected objects.

Smooth shapes Remove excess reshape-nodes from selected 
embroidery objects.

Reshape Reshape an object shape, edit stitch angles, adjust 
entry and exit points, or customize envelopes. <H>

Add stitch angles Add stitch angles to selected filled or lettering object.

Remove stitch 
angles

Remove stitch angles from closed objects with turning 
stitches.

Knife Cut objects along digitized line, preserving stitch 
settings and colors.

Weld Merge selected overlapping objects into single 
‘flattened’ object.

Break apart
Split composite objects – monograms, appliqués, 
lettering, etc – into components. Allows each to be 
edited individually.

<Ctrl+K>

Remove overlaps
Remove stitches that are covered by the selected 
objects. Overlap value can be changed in the Overlap 
tab of Embroidery Settings dialog.

Create color 
blend

Generate color blends, perspective effects and 
shading in selected objects.

Branching Automatically sequence and group selected 
embroidery objects. <I>
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Digitize toolbox
The Digitize toolbox provides all the digitizing tools necessary to create 
embroidered shapes. See also Digitize Objects (User Guide).

Redwork
Automatically sequence and group selected 
embroidery objects to create Redwork object with 
entry and exit points at same position.

<Ctrl+I>

Apply closest join Join selected objects at closest point. Re-apply closest 
join after editing. <J>

Sequence >> Open Sequence docker. Click again to close. Also 
available via Windows > Dockers menu. <Shift+L>

Sequence by 
selection order

Resequence objects in order of selection. Hold down 
<Ctrl> and click to select.

Stitch edit

Select individual or multiple stitches by clicking needle 
points holding <Ctrl> or <Shift>, or dragging selection 
marquee around them. Insert stitches at current stitch 
cursor position, and move or delete selected stitches.

<E>

Tool Tip Shortcut

Rectangle / 
square

Click two corners of rectangle, or press <Ctrl> for 
square.

Circle / oval Click center point plus two size points for an oval, or 
press <Ctrl> for circle.

Standard shapes
Digitize standard shapes. Press <Ctrl> to keep 
proportions of the shape. Press <Shift> to center at 
first point entered.

Freehand open 
shape

Click and hold to draw freehand open shapes. Adjust 
smoothing control for preferred result.

Freehand closed 
shape

Click and hold to draw freehand closed shapes. Adjust 
smoothing control for preferred result.

Digitize open 
shape

Digitize open shapes with left and right mouse clicks 
for straight lines and curves. <Shift+N>

Digitize closed 
shape

Digitize closed shapes with left and right mouse clicks 
for straight lines and curves.

Digitize blocks Digitize column shapes of varying width, setting stitch 
angle at each pair of points.

Tool Tip Shortcut
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Carving stamp 
>>

Toggle display of Carving Stamp docker. Create 
needle penetrations with a ‘carving stamp’ as 
template.

Motif stamp

Add motifs to design one-by-one. Rotate, scale with 
<Shift>, or mirror with right-click as you add, or press 
<Enter> to accept default position and settings. Press 
Esc to stop adding motifs.

Add stitch angles Add stitch angles to selected filled or lettering object.

Remove stitch 
angles

Remove stitch angles from closed objects with turning 
stitches.

Digitize holes Digitize holes in selected filled object.

Fill holes
Fill holes via creating new objects based on hole 
boundaries of selected object with current fill stitch 
type. Right-click for settings.

Remove holes Remove holes from selected object.

Weld Merge selected overlapping objects into single 
‘flattened’ object.

Backtrack Reinforce an outline, stitching it in reverse direction to 
the original. <Ctrl+B>

Repeat Duplicate an outline in same direction. Normally used 
with closed shapes.

Branching Automatically sequence and group selected 
embroidery objects. <I>

Redwork
Automatically sequence and group selected 
embroidery objects to create Redwork object with 
entry and exit points at same position.

<Ctrl+I>

Tool Tip Shortcut
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Appliqué toolbox
The Appliqué toolbox provides an easy way to create all the stitching you need for 
most simple appliqué work. See also Appliqué (User Guide).

Create Layouts toolbox
The Create Layouts toolbox lets you easily combine designs and design elements 
by inserting the contents of one file into another. See also Design Layouts (User 
Guide).

Tool Tip Shortcut

Frame-out 
options

Access frame-out options in Appliqué tab of 
Embroidery Settings dialog.

Convert to 
appliqué

Convert selected closed objects into individual 
appliqués.

Digitize appliqué 
>>

Show Appliqué tab of Object Properties docker. 
Digitize appliqué objects with up to four layers of 
stitching – placement line, cutting line, tack stitches, 
and cover stitches.

Digitize appliqué 
with holes >>

Show Appliqué tab of Object Properties docker. 
Digitize appliqué objects with holes with up to four 
layers of stitching – placement line, cutting line, tack 
stitches, and cover stitches.

Remove overlaps
Remove stitches that are covered by selected objects. 
Overlap value can be changed in Overlap tab of 
Embroidery Settings dialog.

Partial appliqué Remove unwanted cover stitching from underlying 
appliqué objects.

Combine 
appliqué

Break apart appliqué into component objects and 
recombine and resequence for efficient stitchout.

Break apart

Split composite objects – monograms, appliqués, 
lettering, etc – into components. Allows each to be 
edited individually. This tool is also available via Edit 
menu.

<Ctrl+K>

Tool Tip Shortcut

Insert design Insert an existing embroidery design into current 
design.

Mirror-copy 
horizontal Mirror and copy selected objects horizontally.

Mirror-copy 
vertical Mirror and copy selected objects vertically.
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Mirror-copy both Mirror and copy selected objects around a center 
point.

Copy array
Duplicate designs, such as badges, automatically 
resequencing color blocks for efficient multiple design 
stitchouts.

Copy reflect Duplicate and mirror objects or designs. Create 
decorative borders.

Circle layout
Duplicate selected objects around a center point. 
Specify how many copies and if alternate copies are 
mirrored in Context toolbar.

Define work area Define shape, size, color and view of the work area. <Ctrl+W>

Mirror-copy to 
work area

Automatically mirror and copy selected object/s 
around center (0,0) of the work area.

Circle layout to 
work area

Automatically create copies of selected object/s 
(specified by Number of Copies in Context toolbar) 
around center of the work area.

Auto center to 
work area

Automatically move selected object/s to center of the 
work area (0,0).

Buttonholes >>
Show Buttonholes tab of Object Properties docker. 
Use Place Buttonholes to place a string of buttonholes 
with all necessary stitching.

Ambience 
quilting Create ‘echo’ quilting blocks.

Create outlines & 
offsets

Create outlines and offsets for selected embroidery 
object(s).

Create trapunto 
outlines

Use in conjunction with Raised Satin to create stitching 
for a raised ‘quilted’ look.

Laydown stitch Generate light fill to flatten the nap of textured fabrics 
like terry toweling or fur for subsequent embroidery.

Basting stitch 
marker Insert reference marker at any angle and position.

Insert graphic 
marker

Insert graphic marker representing adhesive stickers 
attached to fabric to indicate location and orientation.

Tool Tip Shortcut
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Multi-Hooping toolbox
If your embroidery is too large or contains a number of designs spaced around an 
article, you can use the Multi-Hooping toolbox to split it into multiple hoopings.

Output Design toolbox
Using the Output Design toolbox you can output embroidery designs in a variety of 
ways – by printing as worksheets, as appliqué patterns, color sequence, or as 

Tool Tip

Multi-hooping 
options

Change multi-hooping options in Multi-Hooping tab of the 
Embroidery Settings dialog.

Automatically 
add hoops Add hoops automatically to cover entire design.

Add splitting line Digitize one or more guides in multi-hoop layout to split objects 
between hoopings.

Preview 
hoopings

Calculate object distribution and registration marks for given hoop 
positions and display hooping thumbnails in docker. Click hooping 
thumbnail in the docker to view in the design window.

Calculate 
hoopings Calculate hoopings that will result from current layout.

Add hoop Add new hoop to multi-hoop layout.

Delete hoop Remove selected hoop from multi-hoop layout.

Add hoop right Place new hoop position to right of selected hoop. Allow 10mm 
overlap between sewing fields.

Add hoop left Place new hoop position to left of selected hoop. Allow 10mm 
overlap between sewing fields.

Add hoop down Place new hoop below selected hoop. Allows 10mm overlap 
between sewing fields.

Add hoop up Place new hoop position above selected hoop. Allows 10mm 
overlap between sewing fields.

Add 4 hoops 
around

Place four hoops around selected hoop’s perimeter. Allows 10mm 
overlap between sewing fields.

Add 8 hoops 
around

Place eight hoops around selected hoop’s perimeter. Allows 10mm 
overlap between sewing fields.
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thread charts. Hatch Embroidery also allows you to save your designs as images 
for use with fabric and garment applications. You can also send them directly to 
machine for stitching. When working with designs that are larger than the 
available physical hoop, you can split them into parts, each containing an object 
or group of objects. Hatch Embroidery automatically calculates which files are to 
be sent and shows you how they will look.

Keyboard shortcuts

Hatch Embroidery uses toolbars and shortcut keys to provide quick and easy 
access to common commands. This section provides a list of all keyboard shortcuts 
available in Hatch Embroidery, as well as short descriptions of the tools you will find 
in the toolbars. Not all shortcuts are applicable to all product levels.

Tip: In addition to shortcut keys, standard MS Windows® Alt key shortcuts apply to 
menu commands. Use the Alt key in combination with the letters underlined in the 
menus. For example, press Alt+F+O to access the Open Design command in the 
File menu.

Tool Tip Shortcut

Auto start & end Set auto start and end points for entire design.

Save design as Save current EMB design with different name or 
location.

Export design Export current design to machine file for stitching.

Export cutting Export current design or selected objects to SVG file 
format for cutting.

Transfer design Transfer current design to preset design folder. 
Right-click for settings.

Print preview Preview worksheets. Print from preview window.

Print design Print current design. <Ctrl+P>

Capture design 
image

Save design image as bitmap exactly as it appears on 
screen.
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General functions
Keyboard shortcuts are available for most general functions:

Selection functions
Keyboard shortcuts are available for most selection functions:

To... Press...

Activate ‘Digitize Open Shape’ and open Outline tab <Shift+N>

Activate Lettering and open Lettering docker <A>

Apply/select satin <Shift+I>

Apply/select tatami <Shift+M>

Create new design <Ctrl+N>

Close software <Alt+F4>

Define layout work area ^ <Ctrl+W>

Export machine file <Shift+E>

Open an existing design <Ctrl+O>

Print design <Ctrl+P>

Save design <Ctrl+S>

Toggle Design Colors toolbar <Ctrl+Shift+R>

Toggle Design Information docker <Alt+P>

Toggle grid <Shift+G>

Toggle rulers <Ctrl+R>

Toggle Overview window <Shift+V>

Toggle Sequence docker <Shift+L>

Toggle Threads docker <Alt+T>

Toggle work area <W>

^ Press <Esc> to close

To... Press...

Add next object to selection <Ctrl+Tab>

Add previous object to selection <Ctrl+Shift+Tab>

Choose Select tool <O>

Deselect all objects <Esc> or <X>

Select range of objects <Shift>+left-click first and last objects

Select all objects <Ctrl+A>

Select multiple objects <Ctrl>+left-click

Select component within grouped object <Alt>+left-click
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Viewing functions
Keyboard shortcuts are available for most viewing functions:

Zoom functions
Keyboard shortcuts are available for most zoom functions:

Select underlying object <2>+left-click

Select next object <Tab>

Select previous object <Shift+Tab>

To... Press...

Center at current stitch <C>

Measure distance on screen ^ <M>

Refresh screen display <R>

Previous view <V>

Toggle connectors <Shift+C>

Toggle function symbols <Shift+F>

Toggle hoop <Shift+H>

Toggle images <D>

Toggle needle points <.> (period)

Toggle shapes <L>

Toggle Stitch Player <Shift+R>

Toggle stitches <S>

Toggle unselected <Shift+S>

Toggle vectors <Shift+D>

Toggle TrueView <T>

View by color <Alt+C>

Zoom box in Overview window <Shift+B>

Zoom to article <Ctrl+0>

^ Press <Esc> to close

To... Press...

Pan <P>

Zoom <B>

Zoom 1:1 <1>

Zoom in 1.25x <+>

To... Press...
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Travel functions
Keyboard shortcuts are available for most travel functions:

Editing functions
Keyboard shortcuts are available for most editing functions:

Zoom out 1.25x <->

Zoom in 2x <Z>

Zoom out 2x <Shift+Z>

Zoom to fit <0> (zero)

Zoom to hoop </>

Zoom to selected <Shift+0> (zero)

Zoom factor <F>

To travel... Keyboard † Keypad ‡

To start of design <Home> <7>

To end of design <End> <1>

To next color <PgDn> <3>

To previous color <PgUp> <9>

To next object <Ctrl+T>

To previous object <Shift+T>

100 stitches forward <+>

100 stitches backward <->

10 stitches forward ˅ <2>

10 stitches backward ˄ <8>

1 stitch forward > <6>

1 stitch backward < <4>

† Press <Esc> first ‡ Num Lock OFF

To... Press...

Add stitch angles <Ctrl+H>

Apply closest join to selected objects <J>

Apply Redwork to selected objects <Ctrl+I>

Break apart composite objects <Ctrl+K>

Copy selected objects <Ctrl+C>

Cut selected objects <Ctrl+X>

To... Press...
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Digitizing functions
Keyboard shortcuts are available for most digitizing functions:

Delete last reference point (when digitizing) <Bksp>

Delete selected objects <Delete>

Duplicate selected objects <Ctrl+D>

Duplicate selected objects with offset <Ctrl+Shift+D>

Generate stitches for selected objects. <G>

Group selected objects <Ctrl+G>

Lock selected objects <K>

Mirror horizontally <Ctrl+1>

Mirror vertically <Alt+1>

Nudge selected objects Left-click+arrow keys

Paste selected objects <Ctrl+V>

Redo command <Ctrl+Y>

Remove overlaps <Ctrl+Shift+E>

Reshape selected objects <H>

Toggle ‘Select While Traveling’ (Stitch Edit mode) <Q>

Toggle underlay of selected objects <U>

Undo command <Ctrl+Z>

Ungroup selected objects <Ctrl+U>

Unlock all <Shift+K>

To... Press...

Cancel command <Esc>

Create outlines and offsets <Ctrl+Shift+O>

Digitize appliqué <F7>

Toggle Auto Scroll <Ctrl+Shift+A>

Deactivate (temporarily) Auto Scroll <Shift> (hold)

To... Press...
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STANDARD FONTS

The table below includes all embroidery fonts that are standard with your Hatch 
Embroidery. Categories include:

Minimum & maximum sizes
For best results when stitching, do not exceed the recommended maximum or 
minimum sizes. Note, however, that recommended maximum and minimum 
heights refer to UPPER CASE letters. Most embroidery fonts are digitized from an 
original TrueType Font (TTF), some of which have lower-case letters – e.g. ‘a’ and 
‘c’ – which are about 70% the height of a capital letter. As a result, these letters 

Font style Description

Appliqué fonts Created especially for appliqué, containing all the required outline, tack 
and cover stitches. Great for use on large scale and to reduce stitch 
count.

Block fonts San-serif typeface style, very common with names and business logos. 
A great style for embroidery as it is clear and easy to read.

Fancy fonts Anything that is not ‘blocky’ can be used in a decorative way, depending 
on the style of logo.

Monogram fonts Especially designed for monogramming purposes – commonly used for 
creating initials popular with gifts such as towels and linen. 

Outline fonts Commonly used for sports wear, on back of jackets. Work best at larger 
scale.

Run stitch fonts Commonly used for small lettering, anything under 5mm and where 
satin column are not suitable. 

Script fonts Fluid strokes where characters connect, resembling a hand written 
style.

Serif fonts Older style font which includes an embellishment at the ends of the 
stroke, popular with sportswear.

Small fonts Fonts which are 6mm and below, including satin stitch columns with 
push and pull adjustments.

Special fonts Graphical, multi-colors and fill effects are some of the things that are 
associated with special fonts. Commonly used for decorative purposes.

Non-Roman fonts This category includes Cyrillic, Greek and Japanese fonts.
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may be too small to embroider neatly. You may need to increase the size of the 
lower-case characters to suit the embroidery.

Special characters
You can create special characters in each font by holding down the Alt key on 
your keyboard and typing 0 (zero), its code, using the numbers on the keypad. For 
example, to type ê with the code 234, type Alt+0234. The accented letter will 
appear when you release the Alt key. See also Insert special characters (User 
Guide).

Note: Not all characters are available in all fonts.

Join method
The lettering join method is preset to give the best results for each font. Options 
include:

Join Purpose

Bottom join BJ Letters are joined along the baseline. Use it when stitching on toweling – 
joins are hidden in the pile.

Closest join CJ Letters are joined at the closest point. Use it to minimize trims.

As digitized AD Letters are joined as they were digitized. Use it with fonts combining 
different fill stitch types or special effects.

TrueType Font

Embroidery Letters
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If you break apart a lettering object, the join method is lost as the object is no 
longer a lettering object. For further details about join methods, see Split lettering 
(User Guide).

Roman fonts

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

Appliqué fonts

College 
Appliqué 1.0 25 3.2 80 AD

Block fonts

Angle Block 0.4 10 1.2 30 CJ

Art Block 0.4 10 1.6 40 CJ

Avant Garde * 0.3 8 1.2 30 CJ

Bauhaus * 0.3 8 1.0 25 CJ

Block1 0.3 8 0.8 20 CJ

^ New to Hatch 3 * Hatch Digitizer only
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Block2 0.25 6 0.8 20 CJ

Block2-Auto 0.25 6 0.8 20 CJ

Castle 0.6 15 1.0 25 CJ

Endeavor ^ * 0.4 10 1.4 35 CJ

Folio 
Condensed 0.3 7 1.0 25 CJ

Futura 0.4 10 0.8 20 CJ

Helvetica 0.3 8 1.2 30 CJ

Microgramma 0.4 10 1.0 25 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Mystic ^ * 0.3 8 0.8 20 CJ

Narrow Block 0.7 18 2.5 65 CJ

Platinum ^ 0.4 10 1.4 35 CJ

Slim Block 1.0 25 5.0 125 CJ

Square Block * 0.4 10 1.4 35 CJ

Swiss * 0.4 10 1.2 30 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Tahoma * 0.3 8 1.2 30 CJ

Text Block * 0.3 8 1.0 25 CJ

Urbane * 0.4 10 0.8 20 CJ

Verdana * 0.3 8 1.0 25 CJ

Fancy fonts

Addison ^ * 0.4 10 1.0 25 CJ

Anaconda * 0.4 10 1.0 25 CJ

Arnold * 0.5 12 0.6 17 CJ

Blacklight 0.4 10 0.7 18 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Carla * 0.4 10 1.0 25 CJ

Catalan ^ * 0.4 10 0.7 18 CJ

Charcuterie 0.8 20 1.6 40 CJ

Comics 0.4 10 1.0 25 CJ

Croissant * 0.3 8 0.7 18 CJ

Curly 0.7 18 1.6 40 CJ

Enviro * 0.6 15 1.6 40 CJ

Felt Tip 0.4 10 1.2 30 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Flash 0.3 8 1.0 25 CJ

Flourish Light * 0.8 20 1.2 30 AD

Fluky ^ * 0.4 10 1.4 35 CJ

Hana 0.6 15 0.8 20 CJ

Handicraft 0.4 10 1.0 25 CJ

Hobo * 0.3 8 0.8 20 CJ

Kids * 0.4 10 0.8 20 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Kindergarten 
Block 0.4 10 1.0 25 CJ

Lublik * 0.4 10 0.8 20 CJ

Mandarin 0.4 10 0.6 15 CJ

Old English 0.8 20 1.2 30 CJ

Orient Express * 0.4 10 0.8 20 CJ

Pacific North 
West 1.0 25 1.6 40 CJ

Race Track ^ * 0.3 8 1.2 30 CJ

Racer * 0.4 10 0.6 15 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only



146 Roman fonts

Speedy * 0.3 8 0.6 15 CJ

Staccato * 0.6 15 1.0 25 CJ

Swaddle ^ * 0.25 6 0.7 18 CJ

Woodstock 0.3 8 0.8 20 CJ

Monogram fonts

Fancy 
Monogram

0

2.0 50 4.0 100 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Octagon 
Monogram 0.7 18 2.4 60 CJ

Point 
Monogram 0.7 18 2.9 75 CJ

Seal 
Monogram 0.8 20 2.4 60 CJ

Outline fonts

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Dextor Normal 0.4 9 1.2 30 CJ

News Outline * 0.8 20 1.8 45 CJ

Run stitch fonts

Quilting Text * 0.2 5 1.0 25 AD

Run Block 0.2 5 0.5 12 AD

Run Cardigan * 0.2 5 0.5 12 AD

Run Freehand 0.2 5 0.5 12 AD

Run Liberty * 0.2 5 0.5 12 AD

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Run Murray 
Hill 0.2 5 0.5 12 AD

Run Script 0.2 5 0.5 12 AD

Script fonts

Ballantines 
Script 1.2 30 1.4 35 CJ

Book Script 0.4 10 1.2 30 CJ

Cayman * 0.4 10 1.0 25 CJ

Chancery * 0.6 17 1.0 25 CJ

Edwardian 
Script 1.2 30 1.4 35 CJ

Formal Script * 0.3 7 0.6 15 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Italian Script 0.6 15 1.0 25 CJ

Orlando ^ * 0.3 8 1.5 13 CJ

Poetic Script * 0.8 20 1.6 40 CJ

Pomander * 1.6 40 2.5 65 CJ

Script1 0.6 15 1.2 30 CJ

Script2 0.5 12 1.0 25 CJ

Script3 * 0.8 20 2.1 55 CJ

Script4

[

1.2 30 2.0 50 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Upright Script 0.8 20 2.0 50 CJ

Serif fonts

Algerian 0.4 10 0.6 15 CJ

Athletica 0.4 10 1.2 30 CJ

Bodoni 0.6 15 0.8 20 CJ

Casual Serif 0.4 10 1.4 35 CJ

Cheltenham 
Tall * 0.4 10 0.8 20 CJ

City Medium 0.3 8 0.8 20 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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College 0.4 10 0.8 20 CJ

Copperplate 0.4 10 0.8 20 CJ

Garamond 0.6 15 0.8 20 CJ

Schoolbook * 0.6 15 1.2 30 CJ

Seagull ^ 0.4 10 0.8 20 CJ

Serif1 0.3 8 0.6 15 CJ

Serif2 * 0.5 12 0.6 15 CJ

Serif3 * 0.4 10 1.2 30 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Souvenir * 0.3 8 0.8 20 CJ

Stencil Block 0.4 10 0.6 15 CJ

Times Roman * 0.6 15 1.0 25 CJ

Typewriter 0.4 10 1.0 25 CJ

Small fonts

Micro Block * 0.25 6 0.8 20 CJ

Miniature 
Block 0.25 6 0.6 15 CJ

Queensgate 0.25 6 0.8 20 CJ

Sm High Tower * 0.3 8 0.6 15 CJ

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Small Block1 * 0.15 4 0.25 6 CJ

Small Block2 0.15 4 0.25 6 CJ

Small Serif 1 * 0.15 4 0.25 6 CJ

Sm Script 0.15 4 0.25 6 CJ

Times Small 0.4 10 0.6 15 CJ

Special fonts

2 Col Arial 
Shadow 0.6 15 1.0 25 AD

Antique Rose 1.6 40 2.4 60 AD

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only
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Non-Roman fonts

Engraved Serif * 1.0 25 2.0 50 AD

Flair Script 0.4 10 1.6 40 CJ

3D Foam 
Impact * 0.8 20 1.0 25 AD

Invitation * 1.0 25 2.0 50 AD

Shadow Street * 0.6 15 1.0 25 AD

Font Sample
 Recommended sizes

Join 
methodMin Max

in. mm in. mm

^ New to Hatch 3 * Hatch Digitizer only

Greek * 0.4 10 0.6 15 CJ

Heisei Kaisho ^ 0.3 8 2.7 70 CJ

^ New to Hatch 3 * Hatch Digitizer only
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Note: You can insert Japanese characters from the Insert Character dialog or use 
Google Translate and copy and paste into Hatch Embroidery via the Lettering or 
Monogramming tools.

Heisei Kantei ^ 0.4 10 2.7 70 CJ

Heisei Gosic ^ 0.4 10 2.7 70 CJ

Heisei Gyosho ^ 0.3 8 2.7 70 CJ

Heisei Maru 
Gosic 0.3 8 2.7 70 CJ

Heisei Mincho ^ 0.4 10 2.7 70 CJ

^ New to Hatch 3 * Hatch Digitizer only
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